Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Cisco 1812 Integrated Services Router VLAN-Trennung

Frage Netzwerke

Mitglied: Philipp711

Philipp711 (Level 2) - Jetzt verbinden

28.12.2010, aktualisiert 18.10.2012, 5861 Aufrufe, 1 Kommentar

Hi Leute,

habe hier ein funktionierendes Netzwerk. Das Gateway ist ein Cisco 1812 Integrated Services Router mit "default"-Einstellungen.

NAT bzw. Internetverbindung funktioniert. Firewall läuft auch ordnungsgemäß bzw. es kommt auch wirklich nur das von außen rein was rein soll--> getestet durch ftp-server.

Ich würde aber jetzt gerne ein weiteres netzwerk hinzufügen das parallel zu dem jetzigen läuft. Ich dachte mir Switch-Interface 1 dem VLAN1 zuzuordnen und Switch-Interface2 dem VLAN2, dahinter hänge ich jeweils ein normales switch.

Das Interface im VLAN1 bekommt dann die IP: 192.168.10.254/24....Inteface2 im VLAN2 bekommt 192.168.20.254/24

So sollten ja beide Netzwerke über das Öffentliche-Inteface ins Internet geroutet werden. Außerdem finden sie sich gegenseitig NICHT.

Allerdings sollten die Netzwerke auf einigen Protokollen kommunizieren können. Das bedeutet: ich trage Routingeinträge in die statische Tabelle ein.


Frage:

Geht dann dieses Routing von VLAN1 zu VLAN2 mit über die Firewall ?-> kann ich also durch die Firewallregelen beschreiben welche Protokolle rüber dürfen? oder ist die Firewall nur von extern(Internet) nach intern(LAN) aktiv?
Mitglied: aqui
28.12.2010, aktualisiert 18.10.2012
.. ."ich trage Routingeinträge in die statische Tabelle ein."
Das ist Blödsinn, denn statisch routen musst du gar nicht !! Warum auch, denn dein Cisco "kennt" doch beide IP Netze da sie direkt an ihm angeschlossen sind.
Was du machst hat auch so direkt nichts mit VLAN Routing zu tun, da du nur simpel und einfach 2 Interfaces am Router nutzt. Mit VLANs müsstest du einen 802.1q VLAN getaggten Link aufsetzen am Router, was der Cisco natürlich auch kann. Das was du machst ist aber effizienter da beide VLANs nicht über einen tagged Link gehen sondern getrennte, dedizierte Interfaces nutzen, hat aber mit VLANs nix zu tun ! Die VLAN bezeichnung nutzt der 1812 nur intern weil er eben ein Layer 3 Switch mit WAN Interfaces ist wenn man so will.
Infos zu VLANs findest du hier:
http://www.heise.de/netze/VLAN-Virtuelles-LAN--/artikel/77832
und
http://www.administrator.de/wissen/vlan-routing-%c3%bcber-802.1q-trunk- ...
bzw.
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...

Was deinen Cisco 1812 anbetrifft gehst du so vor:
router# vlan database
router(config)# vlan 10
router(config-vlan)# name VLAN-10
router(config-vlan)# exit

router(vlan)# vlan 20
router(config-vlan)# name VLAN-20
router(config-vlan)# exit

router(config)# int vlan 10
router(config-if)# ip address 192.168.10.254 255.255.255.0
router(config)# no shut

router(config)# int vlan 20
router(config-if)# ip address 192.168.20.254 255.255.255.0
router(config)# no shut

router(config)# int fa 1
router(config-if)# switchport access vlan 10
router(config-if)# spanning-tree portfast

router(config)# int fa 1
router(config-if)# switchport access vlan 10
router(config-if)# spanning-tree portfast


Das richtet dir erstmal die beiden Interfaces und deine beiden "VLANs" 10 und 20 ein und legt das VLAN 10 auf Port FastEthernet 1 und das VLAN 20 auf Port FastEthernet 2 !
Soll der Router für beide LAN Ports auch DHCP Adressen vergeben (Bereich .100 bis .150):
ip dhcp excluded-address 192.168.10.1 192.168.10.99
ip dhcp excluded-address 192.168.10.150 192.168.10.254
ip dhcp excluded-address 192.168.20.1 192.168.20.99
ip dhcp excluded-address 192.168.20.150 192.168.20.254
!
ip dhcp pool vlan-10
network 192.168.10.0 255.255.255.0
default-router 192.168.10.254
dns-server 192.168.10.254
domain-name phillip.test
!
ip dhcp pool vlan-10
network 192.168.20.0 255.255.255.0
default-router 192.168.20.254
dns-server 192.168.20.254
domain-name phillip.test

Was du machen musst sind schlicht und einfach simple Accesslisten an den Interfaces einzurichten, wo du eben erlaubst was von einem zum anderen Netz durchdarf und was nicht...fertich !
Folgende Beispiele sind selbsterklärend:
ip access-list extended nurftp
permit tcp 192.168.10.0 0.0.0.255 192.168.20.0 0.0.0.255 eq 50
permit tcp 192.168.10.0 0.0.0.255 192.168.20.0 0.0.0.255 eq 51
deny ip any any

ip access-list extended keinsmb
permit udp host 192.168.10.0 0.0.0.255 192.168.20.0 0.0.0.255 range netbios-ns netbios-ss
permit tcp host 192.168.10.0 0.0.0.255 192.168.20.0 0.0.0.255 eq 445
deny ip any any

ip access-list extended surfenverboten
deny tcp host 192.168.10.0 0.0.0.255 192.168.20.0 0.0.0.255 eq www
deny tcp host 192.168.10.0 0.0.0.255 192.168.20.0 0.0.0.255 eq 443
permit ip any any

Am Interface dann z.B.
interface vlan 10
ip access-group <name-acl> in

...das wars.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
LAN, WAN, Wireless
gelöst Cisco hinter Fritz!box, vom VLAN kein Internet (3)

Frage von PharIT zum Thema LAN, WAN, Wireless ...

Router & Routing
gelöst Cisco SG300 - Kein Routing ins VLAN (4)

Frage von Fluxx1337 zum Thema Router & Routing ...

LAN, WAN, Wireless
gelöst VLAN Trennung sicher? (5)

Frage von mksadm zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (24)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Erkennung und -Abwehr
Spam mit eigener Domain (12)

Frage von NoobOne zum Thema Erkennung und -Abwehr ...