Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Cisco 2924C-XL Probleme mit Webinterface (Java)

Frage Hardware Switche und Hubs

Mitglied: christian3000

christian3000 (Level 1) - Jetzt verbinden

30.08.2008, aktualisiert 31.08.2008, 7888 Aufrufe, 3 Kommentare

Webinterface funktioniert nicht. Java wird geladen, aber die Seite bleibt leer.

Hallo,

Ich habe einen Cisco 2924C XL mit der IOS Version "12.0(5.3)WC(1)" (mit Telnet ermittelt)

Wenn ich die IP des Switches eingebe, komme ich auf die erste Website des Switches.

Aber wenn ich jetzt auf "Cluster Management Suite or Visual Switch Manager " klicke, wird zwar das Java Applet geladen, aber das war es auch schon. Mehr tut sich nicht mehr.

Ich habe es mit dem Aktuellen Internet Explorer, dem Aktuellen Firefox, und dem letzten Netscape probiert.
Habe auch die Aktuelle Java Version installiert.
Ich nutze XP home SP3


Ich habe mal Onmipeek gestartet und gesehen, dass der Browser ständig die Datei "CM.jar" vom Switch anfordert.

Der switch funktioniert einwandfrei. Es ist nur 1 Vlan (default) definiert.

Kann mir da evtl jemand weiterhelfen ? Muss man per Telnet erst noch etwas "freischalten" damit man das Web Interface in vollem Umfang nutzen kann ?


Grüsse

Chris
Mitglied: spacyfreak
30.08.2008 um 17:21 Uhr
Wenn bei "show run" die Option "ip http server" gesetzt ist dann ist der Webserver auch verfügbar.

Andere Frage - warum konfigurierst das Teil nicht einfach per Kommandozeile? Die Weboberfächen bei Cisco scheinen in meinen Augen eh nur Alibi-Funktion zu haben, selbst ein 50€ D-Link Wlan Router ist üer Web einfacher u. stabiler zu konfigurieren als ein teurer Mercedes-Switch der Marke Cisco. Die Cisco Ingenieure mit den drei Hirnen kriegen das einfach nicht gebacken benutzerfreundliche Schnittstellen zum Laufen zu kriegen.

Sind doch nur paar Zeilen die man kennen muss.
Was willst du denn konkret konfiguriert haben?

Beispiel:

Hostname soll "switch123" sein.
Port 1 soll der Uplink Port sein. Damit da mehrere VLANs drüber gehen muss er als Trunkport konfiguriert sein.
Port 2-10 soll ins VLAN 2, und Ports 11-24 sollen ins VLAN 3.
Ausserdem soll Zugriff per telnet für Management Zugriff nur aus dem Netz 10.10.10.0 erlaubt sein.
Ferner will man einen lokalen User haben namens "admin" und Passwort "pa55w0rd" um sich per telnet anzumelden.
Was tun?

switch>enable
switch#conf t
switch(config)#interface FastEthernet1
switch(config-if)#switchport mode trunk
switch(config-if)#switchport trunk encapsulation dot1q
switch(config-if)#description UPLINK zu SWITCH Blah Port Blubb
switch(config-if)#no shut
switch(config-if)#exit

switch(config)#interface range FastEthernet2-10
switch(config-if)#switchport mode access
switch(config-if)#switchport access vlan 2
switch(config-if)#no shut
switch(config-if)#exit

switch(config)#interface range FastEthernet11-24
switch(config-if)#switchport mode access
switch(config-if)#switchport access vlan 3
switch(config-if)#no shut
switch(config-if)#exit

switch(config)#ip access-list 1 permit 10.10.10.0 0.0.0.255
switch(config)#line vty 0 15
switch(config-line)#access-class 1 in
switch(config-line)#login local
switch(config-line)#exit

switch(config)#username admin privilege 15 password 0 pa55w0rd
switch(config)#service password-encryption

switch(config)#hostname switch123
switch123(config)#vtp mode transparent
switch123(config)#no ip domain-lookup
switch123(config)#copy run start
switch123(config)#exit
switch123#sh run
Bitte warten ..
Mitglied: christian3000
31.08.2008 um 15:42 Uhr
Hallo,

danke für Deine Hilfe.

Das Webinterface geht jetzt, man muss nur ne ganze Weile warten, bis sich die Java Seite aufbaut.
Aber es stimmt, das Interface ist etwas bugy.

Wenn man da z.B. einen Port abschaltet, dann kann man ihn im Interface nicht mehr einschalten. Auch wenn man einen Port monitoren will, kann man es zwar aktivieren, aber nicht mehr deaktivieren. Weil im Interface nicht der aktuelle Zustand des Ports angezeigt wird. Per Telnet ist es problemlos und schneller.
Durch die Anleitung mit den Befehlen, bin ich schon um einiges weiter. Und es ist wirklich einfach.

Ich möchte 2 Ports vom Switch zu einem Vlan zusammenfügen und dort dann die WAN Seite meines Draytek Routers und die LAN Seite des DSL Modems anschliesen.

Einen dieser beiden Ports möchte ich dann auf einem Anderen Port im default Vlan monitoren. So kann ich den gesamten Traffic beobachten, der auf der Wan Seite meines Routers abgewickelt wird.

Grüsse

Chris
Bitte warten ..
Mitglied: spacyfreak
31.08.2008 um 18:46 Uhr
Das IOS ist auch etwas betagt, ich glaub aktuell wäre IOS 12.4.

Ich glaub für dein Szenario hättest du auch einfach nen Hub nehmen können, zwischen DSLModem und LAN hängen, Laptop dran und mit wireshark sniffen.
Bitte warten ..
Ähnliche Inhalte
Switche und Hubs
Cisco Catalyst 3560G - kein Zugriff aufs Webinterface
gelöst Frage von VelmontSwitche und Hubs9 Kommentare

Hallo zusammen, ich habe eine Ladung Cisco Switche (Catalyst 3560G), welche ich auf Funktion prüfen möchte. Meine Vorgehensweise: 1. ...

Router & Routing
Cisco RV325 Webinterface nur aus lokalem Subnetz aufrufbar - warum?
Frage von stephan902Router & Routing4 Kommentare

Hallo, mein Cisco RV325 ist nur aus dem lokalen Subnetz herausbar administrierbar. Woran könnte das liegen?

LAN, WAN, Wireless
Webinterface
Frage von dastinLAN, WAN, Wireless8 Kommentare

Hallo! Ich habe eine Frage. Ich habe ein LAN-Switch LANCOM GS-1224. Indirekt (mein PC ist mit Router verbunden LAN1, ...

Voice over IP
Cisco 7960 Probleme
Frage von uridium69Voice over IP5 Kommentare

Folgende Probleme habe ich beim Cisco 7960: - Eingehende Anrufe (intern wie auch extern) klingeln, aber nimmt man ab, ...

Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 1 TagWindows 103 Kommentare

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 1 TagSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 1 TagInternet5 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 1 TagDSL, VDSL2 Kommentare

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
Windows Server
GPO nur für bestimmte Computer
Frage von Leo-leWindows Server13 Kommentare

Hallo Forum, gern würde ich ein Robocopy script per Bat an eine GPO hängen. Wichtig wäre aber dort der ...

Windows Server
KMS Facts for Client configuration
Frage von winlinWindows Server13 Kommentare

Hey Leute, wir haben in unserem Netz nun einen neuen KMS Server. Haben Bestands-VMs die noch nicht aktiviert sind. ...

Router & Routing
OpenWRT bzw. L.E.D.E auf Buffalo WZR-HP-AG300H - update
gelöst Frage von EpigeneseRouter & Routing11 Kommentare

Guten Tag, ich habe auf einem Buffalo WZR-HP-AG300H die alternative Firmware vom L.E.D.E Projekt geflasht. Ich bin es von ...

Windows Tools
Software-Tool zum Entfernen von bösartigem Windows
Frage von emeriksWindows Tools11 Kommentare

Hi, siehe Betreff hat das jemals irgendjemand schonmal sinnvoll eingesetzt? (MRT) E.