Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Cisco 2960 vlan tagged, untagged

Frage Hardware Switche und Hubs

Mitglied: halooos111

halooos111 (Level 1) - Jetzt verbinden

18.12.2011, aktualisiert 18.10.2012, 7898 Aufrufe, 6 Kommentare

Hallo Admins,

ich habe ein Problem bei der Konfiguration eines Cisco switch 2960 catalyst.

in unsere Firma arbeiten wir mit 2 vlans:

in vlan1 sind alle unsere switche und alle windows pcs + AD server

in vlan2 sind alle Macs + mac dhcp server

im einsatz haben wir hp switche dort ist kein Problem mit tagged und untagged vlans:

-hp switch default vlan ist vlan1
-hp switch ist Tagged in vlan1 und in vlan2
-windows pcs sind untagged in vlan1
-macs sind untagged in vlan2

aber dieses mal muss ich ein Cisco 2960(mein erste cisco switch) konfigurieren wie die hp switche und es klappt nicht!

ich habe folgendes gemacht:

hp switch port 2 mit cisco switch port 1 verbunden

hp port 2 ist tagged in vlan1 und vlan2

wie bekomme ich es hin mit dem Cisco das:

port 1 ist tagged in vlan1 und vlan2
port 2 ist untagged vlan1
port 3 ist untagged vlan2(da wenn ich ein mac anschliesse bekommt es eine ip vom dhcp server)

ich bin dankbar für jede Hilfe
Viele Grüsse, Tony
Mitglied: aqui
18.12.2011, aktualisiert 18.10.2012
Guckst du hier:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
Da findest du eine Beispielkonfig für deinen 2960 zum Abtippen. Die Konfig ist kinderleicht, da die Kommando Syntax ähnlich wie bei HP ist. In deine Falle sollte deine Cisco Switch Konfiguration genau so aussehen:

Cisco_Switch#

clock timezone MET 1
clock summer-time MEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
description Tagged Link zum HP Switch
switchport mode trunk
(switchport trunk encapsulation dot1q)
-->> (Ist bei neuerer IOS Version ggf. Default und kann dann entfallen !)
!
interface FastEthernet0/2
description Enduser Ports in VLAN 1
switchport access
spanning-tree portfast
!
interface FastEthernet0/3
description Enduser Ports in VLAN 2
switchport access vlan 2
spanning-tree portfast
!
interface Vlan1
description Management IP Adresse
ip address 172.16.1.254 255.255.255.0
no ip route-cache
!
ip http server
ip http secure-server
!
end


Fertig ist der Lack ! So einfach ist das ! Die Syntax ist wie bereits gesagt fast identisch !
Vorher musst du auf dem Cisco natürlich noch das VLAN 2 anlegen mit vlan 2 und danach name Mac VLAN oder wie auch immer das VLAN 2 heissen soll. Das VLAN 1 ist das default VLAN und per Default angelegt. Mit show vlan auf dem Cisco kannst du seine konfigurierten VLANs sehen.
Die Management IP des Cisco kannst du auch ins VLAN 2 legen je nachdem über welches VLAN du die Switches managst.
Noch eine Warnung zum Schluss: Billigheimer HP supportet KEIN per VLAN Spanning Tree (PVSTP+) wie es beim Cisco Switch per Default aktiv ist !! Und eigentlich sinnvoll wäre in redundanten Umgebungen !! Ist (R)STP auch auf dem HP aktiv kommt es zu STP Protokoll Konflikten und Problemen im gesamten Netz, da beide STP Protoklle nicht kompatibel sind.
Du musst also STP generell ganz ausschalten auf dem HP (und ggf. auch Cisco) und nur auf dem Cisco laufen lassen oder gar kein STP verwenden (auf beiden ausschalten).
Letzteres birgt dann aber die Gefahr eines Loops im Netzwerk und eine Redundanz ist dann auch nicht realisierbar.
Man kann dann entweder (R)STP durchschleifen auf den HPs oder stellt das nicht optimale Single Span STP ein, das einzige was Billigheimer HP supportet.
In einem redundanten Szenrio mit (R)STP ist HP generell keine gute Wahl deshalb ! Das aber nur nebenbei....
Bitte warten ..
Mitglied: clSchak
19.12.2011 um 08:01 Uhr
Kann mich da Aqui nur anschließen, aufgrund der inkompatibilität der HP Switche zu Standard Protokollen hatte ich auch die nette Erfahrung das man damit "mal" eben das gesamte Netz lahmlegt.

Ich würde auf dauer die gesamten HP Kisten austauschen und die ggf. nur noch im äußeren Access Bereich einsetzen (wenn überhaupt) das wird dir jede Menge Probleme ersparen
Bitte warten ..
Mitglied: halooos111
19.12.2011 um 14:00 Uhr
hey, danke für die schnelle Antwort aber es hat leider bei mir nicht funktioniert.

ich habe folgendes gemacht: STP auf beide ausgeschaltet

show running interface auf port 1: (Tagged mit hp switch)

switchport trunk native vlan 2
switchport trunk allowed vlan 1
switchport mode trunk


show running interface auf port 3: (untagged in vlan 2)

switch port access vlan 2
switchport mode access
spanning-tree port fast
aber mein mac bekommt kein ip vom der dhcp server

Gruß
Tony
Bitte warten ..
Mitglied: aqui
19.12.2011 um 16:08 Uhr
Das:
switchport trunk native vlan 2
switchport trunk allowed vlan 1
switchport mode trunk

Ist totaler Schwachsinn in der Konfig, sorry für die harten Worte aber genau so steht es nicht oben in der Antwort wie du es machen sollst !!!
Lies dir doch bitte die Feedbacks auf deinen Thread genau durch und halte dich auch daran wenn du ein Erfolgserlebnis haben willst !!!
switchport trunk native vlan 2 = Diese Kommando überträgt das VLAN 2 dann untagged an dem Port zum HP !! Genau das was du ja NICHT willst denn VLAN 1 soll untagged sein !
switchport trunk allowed vlan 1 = ist völliger Unsinn denn VLAN 1 wird immer untagged übertragen im Default.

Also nochmal ganz vom Anfang: Weg mit deiner völlig unsinnigen Konfig von Port 1 und konfiguriere bitte folgendes darauf:
interface FastEthernet0/1
description Tagged Link zum HP Switch
switchport mode trunk
(switchport trunk encapsulation dot1q)

Alles andere ist falsch !
Die Konfig für den Port 2 ist soweit OK.
Bitte tu uns allen hier einen Gefallen und lese die geposteten Informationen genau...wozu fragst du denn sonst hier, wenn du so oder so alles im freien Fall geraten ausprobierst ??
Bitte warten ..
Mitglied: marolli1983
07.06.2013 um 12:04 Uhr
Hallo,
Hab momentan ein Projekt für die Schule, soll einen cisco catalyst 2900 XL konfigurieren, klappt auch soweit bis auf meinen trunk port.
Bin zu Hause am ausprobieren und habe den switch an meinem Router hängen und meinen Laptop an einem vlan. Jetzt soll der trunk port aber untagged sein, und da Hänge ich. Ich weiß nicht wie ich es hinbekomme das alle vlans auf diesem trunk port untagged übertragen werden. Wenn ich es wie oben native mit dem vlan mache wo mein Lappi dran hängt geht es, aber so kann man ja nur ein vlan übertragen. Bräuche bitte Hilfe.
Bitte warten ..
Mitglied: aqui
07.06.2013 um 19:34 Uhr
Bitte keine Doppelposts hier im Forum !!:
http://www.administrator.de/contentid/207682

Dieses Tutorial erklärt die das bis ins Detail fertig zum Abtippen...sogar mit Cisco Catalyst Konfig UND der Firewall Kopplung !
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...

Einfacher gehts nicht !!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
LAN, WAN, Wireless
gelöst Cisco 2960-S, kein Failover in Etherchannel (6)

Frage von thaefliger zum Thema LAN, WAN, Wireless ...

Netzwerkgrundlagen
gelöst VLAN Verständnisfrage Tagged und Untagged - 2 Wege 1 Lösung (10)

Frage von epionier zum Thema Netzwerkgrundlagen ...

LAN, WAN, Wireless
gelöst Cisco hinter Fritz!box, vom VLAN kein Internet (3)

Frage von PharIT zum Thema LAN, WAN, Wireless ...

Router & Routing
gelöst Cisco SG300 - Kein Routing ins VLAN (4)

Frage von Fluxx1337 zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...