Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Netzwerke Router & Routing

GELÖST

Cisco 3750 Ip Http funktioniert nicht

Mitglied: fmario

fmario (Level 1) - Jetzt verbinden

30.03.2009, aktualisiert 12:58 Uhr, 9236 Aufrufe, 6 Kommentare

Hallo lieber Leser.

Ich habe ein wenig Probleme mit meinem Cisco 3750
und zwar kann ich mich nicht an dem Gerät Anmelden.

Folgendes habe ich Probiert :

Ich habe mich als Root an dem Router Angemeldet und nach dem Conf t habe ich
den Befehl Ip Http Server eingegen.

Wenn ich jetzt mit dem Internet Explorer über : Http://IpAdresse auf den Router connecte erhalte ich
diesen Bildschirm :

c2ad9a2b53a39e2857b74c714673c069-login-cisco-1 - Klicke auf das Bild, um es zu vergrößern

Dort gebe ich dann als Benutzer : root mit dem passenden Passwort ein, leider geht es dann aber nicht weiter.

Vieleicht habt Ihr einen Rat ....

Danke
Mario
Mitglied: aqui
30.03.2009 um 13:06 Uhr
Du verwechselst da wohl was...oder ??

Ein Cisco Switch hat mit einem Unix root User nicht das geringste zu tun da dort natürlich logischerweise gar kein Unix drauf rennt.

So löst du dein Problem:

Du telnettest den Switch oder nimmst die Konsole.
Dann ena und conf t
Nun gibst du ein username admin password admin
Mit ctrz-z verlässt du den Konfig Modus und sicherst die Konfig mit wr.

Ein Telnet und enable Passwort solltest du auch besser setzen wenn du es noch nicht gemacht hast !!!

Wenn du nun User: admin und bei Passwort: admin in deine Maske eingibst solltest du auf dem Switch landen !!
Bitte warten ..
Mitglied: fmario
30.03.2009 um 14:09 Uhr
Hallo.

Erstmal recht Herzlichen Dank für deine Hilfe.

Leider besteht das Problem weiterhin, ich habe deinen Tip umgesetzt aber
das Anmelde Fenster kommt trotzdem immer wieder.

Vieleicht noch eine Idee ?

Gruß
Mario
Bitte warten ..
Mitglied: aqui
30.03.2009 um 14:47 Uhr
OK, hier ist eine getestete lauffähige und funktionierende Konfig:

Web Zugangspassword ist "admin" und "admin".
Der Test zeigt das ein Username nicht einmal erforderlich ist !!
Es reicht ein Telnet Passwort und ein Enable Passwort !
Eins davon hast du vermutlich schlicht und einfach vergessen !

01.
Current configuration  
02.
03.
version 12.2 
04.
no service pad 
05.
service timestamps debug datetime msec 
06.
service timestamps log datetime localtime 
07.
no service password-encryption 
08.
09.
hostname Switch 
10.
11.
enable password admin 
12.
13.
no aaa new-model 
14.
clock timezone CET 1 
15.
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00 
16.
17.
spanning-tree mode rapid-pvst 
18.
spanning-tree extend system-id 
19.
20.
vlan internal allocation policy ascending 
21.
22.
interface FastEthernet0/1 
23.
 spanning-tree portfast 
24.
25.
usw. usw. Interfaces 
26.
27.
interface Vlan1 
28.
 ip address 172.16.1.254 255.255.255.0 
29.
 no ip route-cache 
30.
31.
ip http server 
32.
ip http secure-server 
33.
34.
line con 0 
35.
line vty 0 4 
36.
 password admin 
37.
 login 
38.
line vty 5 15 
39.
 login 
40.
41.
end 
42.
 
43.
Switch#
Wie du am nachfolgenden Screenshot sehen kannst funktioniert das einwandfrei !!

4f72a8613cb4858b23850705af878aaf-cisco - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: fmario
31.03.2009 um 12:09 Uhr
Hallo Aqui.

Ich glaube ich sollte da mal was erklären.
Also den Router habe ich aus dem Vorbestand des Werkes übernommen,
das Gerät ist verbaut und läuft Produktiv, dann sollte ich vieleicht noch hinzufügen daß das Gerät im Stack läuft.

Da ich deine Config nicht komplett übernehmen konnte habe ich nur folgendes übernommen :

Als erstes habe ich mich über Telnet auf den Router mit dem Benutzer . root Angemeldet (Volle Rechte)
dann habe ich folgende Befehle eingehackt.

conf t

enable password admin

ip http server
ip http secure-server

line con 0
line vty 0 4
password admin
login
line vty 5 15
login

Wie gesagt ich kenne mich mit dem Gerät fast garnicht aus, aber am Webinterface kann ich mich immernoch nicht Anmelden

Und durch die neue Configuration habe ich auch kaum noch Rechte auf dem Switch, z.b. kann ich mich mit dem alten Benutzer root nicht mehr Anmelden da nur noch eine Passwort abfrage kommt.

Es gab voher den User : root und einem Passwort mit vollen Rechten kann man den Uhrzustand wieder herstellen ?
Ich habe noch kein Write eingegeben, nehmen wir mal an Ich würde am WE ein Neustart vollziehen wären dann die Änderungen wieder weg. ?


Danke im voraus
Mario
Bitte warten ..
Mitglied: aqui
31.03.2009 um 15:18 Uhr
Dein Problem ist ein ganz anderes !!

Nochmals, da du es scheinbar nicht verstanden hast oder verstehen willst:
Einen User root gibt es NICHT bei Cisco und auf allen Cisco Geräten. Usernamen legt man selber lokal fest oder über externe Authentifizierungsserver (TACACS+ oder Radius) !!

Vermutlich hat derjenige, der den Router/Switch anfangs eingerichtet hat, eine externe User Überprüfung mit TACACS+ oder Radius konfiguriert.
Daher vermutlich auch dieser ominöse Name root der vermutlich einem Root User auf einer externen Unix Maschine entspricht.

Keinesfalls erlangst du damit immer Konfigurationsrechte oder volle Rechte auf dem Cisco Device, das ist ein Trugschluss !
Es ist das relevant, was auf diesem Radius oder TACACS+ Server als Rechte eingerichtet sind für einen User mit Namen root !! Das hat rein gar nix mit Unix Root Rechten zu tun !!
Lokal ist dafür einzig das enable password relevant sofern denn die Authentifizierung lokal ist, wenn in der Cisco Konfig z.B. username root passwort admin steht !!!
In der Beziehung bist du also voll auf dem Holzweg !!
Das bist du so oder so wenn du die Konfig des Systems nicht kennst !!

Du hast eine kleine Chance sofern der Router dieses Konfg Kommando für dich zulässt ?!
Dann kannst du lokal nur für den Web Zugang (HTTP) diese AAA oder lokale Benutzerprüfung lokal setzen oder gleich ganz abschalten.
Das geht mit dem Kommando:

ip http authentication local (Das erfordert aber eine username x password y Konfig !)

oder...
Du kannst aber auch die gesamte Authentifizierung am HTTP Server abschalten sofern deine Sicherheitsprinzipien dies zulassen !!
Das geht dann mit dem Kommando:

no ip http authentication enable

Mit einem der beiden Tricks sollte der Web Zugriff dann auf alle Fälle klappen !!!
Bitte warten ..
Mitglied: fmario
01.04.2009 um 09:33 Uhr
Hallo Aqui.

Also ich schätze sehr das du mir Hilfst, das ist trotzdem gerade kein Grund unhöflich zu werden.

Zitat :
(Nochmals, da du es scheinbar nicht verstanden hast oder verstehen willst: )
Zitat Ende :

Ich habe den Router neu gestartet um den Krempel wieder runter zu bekommen und wenn du dich
auf den Kopf stellst,
nach dem neustart mache ich eine gepflegte Telnet Session auf die Mühle und was sehe ich da ??

Eine Eingabe Aufforderung die dann auch gleich meinen User ROOT auch wenn du es nicht wahr
haben willst aktzeptiert,
mit dem passenden Passwort lande ich nun auf dem Router mit VOLLEN Rechten.

Und nein es gibt keinen Radius Server.

Der Befehl : ip http authentication local hat es nun endlich gebracht.

Also kann der Thread geschlossen werden.

Was eine Geburt nur für ein Stück Webinterface.

Trotzdem Danke.
Gruß
Mario
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Cisco Catalyst 3750 Grundkonfiguration
Frage von Thomas2Router & Routing5 Kommentare

Hallo, ich habe 3 Cisco Catalyst 3750 Switche, die zu einem Stack zusammengefasst werden sollen. Ich habe jedoch schon ...

Router & Routing
Cisco Stack mit 3x 3750-x klappt nicht
gelöst Frage von Thomas2Router & Routing13 Kommentare

Hallo Community, ich versuche einen Cisco Stack mit 3x 3750-x Switchen aufzubauen. 2 davon haben 12 GBIC Ports und ...

LAN, WAN, Wireless
Cisco Catalyst 3750 mit sporadischen PoE Problemen
Frage von HansWurstAugustLAN, WAN, Wireless13 Kommentare

Hallo zusammen, wir haben ab und zu mal das Problem das unsere Cisco Switches (3750) - 48 Port /8 ...

Router & Routing
Wie funktioniert DNAT mit einem Cisco 1841
gelöst Frage von Garibaldi69Router & Routing4 Kommentare

Hallo zusammen. Ich habe ein Problem mit der Konfiguration von NAT. Mein Problem sieht so aus: Router A (Cisco ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 2 TagenLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 3 TagenTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 3 TagenSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 3 TagenSicherheit12 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
Firewall
Penetrationstester-Labor - Firewalls
Frage von Oli-nuxFirewall10 Kommentare

Mich würde interessieren warum man beim Einrichten eines Penetrationstester-Labor (VMs) die Firewall der Systeme deaktivieren soll? Hat das nur ...

SAN, NAS, DAS
Wer kennt sich mit QNAP und CISCO aus ?
gelöst Frage von MachelloSAN, NAS, DAS9 Kommentare

Hallo Zusammen hier im Forum, Ich habe ein QNas 451+ und dieses NAS hat zwei GBit Lan Adapter die ...

Netzwerkgrundlagen
IPv6 Inter-VLAN Routing
gelöst Frage von clSchakNetzwerkgrundlagen9 Kommentare

Hi ich befasse mich gerade mit der Implementierung von IPv6 was bisher (in einem VLAN) korrekt funktioniert inkl. DNS ...

Windows Netzwerk
Zugriff auf den Desktop Ordner eines anderen Rechners in der gleichen Domäne
gelöst Frage von JensNomaWindows Netzwerk6 Kommentare

Guten Abend, ich war neulich mit unserem Admin am Tisch gesessen. Er an seinem Notebook angemeldet mit dem Domänen-Admin, ...