Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Cisco Catalyst 2950 - Web Interface ohne Funktion

Frage Hardware Switche und Hubs

Mitglied: jayjay0911

jayjay0911 (Level 2) - Jetzt verbinden

28.12.2012, aktualisiert 17:04 Uhr, 8548 Aufrufe, 17 Kommentare

Hi Leute,
ich habe hier zum basteln und probieren einen Cisco Catalyst 2950 mit dem IOS c2950-i6k2l2q4-mz.121-22.EA14.bin. Im Flash liegt ebenfalls der html Ordner mit den Files drin. Laut einigen Seiten wird das Web Interface durch den einfachen Befehl ip http server aktiviert. Jedoch bekomme ich über den Browser keine Verbindung. Es passiert einfach nichts (Internet Explorer cannot display the webpage). Proxy ist deaktiviert.
Jetzt meine Frage: Mit welchen Debugbefehlen kann ich auf dem Switch am besten überprüfen, ob der HTTP-Server läuft und ob meine Anfrage überhaupt ankommt?

Ach so: Access Lists o.ä. die den Zugriff blockieren könnten sind nicht konfiguriert.

Bin für alle Ideen dankbar.

Gruß jayjay0911
Mitglied: cheatercrack
28.12.2012 um 10:14 Uhr
Hallo jayjay0911,

hast Du auch überprüft, auf welchem Port der Server läuft und ob ggf. HTTPS gefordert wird?


Gruß,

Philipp
Bitte warten ..
Mitglied: jayjay0911
28.12.2012 um 10:18 Uhr
Hi cheatercrack,
alles Standard auf dem Catalyst, sprich Port 80. https geht nicht, der Befehl http ip secure-server wird nicht akzeptiert, denke, das IOS kann das nicht.
Bitte warten ..
Mitglied: Dobby
28.12.2012, aktualisiert um 10:20 Uhr
Hallo jayjay0911,

Es passiert einfach nichts (Internet Explorer cannot display the webpage). Proxy ist deaktiviert.
Kann es sein, dass das Webinterface vielleicht erst einmal aktiviert oder freigegeben werden muss?
Oder kurz um, kannst Du nicht erst einmal versuchen das Webinterface frei zu geben, um es danach
zu benutzen! Denn nicht alle Administratoren aktivieren das Webinterface, wohl aus Sicherheitsgründen zur Konfiguration.

Gruß
Dobby

P.S.

Ich würde versuchen per CLI oder SSH Terminal das Webinterface zu aktivieren und es dann noch einmal versuchen.
Bitte warten ..
Mitglied: jayjay0911
28.12.2012 um 10:28 Uhr
Durch den Befehl ip http server ist das Web Interface ja aktiviert. Ich habe auch schon versucht, diesen mal zu deaktiveren, Switch neu booten, Befehl wieder rein, neu booten. Hat auch nichts gebracht. Sind vielleichts die Files des http Servers defekt??

Ach so, ein debug ip tcp packet zeigt mir an, dass die Anfrage von meinem Rechner auf Port 80 bei dem Switch ankommt.
Bitte warten ..
Mitglied: Dobby
28.12.2012 um 10:38 Uhr
Hallo jayjay0911,

so wie ich das heraus gelesen habe ist das ein Cisco Switch den Du Dir gebraucht geholt hast, richtig?
Bitte korrigiere mich wenn ich da was nicht richtig verstanden habe!
Und mit diesem Switch möchtest Du jetzt etwas "herum spielen" und üben, kurz um alles erkunden
was der Switch bietet um sicherer zu werden, richtig? Das selbe wie oben wenn nicht bitte gleich
melden! Also ganz im Ernst, ist zwar etwas unpopulär und sicherlich auch nicht unspektakulär, aber
ich würde den Switch zuerst "resetten" also ein "restore defaults" durchführen um den Switch in den
Werkszustand zu versetzen und dann das Firmware update durchführen!

Das spart Zeit und dann sind auch keine Einstellungen und/oder Konfigurationen drauf die von nicht Dir gemacht worden sind!!

Gruß viel Erfolg und guten einen Rutsch in neue Jahr
Dobby
Bitte warten ..
Mitglied: jayjay0911
28.12.2012 um 10:43 Uhr
Hi D.o.b.b.y,
danke für den Tipp. Das ist richtig, der Switch war konfiguriert. Ich habe diesen allerdings platt gemacht, sprich mit leerer Konfig versehen, gebootet. Anschließend das Firmwareupdate durchgeführt (tar-File auf dem Switch entpacken lassen). Anschließend eine kleine Grundkonfiguration vorgenommen (VLAN1-IP, etc.), wo ich auch den http Server aktiviert habe.
Der Switch hat also von Anfang an bei einer (fast) leeren Konfig nicht den http Server gestartet bzw. nur fehlerhaft.
Daher würde ich auf ein defektes tar-File tippen.
Mich würde aber noch interessieren: Gibt es irgendeinen Befehl, mit dem ich mir anzeigen lassen kann, ob der http-Server läuft?
Bitte warten ..
Mitglied: Dobby
28.12.2012 um 10:59 Uhr
Hallo jayjay0911,

schau Dir die beiden Beiträge hier einmal an und versuch Dein Gück.

How to Enable a Web Interface on a Cisco Catalyst

Enabling WebGUI on a Cisco Catalyst 2960

Vielleicht bringt Dich das ja weiter, ansonsten wäre die Bedienungsanleitung und die "CLI Command reference" oder CLI Befehlsliste, immer die beste Wahl bei solchen Geräten! Ist zwar nur meine Meinung,
aber wenn Du die Bedienungsanleitung durch gelesen hast und auch die CLI Befehlsliste Dein Eigen
nennst kannst Du qamit richtig loslegen und je mehr Du über den Switch ließt um so besser verstehst Du Ihn und seine Funktionsweise auch. Was auch nett ist einfach die Bedienungsanleitung einmal
komplett mit "learning by doing" durch gehen, das bleibt dann im Gedächtnis besser haften.

Cisco Catalyst Config Guide PDF Datei

CLI Command Reference HTML Datei

Gruß
Dobby
Bitte warten ..
Mitglied: MrNetman
28.12.2012 um 11:41 Uhr
Hi zweizylinder porsche

Kann es sein, dass das Web-Interface beim 2950 eher eine überflüssige Funktion denn eine sinnvolle Konfigurationsoberfläche ist?
Test einfach via "telnet ip 80" auf den Switch. Dann siehst du wenigstens ob der Service läuft.

Gruß
Netman
Bitte warten ..
Mitglied: jayjay0911
28.12.2012 um 11:51 Uhr
Klappt...also insoweit, dass kein Could not open connection to host erscheint, sondern ein einfacher blinkender Cursor.
Klar, das Web Interface ist nicht der Knaller, aber hier geht's einfach nur um die Funktionalität.

P.S. Selbe Config auf einem anderen Switch mit älterem IOS und das Web Interface läuft sofort. Werde es deshalb mal mit einem älteren IOS ausprobieren.
Bitte warten ..
Mitglied: aqui
28.12.2012 um 12:10 Uhr
Das Webinterface ist immer eine überflüssige Funktion denn es gilt immer "real men do CLI !" Aber egal.
Eine grundlegende Frage die nicht beantwortet wurde:
Kannst du den Switch überhaupt per Telnet erreichen oder anpingen aus dem IP Netzwerk ??
Das ist Grundvoraussetzung damit auch der HTTP Zugriff funktioniert !
In der Grundkonfig reicht ein ip http-server vollkommen aus in der Konfig.
Wenns nicht klappt, kann es sein das Vorbesitzer im Flash Filesystem rumgefummelt haben.
Mach einfach ein Upgrade auf eine aktuelle IOS Version und gut ist !!
Damit kommt auch dein HTTP Webserver wieder ans Fliegen....
Obwohl das CLI Interface wahrlich sinnvoller und intuitiver ist ! Aber egal, wer Klicki Bunti gewöhnt ist.....
Bitte warten ..
Mitglied: jayjay0911
28.12.2012 um 12:17 Uhr
Wie schon erwähnt, hier geht's nur um die Funktionalität für Tests, etc. Darüber soll nix konfiguriert werden, also nix Klicki Bunti...
Flash wurde bereits formatiert und IOS-tar-File komplett neu eingespielt, keine Veränderung.
Ping geht einwandfrei, auch telnet (auch über Port 80).
Bitte warten ..
Mitglied: MrNetman
28.12.2012 um 12:26 Uhr
Ich habe schon erlebt, dass die 2950er trotz identischer Hardware und Firmware ID und Versionsnummer unterschiedlich gearbeitet haben. Etwa die Hälfte der gut verteilten Switche hat andere SNMP-Antworten geliefert als die anderen. Ich konnte von aussen keine Unterschiede feststellen. Nur durch probieren der unterschiedlichen Anfragen bin ich dahinter gekommen. Am Ende hat das Netz sauber funktioniert. Der Glaube an die eigene Wahrnehmung hat zwischenzeitlich aber gelitten

Gruß
Netman
Bitte warten ..
Mitglied: aqui
28.12.2012, aktualisiert um 14:23 Uhr
Trotzdem liegt der Fehler da wohl irgendwie zwischen Stuhl und Tastatur....
Die Release Notes hast du gelesen ?? Wenn du upgradest vorher delete /r /f flash:html ausführen um die alten HTML Files zu löschen !

Beispielkonfig 2950:
01.
version 12.1 
02.
service timestamps debug uptime 
03.
service timestamps log datetime localtime 
04.
05.
hostname cat2950 
06.
07.
clock timezone CET 1 
08.
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00 
09.
10.
spanning-tree mode rapid-pvst 
11.
no spanning-tree optimize bpdu transmission 
12.
spanning-tree extend system-id 
13.
14.
interface FastEthernet0/1 
15.
16.
interface FastEthernet0/2 
17.
...(gekürzt der Länge wegen...) 
18.
19.
interface GigabitEthernet0/2 
20.
21.
interface Vlan1 
22.
 ip address 192.168.7.211 255.255.255.0 
23.
 no ip route-cache 
24.
25.
ip http server 
26.
27.
line con 0 
28.
line vty 0 4 
29.
 password cisco 
30.
 login 
31.
line vty 5 15 
32.
 login 
33.
34.
end 
Hier das Flash Filesystem:
01.
cat2950#dir 
02.
Directory of flash:/ 
03.
 
04.
    2  drwx        4416  Mar 01 1993 01:41:06 +01:00  html 
05.
    3  -rwx         334  Mar 01 1993 01:02:10 +01:00  env_vars 
06.
    5  -rwx     3721946  Mar 01 1993 01:40:07 +01:00  c2950-i6k2l2q4-mz.121-22.EA13.bin 
07.
    6  -rwx        1401  Mar 01 1993 01:05:55 +01:00  config.text 
08.
    7  -rwx         112  Mar 01 1993 01:37:09 +01:00  info 
09.
  332  -rwx         736  Sep 10 2009 18:02:45 +02:00  vlan.dat 
10.
   85  -rwx         112  Mar 01 1993 01:41:40 +01:00  info.ver 
11.
  333  -rwx          24  Mar 01 1993 01:05:55 +01:00  private-config.text 
12.
 
13.
7741440 bytes total (2144256 bytes free) 
14.
cat2950# 
Zugriff mit Webbrowser Firefox, Safari und Co.....

6e05fe9358db3078aee100f3e09c043a - Klicke auf das Bild, um es zu vergrößern

Schafft eigentlich auch jeder Anfänger....?!
Bitte warten ..
Mitglied: jayjay0911
28.12.2012 um 14:25 Uhr
Jetzt's klappts. Nach Sicherung der Konfig, Flash-Formatierung, IOS aufspielen, Konfig zurückkopieren funktioniert es. Allerdings kann ich immer noch nicht genau sagen, wo der Fehler lag.
Bitte warten ..
Mitglied: panguu
26.09.2014 um 13:22 Uhr
Ich häng mich mal hier an diesen älteren Fred dran, denn ich habe dasselbe Problem. Ich habe mittlerweile drei WS-C3560G Modelle von ipbase auf ipservicesk9 upgegradet, und ich komm über Web einfach nicht drauf. ip http server und secure-server sind aktiv, port 80 und 443 sind offen und darauf verbindet sich auch der Client/Webbrowser. Jedoch erscheinen nur 4 Symbole, man kann nix anklicken, leere Tabelle, kein Text. Man kann gar nix anstellen. Ich habe diverse Clients und Browser probiert (Firefox, Opera, IE, usw...) nur von einem Debian Wheezy Client mit IceWeasel kann ich die Seite korrekt anzeigen und bedienen.

Nun hat aqui geschrieben:

Wenn du upgradest vorher delete /r /f flash:html ausführen um die alten HTML Files zu löschen !

Das habe ich tatsächlich nicht gelesen und gewußt. Liegt es also daran? Aber wieso kann der Iceweasel auf meinem DebianHost sich problemlos verbinden und die Seite anzeigen? Das ergibt ja irgendwie auch keinen Sinn ?

Kann ich das irgendwie dingfest machen und überprüfen, ob's an dem Flash-Inhalt und diesen html-Ordner liegt? Und kann ich das nachträglich fixen, oder müßte ich da den kompletten switch wieder erneut flashen und reloaden (das wäre blöd).
Bitte warten ..
Mitglied: aqui
26.09.2014 um 17:10 Uhr
Die Web GUI nutzt Java. Das ist die Crux, denn viele aktuelle Browser blocken aus Sicherheitsgründen Java Inhalte oder du musst sie im Setup explizit freigeben. Bei manchen passiert das auch mit Flash Inhalten !
Es ist auch möglich das du einen Java Versions Mismatch hast und ältere (oder auch neuere) Java Versionen das nicht anzeigen. Hier hilft dann ein Java Update. Vergleiche das mit der Java Version auf dem Debian. "java -v" gibt die Version aus.
Bei Cisco ist die erste Anlaufstelle immer das System Log !! Was sagt also ein "show logg" ? Ist da was zu sehen ??
Ansonsten debugst du das mal mit dem debug Kommando ob dort wa relevantes kommt.
Nachher undebug all nicht vergessen !
Bitte warten ..
Mitglied: panguu
28.09.2014 um 12:38 Uhr
Also laut http://www.java.com/verify ist mein Java in Ordnung, ich krieg 'nen grünen Haken und die Info "Herzlichen Glückwunsch, Sie haben die empfohlene Java-Version installiert, Version 7 update 67. Es wurden keine veralteten Java-Versionen gefunden." Ich hab ja auch 3 andere Clients probiert, ebenfalls mit jeweils IE + Firefox. Da geht's auch nicht, und die sind auch alle Java-aktuell. Dann hab ich trotzdem mal in meinem Firefox die fehlerhaft dargestellte Switch-WebUI geöffnet, und dann links neben der Adresszeile auf den Globus geklickt, auf dem man die Site-Konfiguration durchführen kann. Ich habe explizit JAVA erlaubt, aber das brachte auch keine Änderung.

Auf der Debian-Kiste, bei der es komischerweise zu funktionieren scheint, gibt ein "java -version" aus:

java version "1.6.0_32"
OpenJDK Runtime Environment (IcedTea6 1.13.4) (6b32-1.13.4-1~deb7u1)
OpenJDK 64-Bit Server VM (build 23.25-b01, mixed mode)

Wie soll mir das nun aber weiterhelfen?

Auf dem switch habe ich "sh logging" bemüht, aber keine relevanten Informationen (außer link-state-changes up/down) zu entnehmen. Wie ich "debug" anwenden sollte ist mir auch unklar. Ein "debug all" wollte ich mich nicht trauen, und ein "debug http" oder ähnlich klingend, konnte ich nicht finden. Wie kann ich also den http-traffic des http-servers debuggen?
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...