Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Cisco Catalyst 3750 InterVLAN Routing

Frage Netzwerke Router & Routing

Mitglied: Kosh

Kosh (Level 2) - Jetzt verbinden

16.02.2007, aktualisiert 17.02.2007, 9577 Aufrufe, 3 Kommentare

Guten Abend Leute.

ich sitze hier vor einer echten (zumindest für mich) problemstellung.

ich habe einen cisco catalyst 3750, und auf diesem vlans konfiguriert.
aber aus irgendeinem grund routet er zwischen den vlans nicht.
ich hab nun zB die ip: 192.168.2.200 (default vlan) und als gateway: 192.168.2.253 (den catalyst)
wenn ich nun meinen dhcp server 192.168.3.9 anpinge (ein server der direkt am switch hängt, port ist auf VLAN_3 konfiguriert)

ip-adressen beziehen vom dhcp funktionert auch nicht, obwohl ich einen neuen multicastbereich am dhcp angelegt habe.

anbei mal die config:

01.
interface Vlan1 
02.
 ip address 192.168.2.253 255.255.255.0 
03.
 ip helper-address 192.168.3.255 
04.
05.
interface Vlan3 
06.
 ip address 192.168.3.253 255.255.255.0 
07.
08.
interface Vlan4 
09.
 ip address 192.168.4.1 255.255.255.0 
10.
 ip helper-address 192.168.3.255 
11.
12.
ip default-gateway 192.168.3.1 
13.
ip classless 
14.
ip route 0.0.0.0 0.0.0.0 192.168.3.1 
15.
ip http server 
16.
 
bitte um rasche hilfe.
Mitglied: brammer
16.02.2007 um 23:22 Uhr
Guten Abend Leute.

ich sitze hier vor einer echten (zumindest
für mich) problemstellung.

ich habe einen cisco catalyst 3750, und auf
diesem vlans konfiguriert.
aber aus irgendeinem grund routet er
zwischen den vlans nicht.
ich hab nun zB die ip: 192.168.2.200
(default vlan) und als gateway: 192.168.2.253
(den catalyst)
wenn ich nun meinen dhcp server 192.168.3.9
anpinge (ein server der direkt am switch
hängt, port ist auf VLAN_3
konfiguriert)

ip-adressen beziehen vom dhcp funktionert
auch nicht, obwohl ich einen neuen
multicastbereich am dhcp angelegt habe.

anbei mal die config:

01.
> interface Vlan1 
02.
>  ip address 192.168.2.253 255.255.255.0 
03.
>  ip helper-address 192.168.3.255 
04.
 
05.
 
06.
wieso nimmst du die Broadcast adresse als helper adresse ??? 
07.
nimm mal die .254 
08.
 
09.
 
10.
> ! 
11.
> interface Vlan3 
12.
>  ip address 192.168.3.253 255.255.255.0 
13.
> ! 
14.
> interface Vlan4 
15.
>  ip address 192.168.4.1 255.255.255.0 
16.
>  ip helper-address 192.168.3.255 
17.
> ! 
18.
> ip default-gateway 192.168.3.1 
19.
> ip classless 
20.
> ip route 0.0.0.0 0.0.0.0 192.168.3.1 
21.
> ip http server 
22.
>  
23.
> 
bitte um rasche hilfe.
Bitte warten ..
Mitglied: aqui
16.02.2007 um 23:52 Uhr
Die .254 als Helper Adresse zu nehmen ist vollkommener Unsinn ! Auf der Adresse gibt es ja gar keinen Host ! Broadcasts die über die Helper Adresse vom Switch dahin geforwardet werden landen also im Nichts....
Wenn, dann muss es die 192.168.3.9 sein, denn das ist ja dein physischer DHCP Server für den wirklich diese BOOTP Broadcasts (DHCP) bestimmt sind !!
Eigentlich kannst du beides machen denn der Cisco forwardet den DHCP Request auf das .3.0er Segment als Multicast wenn du die .255 nimmst. Es kann aber sein das dein Server das nicht mag, also gib erstmal besser die dedizierte Adresse des DHCP Servers an, also die 192.168.3.9, dann wird das als Unicast direkt an den DHCP Host gesendet.
(Vorher mit "no ip help..." die .255 entfernen, sonst wird es doppelt geforwardet !)

Als 2ter Punkt ist deine default Route nicht ganz korrekt also entweder default Gateway oder default Route !!!
Das default Gateway solltest du weglöschen, die default Route reicht !

Ansonsten ist die Konfig korrekt. Leider ist deine Beschreibung WIE du das Routing testest etwas dürftig !!??
Vermutlich hast du 2 PCs in den unterschiedlichen VLANs .2.0 und .4.0 ?! Es sollte klar sein das die jeweilegen default Gateway Einträge dieser PCs auf die entsprechnde IP Addresse des Vlanx Interfaces zeigen sollte in dem sich diese PCs befinden !!!

Ein Ping an das Vlanx Interface muss erfolgreich sein. Ist es das nicht, steckst du vermutlich im falschen VLAN und hast die Portzuordnung zu den VLANs falsch gemacht.
Um nicht von DHCP abhängig zu sein solltest du diesen Test erstmal mit statischen IP Adressen machen.
Damit sollte ein Routing von VLAN zu VLAN problemlos möglich sein.

Ein Multicastbereich musst du am DHCP Server nicht einrichten...was soll das sein ???
Vermutlich meinst du ein weiteres Subnetz !?
Du musst natürlich 2 eintragen nämlich 192.168.2.0/24 und 192.168.4.0/24. Die Gateways die mitgegeben werden sind dann logischerweise immer die VLAN IPs des Switches passend zum Subnetz bzw. VLAN !!!
Bitte warten ..
Mitglied: Kosh
17.02.2007 um 00:18 Uhr
ahoi.

als erstes mal danke für die schnellen antworten.
ich wollte nur mal anmerken dass ich, wie es wohl vielen anderen auch schon mal passiert ist, den wald vor lauter bäumen nicht gesehen habe.

problem war:
ich hatte zwar bei vlan_4 bei den clients als gateway das vlan_4 interface des 3750ers, aber bei den vlan_3 clients (die ja noch die settings vom dhcp server bekamen) noch die 192.168.3.1 als gateway drin.

man glaubt gar nicht wie schnell das funktioniert wenn man dann erst am dhcp-server das richtige gateway einstellt ; )

also nochmal danke an alle, für die hilfe (vor allem zu so später stunde)

Grüsse

Kosh
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Cisco Catalyst 3750 Grundkonfiguration
Frage von Thomas2Router & Routing5 Kommentare

Hallo, ich habe 3 Cisco Catalyst 3750 Switche, die zu einem Stack zusammengefasst werden sollen. Ich habe jedoch schon ...

LAN, WAN, Wireless
Cisco Catalyst 3750 mit sporadischen PoE Problemen
Frage von HansWurstAugustLAN, WAN, Wireless13 Kommentare

Hallo zusammen, wir haben ab und zu mal das Problem das unsere Cisco Switches (3750) - 48 Port /8 ...

Router & Routing
Router für InterVLAN Routing gesucht
gelöst Frage von Ch3p4cKRouter & Routing21 Kommentare

Hallo zusammen, ich bin auf der Suche nach einem Router, den ich zum Routen zwischen VLANs nutzen kann. Zur ...

Router & Routing
InterVlan routing auf HP2920 Pro Curve
gelöst Frage von KomaKurtRouter & Routing10 Kommentare

Hallo zusammen, ich hätte einmal eine Frage zum Thema Vlans Bin neu in dem Thema und versuche immer noch ...

Neue Wissensbeiträge
Verschlüsselung & Zertifikate

Die Hölle friert ein weiteres Stück zu: Microsoft integriert OpenSSH in Windows

Information von ticuta1 vor 8 MinutenVerschlüsselung & Zertifikate

Interessant SSH-Kommando in CMD.exe und PowerShell

Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 1 TagApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 1 TagWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 1 TagWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Heiß diskutierte Inhalte
Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server18 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Hardware
Kein Bild mit nur einer bestimmten Grafikkarten - Mainboard Konfiguration
gelöst Frage von bestelittHardware18 Kommentare

Hallo zusammen, ich hatte schon einmal eine ähnliche Frage gestellt. Damals hatte ich genau das gleiche Problem. Allerdings lies ...

Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement17 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...