Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Cisco IPSEC Tunnel über Externen Router

Frage Netzwerke Router & Routing

Mitglied: Dkuehlborn

Dkuehlborn (Level 1) - Jetzt verbinden

20.07.2010, aktualisiert 18.10.2012, 6831 Aufrufe, 11 Kommentare

Hallo Forum,

ich muss zwischen 2 Standorten in Deutschland und Griechenland einen VPN IPSEC Tunnel aufbauen. Hierzu stehen mir zwei Cisco-Router 1811 zur Verfügung.
Da ich die Interneteinrichtung in Griechenland nicht kenne gehe ich davon aus, dass ich dort einen Router bekomme, der die Internetverbindung herstellt und ich meinen Cisco-Router dahiner schalten muss. In Griechenland ist an dem Internetanschluß ein Tarif mit einer Statischen IP-Adresse geschaltet.

Hier nun mein geplantes Setup:

RouterGR

Fe0: 192.168.1.10 / 255.255.255.0 / Gateway 192.168.1.1 / DNS 192.168.1.1 (Interface ist an Router für Internet angeschaltet)
Fe1: 192.168.110.254 / 255.255.255.0

RouterDE
Fe0: 111.222.333.444 / 0.0.0.0 (Direkter Anschluß an öffentliche IP-Adresse z.B. CompanyConnect o.ä.)
Fe1: 192.168.120.254 / 255.255.255.0

Hier ein Auszug eines typischen Setups für ein GRE-IPSEC-Tunnel, wie ich es schon öffters verwendet habe:

RouterGR:

crypto isakmp policy 20
encr 3des
hash md5
authentication pre-share
group 2
crypto isakmp key PRESHAREKEY address 111.222.333.444
crypto isakmp invalid-spi-recovery
!
!
crypto ipsec transform-set TRANSSET esp-3des esp-md5-hmac
!
crypto map IPSECMAP 1 ipsec-isakmp
set peer 111.222.333.444
set transform-set TRANSSET
match address 101
!
interface Tunnel1
description $FW_INSIDE$
ip address 192.168.195.2 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1432
ip route-cache flow
tunnel source FastEthernet0
tunnel destination 111.222.333.444
crypto map IPSECMAP
crypto ipsec df-bit clear

Nun zu meinen Fragen:

Welche Ports muss ich in Griechenland am Internetrouter weiterleiten, damit ein IPSEC-Tunnel aufgebaut werden kann?
Wie sehen die Parameter aus für z.B. Tunnel source oder Tunnel destination?

Ich hoffe, dass diese Infos ausreichen, um meine Fragen zu klären.

Ansonten danke ich im Voraus für die Bemühungen

Viele Grüße

Dieter
Mitglied: wiesi200
20.07.2010 um 22:04 Uhr
Hey, ich steh im augenblick vor genau dem gleichen Problem in Amerika
Danke das du schon fragst.
Bitte warten ..
Mitglied: Bloedman
20.07.2010 um 22:15 Uhr
?
Steht hier auch in einer Anleitung " UDP500, UDP4500 und TCP10.000 und IP Protokoll ESP zwischen den VPN Partnern offen sind"

Gruss
Bitte warten ..
Mitglied: brammer
20.07.2010 um 22:18 Uhr
Hallo,

nur zum Verständnis, hast du in Deutschland und in Griechenland je einen 1811 mit fester IP als Endpunkt?
Wenn ja, dann bau den IP Sec Tunnel zwischen beiden Router auf und gut ist.
Du kannst keine IPSec Tunnel zwischen einer öffentlichen IP und einer privaten IP aufbauen die hinter einer ROuter mit öffenlticher IP liegt .
Wie soll der Router mit der öffentlichen IP wissen das die gegenseitehinter einer öffnetlichen IP liegt??

Außerdem, wenn du es schaffst 111.222.333.444 in den Router zu konfigurieren hast du adhoc IPv6 überflüssig gemacht!!

brammer

P.S.:
geht auch in America

brammer
Bitte warten ..
Mitglied: wiesi200
20.07.2010 um 22:29 Uhr
Zitat von brammer:

P.S.:
geht auch in America

Schön währ's. Irgendwas zwickt da noch, zumindest bei mir. Obwohl ich zwei feste IP's habe
Bitte warten ..
Mitglied: brammer
20.07.2010 um 22:35 Uhr
Hallo,

dann ist irgendwo ein Fehler in der Config.

Was bekommst du denn für eine Fehlermeldung?

brammer
Bitte warten ..
Mitglied: wiesi200
20.07.2010 um 22:57 Uhr
Ich sehe da
Session disconnected Reason: Unknown
Removing peer from correlator table faild, no match!
construct_ipsec_delete(): No SPI to identify Phase 2 SA!
Bitte warten ..
Mitglied: Dkuehlborn
21.07.2010 um 07:19 Uhr
Hallo an alle,

da habe ich ja eine gutu Diskussion in Gang gebracht.

@brammer
Die IP-Adresse 111.222.333.444 ist eine symbolische Adresse für eine normale öffentliche Adresse im IPv4-Raum, damit ich keine echte Adresse posten muss.
Der externe Router in Griechenland baut die Verbindung im Internet auf und erhält dabei immer die selbe öffentlichen IPv4-Adresse. Es ist vergleichbar, we bei uns mit einem TDSL-Business. Dort findet eine vermutlich eine PPPoE-Einwahl statt.

@Bloedman
Danke für Deine Info. Kannst Du mir hierzu mal einen Link schicken?
Ich bin mal gespannt, ob die das IP-Protokoll ESP weiterleiten kann, wie eine Portweiterleitung. Ich habe schon manche Router in der Hand gehabt, dort konnte ich nur die Protokolle UDP und TCP weiterleten. Sepratae IP-Protokolle wie z.B. GRE oder ESP waren nicht Möglich.

@wiesl200
Ich hatte mal ein ähnliches Problem in den USA. Dort konnte ich keinen IPSec-Client zum Laufenbringen. Der Provider hatte diverse ausgehende Ports geschlossen. Die sind dort ziemlich restriktiv.


Vielen Dank für die rege Beteiligung und Infos

Dieter
Bitte warten ..
Mitglied: wiesi200
21.07.2010 um 09:10 Uhr
So, jetzt haben wir's am laufen. 2 Parameter haben nicht exakt übereingestimmt.

Ich sag auch noch mal Danke für die Hilfe
Bitte warten ..
Mitglied: Dkuehlborn
21.07.2010 um 10:04 Uhr
Hallo Wiesi200,

kannst Du mir erläutern, wie Du diese Installation zum Laufengebracht hast?

VG Dieter
Bitte warten ..
Mitglied: aqui
21.07.2010, aktualisiert 18.10.2012
Port Forwarding muss man nur dann machen wenn VOR dem VPN Router noch ein NAT Router steht. Sonst logischerweise natürlich nicht, wenn man eine öffentliche IP Adresse bekommt.

Cisco benutzt IPsec im ESP Format. Das sind die Ports UDP 4500, UDP 500 und das IP Protokoll Nr. 50 (ESP)

Lauffähige Cisco VPN Config findest du hier:
http://www.administrator.de/Vernetzung_zweier_Standorte_mit_Cisco_876_R ...
bzw.
http://www.administrator.de/wissen/ipsec-vpn-auf-m0n0wall-oder-pfsense- ...


Wenns das denn war bitte
http://www.administrator.de/index.php?faq=32
nicht vergessen !!
Bitte warten ..
Mitglied: Dkuehlborn
26.07.2010 um 19:06 Uhr
Hallo Aqui,

ich habe es zum laufen gebracht. Die Protweiterleitung von UDP 500 hat ausgereicht.

Vielen Dank für die Unterstützung.

Dieter
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Mikrotik - Cisco RV042 IPSec VPN Tunnel
Frage von AndroxinRouter & Routing5 Kommentare

Moin, ich probiere gerade einen Mikrotik Router mit einem CISCO RV042 Router über einen IPSec Tunnel zu verbinden. (Siehe: ...

Router & Routing
Routingproblem IPsec Tunnel
gelöst Frage von tvprog1Router & Routing3 Kommentare

Hallo, folgende Konstellation: Eine Firewall hat drei Interfaces (eth1, eth2 und eth3). eth1 (5.1.1.10/30) dient als Transfernetz zum Provider ...

Router & Routing
Problem mit Cisco Router für IPSEC mit VPN Client einzuwählen
gelöst Frage von frank99Router & Routing10 Kommentare

Hallo Forum-Gemeinde, ich probiere schon seit einigen Tagen, aber irgendwo hängt das Problem ich will vom VPN-Client auf einem ...

Netzwerkmanagement
Bester IPSEC Client für VPN-Verbindung zu CISCO Router
Frage von istike2Netzwerkmanagement4 Kommentare

Hallo, wir müsste zu einem Kunden (bzw. auf seinen Cisco-Router) IPSEC VPN einrichten. Kann jemand für mich einen Windows ...

Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 17 StundenWindows 102 Kommentare

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 19 StundenSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 1 TagInternet3 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 1 TagDSL, VDSL2 Kommentare

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
TK-Netze & Geräte
VPN-fähige IP-Telefone
Frage von the-buccaneerTK-Netze & Geräte16 Kommentare

Hi! Weiss noch jemand ein VPN-fähiges IP-Telefon mit dem man z.B. einen Heimarbeitsplatz gesichert anbinden könnte? Habe nur einen ...

Windows Server
GPO nur für bestimmte Computer
Frage von Leo-leWindows Server13 Kommentare

Hallo Forum, gern würde ich ein Robocopy script per Bat an eine GPO hängen. Wichtig wäre aber dort der ...

Windows Server
KMS Facts for Client configuration
Frage von winlinWindows Server13 Kommentare

Hey Leute, wir haben in unserem Netz nun einen neuen KMS Server. Haben Bestands-VMs die noch nicht aktiviert sind. ...

Windows Tools
Software-Tool zum Entfernen von bösartigem Windows
Frage von emeriksWindows Tools11 Kommentare

Hi, siehe Betreff hat das jemals irgendjemand schonmal sinnvoll eingesetzt? (MRT) E.