Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Cisco ISDN Router 803 anwahl funktioniert nicht

Frage Netzwerke Router & Routing

Mitglied: christiande

christiande (Level 1) - Jetzt verbinden

03.12.2006, aktualisiert 18.10.2012, 6354 Aufrufe, 17 Kommentare

Seit mehreren Tagen versuche ich nun schon meinen Router zu konfigurieren.
Ich möchte eigentlich nur mit 2 PCs über den Router eine ISDN Verbindung ins Internet nutzen. Als Provider nutze ich freenet.

Ich habe nun schon so oft das Fast Step Programm durchgespielt. Immer waren Test und Setup OK. Aber dennoch kriege ich keine Internet Verbindung hin. Der Router wählt sich nicht ein, wenn ich den Browser öffne.
Netzwerkeinstellungen sind auf DHCP.
Ich erreiche den Router mit meinem Browser und kann ihn anpingen. Die Weboberfläche wird angezeigt.
Aber er wählt sich nicht ein.
Beim Setup Test whärend der Installation mit Fast Step hat aber alles geklappt. Test war erfolgreich und die Einwahl auch. Nur beim Browser passiert überhaupt nichts.

Ich habe nun keine Ahnung von Cisco Routern. WEiß auch mit IOS nicht wirklich umzugehen.

Das kann doch nun nicht so schwer sein ODER?

Ich habe auch aus einem anderen Forum eine IOS Konfiguration gefunden, wo jemand behauptet, das es damit gehen soll. Aber wie kriege ich die auf meinen Router drauf?
Mit dem ConfigMaker 2.6 habe ich ebenfalls schon ewig herumprobiert.

Ich bin nahe am aufgeben!!

Bitte helft mir weiter!!
Mitglied: Dani
03.12.2006 um 19:10 Uhr
Hi,
könntest du mal die config posten?! Danke...

Soweit ich mich erinnere kannst du mit dem 803 DSL und ISDN fahren. Sprich ISDN wird normal nur als Backup genommen!
Was läuft den für ein Routingprotokoll??
DNS Server hinterlegt im DHCP Pool??

Gruß
Dani
Bitte warten ..
Mitglied: christiande
03.12.2006 um 20:19 Uhr
Hallo

Danke für die schnelle Antwort.
Hier die Konfiguration, die durch das einrichten mittels Cisco Fast Step entstanden ist. Einstellungen zu Routingprotokoll oder DNS Server sind während des Setup nicht einstellbar. Das weiß ich leider nicht. Aber vielleicht hilft der Script.

!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname ISDN
!
logging buffered 8192 debugging
no logging console
enable password systems
!
username 803 password 7 130416130A0D05
username ISDN password 7 070C285F4D06
!
dial-peer voice 1 pots
call-waiting
ring 0
port 1
destination-pattern 03526345766
!
dial-peer voice 2 pots
call-waiting
ring 0
port 2
destination-pattern 03526345768
!
pots country DE
ip subnet-zero
!
ip dhcp pool 1
network 192.168.10.0 255.255.255.0
default-router 192.168.10.100
!
no ip domain-lookup
isdn switch-type basic-net3
!
!
!
interface Ethernet0
description connected to EthernetLAN
ip address 192.168.10.100 255.255.255.0
no ip directed-broadcast
no ip proxy-arp
ip nat inside
!
interface BRI0
description connected to Internet
no ip address
no ip directed-broadcast
ip nat outside
encapsulation ppp
dialer rotary-group 1
isdn switch-type basic-net3
isdn voice-priority 035263xxxxx out always
isdn voice-priority 035263xxxxx in always
isdn voice-priority 035263xxxxx out always
isdn voice-priority 035263xxxxx in always
isdn incoming-voice modem
no cdp enable
!
interface Dialer1
description connected to Internet
ip address negotiated
no ip directed-broadcast
no ip proxy-arp
ip nat outside
encapsulation ppp
no ip split-horizon
dialer in-band
dialer idle-timeout 300
dialer string 0101901929 class 56K
dialer hold-queue 10
dialer load-threshold 10 outbound
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname aaaaaa
ppp chap password 7 1416130A0D052B
ppp pap sent-username aaaaaa password 7 15130A0D052B2A
ppp multilink
!
router rip
version 2
passive-interface Dialer1
network 192.168.10.0
no auto-summary
!
ip nat inside source list 18 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
map-class dialer 56K
dialer isdn speed 56
access-list 18 permit 192.168.10.0 0.0.0.255
dialer-list 1 protocol ip permit
snmp-server community public RO
!
line con 0
exec-timeout 0 0
password cisco
login
transport input none
stopbits 1
line vty 0 4
exec-timeout 0 0
password cisco
login
!
end
Bitte warten ..
Mitglied: Dani
03.12.2006 um 21:29 Uhr
Hi,
änder mal folgendes ab:
01.
en 
02.
conf t 
03.
service password-encryption
Dann baue mal die ISDN Verbindung manuell mit dem Router auf. Dann siehst du mal, ob der Router erfolgreich im Inet ist. Am besten n ping auf Google o.a. Seiten!


Gruß
Dani
Bitte warten ..
Mitglied: christiande
03.12.2006 um 21:52 Uhr
Werd ich morgen gleich machen. Aber
Wo genau muß ich diese Commandos eingeben?
Und dieser manuelle Verbindungsaufbau, bedeutet das, daß ich von einem PC der am Router Hub hängt ein Ping senden soll? Oder wie ist das gemeint. Der Router hängt ja direkt am NTBA und die Line LED leuchtet.
Wenn die Verbindung aufgebaut ist müsste ja eine rote Ch1 LED leuchten.
Bitte warten ..
Mitglied: Dani
03.12.2006 um 21:58 Uhr
Hi,
du verbindest dich per Telnet oder per Consolenkabel auf den Router. Dann einloggn und wenn das Zeichen ">" erscheint, einfach Codeblock von mir kopieren.
Danach einfach manuell auf dem Router (über Consolekabel oder Telnet) manuell eine ISDN Verbindung aufbauen. auch wieder in den Enable-Modus ("en").
Nun mit ping einen Adresse anwählen.

Hast du Erfahrungen mit Cisco Produkte?


Gruß
Dani
Bitte warten ..
Mitglied: Dani
03.12.2006 um 21:59 Uhr
Hi,
hier mal meine Config. Folgendes musst du anpassen:

0800 => Hier deine ISDN Nummer mit Vorwahl!
enable Passwort => test
Telnet PAsswort => test
test2 => ihr benutzername bei freenet
test3 => das pw dazu

01.
! ****************************************************************** 
02.
! Cisco801.cfg - Cisco router configuration file 
03.
! Automatically created by Cisco ConfigMaker v2.6 Build 6 
04.
!   Sonntag, 3. Dezember 2006, 10:46:38 
05.
06.
! Hostname: Cisco801 
07.
! Model: 801 
08.
! ****************************************************************** 
09.
10.
service timestamps debug uptime 
11.
service timestamps log uptime 
12.
service password-encryption 
13.
no service tcp-small-servers 
14.
no service udp-small-servers 
15.
16.
hostname Cisco801 
17.
18.
enable secret test 
19.
20.
no ip name-server 
21.
22.
isdn switch-type basic-1tr6 
23.
24.
ip subnet-zero 
25.
no ip domain-lookup 
26.
ip routing 
27.
28.
interface Dialer 1 
29.
 description connected to Internet 
30.
 ip address negotiated 
31.
 ip nat outside 
32.
 no ip split-horizon 
33.
 encapsulation ppp 
34.
 dialer in-band 
35.
 dialer idle-timeout 120 
36.
 dialer string 0800 
37.
 dialer hold-queue 10 
38.
 dialer-group 1 
39.
 ppp authentication chap pap callin 
40.
 ppp chap hostname test1 
41.
 ppp chap password test2 
42.
 ppp pap sent-username test1 password test2 
43.
 no ppp multilink 
44.
 no cdp enable 
45.
46.
interface Ethernet 0 
47.
 no shutdown 
48.
 description connected to EthernetLAN 
49.
 ip address 192.168.10.100 255.255.255.0 
50.
 ip nat inside 
51.
 keepalive 10 
52.
53.
interface BRI 0 
54.
 no shutdown 
55.
 description connected to Internet 
56.
 no ip address 
57.
 dialer rotary-group 1 
58.
59.
! Access Control List 1 
60.
61.
no access-list 1 
62.
access-list 1 permit 192.168.10.0 0.0.0.255 
63.
64.
! Dialer Control List 1 
65.
66.
no dialer-list 1 
67.
dialer-list 1 protocol ip permit 
68.
69.
! Dynamic NAT 
70.
71.
ip nat translation timeout 86400 
72.
ip nat translation tcp-timeout 86400 
73.
ip nat translation udp-timeout 300 
74.
ip nat translation dns-timeout 60 
75.
ip nat translation finrst-timeout 60 
76.
ip nat inside source list 1 interface Dialer 1 overload 
77.
78.
! DHCP Server 
79.
80.
service dhcp 
81.
ip dhcp excluded-address 192.168.10.10 192.168.10.99 
82.
ip dhcp pool 1 
83.
 network 192.168.10.0 255.255.255.0 
84.
 default-router 192.168.10.100 
85.
86.
router rip 
87.
 version 2 
88.
 network 192.168.10.0 
89.
 passive-interface Dialer 1 
90.
 no auto-summary 
91.
92.
93.
ip classless 
94.
95.
! IP Static Routes 
96.
ip route 0.0.0.0 0.0.0.0 Dialer 1 
97.
no ip http server 
98.
no snmp-server location 
99.
no snmp-server contact 
100.
101.
line console 0 
102.
 exec-timeout 0 0 
103.
 password test 
104.
 login 
105.
106.
line vty 0 4 
107.
 password test 
108.
 login 
109.
110.
end

Gruß
Dani
Bitte warten ..
Mitglied: aqui
04.12.2006, aktualisiert 18.10.2012
Und weils so schön ist hier:

http://www.administrator.de/forum/netzwerk-linux-und-windows-gemainsame ...

noch eine lauffähige ISDN Konfig !
Bitte warten ..
Mitglied: christiande
04.12.2006 um 17:55 Uhr
Wie kriege ich blos diese Konfiguration in meinen Router rein? Ich weiß absolut nicht wohin ich das kopieren soll. Mit welchem Programm macht man dass?
Bitte warten ..
Mitglied: aqui
05.12.2006 um 14:26 Uhr
Das ist ganz einfach !

Erstmal schliesst du ein Terminal an wie z.B. TeraTerm
http://hp.vector.co.jp/authors/VA002416/teraterm.html
oder das Windows eigene Hyperterm über den Consol Port. Einstellungen 9600 Baud, N81, keine Flusskontrolle. Dein Rechner benötigt dafür eine serielle Schnittstelle (COM Port). Hat er das nicht, musst du dir einen USB-Seriell Adapter für kleines Geld besorgen.
Ich denke mal so weit bist du aber schon....

Jetzt startest du das Terminal Programm und drückst mal <Return> Dann solltest du einen eckigen Prompt vom Router sehen > hier gibst du jetzt "enable" ein (der Prompt wird zum #) und dann
"conf t" Im Prompt erscheint ein (config)#:

Jetzt gibst du die Zeilen der hier geposteten Konfigs (für eine musst du dich entscheiden) entweder Zeile für Zeile ein wie sie hier stehen oder du cut n' pastest sie einfach ins Terminal rein, das klappt auch.
Als Tip solltest du nicht zu viele Zeilen auf einmal nehmen sondern immer so um die 5 Stück weil der Parser des Routers sich manchmal verschluckt wenn zuviel Input auf einmal kommt.
Du solltest die hier geposteten Konfigs am besten erstmal im Notepad editieren und mit deinen eigenen Zugangsdaten und IP Adressen der Wahl editieren und erst dann den Router damit "betanken".

Noch ein Tip:
Falsche Konfigzeilen bekommt man mit "no <Konfigzeile>" wieder weg
Aus dem Konfig Mode kommst du mit <ctrl z> wieder raus und danach musst du UNBEDINGT ein "wr" ausführen um die Konfig zu sichern, sonst ist nach dem nächsten Reboot alles wieder weg. Mit "show run" kannst du dir die Konfig ansehen !
Ist alles schief gegangen kannst du mit einem "wri era" und einem anschliessenden reboot (reload) den Router wieder "nackig" machen
Bitte warten ..
Mitglied: christiande
06.12.2006 um 18:53 Uhr
Vielen Dank für die ganzen guten Tips.
Inzwischen habe ich herausgefunden, das nur der DNS auf dem Router nicht lief.

Mit...

enable
conf t
ip dhcp pool 1
network 192.168.10.0 255.255.255.0
default-router 192.168.10.100
dns-server 212.80.175.1 141.1.27.249
end
wr

.... habe ich ihn zum laufen bekommen und ich kann jetzt zumindes surfen.
Ein Problem habe ich noch.
Es wählen sich immer 2 ISDN Kanäle an. Wie kann ich das verhindern?
Bitte warten ..
Mitglied: Dani
06.12.2006 um 18:59 Uhr
Hi,
so müsste es gehen. Per Telnet einloggn und dann:
01.
en 
02.
DEIN PW
dann einfach copy und paste:
01.
conf t 
02.
03.
int bri0 
04.
dialer pool-member 1 max-link 1 
05.
end
Gruß
Dani
Bitte warten ..
Mitglied: christiande
06.12.2006 um 19:59 Uhr
Ein herzliches Dankeschön an Dani !!!
So klappts jetzt auch nur mit einem Kanal.

Eine kleine Feinheit müsste ich noch korrigieren. Es funktioniert alles nur, wenn ich bei meinem PC die Netzwerkeinstellung auf DHCP gestellt habe.

Geht das nicht, daß ich alles mit fest eingestellten IPs laufen lassen kann?

Was müsste ich da noch ändern?
Bitte warten ..
Mitglied: aqui
06.12.2006 um 20:28 Uhr
Du entfernst einfach den DHCP Server ! Das sind diese Zeilen:

service dhcp ip dhcp excluded-address 192.168.10.10 192.168.10.99
ip dhcp pool 1
network 192.168.10.0 255.255.255.0
default-router 192.168.10.100
!

ein
"no service dhcp ip dhcp excluded-address 192.168.10.10 192.168.10.99"
und
"no ip dhcp pool 1"

im config Modus (danach <ctrl z> und wr)
Entfernt diese und dann rennt kein DHCP mehr

ebenso solltest du mit

no router rip

den RIP Prozess killen, der ist sinnlos für dich in deine Konstellaion und birgt nur die Gefahr das falsche RIP Updates deine ISDN Rechnung erhöhen könnten...
Bitte warten ..
Mitglied: christiande
06.12.2006 um 20:54 Uhr
uuuups

Aqui - das war irgendwie nix
Die Zeilen sind weg aber auch irgendwie mein DNS Server. Das heißt Internetverbindung geht auch nicht mehr. Nicht surfen und auch nicht pingen.

Woran liegt es??

Hier nochmal meine aktuelle Config:

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname ISDN
!
logging buffered 8192 debugging
enable secret 5 $1$6dw4$Vl8XbKlLgeiywOaN.zvbJ/
!
username 803 password 7 08275E4B0C170003
username ISDN password 7 14141B180F0B
!
ip subnet-zero
no ip source-route
!
isdn switch-type basic-net3
!
!
!
interface Ethernet0
ip address 192.168.10.100 255.255.255.0
no ip directed-broadcast
ip nat inside
!
interface BRI0
no ip address
no ip directed-broadcast
encapsulation ppp
dialer pool-member 1 max-link 1
isdn switch-type basic-net3
ppp authentication chap pap callin
ppp multilink
!
interface Dialer1
description ISP
ip address negotiated
no ip directed-broadcast
no ip proxy-arp
ip nat outside
encapsulation ppp
no ip split-horizon
dialer remote-name 803
dialer idle-timeout 60
dialer string 0101901929 class DialClass
dialer hold-queue 10
dialer load-threshold 10 either
dialer pool 1
dialer-group 1
pulse-time 0
ppp authentication chap pap callin
ppp chap hostname freenet
ppp chap password 7 10481B1C0019171F
ppp pap sent-username freenet password 7 0302490E03012458
ppp multilink
!
ip nat inside source list 18 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
map-class dialer DialClass
access-list 18 permit 192.168.10.0 0.0.0.255
access-list 101 permit udp any any
access-list 101 permit tcp any any
dialer-list 1 protocol ip list 101
!
line con 0
exec-timeout 120 0
transport input none
stopbits 1
line vty 0 4
exec-timeout 0 0
login local
!
end
Bitte warten ..
Mitglied: aqui
07.12.2006 um 11:44 Uhr
Ist doch klar
Den DNS Server bekommst du ja auch per DHCP und du wolltest ja kein DHCP mehr hast du gesagt
Also du musst dann natürlich auch deinen DNS Server deines Providers statisch einzeln in den Geräten eintragen !!!

Wenn dir das zu umständlich ist kannst du aber auch beides fahren, da du beim aktivierten DHCP Server auf Adressen "excluden" also ausschliessen kannst, die werden dann nicht vergeben.
Diese Adressen kannst du dann statisch vergeben hast aber parallel auch den DHCP Server am laufen wenn man mal schnell einen gast ans Netzwerk anschliessen will und nicht alles von hand für den konfigurieren will.
Dann musst du den DHCP Server wieder aktivieren mit folgenden Konfig Kommandos:

ip dhcp pool 0
network 192.168.10.0 255.255.255.0
default-router 192.168.10.100
dns-server <deine Provider DNS IP>

nun kannst du mit folgenden Kommandos IP Adressen von der automatischen DHCP Vergabe ausschliessen :

ip dhcp excluded-address 192.168.10.100
(Die obige Adressse ist extrem wichtig denn das ist der Router selber !!! Die darf keinesfalls an Endgeräte vergeben werden !)
ip dhcp excluded-address 192.168.10.1
ip dhcp excluded-address 192.168.10.2
ip dhcp excluded-address 192.168.10.3
usw.

Die Adressen 192.168.10.1 bis .3 sind nun frei und damit kannst du Geräte statisch einrichten. Ggf. kannst du dir beliebige "Exclude" Adressen dazunehmen über die Konfig. Alle diese spart der DHCP Server bei der Vergabe aus.
Das du dann auf diesen Geräten IMMER das Gateway (deine Router IP) UND auch den DNS Server des Providers händisch anlegen musst ist klar !!!
Bitte warten ..
Mitglied: christiande
08.12.2006 um 13:34 Uhr
Achso alles klar. MIr war nicht bewußt, daß DNS nur mit dhcp geht.
Aber mit dem excludieren habe ich nun erreicht was ich mir vorgestellt habe.
Darüber bin ich erstmal glücklich und danke allen für Ihre Hilfe.
Nun wird es die kommende Zeit zeigen ob alles stabil läuft.
Bis jetzt zumindest ist alles OK.

Was mich aber noch interessiert ist, ob man nicht irgendwo ein Handbuch für den 803 bekommt. Jetzt nicht mit den technischen Daten sondern mehr für die Configuration.
Leider sind die gesammten Seiten von Cisco DOWN.
Hat jemand so ein prgrammierhandbuch für den Router als PDF irgendwo noch auf CD?
Oder weiß jemand wo ich mir das mal herunterladen kann.
Damit ich mich mal noch ein bissel einarbeiten kann, welche Befehle es gibt und wie die anzuwenden sind.

Wäre sehr nett.
Bitte warten ..
Mitglied: aqui
08.12.2006 um 23:49 Uhr
Hier:

http://www.cisco.com/en/US/tech/tk713/tk507/tech_configuration_examples ...

kannst du dich etwas "austoben". Ansonsten die IOS Dokumentation durcharbeiten. Es gibt aber auch Wust an Büchern zu dem Thema. Amazon o.ä. sollte dir da weiterhelfen
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
ISDN & Analoganschlüsse
Bintec ISDN Router X4000 - Fehler bei der Anwahl (1)

Frage von Netzheimer zum Thema ISDN & Analoganschlüsse ...

Router & Routing
OpenConnect Hardware Gateway (Cisco ASA Router) (1)

Frage von K-ist-K zum Thema Router & Routing ...

DSL, VDSL
gelöst VPN-Probleme (CISCO AnyConnect) in Zusammenhang mit Router "Vodafone EasyBox" (7)

Frage von donnyS73lb zum Thema DSL, VDSL ...

Router & Routing
Problem - Router cisco 2821 hinter Fritzbox mit WLAN (23)

Frage von Cyberurmel zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...