Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Cisco Pix 501 - Mail for Exchange Routing

Frage Netzwerke Router & Routing

Mitglied: Supergecko

Supergecko (Level 1) - Jetzt verbinden

10.09.2008, aktualisiert 19.09.2008, 3926 Aufrufe, 2 Kommentare

Hallo Administrator.de Gemeinde,

ich habe folgendes Problem. Und zwar haben wir einen Kunden der sein neues Nokia E71 gerne benutzen würde um seine Mails die auf dem Exchange Server liegen zu syncen.
Ansich wäre das auch kein Problem denn das einrichten auf dem Handy ist recht einfach das habe ich soweit auch alles eingetragen. Das Problem stellt die Cisco Firewall Pix 501 dar.
Und zwar:

1. Ich kann auf das Gerät nur über das Webinterface zugreifen und das auch nur wenn ich es von einer Windows 2000 Maschine aufrufe. Von Windows XP Rechner geht das laut der Aussage des Kunden nicht oder nur mit sehr großen Umständen. Wenn ich per Hyperterminal drauf gehen will sagt er mir immer das der Port 23 nicht antworten würde.

2. Der oder die benötigten Ports die ich für Mail for Exchange benötige (80 und 443) sind meiner Meinung nach zwar eingetragen aber ich komme von aussen weder auf die OWA Seite des Exchange Servers noch schafft es das Handy sich mit dem Exchangeserver zu verbinden und abzugleichen.

Ich würde gerne wissen ob ich in der Konfig was falsch gemacht habe oder ob die Weboberfläche einfach nur Schrott ist. Ich hätte es wie gesagt lieber per console gemacht aber auf die komme ich ja leider nicht drauf.

Hier noch die Konfig:

Building configuration...
Saved
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 2KFQnbNIdI.2KYOU encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pixfirewall
domain-name ciscopix.com
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.1.6 ExchangeServer
access-list 100 permit icmp any any echo-reply
access-list 100 permit icmp any any time-exceeded
access-list 100 permit icmp any any unreachable
access-list 100 permit tcp any eq https host ExchangeServer eq https
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 192.168.2.5 255.255.255.0
ip address inside 192.168.1.5 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.1.40 255.255.255.255 inside
pdm location ExchangeServer 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) ExchangeServer ExchangeServer netmask 255.255.255.255 0 0
access-group 100 in interface outside
route outside 0.0.0.0 0.0.0.0 192.168.2.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
aaa authentication enable console LOCAL
aaa authentication http console LOCAL
aaa authorization command LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.9-192.168.1.129 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
username admin password 57nn9lj1mSmNzyaP encrypted privilege 15
privilege show level 0 command version
privilege show level 0 command curpriv
privilege show level 3 command pdm
privilege show level 3 command blocks
privilege show level 3 command ssh
privilege configure level 3 command who
privilege show level 3 command isakmp
privilege show level 3 command ipsec
privilege show level 3 command vpdn
privilege show level 3 command local-host
privilege show level 3 command interface
privilege show level 3 command ip
privilege configure level 3 command ping
privilege show level 3 command uauth
privilege configure level 5 mode enable command configure
privilege show level 5 command running-config
privilege show level 5 command privilege
privilege show level 5 command clock
privilege show level 5 command ntp
privilege show level 5 mode configure command logging
privilege show level 5 command fragment
terminal width 80
Cryptochecksum:5d089f18a4403da79230fb05af884b55
: end
[OK]


Ich wusste leider nicht wie ich die Formatierung hinbekomme das vor der Konfig Nummern stehen.

Ich danke euch schonmal für eure Hilfe.

Mit freundlichen Grüßen

Supergecko
Mitglied: aqui
11.09.2008 um 13:43 Uhr
Laut deiner ACL forwardest du nur TCP 443 auf den Exchange Server aber kein TCP 80 ! Da fehlt also was
Das Telnet (Putty, Hyperterm, TeraTerm) nicht klappt liegt vermutlich daran das Telnet Zugang abgeschaltet ist. (Telnet Server nicht aktiv) Ist auch normal, da was wie HTTP unsichere Zugänge für einen FW sind !
Das Der Webzugang nur mit einem 2k Rechner klappt ist eigentlich Unsinn, das funktioniert natürlich auch von XP, Linux oder MAC !
Vermutlich liegt es an der IP des Rechners denn die FW lässt nur Zugriffe aus 192.168.1.0 zu.

Am besten du plazierst einen Packet Sniffer zwischen FW und Exchange und snifferst mit was da ankommt.
Dann weistt du genau was die FW durchlässt und was nicht !!!
Sniffer SW ist z.B.
WIRESHARK
oder
MS-NetMonitor

(P.S.: Fomratierung bekommst du mit den code Tags in eckigen Klammern hin ! Siehe: http://www.administrator.de/index.php?faq=20#toc26 )
Bitte warten ..
Mitglied: Supergecko
19.09.2008 um 09:52 Uhr
Hallo nochmal also ich habe wie oben gesagt auch noch den Port 80 in die Accessliste eingetragen aber habe immernoch das Problem das ich an der Firewall garnicht vorbei komme. Ich bekomme es einfach nicht auf. Zusätzlich ist es so das ich wenn ich die Accesslisten bearbeite und den Eintrag für die Ports eintrage, ich zusätzlich noch einen NAT eintrag setzten muss der dann den Exchange Server vom Internet trennt. Ich bin mit meinem Wissen echt am Ende und würde gerne nochmal eure Hilfe beanspruchen. Hier nochmal die Konfiguration mit den Eingetragenen Port und der NAT Regel die leider nicht geht.

01.
Building configuration... 
02.
: Saved 
03.
04.
PIX Version 6.3(3) 
05.
interface ethernet0 auto 
06.
interface ethernet1 100full 
07.
nameif ethernet0 outside security0 
08.
nameif ethernet1 inside security100 
09.
enable password 2KFQnbNIdI.2KYOU encrypted 
10.
passwd 2KFQnbNIdI.2KYOU encrypted 
11.
hostname pixfirewall 
12.
domain-name ciscopix.com 
13.
clock timezone CEST 1 
14.
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00 
15.
fixup protocol dns maximum-length 512 
16.
fixup protocol ftp 21 
17.
fixup protocol h323 h225 1720 
18.
fixup protocol h323 ras 1718-1719 
19.
fixup protocol http 80 
20.
fixup protocol rsh 514 
21.
fixup protocol rtsp 554 
22.
fixup protocol sip 5060 
23.
fixup protocol sip udp 5060 
24.
fixup protocol skinny 2000 
25.
fixup protocol smtp 25 
26.
fixup protocol sqlnet 1521 
27.
fixup protocol tftp 69 
28.
names 
29.
name 192.168.1.6 ExchangeSrv 
30.
access-list 100 permit icmp any any echo-reply  
31.
access-list 100 permit icmp any any time-exceeded  
32.
access-list 100 permit icmp any any unreachable  
33.
access-list 100 permit tcp any host ExchangeSrv eq https  
34.
access-list 100 permit tcp any host ExchangeSrv eq www  
35.
pager lines 24 
36.
mtu outside 1500 
37.
mtu inside 1500 
38.
ip address outside 192.168.2.5 255.255.255.0 
39.
ip address inside 192.168.1.5 255.255.255.0 
40.
ip audit info action alarm 
41.
ip audit attack action alarm 
42.
pdm location 192.168.1.40 255.255.255.255 inside 
43.
pdm location ExchangeSrv 255.255.255.255 inside 
44.
pdm logging informational 100 
45.
pdm history enable 
46.
arp timeout 14400 
47.
global (outside) 1 interface 
48.
nat (inside) 1 0.0.0.0 0.0.0.0 0 0 
49.
static (inside,outside) ExchangeSrv ExchangeSrv netmask 255.255.255.255 0 0  
50.
access-group 100 in interface outside 
51.
route outside 0.0.0.0 0.0.0.0 192.168.2.1 1 
52.
timeout xlate 0:05:00 
53.
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00 
54.
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00 
55.
timeout uauth 0:05:00 absolute 
56.
aaa-server TACACS+ protocol tacacs+  
57.
aaa-server RADIUS protocol radius  
58.
aaa-server LOCAL protocol local  
59.
aaa authentication enable console LOCAL 
60.
aaa authentication http console LOCAL 
61.
aaa authorization command LOCAL 
62.
http server enable 
63.
http 192.168.1.0 255.255.255.0 inside 
64.
no snmp-server location 
65.
no snmp-server contact 
66.
snmp-server community public 
67.
no snmp-server enable traps 
68.
floodguard enable 
69.
telnet timeout 5 
70.
ssh timeout 5 
71.
console timeout 0 
72.
dhcpd address 192.168.1.9-192.168.1.129 inside 
73.
dhcpd lease 3600 
74.
dhcpd ping_timeout 750 
75.
dhcpd auto_config outside 
76.
username admin password 57nn9lj1mSmNzyaP encrypted privilege 15 
77.
privilege show level 0 command version 
78.
privilege show level 0 command curpriv 
79.
privilege show level 3 command pdm 
80.
privilege show level 3 command blocks 
81.
privilege show level 3 command ssh 
82.
privilege configure level 3 command who 
83.
privilege show level 3 command isakmp 
84.
privilege show level 3 command ipsec 
85.
privilege show level 3 command vpdn 
86.
privilege show level 3 command local-host 
87.
privilege show level 3 command interface 
88.
privilege show level 3 command ip 
89.
privilege configure level 3 command ping 
90.
privilege show level 3 command uauth 
91.
privilege configure level 5 mode enable command configure 
92.
privilege show level 5 command running-config 
93.
privilege show level 5 command privilege 
94.
privilege show level 5 command clock 
95.
privilege show level 5 command ntp 
96.
privilege show level 5 mode configure command logging 
97.
privilege show level 5 command fragment 
98.
terminal width 80 
99.
Cryptochecksum:c17dad8989a30658001a2e7788d7bef3 
100.
: end 
101.
[OK]
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(2)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (15)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Backup
Clients als Server missbrauchen? (10)

Frage von 1410640014 zum Thema Backup ...