Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Cisco Router 2 VPN Tunnel bündeln (Trunk)

Frage Netzwerke Router & Routing

Mitglied: Dkuehlborn

Dkuehlborn (Level 1) - Jetzt verbinden

12.04.2010, aktualisiert 18.10.2012, 5455 Aufrufe, 2 Kommentare, 1 Danke

Hallo Forum,

wir nutzen zwischen 2 Standorten Cisco-Router Typ 2811. Diese Standorte sind verbunden über 2 MBit-Standleitung und 2 MBit MPLS. Bisher wird nur die Standleitung verwendet. Im Falle eines Ausfalls der Standleitung die Router-Config mauell geändert, so dass die Route über die MPLS geht und somit die Ausfallzeit reduziert wird.

Wir haben auf dem Router das IOS (C2800NM-ADVIPSERVICESK9-M), Version 12.4(6)T10, RELEASE SOFTWARE (fc4) installiert.

Kann man mit diesem Router die Konfiguration so ändern, das beide Verbindungen gleichzeitig verwendet werden und somit die die Transferrate auf 4 MBit erhöht wird und im Ausfall einer Leitung auf einer einzelnen Leitung mit 2 MBit Verbindung hat?

Wenn es erforderlich ist, sende ich gerne meine aktuelle Konfiguration, so dass keiner Raten muss, was ich zurzeit verwende.

Viele Grüße und Dank eim Voraus.

Dieter
Mitglied: dog
12.04.2010 um 10:33 Uhr
Zumindest zur IP-Adressierung zwischen den Netzen musst du schon was schreiben.
MPLS: VPLS oder Layer 3 VPN?
Bitte warten ..
Mitglied: aqui
12.04.2010, aktualisiert 18.10.2012
Nein, das ist nicht möglich wenn du ein reines fifty fifty Load Sharing machen willst, da sich die VPN Leitungen ja wie quasi IP Standleitungen dem Router gegenüber verhalten.
Was du machen kannst ist aber ein dynamische ECMP mit einem dynamischen Routing Protokoll, das funktioniert vollkommen problemlos und nutzt dann beide Leitungen optimal aus je nach Ziel IP Netz oder Ziel IP Hostadresse.
ECMP ist in solchen Szenarien auch gängige Praxis um die Leitungen zu sharen.
Was du machen musst ist recht einfach:
  • 2ten VPN Tunnel konfigurieren über die MPLS Leitung so das beide Tunnel aktiv sind. Hilfe gibt dir ggf. dieser_Thread
  • Dynamisches Routing Protokoll aktivieren z.B. OSPF
Das wars. Damit ereichst du ganz einfach ein Load Sharing und gleichzeitig auch eine vollständige Redundanz beim Ausfall einer Leitung und die Konfig ist in 30 Minuten umgesetzt.
Eine einfache, schnelle Beispielkonfig für deinen 2811er sieht so aus:
interface Ethernet 1
descr Lokales Ethernet LAN
ip address 10.1.1.254 255.255.255.0
i
interface serial 1
descr Serielle 2 Mbit Standleitung
bandwith 2000
ip address 172.16.1.1 255.255.255.252
!
interface Ethernet2
descr 2 Mbit MPLS Leitung
bandwith 2000
ip address 172.16.1.5 255.255.255.252
!
router ospf 1
network 10.1.1.254 0.0.0.255 area 0
network 172.16.1.0 0.0.0.3 area 0
network 172.16.4.0 0.0.0.3 area 0
!

Eine andere Möglichkeit ist noch Policy Based Routing (PBR) die ebenso schnell zu implementieren ist.
PBR hat aber den Nachteil das du manuell definieren musst mit einer ACL was an Traffic über den einen Link oder den anderen gehen soll und hast somit immer eine starre, statische Verteilung des Traffics.
Redundanz hast du hier aber auch durch immer die Angabe eines alternativen next Hop Gateways auf das der Router zurückgeht sollte eine Leitung ausfallen.
Ein Beispiel dazu findest du in diesem Thread:
http://www.administrator.de/forum/cisco-router-2-gateways-f%c3%bcr-vers ...

Beide Möglichkeiten führen zum Erfolg ! Und... .dog war wieder schneller
Bitte warten ..
Ähnliche Inhalte
Netzwerke
VPN-Tunnel von Cisco RV320 zur FB7490
Frage von AlhamanNetzwerke7 Kommentare

Hallo, ich habe die Aufgabe ein paar Feldgeräte in einem Kundennetz so zu verbinden, dass diese unseren internen FTP-Server ...

Router & Routing
VPN Tunnel im Tunnel Cisco RV-320 und Cisco ASA
Frage von realswoodRouter & Routing1 Kommentar

Servus, Ich habe einen Kunden in dessen Netzwerk ich nicht sein darf, deshalb stellt er mir eine interne IP ...

Netzwerkmanagement
Trunk zwischen HP und Cisco
gelöst Frage von homermgNetzwerkmanagement8 Kommentare

Hey Leute, wir haben einen Hauptswitch (Cisco) und einen Etagenswitch HP 2530. Die beiden habe ich mit 2x Glassfaserkabel ...

Switche und Hubs
Cisco trunk einstellen
gelöst Frage von homermgSwitche und Hubs11 Kommentare

Hey Leute, ich arbeite relativ selten mit unseren switchen und bin mir nun bei einer Sache nicht ganz sicher. ...

Neue Wissensbeiträge
Windows 10

Windows 10 Fall Creators Update - Neue Funktion Hyper-V Standardswitch kann ggf. Fehler bei Proxy Configs verursachen

Erfahrungsbericht von rzlbrnft vor 9 StundenWindows 102 Kommentare

Hallo Kollegen, Da wir die Gefahr lieben, haben wir bei einigen Usern nun mittlerweile das Creators Update drauf. Einige ...

Sicherheit

TLS-Zertifikat und privater Schlüssel von Microsofts Dynamics 365 geleakt

Information von Penny.Cilin vor 11 StundenSicherheit

Microsoft hat versehentlich das TLS-Zertifikat inklusive dem privaten Schlüssel seiner Business-Anwendung Dynamics 365 geleakt. TLS-Zertifikat und privater Schlüssel von ...

Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 1 TagViren und Trojaner3 Kommentare

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 1 TagRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

Netzwerkmanagement
NAS über zwei weitere Ethernet Anschlüsse verbinden
gelöst Frage von Sibelius001Netzwerkmanagement15 Kommentare

Sorry - ich bin hier wahrscheinlich als kompetter IT Trottel unterwegs. Aber eventuell kann mir jemand ganz einfach helfen: ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...

Netzwerkgrundlagen
Hi eine blöde frage. xD
Frage von 132954Netzwerkgrundlagen12 Kommentare

Also: Habe 2012 r2 essentials neuinstalliert, allerdings installiert diese version ja gleich diesen gangen AD kram mit, den hab ...