Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Cisco Router - Clients können nicht ins Internet

Frage Netzwerke Router & Routing

Mitglied: Netflag

Netflag (Level 1) - Jetzt verbinden

09.02.2009, aktualisiert 09:59 Uhr, 5589 Aufrufe, 3 Kommentare

Morgen,
es soll folgendes Szenario realisiert werden:

Mehrere Clients sollen über ein Switch, der an einem Router A angeschlossen ist, der wiederum an den Hauptrouter B angeschlossen ist, eine Internetverbindung herstellen können.

Folgende Konfiguration:

Clients:
IP: 192.168.1.2/24 – 192.168.1.7/24
Gateway: 192.168.1.1

Router A (Cisco Router 1760):
FastEthernet0/0:
IP: 192.168.1.1/24
Ethernet0/0:
IP: 192.168.5.105/24 (per DHCP von Router B zugewiesen)

Router B (Netgear RP614V2):
ISP Zugangsdaten korrekt eingegeben
IP: 192.168.5.2/24

Derzeitiges Problem:
Router A kann per ping auf google.de zugreifen, somit auch auf 192.168.5.2 (Router B). Die Clients können per ping auf die Ethernet0/0- (192.168.5.105) und FastEthernet0/0-Schnittstelle (192.168.1.1) von Router A zugreifen, jedoch nicht auf die 192.168.5.2 (Router B) und somit auch nicht auf google.de.
(Getestet wurde auch, ob die Clients ins Internet kommen, wenn wir diese über ein Switch direkt an Router B angeschlossen haben. Dies funktionierte mit einer automatischen IP Zuweisung automatisch.)

Bisherige Routing-Konfigurationen in Router A:
1. „ip route 192.168.5.0 255.255.255.0 192.168.1.0“
2. „ip route 192.168.5.0 255.255.255.0 192.168.1.1“
3. „ip route 192.168.1.0 255.255.255.0 192.168.5.0“
4. „ip route 192.168.1.1 255.255.255.0 192.168.5.0“
5. Mittels RIP:
- Version 2
- Network 192.168.5.0
- Network 192.168.1.0

Bei Eingabe des Befehls „show ip route“ wird keine der eingegeben Routen angezeigt, allerdings folgendes:
C 192.168.5.0/24 is directly connected, Ethernet0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 [254/0] via 192.168.5.2

Alle Switches, Clients und Router befinden sich in einem einwandfreien Zustand, da wir die Konfigurationen parallel in 2 Gruppen mit identischen Geräten getestet haben!

Wäre super, wenn uns jemand dabei helfen könnte, sodass die Clients problemlos ins Internet gelangen.

Vielen Dank im Voraus!
Mitglied: aqui
09.02.2009 um 19:18 Uhr
Alle deine Routen auf Router A sind Unsinn und du kannst sie wieder loeschen ! Als Gateway Adressen hast du IP Netze angegeben, was vollkommen falsch ist !!
Also alles mit "no ip route xxxxx..." wieder wegloeschen vom Cisco !!!
Der Cisco braucht auch gar keine Routen in das .5.0er Netz und in das .1.0er Netz denn sie sind ja an ihm direkt angeschlossen und er kennt diese Netze somit !!! Routen dahin sind also auf diesem Router kompletter Unsinn und logischerweise damit ueberfluessig !

Auf Router A muss lediglich eine einzige default Route stehen:

ip route 0.0.0.0 0.0.0.0 192.168.5.2

Damit wird alles was den Cisco (Router A) erreicht an den NetGear Router gesendet und somit dann ins Internet.

Der NetGear kennt allerdings NICHT das 192.168.1.0er Netz, da es hinter dem Router A liegt ! Dieses IP Netz du dem NetGear also noch zwingend mit einer statischen Route beibringen, damit er weiss das er IP Pakete fuer das .1.0er Netz an die .5.105 senden muss damit sie das .1.0er Netz erreichen !!

Also dort im Websetup musst du noch eine Route eintragen ala:

Zielnetz: 192.168.1.0 Maske: 255.255.255.0 Gateway: 192.168.5.105

Damit sollte das Netzwerk problemlos funktionieren !!

(Siehe dazu auch den Thread Routing mit 2 Netwerkkarten hier unter Routing fuer die technischen Details !!!)

Noch ein Tipp:
Router sollten NIEMALS dynamische IP Adressen bekommen !!! Du solltest also die .105 am Router A NICHT dynamisch zuteilen lassen sondern immer statisch festlegen.
Achtung> Die IP darf dann NICHT im DHCP Bereich des Routers B liegen oder du solltest DHCP hier besser ganz ausschalten !!!

Der Grund liegt auf der Hand:
Sollte die .105 sich aufgrund der Dynamik von DHCP mal aendern ist die statische Route in das .1.0er Netz auf dem NetGear wirkungslos...und nix geht mehr bei dir im Netz !!!
Bitte warten ..
Mitglied: Netflag
10.02.2009 um 07:11 Uhr
Vielen Dank für deine schnelle Antwort!

Eine statische Route musste am Inet Router (Router B) in das Netz 192.168.1.0 mit dem Gateway 192.168.5.105 eingetragen werden. Die Metrik wurde erstmal auf 1 gesetzt.

Beim Client musste zudem noch der DNS Server und der Alternative DNS Server eingetragen werden bei den TCP/IP Einstellungen.

Die Routen innerhalb des Routers hatten wir auch gelöscht gehabt.

Das Szenario sollte auch nur zur Veranschaulichung dienen, nicht zum Betriebseinsatz. Demnächst wird dann die IP nicht mehr per DHCP zugewiesen werden.

Dank dir!
Bitte warten ..
Mitglied: aqui
10.02.2009 um 19:55 Uhr
Kein Problem...immer gerne wieder !

Wenns das war bitte dann
http://www.administrator.de/index.php?faq=32
nicht vergessen !
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(2)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Router & Routing
VoIP hinter Cisco Router (23)

Frage von PharIT zum Thema Router & Routing ...

Netzwerkmanagement
SSH auf Cisco Router aktivieren, allerdings ohne line vty (8)

Frage von M.Marz zum Thema Netzwerkmanagement ...

Router & Routing
gelöst Cisco Router C886VAJ-K9 WLAN? (19)

Frage von oce zum Thema Router & Routing ...

Router & Routing
Übungen zu Cisco Router Konfiguration (3)

Frage von M.Marz zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (15)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...