Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Cisco Router ISDN Backup Konfiguration

Frage Netzwerke Router & Routing

Mitglied: 106747

106747 (Level 1)

16.05.2012, aktualisiert 18.10.2012, 3197 Aufrufe, 7 Kommentare

Hi zusammen,


Ich konfiguriere zur Zeit einen Cisco Router 886V. Die Hauptleitung ist DSL, wenn dieses jedoch ausfällt, soll er ein Backup über die ISDN-Verbindung aufbauen.


Mein Problem ist, dass das NAT nicht richtig funktioniert. Wenn ich über DSL verbunden bin und "ip nat inside source route-map backup interface Dialer2 overload" gesetzt ist, komme ich nicht raus(PING und http). Wenn ich es rausnehme, funktioniert es. Das selbe wenn ich über ISDN verbunden bin. Ich muss dann zuerst "ip nat inside source route-map primary interface Dialer1 overload" rausnehmen, damit ich pingen und ins Web kann.

Weiss jemand Rat?


Vielen Dank für eure Hilfe im voraus.



Hier meine Config:



!
ip source-route
!
!
!
ip dhcp excluded-address xxx.xxx.xxx.xxx
!
ip dhcp pool LAN
network xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx
default-router xxx.xxx.xxx.xxx
dns-server xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx
!
!
ip cef
ip domain name xxx
ip name-server xxx.xxx.xxx.xxx
ip name-server xxx.xxx.xxx.xxx
no ipv6 cef
!
!
isdn switch-type basic-net3
!
!
username xxx password xxx
!
!
!
!
controller VDSL 0
operating mode vdsl2
!
!
track 1 interface Dialer1 ip routing
!
!
!
!
!
!
!
interface Ethernet0
backup interface BRI0
no ip address
pppoe-client dial-pool-number 1
!
interface BRI0
bandwidth 512
no ip address
encapsulation ppp
dialer pool-member 2
isdn switch-type basic-net3
no isdn termination multidrop
isdn point-to-point-setup
ppp authentication chap callin
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
ip address xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx
ip nat inside
ip virtual-reassembly in
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer idle-timeout 0
dialer persistent
dialer-group 1
ppp authentication chap callin
ppp chap hostname xxx
ppp chap password xxx
!
interface Dialer2
description ISDN-Failover
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 2
dialer idle-timeout 216000
dialer string 000000000
dialer watch-group 2
dialer-group 2
ppp authentication chap callin
ppp chap hostname xxx
ppp chap password xxx
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source route-map backup interface Dialer2 overload
"
ip route 0.0.0.0 0.0.0.0 Dialer1 track 1
ip route 0.0.0.0 0.0.0.0 Dialer2 254
!
ip access-list extended xxx
permit ip xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx any
permit icmp xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx any
!
logging esm config
access-list 101 permit ip xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx any
access-list 102 permit ip xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx any
dialer watch-list 1 ip 0.0.0.0 0.0.0.0
dialer watch-list 2 ip 0.0.0.0 0.0.0.0
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
!
!
!
!
route-map backup permit 10
match ip address 102
!
route-map primary permit 10
match ip address 101
!
!
Mitglied: aqui
16.05.2012, aktualisiert 18.10.2012
Die Frage die sich stellt ist warum du mit einer Route Map arbeitest. Eigentlich ist das sinnlos, denn du hast keine unterschiedlichen Traffic Flüsse ! Es geht lediglich immer nur um den Traffic vom lokalen LAN (Vlan 1) ins Internet...mehr nicht. Route Maps benötigt man dafür also eigentlich nicht.
Abgesehen davon hält das Backup Interface Kommando das backup Interface immer auf Shutdown solange das Primäre aktiv ist.
Auch "bandwith 512" auf einem ISDN Interface entspricht wohl eher frommem Wunschdenken als technischer Realität...aber nundenn.
Du solltest also 2 ganz simple Dial on Demand Konfigs machen mit 2 Dialern, die statische Default Route am Primär Interface tracken und den Rest vom Backup Interface machen lassen...fertig !
Nochwas:
In PPP Konfigs sollte man es immer vermeiden mit 2 statischen Routen oder generell statischen Routen zu arbeiten und Tracking.
Erheblich besser ist es hier in den beiden Dialer Interfaces ausschliesslich mit dem Kommando ppp ipcp route default zu arbeiten !!
Damit wird je nachdem welches Interface du nutzt die Default Route automatisch mit dem aktiven PPP Interface umgeschaltet. Generell ist das immer besser als statische Routen die auf ein Dial Interface zeigen. Ein Beispiel findest du hier.
Einen gravierenden Nachteil hat diese Konfig immer: Solange nur ein physischer Link auf dem Ethernet 0 Interface aktiv ist schaltet die Verbindung nicht um. Ist also nur mal der DSLAM kabut oder das PPPoE Interface bekommt keine IP o.ä. schlatet sich keine Backup Verbindung. Besser ist es also hier aktiv das Default Gateway zu tracken und dann umzuschalten statt es vom physischen Link abhängig zu machen.
Bitte warten ..
Mitglied: 106747
16.05.2012 um 14:53 Uhr
Hallo aqui

Vielen Dank für deine Tipps. Das mit dem physischen Link muss ich unbedingt beachten. Das mit den Route Maps habe ich aus anderen Configs, die sich mit diesem Thema beschäftigt haben. Die ISDN Bandwidth habe ich jetzt auf 256 festgelegt. Ich habe es so konfiguriert, wie du es empfohlen hast, jedoch immer noch kein Erfolg. Könntest du dir mal meine Config anschauen und mir evtl. sagen, wo der Fehler liegen könnte?

Vielen Dank im voraus.



isdn switch-type basic-net3
!
controller VDSL 0
operating mode vdsl2
!
!
track 1 interface Dialer1 ip routing
!
!
!
!
!
!
!
interface Ethernet0
backup interface BRI0
no ip address
pppoe-client dial-pool-number 1
!
interface BRI0
bandwidth 256
no ip address
encapsulation ppp
dialer pool-member 2
isdn switch-type basic-net3
no isdn termination multidrop
no fair-queue
ppp authentication chap callin
no cdp enable
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
ip address xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx
ip nat inside
ip virtual-reassembly in
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname xxx
ppp chap password xxx
no cdp enable
!
interface Dialer2
description ISDN-Failover
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 2
dialer string 0000000000
dialer watch-group 1
dialer-group 2
ppp authentication chap callin
ppp chap hostname xxx
ppp chap password xxx
ppp ipcp route default
no cdp enable
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source list 101 interface Dialer1 overload
ip nat inside source list 102 interface Dialer2 overload
ip route 0.0.0.0 0.0.0.0 Dialer1 track 1
!
logging esm config
access-list 101 permit ip xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx any
access-list 102 permit ip xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx any
dialer watch-list 1 ip 0.0.0.0 0.0.0.0
dialer-list 1 protocol ip permit
Bitte warten ..
Mitglied: aqui
16.05.2012 um 17:10 Uhr
Nur mal ne doofe Frage: Weisst du eigentlich was ISDN bzw. ein ISDN Basisanschluss (BRI) ist ??
http://de.wikipedia.org/wiki/Integrated_Services_Digital_Network#In_Deu ...
Zitat: "Jeder der beiden Nutzkanäle bietet eine Datenübertragungsrate von 64 kbit/s , der Steuerkanal 16 kbit/s."
Nach Adam Riese macht das dann eine maximal physikalisch erreichbare Bandbreite von 128 kBit/s !! Und das auch nur wenn du beide B-Kanäle parallel mit einer "Bandwith on Demand" Konfig auf dem Router aktivierst. Solltest du übrigens machen wenn du 2 B-Kanäle nutzen kannst um die Bandbreite zu erhöhen sofern du sie denn benötigst. Allerdings muss auch der Provider das supporten (Multilink PPP) also besser vorher abklären !
Da das aber in deiner obigen Konfig nicht zu sehen ist beträgt deine maximale erreichbare Bandbreite dann 64 kBit/s.
Nun kannst du selber über die Sinnhaftigkeit deines Kommandos "bandwidth 256" auf dem BRI Interface nachdenken.
Tip: Lass es besser im Default wenn du nicht weisst was du da tust !!
Nochwas:
ppp ipcp route default musst du auf beiden Dialer Interfaces benutzen. Damit entfallen dann komplett die statischen Routen.
Kannst du selber mal checken wenn du mal "show ip route" eingibst bei aktivem Dialer Interface !!
Einer der Dialer ist ja durch das Backup Kommando immer im shutdown, folglich kann es also immer nur ein default Gateway geben was automatisch mit der PPP Verbindung (Dialer) ausgehandelt wird.
Wechselt dein Dialer durch ein getriggertes Backup, wechselt auch automatisch dein Default Gateway bzw. Default Route ! Kannst du einfach checken indem du mal das VDSL Kabel abziehst !
Das ist der parktische Sinn dieses Kommandos ! Die Watch List kann damit auch entfallen.
Bitte warten ..
Mitglied: 106747
18.05.2012 um 09:13 Uhr
Hallo aqui

Danke für deine Antwort. Wie du sicher schon bemerkt hast, bin ich noch kein Experte auf diesem Gebiet, sonst hätte ich auch keine Hilfe in Anspruch genommen.

Hier noch einmal meine Config. So wie du es mir vorschlägst, funktioniert es nicht. Ich muss eine statische Route konfigurieren. Wo liegt der Fehler?



isdn switch-type basic-net3
!
!
!
!
!
controller VDSL 0
operating mode vdsl2
!
!
!
!
!
!
!
!
interface Ethernet0
backup delay 10 30
backup interface BRI0
no ip address
pppoe-client dial-pool-number 1
!
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 2
isdn switch-type basic-net3
isdn termination multidrop
isdn point-to-point-setup
no fair-queue
ppp authentication chap callin
no cdp enable
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
ip address xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx
ip nat inside
ip virtual-reassembly in
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname xxx
ppp chap password xxx
ppp ipcp route default
no cdp enable
!
interface Dialer2
description ISDN-Failover
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 2
dialer string 0000000000
dialer watch-group 1
dialer-group 2
compress mppc
ppp authentication chap callin
ppp chap hostname xxx
ppp chap password xxx
ppp ipcp dns request
ppp ipcp route default
no cdp enable
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source list 101 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
logging esm config
access-list 101 permit ip xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx any
no cdp run
Bitte warten ..
Mitglied: aqui
18.05.2012 um 14:02 Uhr
Klar das es nicht funktioniert, denn du musst die 2te Dialer ACL auf das NAT loslassen...
ip nat inside source list 102 interface Dialer2 overload
Andernfalls wird doch niemals auf dem Dialer 2 NAT gemacht nach draussen !
Eine ACL 102 mit den gleichen Credentilas wie 101 musst du ebenfalls einrichten.
Ferner fehlt auch die Dialer List für beide Dialer !
Du musst erst beide Verbindungen so aktivieren, das sie sauber laufen. Wenn du dann das Backup Kommando scharf machst geht der sekundäre Link auf Shutdown.
Eigentlich eine ganz logische Konfig !
Bitte warten ..
Mitglied: 106747
18.05.2012 um 14:36 Uhr
funktioniert nicht....

Habe noch die entsprechenden Änderungen gemacht. Egal welchen Dialer ich benutze, ich muss jeweils eine statische Route konfigurieren. Also eine logische Konfig scheint es doch nicht zu sein...
Bitte warten ..
Mitglied: dq28121989
30.09.2013 um 16:17 Uhr
Das Thema ist mit Sicherheit schon beendet, hier allerdings für diejenigen die noch auf der Suche sind ein Link:
http://www.cisco.com/en/US/tech/tk648/tk361/technologies_configuration_ ...

Ich habe mich mit dem selben Problem beschäftigt. Das mit den Route-Maps war der richtige Ansatz! Man braucht zwei verschiedene die zum einen den privaten IP-Bereich mit einer ACL und zum anderen das outgoing Interface matcht (nach dem geroutet wurde).

Ein weiterer Tipp: Die Timeouts für die translation-Tabelle sollten für ein schnelleres Failover verkürzt werden. Ansonsten dauert es ewig bis die Backupleitung natted.

lg
dq
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Router & Routing
Übungen zu Cisco Router Konfiguration (3)

Frage von M.Marz zum Thema Router & Routing ...

Router & Routing
VoIP hinter Cisco Router (23)

Frage von PharIT zum Thema Router & Routing ...

Netzwerkmanagement
SSH auf Cisco Router aktivieren, allerdings ohne line vty (8)

Frage von M.Marz zum Thema Netzwerkmanagement ...

Router & Routing
gelöst Cisco Router C886VAJ-K9 WLAN? (19)

Frage von oce zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...