Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Cisco RV042G konfiguration VPN etc.

Frage Netzwerke Router & Routing

Mitglied: Xaero1982

Xaero1982 (Level 3) - Jetzt verbinden

11.04.2014, aktualisiert 14.04.2014, 2533 Aufrufe, 13 Kommentare

Moin Zusammen,

da unser Draytek 2950 draufgegangen ist haben wir uns schnell eine Alternative mit zwei WAN Ports suchen müssen. Da er eigentlich nicht viel können sollte außer ein bissel Routing und Portweiterleitung musste es auch kein Monsterrouter sein.

So nun haben wir aber irgendwie den Salat, dass das Ding zwar vieles kann aber nicht die einfachsten Dinge die sogar meine FB kann.

Ich hab natürlich auch im Netz gesucht und in der Anleitung um diese Probleme zu lösen - Fehlanzeige.

1. VPN
Ich habe einen Nutzer eingerichtet und mir Quickvpn installiert. Alle Daten angegeben und dann kommt bei "Verifying Network..." folgende Meldung:

01.
Info: The remote gateway is not responding. Do you want to wait?
Mach ich nein beendet er die Verbindung. Bei Ja kommt die Meldung wieder.

Die Suche ergab, dass man an der "vpnserver.conf" die remotelanip ändern soll auf einen PC der pingbar ist. Also hab ich einfach mal die 127.0.0.1 eingetragen und wenn ich dann auf ja drücke kommt die Verbindung zwar zustande - bricht aber sofort wieder ab. Bei den anderen brachte das immer die nötige Lösung. Hier nicht.

2. Portforwarding
Also wir haben u.a. Webdav laufen auf Port 1234 (geändert)
Also gibt es im Router eine Portforwardingregel: Service "Bla" Port 1234-1234 an IP: 123.456.789.123

Das funktioniert, aber auch nur weil der Webdav intern auch auf Port 1234 lauscht.

Nun haben wir noch einen Kameraserver laufen.
Der lauscht intern aber auf Port 8888 (geändert) und wir kommen von extern an Port 12345 (geändert) an. Auch wenn ich den Port intern auf 12345 ändere geht es nicht. Deswegen:

Wie kann ich dort denn irgendwie konfigurieren an welchen Port er weiter leiten soll?

Fritzbox: Von Überall nach Port 443 -> fertig. Aber beim Cisco fehlt die Möglichkeit eines Zielports.


Gruß und Dank
PS: Auf der Seite zu der ich connecten will ist ein SDSL-Modem und dahinter der Cisco. Auf meiner Seite eine Fritzbox.
Mitglied: Xaero1982
11.04.2014 um 15:53 Uhr
Moin,

schade schade ...

Also das VPN hab ich nun mit QuickVPN zum Laufen gebracht. Das Problem war das Loadbalancing. Ich geh zwar über WAN 1 rein, aber offenbar über WAN 2 wieder raus und das haut nicht hin.
Das ist jetzt natürlich suboptimal, weil die VPN Leitung nur eine 2Mbit Leitung ist (das stört ja nicht), aber durch das deaktivieren des Loadbalancings auch der ganze interne Traffic über WAN 1 läuft und unsere VDSL Leitung quasi arbeitslos ist.

Geht das anders?

Gruß
Bitte warten ..
Mitglied: aqui
11.04.2014, aktualisiert um 16:07 Uhr
Ich geh zwar über WAN 1 rein, aber offenbar über WAN 2 wieder raus und das haut nicht hin.
Klar, weiss auch jeder Netzwerker warum, denn wenn du was an Ziel IP Adresse A absendest, die Antwort statt mit Absender IP Adresse A dann mit Absender IP Adresse B kommt bricht jede TCP Session sofort ab. Das ist nicht nur bei VPN so sondern allgemein da es gegen grundlegende TCP/IP Regeln und Standards verstösst.
Da musst du dich also nicht gross wundern....works as designed ! Normalerweise wäre das ein Bug der Firmware denn der Router dürfte das nicht tun !
Hast du die aktuellste Firmware in den Router geflasht ?? Das sollte immer erste Amtshandlung sein bevor man in Betrieb geht.
Du musst dann den VPN Zugang im Router Setup fest auf einen der WAN Ports festnageln !
Grundlegende Infos zu IPsec VPNs findest du hier:
http://www.administrator.de/wissen/ipsec-vpn-mit-cisco-mikrotik-pfsense ...
Bitte warten ..
Mitglied: Xaero1982
11.04.2014, aktualisiert um 17:50 Uhr
Jup, klar soweit.

Die aktuelle Firmware ist installiert.

Bei QuickVPN lässt sich leider gar nichts konfigurieren.
Das "normale VPN" hab ich bisher leider noch nicht zum Laufen bekommen.
Ich bekomme nur PEM Zertifikate (Client und Administrator) und ich bin noch nicht ganz durchgestiegen wie ich diese einsetze

Gruß

Gut nun hab ich wieder den gleichen Fehler wie zuvor ohne was geändert zu haben *jippie*
Bitte warten ..
Mitglied: aqui
11.04.2014 um 22:59 Uhr
Bei QuickVPN lässt sich leider gar nichts konfigurieren.
Deshalb besser das auch gleich vergessen und den freien Shrew Client verwenden, der kann allemal mehr:
https://www.shrew.net
Das "normale VPN" hab ich bisher leider noch nicht zum Laufen bekommen.
WAS bitte meinst du mit "normalem" VPN ?
Bitte warten ..
Mitglied: Xaero1982
11.04.2014 um 23:16 Uhr
Hi,

werde ich morgen mal in Angriff nehmen.

Damit meine ich nicht das vorkonfigurierte quickvpn

Hab jetzt noch die Option protokollbinding gefunden, aber welche Einstellungen muss ich da vornehmen?
Hast du ne Idee?
Bitte warten ..
Mitglied: Xaero1982
12.04.2014, aktualisiert um 13:11 Uhr
Moin,

danke für den Link aus einem anderen Thread Aqui

https://www.shrew.net/support/Howto_Linksys

Das hat sofort funktioniert.

Gruß
Bitte warten ..
Mitglied: Xaero1982
14.04.2014 um 23:12 Uhr
Nabend,

ich vergaß:

Frage zwei ist noch offen. Das mit dem Forwarding will so nicht funktionieren. Ich kann den internen Port leider auch nicht verbiegen.

Gruß
Bitte warten ..
Mitglied: Xaero1982
15.04.2014 um 00:03 Uhr
So, Lösung gefunden:

1. uPNP: Dort muss die entsprechende Regel eingerichtet werden. Angenommen man will über Port 8088 rein und intern auf Port 80 landen, klickt man unter uPNP auf Service Management und gibt dort einen Namen, den externen Port (8088) und den internen Port (80) an. Klickt auf Add to List und auf Ok.
2. Anschließend wählt man den Service aus und dann die Ziel IP und einen Haken auf Enable und auf Add to list und dann save.

3. Ihr müsst die Firewallregeln anpassen. Port 8088 mit dem Ziel-PC.
4. Es darf keine Portweiterleitungsregel geben, weil diese sonst die "Oberhand" hat und keine Umleitung stattfindet.

5. Der uPNP Dienst muss dazu nicht aktiviert sein!!

Gruß
Bitte warten ..
Mitglied: aqui
15.04.2014, aktualisiert um 08:55 Uhr
Angenommen man will über Port 8088 rein und intern auf Port 80 landen
Das ist ganz simples und normales Port Translation was jeder 20 Euro Baumarkt Router so auch an Bord hat und mit 3 Mausklicks eingerichtet ist.
Mit UPnP hat das rein gar nichts zu tun und warum es bei deinem Router an dieser Stelle der Konfig untergebracht ist schleierhaft weil schlicht falsch !

Generell sollte man NIEMALS UPnP auf einem Router aktivieren, denn damit setzt man seine Sicherheit aufs Spiel. Damit erlaubt man Anwendungen und auch generell Angreifern ohne eigenen Einfluss Ports im Router zu öffnen.
Eine Katastrophe, denn dann ist der Router ein löchriger Schweizer Käse und das interne LAN vollkommen ungeschützt.
Deshalb gibt es immer nur eins: UPnP AUS auf einem Router !
Ist bei dir ja glücklicherweise noch der Fall....hoffentlich
Bitte warten ..
Mitglied: Xaero1982
15.04.2014 um 09:30 Uhr
Hi aqui,

da bist du nicht der einzige der sich das fragt

Natürlich ist UPnP aus - schrieb ich ja oben. Warum das nun dort untergebracht ist keine Ahnung und finde ich persönlich auch falsch, weil ich da nicht mal hingeklickt habe - na gut ein mal am Anfang um zu schauen, ob es aus ist.

In dem Bereicht macht man letztlich wirklich nichts mehr außer zu sagen: Dieser externe Port X ist dem internen Port y zugeordnet.

Richtig, das ist simples und normales Port Translation was aber leider nicht an dem Punkt zu finden war wo ich es und vermutlich auch jeder andere vermutet hat - unter Forwarding. Denn nur dort macht es Sinn. Und ich sag dir noch was:

https://supportforums.cisco.com/discussion/11057366/rv042-different-inte ...

Laut Cisco geht es nicht.
Zitat: "Not on the RV042, it only can port forward say, port 161 and not alter that destination port number."

Gut, der Rv042 ist ein anderer als der Rv042G, aber auch wohl nur in der Hinsicht, dass er Gigabitports hat.

Gruß
Bitte warten ..
Mitglied: aqui
15.04.2014, aktualisiert um 10:32 Uhr
Eigentlich traurig für einen so renomierten Hersteller. Aber vermutlich ist das gewollt damit die nicht ihre "richtigen" IOS Routermodelle wie die Cisco 8xx damit kanibalisieren, denn die können das logischerweise problemlos...?!
Bitte warten ..
Mitglied: Xaero1982
15.04.2014 um 11:40 Uhr
Der Sinn bleibt mir verborgen, denn es geht ja defakto, wenn auch etwas versteckt.

Ich glaube kaum, dass die Firmware zwischen 042 und 042g so unterschiedlich ist, aber wer weiß.

Über den oben beschriebenen Weg ist es möglich und funktioniert auch. Auch wenn der nette Mitarbeiter von Cisco was anderes sagt.

Gruß
Bitte warten ..
Mitglied: aqui
15.04.2014, aktualisiert um 16:30 Uhr
...naja immerhin sind das 7 ! Versionssprünge. Das ist schon gewaltig und da sollte man sicherheitshalber immer die latest but greatest einspielen. Gerade bei VPNs !
Ob es das GUI logischer macht ist in der Tat zu bezweifeln. Hilft vermutlich nur ein anderer (besserer) Router.
Wenns aber jetzt klappt...who cares ?! Never touch a running system.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...