Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Cisco RV110W mit ausgehender PPTP

Frage Netzwerke Router & Routing

Mitglied: torak323

torak323 (Level 1) - Jetzt verbinden

25.02.2012, aktualisiert 30.05.2012, 6134 Aufrufe, 4 Kommentare

Konfig:

1. DSL Splitter
2. Speedport W700V Router inkl. Modem (baut PPOE auf)
3. Cisco RV110W (baut PPTP auf)
4. 24Port Gigabit Switch mit mehreren angeschlossenen Endgeräten

Ich habe folgendes Problem:

Wenn ich eine PPTP VPN Verbindung mit Windows oder auch Linux aufbaue, kann ich meine Volle Internetbandbreite über den VPN Tunnel ausnutzen.
Jetzt habe ich mir einen Cisco RV110W zugelegt und diesen hinter meinen Router geklemmt, so das der RV110W sich per PPTP über die Normale Internetverbindung die der Router aufgebaut hat einwählt.

Das Problem ist jetzt nur, egal was ich mache, ich komme nicht über 1000kb Down.
Ich habe schon alles versucht, MTU wert getestet und angeglichen, anderer VPN Anbieter, QoS eingestellt, jegliche last durch Logging oder Wlan vom RV110W genommen... das hat alles nichts gebracht.
Das teil hat auch nicht wirklich einstellmöglichkeiten was die PPTP einwahl angeht, der MTU wert is das einzigste was man wirklich verändern kann.

Langsam bin ich recht ratlos woran das noch liegen kann, ich kann mir höchstens noch vorstellen, das der CPU des RV110W zu schwach ist um eine höhere Bandbreite zu liefern.
Wenn ich den RV110W aber per DHCP ohne VPN Tunnel betreibe, habe ich auch meine Volle Internetbandbreite.

Für einen Rat oder Tipp woran das noch liegen kann wäre ich sehr dankbar.

Mit freundlichen Grüßen

Stefan
Mitglied: Pjordorf
25.02.2012 um 21:26 Uhr
Hallo und willkommen im Forum,

Zitat von torak323:
Wenn ich eine PPTP VPN Verbindung mit Windows oder auch Linux aufbaue, kann ich meine Volle Internetbandbreite über den VPN Tunnel ausnutzen.
Das halte ich für eine Falschaussage und trifft bestimmt nicht zu.

Jetzt habe ich mir einen Cisco RV110W zugelegt und diesen hinter meinen Router geklemmt,
Mit oder ohne NAT?

so das der RV110W sich per PPTP über die Normale Internetverbindung die der Router aufgebaut hat einwählt.
Also ein Standort - Standort VPN und kein Client - Standort VPN

Das Problem ist jetzt nur, egal was ich mache, ich komme nicht über 1000kb Down.
Du meinst also nicht mit mehr als 1 Mbit/sek. was die Standarduploadgeschwindigkeit einer 16 MBit/sek DSL Leitung entspricht.

Ich habe schon alles versucht, MTU wert getestet und angeglichen,
Was musstest du denn da angleichen und warum? Hat aber nichts damit zu tun.

anderer VPN Anbieter,
Das Erkläre aber jetzt mal genauer.

QoS eingestellt, jegliche last durch Logging oder Wlan vom RV110W genommen... das hat alles nichts gebracht.
Richtig.

Das teil hat auch nicht wirklich einstellmöglichkeiten was die PPTP einwahl angeht, der MTU wert is das einzigste was man wirklich verändern kann.
Was willst du bei VPN denn noch alles Einstellen können?

das der CPU des RV110W zu schwach ist um eine höhere Bandbreite zu liefern.
Nein.

Wenn ich den RV110W aber per DHCP ohne VPN Tunnel betreibe, habe ich auch meine Volle Internetbandbreite.
Richtig.

Für einen Rat oder Tipp woran das noch liegen kann wäre ich sehr dankbar.
Du hast bei deinem VPN durch deinen Client dich auf einen VPN Server eingewählt und hast aber in den Client Einstellungen drin gehabt das dein Client für lokale Verbindungen (Surfen) dein Standardgateway und nicht das Gateway deines VPN verwenden soll. Damit ging alles was NICHT ans VPN gerichtet war daran vorbei und du hast die Volle Bandbreite (gerade im Download was ja widerum ein Upload an der anderen Seite darstellt) deines DSL gehabt.

Nachdem jetzt dein RV110W den VPN Endpunkt darstellt und vermutlich auch dein Gateway, kommt alles was du jetzt saugst über das VPN zustande. Hier ist jetzt maßgeblich mit welcher Geschwindigkeit der VPN Endpukt auf der anderen Seite Daten liefern kann (sein Upload ist dein Download).

Wie sehen also zu welcher Zeit deine Routen aus? Was für Routen sind wann auf welchen Routern konfiguriert und was und wo ist als dein Gateway definfiniert. Wir können davon ausgehen das du immer ein PPTP verrwendet hast, oder?

Gruß,
Peter
Bitte warten ..
Mitglied: torak323
27.02.2012 um 11:52 Uhr
Danke erstmal für die Antwort Peter.

Zitat von Pjordorf:
Das halte ich für eine Falschaussage und trifft bestimmt nicht zu.

Ist aber genau so, bei SecureSwiss, SwissVPN und bei Perfect-Privacy habe ich die volle Bandbreite meiner DSL Leitung wenn ich mich direkt von Windows per PPTP einwähle.

Zitat von Pjordorf:
Mit oder ohne NAT?

ohne NAT

Zitat von Pjordorf:
Also ein Standort - Standort VPN und kein Client - Standort VPN

Richtig

Zitat von Pjordorf:
Du meinst also nicht mit mehr als 1 Mbit/sek. was die Standarduploadgeschwindigkeit einer 16 MBit/sek DSL Leitung entspricht.

Nein ich meine 1000kByte/sek oder ca 10000MBit/sek, theoretisch gehen bei meiner DSL Leitung ja ca. 1600kByte/sek

Zitat von Pjordorf:
Was musstest du denn da angleichen und warum? Hat aber nichts damit zu tun.

Angleichen musste ich garnichts, ich wollte nur wie gesagt jegliche Last vom RV110W nehmen das dieser die evtl. zu großen Pakete nicht vom Router fragmentiert werden müssen.

Zitat von Pjordorf:
Das Erkläre aber jetzt mal genauer.

Was denn genau?

http://www.secureswiss.ch/
http://www.swissvpn.net
http://www.perfect-privacy.com/

alle 3 getestet und bei allen 3 tritt das selbe problem mit den 1000kByte/sek auf.

Zitat von Pjordorf:
> das der CPU des RV110W zu schwach ist um eine höhere Bandbreite zu liefern.
Nein.

der CPU des RV110W ist laut Weboberfläche zu ca. 90% ausgelastet wenn ich eine VPN aufgebaut habe und etwas Downloade.
wenn ich den RV110W per DHCP laufen lasse ohne VPN liegt die Auslastung bei 30-40%.
genauso nur 30-40% Auslastung wenn ich den RV110W als DHCP konfiguriert habe, und dann eine PPTP VPN mit Windows aufbaue.


Zitat von Pjordorf:
Du hast bei deinem VPN durch deinen Client dich auf einen VPN Server eingewählt und hast aber in den Client Einstellungen
drin gehabt das dein Client für lokale Verbindungen (Surfen) dein Standardgateway und nicht das Gateway deines VPN verwenden
soll. Damit ging alles was NICHT ans VPN gerichtet war daran vorbei und du hast die Volle Bandbreite (gerade im Download was
ja widerum ein Upload an der anderen Seite darstellt) deines DSL gehabt.

Nein das stimmt so nicht, der Gateway läuft bei der Direktwahl per Windows über den VPN Anbieter, da ich ja einen direkten Tunnel von meinem PC bis zum VPN Anbieter aufbaue.
Dabei wird aber auch alles über den VPN geschickt. (zumindest von meinem PC aus)

Bei der Einwahl mit dem Cisco ist mein Gateway ja logischerweise der Cisco Router.


Zitat von Pjordorf:
Nachdem jetzt dein RV110W den VPN Endpunkt darstellt und vermutlich auch dein Gateway, kommt alles was du jetzt saugst über
das VPN zustande.

Richtig so war das auch geplant das eben alle Pc`s im Netzwerk über die VPN gehen.

Zitat von Pjordorf:
Hier ist jetzt maßgeblich mit welcher Geschwindigkeit der VPN Endpukt auf der anderen Seite Daten liefern
kann (sein Upload ist dein Download).

Das ist mir schon klar es ist aber tatsächlich so, dass NUR wenn ich eine Verbindung über den Cisco aufbaue die 1000kByte/s ankommen, per normaler einwahl über Windows aber die volle Bandbreite.
Die Anbieter versprechen auch so gut wie volle Bandbreite, klar dass das auch nicht immer zutreffen mag wenn man einen VDSL oder 100MBit/sek Kabel Anschluss hat.

Zitat von Pjordorf:
Wie sehen also zu welcher Zeit deine Routen aus? Was für Routen sind wann auf welchen Routern konfiguriert und was und wo ist
als dein Gateway definfiniert. Wir können davon ausgehen das du immer ein PPTP verrwendet hast, oder?

PPOE einwahl des Speedports ganz normal per T-Online.
PPTP einwahl des Ciscos über die schon aufgebaute PPOE Verbindung.
Der Cisco ist also mein Gateway.

Speedport hat die IP 192.168.2.1
RV110W hat die IP 192.168.178.1
DHCP Server ist bei beiden an und funktioniert auch einwandfrei.

die Netzwerkeinstellungen auf Windows sind also im IP kreis 192.168.178.x
Sandartgateway und DNS sind 192.168.178.1 also der Cisco Router.

Also was den VPN angeht habe ich immer PPTP verwendet, da der Cisco sowieso kein Ipsec oder ähnliches kann.
Auch in Windows habe ich immer PPTP verwendet.
SwissVPN und Perfect-Privacy bieten auch Open VPN an, habe ich auch getestet, geht auch ohne probleme, nur wie gesagt der Cisco kann nur PPTP von daher ist das recht uninteressant für mich.
Es hat auch nichts mit der Tages oder Nachtzeit zu tun, das hab ich ausgiebig getestet, Nachts um 4 Uhr oder Tagsüber um 18 Uhr, das Ergebnis ist das selbe Cisco 1000kByte/sek, mit normaler Windows einwahl 1600kByte/sek.

Die VPN Verbindung steht ja sowohl über den Cisco, als auch direkt per Windows 1A, keine Verbindungsabbrüche oder ähnliches, nur es fehlen eben ca 600kByte/sek.

Das Problem liegt entweder am Cisco oder an dem Speedport, bzw. an den Einstellungen, wobei ich wirklich schon fast alles versucht habe.
Oder ich stehe komplett auf dem Schlauch was aber manchmal passieren kann, vorallem beschäftige ich mich jetzt erst das erste mal mit VPN`s.

hier mal 4 Screenshots:

Cisco PPTP Einstellungen
http://www.torak323.de/ciscoPPTP.png

PPTP über den Cisco
http://www.torak323.de/PPTPueberCisco.png

DHCP am Cisco ohne VPN
http://www.torak323.de/DHCPueberCisco.png

PPTP Einwahl über Windows, DHCP am Cisco eingestellt.
http://www.torak323.de/PPTPueberWindows.png


Gruß und danke schonmal im Voraus

Stefan
Bitte warten ..
Mitglied: torak323
01.03.2012 um 19:25 Uhr
Hat keiner einen Rat?

Ich habe einen Speedport W700V, dieser wählt sich ganz normal wie jeder andere Router per PPOE zu T-Online ein.
Am erstene Lan port streckt der Entertain Reciever.
Am zweiten Lan Port hängt ein Cisco/Linksys RV110W Small Business VPN Firewall Router am WAN anschluß und wählt sich per PPTP über die schon bestehende Verbindung des Speedport W700V auf einen Schweizer VPN Anbieter ein.
Danach Verteilt ein 24Port Gigabit Switch die VPN Verbindung ans Netzwerk.
Das geht auch soweit ganz gut, aber maximal mit 950-1000kByte/sek, dabei ist die Auslastung des Cisco Router`s bei 80-90%
Wenn ich jetzt aber den Cisco Router per DHCP des Speedports eine IP zuweisen lasse, oder eine Satische IP vergebe, und mich per Windows oder Linux auf den Selben VPN Server verbinde, bekomme ich die an meinem Anschluß Vorhandene Geschwindigkeit von ca. 1650kByte/sek.

Ich kanns mir eigentlich nur noch so erklären das der Cisco tatsächlich zu langsam ist, aber wieso? Kann doch eigentlich nicht sein oder!?!
Bitte warten ..
Mitglied: Pjordorf
01.03.2012 um 21:10 Uhr
Hallo,

Zitat von torak323:
Hat keiner einen Rat?
Doch. Deine Angaben sind verwirrend
oder ca 10000MBit/sek
entspricht 10 GBit/sek. wobei deine DSL Leitung nur
1600kByte/sek
entsprechend 12800kBit/sek oder 12,8MBit/sek oder 0,012 GBit/sek hergibt das deutet auf einer klassischen 16 MBit DSl Leitung bei dir hin.

Nachdem du uns dein VPN und deine damit verbunden Anforderung (Anonym Surfen etc.) etwas näher erläutert hat (normalerweise wenn wir hier von VPN reden meinen wir tatsächlich das VPN zwischen 2 oder mehr Standorte und oder die Client Einwahl in Firmennetze usw.) ist dein Konstrukt auch leichter erkennbar.

Kann doch eigentlich nicht sein oder!?!
Warum das denn nicht? Das ist doch auch nur ein Rechner und hat seine grenzen. Die CPU da drin hat welche Eckdaten und kommt somit genauso an ihre Grenzen wie dein Desktop oder Laptop oder Smartphone usw.? Es scheint das dein Cisco im Downstream mit NAT (das hat nichts mit deinem DHCP zu tun) halt nicht über die 12,8 Mbit/sek raus kommt wenn dieser auch den VPN Endpunkt darstellt. Warum es schneller geht wenn du mit einem Client dein VPN direkt aufbaust? Nun, dein Cisco muss dann tatsächlich deutlich weniger Rechnen sprich er kümmert sich ja nicht mehr um das VPN. Das NAT was dein Cisco ja immer macht scheint den nicht weiter zu belasten.

Habe mal bei Cisco nachgesehen was dort an Throughput für deine Hardware steht (was du ja schon in deinen Techn. Specs. gelesen hast): http://www.cisco.com/en/US/prod/collateral/routers/ps10907/ps9923/data_ ... Dort steht • VPN throughput: 5Mbps und deine 5 Mbps sind Mega Bit per second http://en.wikipedia.org/wiki/Data_rate_units#Megabit_per_second Damit liegst du mit deinen 12,8 MBit/sek doch ganz gut da, oder?

Gruß,
Peter
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Voice over IP
Cisco 2600xm SIP Trunk autentifizieren

Frage von Herbrich19 zum Thema Voice over IP ...

LAN, WAN, Wireless
gelöst Cisco Aironet Radio-Settings (6)

Frage von swisstom zum Thema LAN, WAN, Wireless ...

SAN, NAS, DAS
gelöst Cisco LAG-LACP an Synology RS3614xs+ Bonding Bandbreite zu niedrig (20)

Frage von Ex0r2k16 zum Thema SAN, NAS, DAS ...

LAN, WAN, Wireless
Cisco AccessPoint 1131 - Status LED Red Radio LED blinkt rot (9)

Frage von 1x1speed zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...