Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Cisco SG300 - DHCP Server mit VLAN funktioniert nicht nach Layer 3 downgrade

Frage Hardware Switche und Hubs

Mitglied: HomeUser6866

HomeUser6866 (Level 1) - Jetzt verbinden

05.10.2014, aktualisiert 21:18 Uhr, 3590 Aufrufe, 3 Kommentare

Ich bin am verzweifeln.

Bisher hatte ich meinen Cisco SG 300 als layer 3 switch eingesetzt und alles funktionierte prima.

Nachdem ich mir eine Sohos UTM Firewall zugelegt habe, soll diese das Routine der VLANS übernehmen. Also habe ich den SG 300 auf Layer 2 zurückgestellt und alles neu konfiguriert. Der SG300 ist weiterhin der DHCP Server - DHCP Pools sind angelegt wie vorher.

Funktioniert auch mit einer Ausnahme:

Die angeschlossenen PC's erhalten bei DHCP keine IP Adresse.

Was mir nicht klar ist, woher der DHCP Server wissen soll, aus welchem Pool er einem VLAN Client eines IP-Adresse zuweisen soll.

Ich vermute auch dass dies das Problem ist, aber ich habe keine Ahnung wie dieser Bezug hergestellt wird.

Die default Gateways der einzelnen VLANS Liegen jetzt auf einem externen Server (UTM z.B. 192.168.20.1 für VLAN 20 - Firewall ist vorerst völlig offen VLAN xx ->any->any)).

Hat jemand eine Idee - ich bin am verzweifeln.

Statisch zugewiesenen IP's funktionieren!!!!

Viele Dank für Eure Hilfe im Voraus
Mitglied: aqui
LÖSUNG 05.10.2014, aktualisiert um 21:18 Uhr
Ich bin am verzweifeln.
Muss man hier nicht. Wir haben für (fast) alles eine Lösung
SG 300 als layer 3 switch eingesetzt und alles funktionierte prima.
Das sollte er auch....
Die angeschlossenen PC's erhalten bei DHCP keine IP Adresse.
Das ist sehr ungewöhnlich das der Switch selber DHCP Server ist. Bist du dir da ganz sicher ?? Wo ist diese Funktion im Handbuch beschrieben ?
In der Regel ist ein L3 Switch ein DHCP Relay Server oder DHCP Helper, d.h. er forwardet Pakete aus allen VLANs auf einen zentralen DHCP Server die die IPs vergibt.
woher der DHCP Server wissen soll, aus welchem Pool er einem VLAN Client eines IP-Adresse zuweisen soll.
Im Relay Mode bei L3 Betrieb ersetzt der DHCP Relay Server die Absender IP mit der IP Adresse seines eigenen VLAN Interfaces. Der zentrale DHCP Server erkennt dann anhand der Absender IP den richtigen Scope und vergibt einen IP aus dem Bereich.
Im L2 Mode funktioniert das logischerweise nicht mehr und es ist deshalb stark zu bezweifeln das der Switch selber Server sein kann, denn über ein VLAN Index müsste er irgendwie den Scope detektieren, was mehr als ungewöhnlich ist und vermutlich auch nicht supportet, deshalb wäre hier der Abschnitt im Manual interessant der diese Funktion beschreibt.

Wenn der Switch dann selber kein Routing mehr macht durch die deaktivierten L3 Funktionen hast du die UTM vermutlich mit einem tagged Uplink zentral an den Switch angeschlossen wie in diesem Forums Tutorial beschrieben:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
Richtig ??
Dann musst du vermutlich die UTM DHCP Server für die einzelnen VLAN Segmente spielen lassen wie es in solch einem Design üblich ist.
Es ist wie gesagt zu bezweifeln das der Switch selber noch irgendeine DHCP Funktion dann ausführt was wie gesagt generell ja üblich ist für L2 Switches.
Die default Gateways der einzelnen VLANS Liegen jetzt auf einem externen Server
Die UTM ist doch kein "Server" sondern einen Firewall ! Oder was meinst du mit "Server" ??
Statisch zugewiesenen IP's funktionieren!!!!
Ääähh, ja, das ist klar aber vermutlich nicht dein Ziel ?!
Bitte warten ..
Mitglied: Pjordorf
05.10.2014 um 19:48 Uhr
Hallo,

Zitat von aqui:
Das ist sehr ungewöhnlich das der Switch selber DHCP Server ist.
Ja, das kann der...

Bist du dir da ganz sicher ?? Wo ist diese Funktion im Handbuch beschrieben ?
http://www.cisco.com/c/dam/en/us/td/docs/switches/lan/csbms/sf30x_sg30x ... ab Seite 268. Scheint das dort ein vollwertiger DHCP drin steckt.
Entweder DHCP Server oder DHCP Relay und DHCP Server nur wenn er selbst kein Dynamische IP selbst erhält....

Gruß,
Peter
Bitte warten ..
Mitglied: HomeUser6866
05.10.2014 um 21:21 Uhr
Genau der Unterschied zwischen Layer 3 und Layer 2 bei der Zuweisung von DHCP Pools zum VLAN war das Problem.
Bin Deinem Vorschlag gefolgt und habe DHCP Server auf dem Cisco SG300 gelöscht und auf der UTM angelegt.
geht prima !!!!!

Nochmals herzlichen Dank

PS: Ob und wie man es mit dem DHCP Server auf dem Cisco SG300 in Layer 2 Mode zum laufen kriegt, habe ich nicht weiter verfolgt.
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Netzwerkmanagement
gelöst Cisco SG300 DHCP an VLAN (17)

Frage von Maik82 zum Thema Netzwerkmanagement ...

Router & Routing
Cisco Switch SG300-20 als DHCP Server (7)

Frage von carbo1 zum Thema Router & Routing ...

Netzwerkmanagement
gelöst VLAN Konfiguration für Cisco SG300-28 (5)

Frage von Silece zum Thema Netzwerkmanagement ...

Router & Routing
gelöst Cisco SG300 - Kein Routing ins VLAN (4)

Frage von Fluxx1337 zum Thema Router & Routing ...

Heiß diskutierte Inhalte
CPU, RAM, Mainboards
Kaufberatung für mind. 8 verschiedene HighEnd-Mainboards (23)

Frage von yperiu zum Thema CPU, RAM, Mainboards ...

Mac OS X
Mac kann nicht im LAN pingen alle anderen schon (19)

Frage von smartino zum Thema Mac OS X ...

Hyper-V
Langsames Netzwerk i210 LAN Karte (10)

Frage von Akcent zum Thema Hyper-V ...

Windows Server
Server 2016 - Kuriositäten (8)

Frage von certifiedit.net zum Thema Windows Server ...