Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Cisco VLAN Routingproblem

Frage Netzwerke LAN, WAN, Wireless

Mitglied: diefas

diefas (Level 1) - Jetzt verbinden

12.04.2010, aktualisiert 15:59 Uhr, 8771 Aufrufe, 3 Kommentare

Hallo zusammen,

ich habe mit unseren Cisco Switchen bei der Einrichtung von VLANs ein kleines Problemchen, und zwar

ich habe einen Cisco 3760 als VTP-Server der als Hauptswitch für die Server gilt und Cisco 2960G als Produktionsswitche.
Dabei sind meherer VLANs eingerichtet und unter anderem auch eines für Drucker und MuFu`s.

Soweit so gut, im Grunde kommt jeder überall hin und das Drucken geht auch.
Okay aber ein MuFu kann ja auch scannen und den Scan per Mail versenden und genau das läuft nicht mehr.
IP-Adressen und DNS sind eingeschaltet und auch korrekt.

Das MuFu ist in VLAN20 und der Mailserver in VLAN1, bei einem Verbindungstest vom MuFu zum Mailer
erhalte ich einen Verbindungsfehler, wobei das Drucken und Pingen zu anderen Maschinen funktioniert.

Das heißt für mich, SMTP wird wohl nicht weiter geroutet.

Welchen Eintrag muss ich im Cisco 3760 setzen, damit es funktioniert?

Danke für Eure Hilfe.

Gruß diefas
Mitglied: aqui
12.04.2010 um 20:22 Uhr
Der Cisco hat keine Ahnung von Diensten die über IP abgebildet sind, denn wie du ja selber weisst kann ein Switch nur bis maximal zum OSI Layer 3 "sehen", er kennt also nur IP Netze mehr aber auch nicht.
Ob HTTP, SMTP oder was auch immer über ihn abgewickelt wird ist ihm damit logischerweise völlig unbekannt.
Fazit: Du hast vermutlich, wie so oft hier, vergessen auf deinem MuFu das Default Gateway zu setzen, denn du musst ja vom MuFu VLAN 20 in das VLAN 1 des Servers routen und das macht einer deiner Core Switches, der die VLANs routet....vermutlich der 3760 ?!
Dort sollte es in etwa (geraten da keine Konfig gepostet) so aussehen in der Konfig ((simples Beispiel, Interface Nummer mögen bei dir anders sein
Cisco_Switch#
!
clock timezone MET 1
clock summer-time MEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
description Tagged Upink zum Cisco 2960
switchport mode trunk
switchport trunk encapsulation dot1q
!

interface FastEthernet0/2
description Port zum MuFu Drucker
switchport access vlan 20
spanning-tree portfast
!
interface FastEthernet0/3
description Port zum Mailserver
switchport access vlan 1
spanning-tree portfast

!
interface Vlan1
ip address 172.16.1.254 255.255.255.0
no ip route-cache
!
interface Vlan20
ip address 172.16.20.254 255.255.255.0
no ip route-cache
!
ip route 0.0.0.0 0.0.0.0 172.16.1.1 (Internet Router)
end


In diesem Beispiel muss das Gateway des Mailservers im VLAN 1 auf die 172.16.1.254 zeigen und das Gateway des MuFu im VLAN 20 auf die 172.16.20.254 die Gateways (Cisco 3760 IPs) in ihren jeweiligen VLANs.
Ein Ping des Mailservers vom MuFu und auch andersrum muss fehlerfrei laufen !!
Es mag sein das dein Mailserver und der MuFu auf anderen Switches liegen, das ist OK sofern dort die VLAN Zuordnungen 1 und 20 zu den Ports wieder korrekt sind und diese VLANs über die tagged Uplinks am Routing (Layer 3) Switch (vermutlich der 3760) anliegen.

Das wichtigeste nämlich die Konfig der Switches wo geroutet wird bzw. wo die Endgeräte Server und MuFu dran sind postest du ja leider nicht, deshalb ist eine dedizierte Hilfe nicht leicht und wir müssen hier leider wegen dieser fehlenden Information raten
Bitte warten ..
Mitglied: diefas
13.04.2010 um 16:01 Uhr
Hallo,

zunächst vielen Dank für die prompte Unterstützung.

Nun zu den Verbindungen:

- Exchange-Server ist am 3750 angeschlossen und im VLAN 1
- das MuFu ist am 2960G angeschlossen und im VLAN 20

- der 3750 ist VTP-Server und der 2960 ist ein VTP-Client, verbunden sind die
über Etherchannel und einem Trunk

- Adressen sind alle richtig gesetzt, wie gesagt ein Ping läuft von allen Seiten.
- Jedoch ein Versuch eine Telnetverbindung mittels PC aus dem VLAN 20 auf den
Exchange schlägt fehl.

die wesentliche Config 3750

clock timezone MEZ 1
switch 1 provision ws-c3750g-24ts-1u
switch 2 provision ws-c3750g-24ts-1u
system mtu routing 1500
ip subnet-zero
ip routing
no ip domain-lookup
!
!
!
!
archive
path tftp://172.20.1.130/RZ1SW01
write-memory
no file verify auto
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree uplinkfast
spanning-tree vlan 1 priority 0
!
vlan internal allocation policy ascending
!
interface Port-channel1
switchport trunk encapsulation dot1q

interface GigabitEthernet2/0/17
description testport Adminbuero vp1/7
switchport access vlan 20
switchport mode access
spanning-tree portfast

!
interface Vlan20
ip address 172.16.20.254 255.255.255.0
ip helper-address 172.20.1.102
ip helper-address 172.20.1.104
!
ip default-gateway 172.20.1.2
ip classless
ip route 0.0.0.0 0.0.0.0 172.20.1.2

die wesentliche Config 2960

no aaa new-model
clock timezone MEZ 1
system mtu routing 1500
ip subnet-zero
!
no ip domain-lookup

spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree uplinkfast
spanning-tree vlan 1 priority 16384
!
vlan internal allocation policy ascending
!
!
!
interface Port-channel1
!
interface Port-channel2
switchport mode trunk
!
interface GigabitEthernet0/1
switchport mode trunk
channel-group 2 mode on
!
interface GigabitEthernet0/2
switchport mode trunk
channel-group 1 mode on

!
interface GigabitEthernet0/37
switchport access vlan 20
switchport mode access

interface Vlan20
no ip address
no ip route-cache
!
ip default-gateway 172.20.1.2

Vielleicht hat noch jemand dazu einen Tipp.

Danke

Gruss diefas
Bitte warten ..
Mitglied: aqui
14.04.2010 um 16:39 Uhr
Oha, da ist ziemlich viel Murks in der Konfig... !!
So müsste es aussehen wenn der Mailserver im VLAN 1 an Port FasteEthernet 0/3 angeschlossen ist am 3750, der 3750 einen 2 fach aggregated Link hat zum 2960 (Port Channel) und der MuFu Drucker am 2960 am Port 10 im VLAN 20 angeschlossen ist !!
ACHTUNG: Folgende Gateway Einträge müssen zwingend gemacht werden:
Mailserver: 172.16.1.254
MuFu Drucker: 172.16.20.254

Cisco 3750:
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
!
interface GigabitEthernet2/0/1
Description Uplink Trunk zum Cisco 2960
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
channel-group 1 mode on
!
interface GigabitEthernet2/0/2
Description Uplink Trunk zum Cisco 2960
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
channel-group 1 mode on
!
interface FastEthernet0/3
description Port zum Mailserver (im VLAN 1 !)
spanning-tree portfast

interface Vlan1
ip address 172.16.1.254 255.255.255.0
!
interface Vlan20
ip address 172.16.20.254 255.255.255.0
ip helper-address 172.20.1.102
ip helper-address 172.20.1.104
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.20.1.2

Cisco 2960:
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
!
interface GigabitEthernet0/0/1
Description Uplink Trunk zum Cisco 3750
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
channel-group 1 mode on
!
interface GigabitEthernet2/0/2
Description Uplink Trunk zum Cisco 3750
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
channel-group 1 mode on
!
interface FastEthernet0/10
description Port zum MuFu Drucker (im VLAN 20 !)
switchport access vlan 20
spanning-tree portfast

interface Vlan1
ip address 172.16.1.253 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.20.1.2

Ein Ping vom Mailserver auf den MuFu muss funktionieren und acu andersrum sofern der MuFu pingen kann !!
Deine Cisco Konfig hat in mehreren Ebenen gravierende Fehler und sieht eher nach einer "Bastelei" aus !!
Die Link Aggregation wie oben dargestellt funktioniert so wenigstens nicht !!
Ein "show vlan" wäre noch hilfreich um zu sehen das die VLAN/Port Zuordnung korrekt ist !!
Bitte warten ..
Ähnliche Inhalte
Netzwerkmanagement
gelöst Cisco SG300 DHCP an VLAN (17)

Frage von Maik82 zum Thema Netzwerkmanagement ...

Router & Routing
Cisco SRW2024, VLAN, DHCP (9)

Frage von Ruckola zum Thema Router & Routing ...

Netzwerkgrundlagen
gelöst Cisco SG300 mit VLANs und Fritzbox (8)

Frage von vinzgreg zum Thema Netzwerkgrundlagen ...

Netzwerkmanagement
Cisco Switch - Extended VLANs konfigurieren (3)

Frage von kevische zum Thema Netzwerkmanagement ...

Neue Wissensbeiträge
Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(14)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

RedHat, CentOS, Fedora

Fedora 27 ist verfügbar

Information von Frank zum Thema RedHat, CentOS, Fedora ...

Heiß diskutierte Inhalte
Server
Bilder aus dem Web mit CSV runterladen (30)

Frage von Yannosch zum Thema Server ...

Windows Update
WSUS 4 (Server 2012 R2) - Windows 10 Updates nicht möglich (12)

Frage von c0d3.r3d zum Thema Windows Update ...

Windows Userverwaltung
gelöst Administrator hat alle Rechte verloren (10)

Frage von mrdead zum Thema Windows Userverwaltung ...