Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Citrix TS - XENAPP5 - MMC wird nicht ausgeführt ausser ich starte vorher ein anderes Programm

Frage Microsoft Windows Server

Mitglied: Smoke-the-Lord

Smoke-the-Lord (Level 1) - Jetzt verbinden

12.07.2010, aktualisiert 12:47 Uhr, 4993 Aufrufe, 7 Kommentare

Hi Gemeinde,
ich habe folgendes Problem:

Ich starte eine MMC + MSC (liegen lokal) die über Citrix veröffentlicht wurde. Der User wird am Server angemeldet (Anmeldefenster erscheint)... nichts passiert... der User wird abgemeldet (Abmeldefenster erscheint).

Wenn ich nun aber eine andere App (z.B IE8) auf dem Server starte um mich dort anzumelden und dann erst die MMC starte öfffnet sie sich ohne Probleme. Dieses Verhalten habe ich nur beim W2K8 SP2 mit XENAPP5. Dieser ist Mitglied in einer PS 4.5 Farm mit W2K3 Maschinen. Auf denen funktioniert das öffnen auch problemlos.

Woran kann das liegen?

Danke für die Antworten.
Mitglied: BigWim
12.07.2010 um 11:16 Uhr
Mal so ein Schuß ins Blaue.

Hört sich danach, dann der W2K8-Server die Task nicht erkennen kann als geöffnetes Programm.

Citrix führt eine Liste der OS-Task, um zu erkennen, wann die PA beendet ist. Vielleicht solltest Du diese mal etwas näher unter die Lupe nehmen ....

Markus
Bitte warten ..
Mitglied: Smoke-the-Lord
12.07.2010 um 12:47 Uhr
a31cabeae82d0f47e15d54540be77efe - Klicke auf das Bild, um es zu vergrößern

Danke für die Antwort. Citrix führt die MMC in der Prozessliste vom Server. Von daher denk ich vorbei geschossen. Oder meinst du was anderes?
Bitte warten ..
Mitglied: BigWim
12.07.2010 um 14:05 Uhr
ich meine, die Funktionalität rund um den Key HKLM->System->CurrentControlSet->Control>Terminal Server->SysProcs


Markus
Bitte warten ..
Mitglied: Smoke-the-Lord
12.07.2010 um 16:37 Uhr
Jetzt weiß ich worauf du hinaus willst. Du meinst wenn dort mmc.exe gelistet wäre, würde die connection beendet werden, obwohl die mmc auf dem Server noch läuft. Richtig verstanden?
Dann müsste logischerweise, nachdem ich den IE8 und die MMC geöfnnet habe, die Connection bei beenden vom IE getrennt werden. Ist leider nicht der Fall... die MMC läuft weiter.

Das hier ist im Key zu finden, für mich würde nichts auf das Problem hinweisen.

screg.exe REG_DWORD 0x0
netdde.exe REG_DWORD 0x0
clipsrv.exe REG_DWORD 0x0
lmsvcs.exe REG_DWORD 0x0
MsgSvc.exe REG_DWORD 0x0
NETSTRS.EXE REG_DWORD 0x0
nddeagnt.exe REG_DWORD 0x0
os2srv.exe REG_DWORD 0x0
wfshell.exe REG_DWORD 0x0
win.com REG_DWORD 0x0
conime.exe REG_DWORD 0x0
proquota.exe REG_DWORD 0x0
imepadsv.exe REG_DWORD 0x0
ctfmon.exe REG_DWORD 0x0
TaskEng.exe REG_DWORD 0x0
dwm.exe REG_DWORD 0x0
rdpclip.exe REG_DWORD 0x0
ssonsvr.exe REG_DWORD 0x0
Bitte warten ..
Mitglied: BigWim
13.07.2010 um 09:12 Uhr
Zitat von Smoke-the-Lord:
Jetzt weiß ich worauf du hinaus willst. Du meinst wenn dort mmc.exe gelistet wäre, würde die connection beendet
werden, obwohl die mmc auf dem Server noch läuft. Richtig verstanden?
Ja, das war mein Hintergedanke. Konnte ich hier nicht prüfen, haben "nur" W2K3 SE

Dann könnte ich mir noch vorstellen, dass Du vor einem Timing-Problem stehst. Warum und wie auch immer. Ich würde das vorab testen, in dem ich den Startaufruf der PA in eine CMD verpacke mit einem Sleep oder eine Pause.

Also sinngemäß so:

01.
Sleep 10 
02.
start mmc.exe
oder eben statt des Sleep ein "Pause", um zu sehen, was da passiert ....

Markus
Bitte warten ..
Mitglied: Smoke-the-Lord
13.07.2010 um 14:02 Uhr
Anscheinend startet er die mmc garnicht. Wenn ich eine cmd hinterlege bleibt das Verhalten unverändert. Ein Echo >> Datei in der cmd wird auch nicht geschrieben.

Im Windows Application Log hab ich folgendes Event gefunden was die erfolgreiche und missglückte Anmeldung unterscheidet.

Information 13.07.2010 13:03:32 Source: Microsoft-Windows-Winlogon Event ID:4004 Task:None
The Windows logon process has failed to terminate the currently logged on user's processes.

MS spuckt das hier aus:
http://technet.microsoft.com/en-us/library/dd363910%28WS.10%29.aspx


Allerdings ist mir der Unterschied zwischen einer Iexplore.exe und einer mmc.exe in diesem Zusammenhang nicht ersichtlich.
Bitte warten ..
Mitglied: BigWim
13.07.2010 um 15:08 Uhr
Zitat von Smoke-the-Lord:
Allerdings ist mir der Unterschied zwischen einer Iexplore.exe und einer mmc.exe in diesem Zusammenhang nicht ersichtlich.
Stimme ich Dir zu; kann ich jetzt auch so nichts entdecken.

Anscheinend startet er die mmc garnicht. Wenn ich eine cmd hinterlege bleibt das Verhalten unverändert. Ein Echo >>
Datei in der cmd wird auch nicht geschrieben.
Ich kann das hier leider nicht nachstellen und mir gehen. Hast Du es auch mit einer Pause probiert.
Bei diesem Test käme es mir wirklich darauf, dass der Server mit dem Start der Anwendung beschäftigt ist.

Einen IE zu starten oder eine "kleine" mmc.exe wird sich schon zeitlich auswirken. Mit der Pause kannst dann sehen, ob er wirklich nicht startet.

Kann es evtl. sein, dass eine "Verbotsliste" dafür sorgt, dass die Anwendung als PA nicht gestartet werden darf?

Ansonsten gehen mir jetzt die Idee aus ...

Markus
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Programm wird sehr langsam ausgeführt (19)

Frage von Peter32 zum Thema Batch & Shell ...

Windows 7
gelöst Programme starten nicht und werden nicht installert (4)

Frage von Zoom78 zum Thema Windows 7 ...

Sicherheitsgrundlagen
Programm ohne UAC und Administratorrechte starten (3)

Anleitung von agowa338 zum Thema Sicherheitsgrundlagen ...

Windows Netzwerk
Citrix Anmeldung Problem

Frage von DaHuber zum Thema Windows Netzwerk ...

Neue Wissensbeiträge
Linux Netzwerk

Ping und das einstellbare Bytepattern

(1)

Erfahrungsbericht von LordGurke zum Thema Linux Netzwerk ...

Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(3)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Heiß diskutierte Inhalte
SAN, NAS, DAS
MSA 2050 RAID Konfig (27)

Frage von Leo-le zum Thema SAN, NAS, DAS ...

Netzwerkmanagement
Windows Server 2008 R2: "netsh reset" nicht verfügbar? (11)

Frage von RickTucker zum Thema Netzwerkmanagement ...

Outlook & Mail
Outlook Suche liefert kein Ergebnise mehr (8)

Frage von Bjoern-B zum Thema Outlook & Mail ...

Windows Server
gelöst "Kiosk"System für Demoversion und neue Versionen einer Anwendung (7)

Frage von kpieper zum Thema Windows Server ...