Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Client als "Satellit" in fremdem Subnetz einsetzen

Frage Netzwerke Router & Routing

Mitglied: b1ggi1

b1ggi1 (Level 1) - Jetzt verbinden

26.11.2014, aktualisiert 19:58 Uhr, 1110 Aufrufe, 10 Kommentare

Hallo,

erstmal hallo, dies ist mein erster Beitrag hier. Ich schieße mal gleich los:

Ich habe 2 (räumlich getrennte) Subnetze.
Beide haben ein Gateway ins Internet (1x WRT1900AC und 1x Fritzbox 7360), und beide sind durch ein Gerät gekoppelt (Ubiquiti Nanostation M5 im Router-modus | IPs: 192.168.1.237/192.168.0.237).
Statische Routen sind auf beiden Gateways konfiguriert, um sich gegenseitig zu erreichen.

Subnetz 1 hat die 192.168.0.0, Subnetz 2 die 192.168.1.0

In Subnetz 1 befindet sich ein Server, auf dem der Plex Mediaserver (192.168.0.210) läuft.
In Subnetz 2 befindet sich ein TV mit der Plex App, welcher gerne auf den Plex Mediaserver aus Subnetz 1 zugreifen möchte.


Normalerweise wäre das kein Problem, da die statischen Routen ja zulassen, dass man aufs jeweils andere Netz kommt.

Im Falle der Plex App auf dem Samsung TV in Subnetz 2 kann man aber keine "Server-Adresse" eingeben.
Dort bin ich mit einem Plex Account angemeldet, und dieser Plex Account weiß auch wie er den Mediaserver aus dem Internet erreichen könnte.

Mein Ziel ist logischerweise aber, dass die Filme nicht den Weg übers Internet gehen, sondern über die Kopplung gesendet werden. Die App erkennt nicht, dass sie nur die 192.168.0.210 aufrufen muss, um den Plex Media Server zu erreichen.

Wären TV und Server im gleichen Subnetz, würden sie sich gegenseitig sehen, und auch direkt streamen.

Deswegen suche ich nach einer Möglichkeit den TV durch einen Tunnel ins Subnetz 1 exklusiv anzuschließen.

- Wäre es möglich, dem TV eine Adresse wie 192.168.0.99 mit Gateway 192.168.1.237 zu geben?
- Wäre es eine Möglichkeit, IP Aliasing auf der Kopplung zu aktivieren, um in Richtung Subnetz 2 eine 192.168.0.x Adresse zusätzlich einzurichten, oder gibt das Routingprobleme?
- Wäre es möglich, einen managed switch zwischen TV und Subnetz 2 zu setzen, um ein VLAN Tag zu setzen, und dieses VLAN durch die Kopplung zu bridgen, und danach wieder zu entfernen?
- VPN denke ich würde natürlich gehen, aber meine E3200 und WRT54GL die ich noch übrig habe, sind wohl routingtechnisch zu langsam denke ich. Es werden ca 20 Mbit/s benötigt.
Mitglied: aqui
26.11.2014, aktualisiert um 18:40 Uhr
Finde doch erstmal raus WIE die App mit dem Server kommuniziert. Häufig basiert das auf Multicast oder DDNS (Bonjour).
Dann reicht es ganz einfach das im Router zu aktivieren und fertig ist der Lack. Bei DDNS mit einem Proxy. Dann finden sich auch beide problemlos über die Subnetze.
Ein sehr hilfreiches Tool um die Kommunikation rauszufinden (wenn man nicht Dr. Google befragen will) ist der allseits beliebte Wireshark Sniffer !
Grundlagen findest du zu dem Thema u.a. hier:
http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...
Bitte warten ..
Mitglied: b1ggi1
26.11.2014 um 18:45 Uhr
Hallo,

Es ist mir vorhin wie Schuppen von den Augen gefallen. Gateway 192.168.1.237 für den TV. Dann benutzen tv und server die gleiche wan adresse, und somit bleibt die Anfrage lokal
Bitte warten ..
Mitglied: aqui
26.11.2014, aktualisiert 28.11.2014
Und... ?? War das jetzt die Lösung ??

Wenn ja dann bitte auch
http://www.administrator.de/faq/32
nicht vergessen !
Bitte warten ..
Mitglied: AnkhMorpork
27.11.2014 um 10:34 Uhr
Meinst du das mit der Lösung ernst?
Bitte warten ..
Mitglied: aqui
27.11.2014, aktualisiert um 20:49 Uhr
Nicht wirklich, denn die oben gepostete Lösung ist ja etwas sinnfrei. Aber wenns für den TO ne Lösung ist...?!
Bitte warten ..
Mitglied: b1ggi1
27.11.2014 um 22:03 Uhr
Ja, natürlich habe ich das ernst gemeint, dumme Frage. Für mich hat sich es erledigt, obwohl wir natürlich trotzdem drüber diskutieren können, wie man das anders lösen hätte könne.
Bitte warten ..
Mitglied: AnkhMorpork
28.11.2014 um 07:48 Uhr
Zitat von b1ggi1:

Ja, natürlich habe ich das ernst gemeint, dumme Frage. Für mich hat sich es erledigt, obwohl wir natürlich trotzdem
drüber diskutieren können, wie man das anders lösen hätte könne.
Schau dir doch bitte mal an, welchen Post du als Lösung markiert hast, bevor du Leuten dumme Fragen unterstellst!
Bitte warten ..
Mitglied: b1ggi1
28.11.2014 um 14:12 Uhr
Ich könnte meinen eigenen Post nicht als Lösung markieren, liegt wohl an der Forensoftware. Ich hatte deine Antwort wohl etwas falsch aufgefasst, sorry dafür.
Bitte warten ..
Mitglied: AnkhMorpork
28.11.2014 um 14:17 Uhr
Zitat von b1ggi1:

Ich könnte meinen eigenen Post nicht als Lösung markieren, liegt wohl an der Forensoftware. Ich hatte deine Antwort wohl
etwas falsch aufgefasst, sorry dafür.

Kein Thema. Du kannst aber die Markierung wieder löschen. Findet man unter "Mehr" glaube ich.

Gruß

ankh
Bitte warten ..
Mitglied: aqui
LÖSUNG 28.11.2014, aktualisiert 29.11.2014
Was Kollege AnkhMorpork meint ist deine vollkommen sinnfreie Antwort auf dein in sich unlösbares Problem.
Vielleicht mal ein Beispiel im übertragenen Sinne:
Du fragtest: "Wie bekomme ich ein Fisch auf ein Fahrrad ??"
Antwort war das das gar nicht geht weil unmöglich usw.
Darauf du mit der Lösung: "OK, habs gelöst. Der Fisch brauchte nur ein paar Schuhe auf die Flossen !"
Du erkennst dann wie wir glauben vermutlich selber die Sinnfreiheit deiner o.a. Lösung.
Nur so viel:
Aus einem Layer 2 Segment mit einer IP Adresse x kann man niemals ein Endgerät betreiben was die IP Adresse y hat und dem dann ein Gatway in x eintragen. (Jedenfalls nicht mit billigem Consumer Equipment was du hast !) Das ist so wie die Quadratur des Kreises....
Mit Verlaub gesagt liegt es vermutlich an etwas löchrigem Netzwerk Wissen. Letztlich aber auch vollkommen egal denn wenns jetzt alles rennt bei dir ist das die Hauptsache. Nur die Erklärung dazu, die kann nicht stimmen
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Werte in Spalten vergleichen und einsetzen
gelöst Frage von Inge88Microsoft Office4 Kommentare

Halihalo, ich bin neu hier und versuche eine Lösung zu finden, bzw. kompetente Excel-Kenner: Ich habe mehrere Spalten (A, ...

Viren und Trojaner
Fremder auf meinem PC?
gelöst Frage von zzbaronViren und Trojaner12 Kommentare

Hallo an alle, ich habe da seit zwei Tagen etwas merkwürdiges auf meinem PC: Ich benutze Windows 10 mit ...

Windows 7
Windows OEM in Unternehmen einsetzen?
gelöst Frage von tomtom00Windows 75 Kommentare

Hallo, ich habe mal eine kleine Frage. Mein Schwager hat ein kleines Unternehmen (5 Arbeitsplatzrechner). Da auf diesen noch ...

Netzwerke
VPN - Welche Lösung einsetzen?
Frage von br00talNetzwerke12 Kommentare

Hallihallo :) Habe mich natürlich erst ein bisschen reingelesen und unter anderem auch diese Anleitung durchgelesen: Da würde mich ...

Neue Wissensbeiträge
Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 2 StundenWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 2 StundenWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 14 StundenInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Verschlüsselung & Zertifikate

19 Jahre alter Angriff auf TLS funktioniert immer noch

Information von BassFishFox vor 20 StundenVerschlüsselung & Zertifikate1 Kommentar

Interessant zu lesen. Der Bleichenbacher-Angriff gilt unter Kryptographen als Klassiker, trotzdem funktioniert er oft noch. Wie wir herausgefunden haben, ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Von rj11 auf rj45
Frage von jensgebkenLAN, WAN, Wireless19 Kommentare

Hallo Gemeinschaft, könnt ihr mir vielleicht bei der anfertigung eines Kabels helfen - habe ein rj 11 stecker und ...

Netzwerkmanagement
NAS über zwei weitere Ethernet Anschlüsse verbinden
gelöst Frage von Sibelius001Netzwerkmanagement17 Kommentare

Sorry - ich bin hier wahrscheinlich als kompetter IT Trottel unterwegs. Aber eventuell kann mir jemand ganz einfach helfen: ...

Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...