Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Client für SUS1.0 mit SP1 - brauche ich den Client wirklich?

Frage Netzwerke

Mitglied: 2795

2795 (Level 1)

29.12.2004, aktualisiert 05.01.2005, 5284 Aufrufe, 6 Kommentare

Hi,

nachdem ich nun endlich SUS 1.0 mit SP1 auf meinem Server installiert habe, und der Service inzwischen alle WindowsUpdates aus den Netz geholt hat, wollte ich eigentlich die PC's mit
dem Client ausstatten.
Der Client lässt sich aber leider nicht installieren!
Zur Info. Ich habe hier mehrere PC's mit Win2k und SP4 und ein paar mit XP+SP2.
Auf den PC's mit Win2K+Sp4 erhalte ich die Mitteilung, das Win2K mit SP2 oder WinXP
benötigt wird. Ich fühl mich etwas verarscht.

Brauche ich diesen Client wirklich? Reicht es vielleicht die Einträge in der Reg zu ändern?
Oder gibt es noch andere Alternativen?

Kerl
Mitglied: Knigge
29.12.2004 um 11:57 Uhr
Hallo!

Du benötigst keinen client. Es sind eigentlich nur ein paar Registry Einträge um die Clients zu konfiguriren. Die CT hatte einmal einen Vorzügliche Artikel hierzu.

Dies sind die Keys:

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate]
"WUServer"="http://IP"
"WUStatusServer"="http://IP"

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]
"NoAutoUpdate"=dword:00000000
"AUOptions"=dword:00000004
"ScheduledInstallDay"=dword:00000000
"ScheduledInstallTime"=dword:0000000c
"UseWUServer"=dword:00000001
"RescheduleWaitTime"=dword:0000001e
"NoAutoRebootWithLoggedOnUsers"=dword:00000001

und dieses batch file ausführen:

@echo off
REM Autor: Stefan Finkenzeller, Karsten Violka
REM Stand: 10.10.2003
REM
REM Der AutoUpdate Client prft nach dem Ausfhren des Skriptes
REM innerhalb der n?chsten zehn Minuten, ob Microsofts
REM Internetserver oder ein lokaler SUS-Server neue Updates
REM fr ihn bereith?lt.

REM Prfen, ob das Program REG.EXE vorhanden ist
if EXIST %systemroot%\system32\REG.EXE goto WEITER

echo Das Skript kann nicht ausgefhrt werden, weil das Programm
echo %systemroot%\system32\REG.EXE fehlt!
echo Sie finden dieses Tool auf Ihrer Windows 2000 CD im Archiv
echo \Support\Tools\support.cab.

goto ENDE

:WEITER
echo Dienst "Automatische Updates" stoppen...
%systemroot%\system32\net stop wuauserv 2>nul

echo Registry-Werte ?ndern ...

REM "LastWaitTimeout" l?schen, wenn nicht vorhanden Fehlermeldung
REM unterdrücken (mit "2>null")
%systemroot%\system32\REG DELETE "HKLM\Software\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update" /v LastWaitTimeout /f 2>null
%systemroot%\system32\REG ADD "HKLM\Software\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update" /v AUState /t REG_DWORD /d 2 /f

REM AutoUpdate-Dienst wieder starten
%systemroot%\system32\net start wuauserv
if errorlevel 2 goto ERR_SERVICEDISABLED
goto ALLESKLAR

:ERR_SERVICEDISABLED
echo -------------------------------------------------------------
echo Hinweis: Der Dienst "Automatische Updates" ist wahrscheinlich
echo deaktiviert. Starten Sie "services.msc" und setzen Sie hier
echo seinen Starttyp auf "manuell".
echo -------------------------------------------------------------
goto ENDE

:ALLESKLAR
echo ------------------------------------------------------------
echo Die Registry-Einstellungen wurden zurckgesetzt und der
echo AutoUpdate-Dienst neu gestartet.
echo In den n?chsten zehn Minuten sollte der Dienst seinen
echo Server ansprechen, um nach neuen Updates zu suchen.
echo ------------------------------------------------------------

:ENDE
pause

Gruß Knigge
Bitte warten ..
Mitglied: 2795
29.12.2004 um 14:58 Uhr
Danke.

Ich werds probieren und dir bescheid geben.

Kerl
Bitte warten ..
Mitglied: Atti58
29.12.2004 um 15:54 Uhr
Du arbeitest nicht in einer Domäne, oder? Wenn doch, solltest Du Dir die Doku ansehen, die mit dem SUS geliefert wird, dort wird genau erläutert, wie man das Ganze über Gruppenrichtlinien sehr effektiv einrichten kann,

Gruß

Atti.
Bitte warten ..
Mitglied: 2795
31.12.2004 um 16:06 Uhr
Hi @Atti,

ich bin ehrlich. Ich habe die Dokumentation nur überflogen, sonst wäre ich wahrscheinlich
drauf gestossen und Ja ich arbeite in einer Domäne.

Das wird auf jeden Fall meine nächste Aktion (imj nächsten Jahr) werden.

Jetzt läuft erstmal der ein Test mit dem was mir @Knigge gegeben, und das bisher sehr erfolgreich.

Euch beiden noch einen guten Rutsch ins neu Jahr - man sieht sich

Kerl
Bitte warten ..
Mitglied: 2795
05.01.2005 um 12:01 Uhr
Hi @Knigge,

der erste Testlauf war ziemlich Erfolg versprechend. Allerdings hat es sich gezeigt, dass man auf die Reg.-Einträge:

"ScheduledInstallDay"=dword:00000000
"ScheduledInstallTime"=dword:0000000c
"RescheduleWaitTime"=dword:0000001e

verzichten sollte.

Ich hatte jetzt mehrmals den Fall, das die Kiste seine Updates vom Server geholt hat und dann
mal mit mal ohne Ankündigung nach der Installation einen Neustart vornahm.
Dabei hatte ich hinundwieder die Möglichkeit vorher offene Dateien zu schließen, aber nicht immer. Auch kam es wiederholt vor, das er immer wieder die gleichen Updates installierte.
Ein nicht so prickelnder Zustand.

Indem ich auf die o.g. Reg.-Einträge verzichte, habe ich die Möglichkeit Einfluss auf den weitere
Ablauf der Installation, nach dem Download, zu nehmen.


Kerl
Bitte warten ..
Mitglied: Knigge
05.01.2005 um 12:57 Uhr
Hallo!

Dieser Umstand tritt in unserer Domäne so nicht auf. Jedoch gibt es bei uns das Problem, daß der ein oder andere Client OHNE Adminrechte die Updates beziehen kann. Da wir unsere ADS nocht nicht für die Policies einsetzten, ein sehr merkwürdiger Zustand. Aber mit dem WUS wird ja alles besser. Wünsche noch ein gutes neues!

Gruß Knigge
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Welche Zertifikate werden für den Exchange wirklich benötigt?
Frage von magicpeterExchange Server8 Kommentare

Moin, ich betreibe einen Exchange 2013 mit folgenden Zertifikaten und SplittDNS (remote.domain.com). Welches Zertifikate werden für den Exchange benötigt? ...

Humor (lol)
Backups zahlen sich wirklich aus
Frage von Melvin.van.HorneHumor (lol)22 Kommentare

Moin, Ich arbeite im öffentlichen Dienst. Und da habe ich eine Höhergruppierung beantragt. Die Antwort war "Das sieht nicht ...

Windows Userverwaltung
Nach Backup Wiederherstellung des Servers brauchen die Clients sehr lange zum starten
Frage von roeggiWindows Userverwaltung6 Kommentare

Hallo Zusammen Wir mussten bei einem Kunden ein Backup vom SBS2011 zurückspielen. Leider war das Backup ca. 3 Monate ...

CPU, RAM, Mainboards
Serverboard wirklich von nöten?!
gelöst Frage von 106561CPU, RAM, Mainboards34 Kommentare

Habe mal eine frage an euch: wo liegt der unterschied zwischen einen Desktop Board und einem Serverboard. Ich denke ...

Neue Wissensbeiträge
Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 2 StundenWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 2 StundenWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 14 StundenInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Verschlüsselung & Zertifikate

19 Jahre alter Angriff auf TLS funktioniert immer noch

Information von BassFishFox vor 21 StundenVerschlüsselung & Zertifikate1 Kommentar

Interessant zu lesen. Der Bleichenbacher-Angriff gilt unter Kryptographen als Klassiker, trotzdem funktioniert er oft noch. Wie wir herausgefunden haben, ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Von rj11 auf rj45
Frage von jensgebkenLAN, WAN, Wireless19 Kommentare

Hallo Gemeinschaft, könnt ihr mir vielleicht bei der anfertigung eines Kabels helfen - habe ein rj 11 stecker und ...

Netzwerkmanagement
NAS über zwei weitere Ethernet Anschlüsse verbinden
gelöst Frage von Sibelius001Netzwerkmanagement17 Kommentare

Sorry - ich bin hier wahrscheinlich als kompetter IT Trottel unterwegs. Aber eventuell kann mir jemand ganz einfach helfen: ...

Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...