Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

client verbindet sich nicht mit vpn-server

Frage Netzwerke LAN, WAN, Wireless

Mitglied: tuser13

tuser13 (Level 1) - Jetzt verbinden

12.09.2008, aktualisiert 25.09.2008, 5978 Aufrufe, 4 Kommentare

OPENVPN

Hallo!

Ein entferntes Lan besteht aus zwei Rechnern.
Ich möchte meinen Rechner mit diesem Lan connecten.
Auf dem Hauptrechner im entfernten Lan habe ich openvpn installiert.
Die Schlüssel erstellt (Server und Client).
Der Server läuft auch.
Auf meinem Rechner (XP) habe ich dann die Schlüssel in die richtigen Verzeichnisse kopiert, die Client.ovpn per Editor erstellt und erhalte auch keine Fehlermeldung bzgl. falscher Pfade.
Starte ich jetzt den Client dann habe ich folgendes Log-File:

Fri Sep 12 22:56:47 2008 us=626941 Current Parameter Settings:
Fri Sep 12 22:56:47 2008 us=627081 config = 'C:\Programme\OpenVPN\config\levcl
ient.ovpn'
Fri Sep 12 22:56:47 2008 us=627149 mode = 0
Fri Sep 12 22:56:47 2008 us=627181 show_ciphers = DISABLED
Fri Sep 12 22:56:47 2008 us=627221 show_digests = DISABLED
Fri Sep 12 22:56:47 2008 us=627252 show_engines = DISABLED
Fri Sep 12 22:56:47 2008 us=627288 genkey = DISABLED
Fri Sep 12 22:56:47 2008 us=627322 key_pass_file = '[UNDEF]'
Fri Sep 12 22:56:47 2008 us=627359 show_tls_ciphers = DISABLED
Fri Sep 12 22:56:47 2008 us=627396 proto = 0
Fri Sep 12 22:56:47 2008 us=627424 local = '[UNDEF]'
Fri Sep 12 22:56:47 2008 us=627454 remote_list[0] = {'xxx.dyndns.org', 11
94}
Fri Sep 12 22:56:47 2008 us=627502 remote_random = DISABLED
Fri Sep 12 22:56:47 2008 us=627533 local_port = 1194
Fri Sep 12 22:56:47 2008 us=627613 remote_port = 1194
Fri Sep 12 22:56:47 2008 us=627708 remote_float = ENABLED
Fri Sep 12 22:56:47 2008 us=627779 ipchange = '[UNDEF]'
Fri Sep 12 22:56:47 2008 us=627810 bind_local = DISABLED
Fri Sep 12 22:56:47 2008 us=627840 dev = 'tap'
Fri Sep 12 22:56:47 2008 us=627868 dev_type = '[UNDEF]'
Fri Sep 12 22:56:47 2008 us=627898 dev_node = '[UNDEF]'
Fri Sep 12 22:56:47 2008 us=627927 tun_ipv6 = DISABLED
Fri Sep 12 22:56:47 2008 us=627957 ifconfig_local = '[UNDEF]'
Fri Sep 12 22:56:47 2008 us=628741 ifconfig_remote_netmask = '[UNDEF]'
Fri Sep 12 22:56:47 2008 us=629581 ifconfig_noexec = DISABLED
Fri Sep 12 22:56:47 2008 us=630374 ifconfig_nowarn = DISABLED
Fri Sep 12 22:56:47 2008 us=631164 shaper = 0
Fri Sep 12 22:56:47 2008 us=631964 tun_mtu = 1500
Fri Sep 12 22:56:47 2008 us=632755 tun_mtu_defined = ENABLED
Fri Sep 12 22:56:47 2008 us=633554 link_mtu = 1500
Fri Sep 12 22:56:47 2008 us=634343 link_mtu_defined = DISABLED
Fri Sep 12 22:56:47 2008 us=635172 tun_mtu_extra = 32
Fri Sep 12 22:56:47 2008 us=635938 tun_mtu_extra_defined = ENABLED
Fri Sep 12 22:56:47 2008 us=636731 fragment = 0
Fri Sep 12 22:56:47 2008 us=637632 mtu_discover_type = -1
Fri Sep 12 22:56:47 2008 us=638475 mtu_test = 0
Fri Sep 12 22:56:47 2008 us=639258 mlock = DISABLED
Fri Sep 12 22:56:47 2008 us=640065 keepalive_ping = 0
Fri Sep 12 22:56:47 2008 us=640892 keepalive_timeout = 0
Fri Sep 12 22:56:47 2008 us=641702 inactivity_timeout = 0
Fri Sep 12 22:56:47 2008 us=642504 ping_send_timeout = 0
Fri Sep 12 22:56:47 2008 us=643322 ping_rec_timeout = 120
Fri Sep 12 22:56:47 2008 us=644147 ping_rec_timeout_action = 2
Fri Sep 12 22:56:47 2008 us=644945 ping_timer_remote = DISABLED
Fri Sep 12 22:56:47 2008 us=645874 remap_sigusr1 = 0
Fri Sep 12 22:56:47 2008 us=646719 explicit_exit_notification = 0
Fri Sep 12 22:56:47 2008 us=647596 persist_tun = DISABLED
Fri Sep 12 22:56:47 2008 us=648569 persist_local_ip = DISABLED
Fri Sep 12 22:56:47 2008 us=649401 persist_remote_ip = DISABLED
Fri Sep 12 22:56:47 2008 us=650254 persist_key = DISABLED
Fri Sep 12 22:56:47 2008 us=651130 NOTE: --mute triggered...
Fri Sep 12 22:56:47 2008 us=652048 138 variation(s) on previous 50 message(s) su
ppressed by --mute
Fri Sep 12 22:56:47 2008 us=653589 OpenVPN 2.0.9 Win32-MinGW [SSL] [LZO] built o
n Oct 1 2006
Fri Sep 12 22:56:47 2008 us=655267 IMPORTANT: OpenVPN's default port number is n
ow 1194, based on an official port number assignment by IANA. OpenVPN 2.0-beta1
6 and earlier used 5000 as the default port.
Fri Sep 12 22:56:47 2008 us=659410 Control Channel MTU parms [ L:1573 D:138 EF:3
8 EB:0 ET:0 EL:0 ]
Fri Sep 12 22:56:48 2008 us=705073 Data Channel MTU parms [ L:1573 D:1450 EF:41
EB:4 ET:32 EL:0 ]
Fri Sep 12 22:56:48 2008 us=706387 Local Options String: 'V4,dev-type tap,link-m
tu 1573,tun-mtu 1532,proto UDPv4,cipher BF-CBC,auth SHA1,keysize 128,key-method
2,tls-client'
Fri Sep 12 22:56:48 2008 us=708194 Expected Remote Options String: 'V4,dev-type
tap,link-mtu 1573,tun-mtu 1532,proto UDPv4,cipher BF-CBC,auth SHA1,keysize 128,k
ey-method 2,tls-server'
Fri Sep 12 22:56:48 2008 us=709966 Local Options hash (VER=V4): '2c50bd2c'
Fri Sep 12 22:56:48 2008 us=710578 Expected Remote Options hash (VER=V4): '0ddbb
6e3'
Fri Sep 12 22:56:48 2008 us=711801 Socket Buffers: R=[8192->8192] S=[8192->8192]

Fri Sep 12 22:56:48 2008 us=712981 UDPv4 link local: [undef]
Fri Sep 12 22:56:48 2008 us=713602 UDPv4 link remote: xx.xx.xx.173:1194

Hier hört es dann auf und es geht nicht weiter.
Ich habe im entfernten Router und in meinem Router die Firewall bereits abgeschaltet, aber das hilft nicht.

Ich bin jetzt etwas demotiviert. Zum testen habe ich das mal mit meinen Rechnern hier zu Hause getestet die beide eine eigene Internet-IP haben. Es hat wunderbar geklappt.

Kann mir jemand helfen? Wäre super!

tuser
Mitglied: tuser13
13.09.2008 um 01:28 Uhr
Hat sich erledigt.
Es war ein einfaches NAT-Problem
Bitte warten ..
Mitglied: c.t
24.09.2008 um 20:18 Uhr
Hi,

kannst du mal erläutern was ein einfaches NAT Problem war? Wie hast du es gelöst. Bin gerade auch mit openvpn zu Gange aber es funktioniert nicht.

Fri Sep 12 22:56:48 2008 us=712981 UDPv4 link local: [undef]
Fri Sep 12 22:56:48 2008 us=713602 UDPv4 link remote: xx.xx.xx.173:1194

Das auch meine letzten Zeilen. Habe die ahnung, das der Server vom Client nicht erreicht wird.

Gruss

C.T
Bitte warten ..
Mitglied: tuser13
25.09.2008 um 11:37 Uhr
Moin Christian,

bei mir lag der Fehler in der Einstellung des Routers. Ich habe NAT mit falschen Werten gesetzt.

Du müsstest etwas konkreter werden.

Was willst Du mit OpenVpn verbinden?
Sind Router dazwischengeschaltet?
usw.
Hier eine gute Seite (die Du bestimmt vlt. schon kennst wenn Du mit OpenVPN zugange bist):

http://www.vpnforum.de/

Im Wiki sind fertige Scripte die Du nur Deinen Begebenheiten (Pfade zu den Certifikaten, Remote-Adresse, usw. anpassen brauchts)
Bei mir hats damit auf Anhieb geklappt.

Wie gesagt, Details sind wichtig sonst kann ich nicht helfen.

tuser13
Bitte warten ..
Mitglied: c.t
25.09.2008 um 20:32 Uhr
Hi,

habe es heute hinbekommen. Leider nur die einfache Config. Komme vom Client nur auf das Gateway. Werde mich jetzt mal an den Server-Mode wagen. Hatte zuerst ein Problem mit meiner LANCOM. Musste eine Portweiterleitung einrichten und Regeln der Fortigate-Firewall anpassen.

Würde mich aber gerne nochmal an dich wenden (mit ausführlichen Infos), wenn ich Probleme habe.

Gruss

Christian
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Linux Netzwerk
VPN Server mit Drosselung Linux Debian basiert (4)

Frage von Niklas434 zum Thema Linux Netzwerk ...

Router & Routing
gelöst VPN-Server (Fritzbox) hinter Zyxel 5501 betreiben (7)

Frage von basti76nie zum Thema Router & Routing ...

Server
gelöst Client bei Windows Server 2003 ändern (5)

Frage von Therealcookie zum Thema Server ...

Router & Routing
OpenWRT als Open VPN Server im Heimnetz verwenden? (36)

Frage von Mr.Heisenberg zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...

Exchange Server
DNS Einstellung - zwei feste IPs für Mailserver (15)

Frage von ivan0s zum Thema Exchange Server ...