Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Client zieht keine Updates vom WSUS

Frage Microsoft Windows Server

Mitglied: Fenris14

Fenris14 (Level 1) - Jetzt verbinden

31.03.2014, aktualisiert 13:57 Uhr, 9930 Aufrufe, 13 Kommentare

Guten Tag,

Ich hab jetzt schon mehrmals die Suche und Google betätigt und verschiedene Sachen durchgespielt, komme aber einfach nicht weiter. Folgendes Problem:

Ich habe zu Testzwecken einen WSUS-Server in einer virtuellen Maschine unter Hyper-V installiert. Nach anfänglichen Problemen mit der Erstsynchronisation verlief die weitere Installation problemlos. Nachdem ich unter "Produkte und Klassifizierungen" die erforderlichen Updates festgelegt und heruntergeladen hatte, wurden Sie mit der "automatischen Standardgenehmigungsregel" genehmigt. Soweit so gut.

Nun habe ich einen Test-Client mit Windows 7 Ultimate unter Hyper-V gebaut. Beide anschließend an den selben virtuellen Switch. Da kein AD vorhanden wurden die Lokalen Gruppenrichtlinien angepasst. Der Server mit dessen URL ist auch erreichbar. Nach einigen Minuten wurde der Client auch unter "nicht zugewiesen" angezeigt, aber es wurden keine Updates vom Client heruntergeladen. Obwohl 179 erforderliche Updates angezeigt wurden. Auch nach mehrmaligen betätigen vom Schalter "nach neuen Updates Suchen" wurde immer nur angezeigt: "Windows ist auf dem neusten Stand".

Mittlerweile weiß ich auch nicht mehr weiter. Die Dinge habe ich noch probiert:

wuauclt /detectnow und /reportnow

danach habe ich noch versucht das Downloadverzeichnis zu löschen -

01.
net stop wuauserv 
02.
rd /s /q %windir%\SoftwareDistribution 
03.
net start wuauserv 
04.
wuauclt /detectnow
Hat jemand noch eine Idee was man machen könnte?

danke für eure Hilfe.
Mitglied: Crofex
31.03.2014 um 14:29 Uhr
Was steht denn in %windir%\WindowsUpdate.log ?
Bitte warten ..
Mitglied: Alchimedes
31.03.2014 um 14:43 Uhr
Hallo ,

Du hast die Gruppenrichtliene geaendert und musst diese neueinlesen.
gpupdate /force

Dann holt sich der Rechner die Updates. ( Wenn Du in den Gruppenrichtlienen den Internen Pfad richtig gesetzt hast? )

Gruss
Bitte warten ..
Mitglied: Fenris14
31.03.2014 um 14:45 Uhr
Aufjedenfall findet verkehr zwischen beiden statt und er sendet Reports an den richtigen Server.

Er sagt nach jedem refresh das er angeblich keine Updates finden konnte. folgendes ist mir öfters aufgefallen:

01.
Warning: Failed to evaluate installed rule, updateid=...
Bitte warten ..
Mitglied: Fenris14
31.03.2014 um 14:48 Uhr
Gpupdate /force macht er doch normalerweise auch nachdem neustart, oder?? Habe sicherheitshalber nochmals versucht, aber auch hier wieder das gleiche.
Bitte warten ..
Mitglied: jsysde
31.03.2014 um 18:57 Uhr
N'Abend.

Was steht in der Registry unter HKLM\Software\Policies\Microsoft\Windows\WindowsUpdate?
Ist das Win7 mit SP1 oder RTM?

Ist der Server aktuell gepatcht, alles WSUS-Updates auf dem Server selbst eingespielt?

Cheers,
jsysde
Bitte warten ..
Mitglied: Fenris14
01.04.2014 um 08:57 Uhr
Es handelt sich um Windows 7 SP1. In der Registry ist die URL richtig hinterlegt und der Server ist natürlich maximal aufgepatcht.

Ich habe mich dann nochmal an den Server rangesetzt. Laut dem "Best Practice Analyzer" hat die Website ein Problem mit dem Virtuellen Pfad "SelfUpdate". Dieser Ordner wäre angeblich nicht richtig installiert. Daraufhin habe ich die Berechtigungen überprüft und habe sicherheitshalber noch die Gruppe "Jeder" mit Lesen und Ausführen hinzugefügt. Aber ansonsten alles richtig installiert.

Jemand noch ne Idee?
Bitte warten ..
Mitglied: Ultra410
LÖSUNG 02.04.2014, aktualisiert 03.04.2014
Zitat von Fenris14:

...Nach einigen Minuten wurde der Client auch unter "nicht zugewiesen" angezeigt, aber es wurden keine Updates vom Client
heruntergeladen. Obwohl 179 erforderliche Updates angezeigt wurden. Auch nach mehrmaligen betätigen vom Schalter "nach
neuen Updates Suchen" wurde immer nur angezeigt: "Windows ist auf dem neusten Stand".

Hast du in den lokalen Richtlinien auch den Updatetyp gesetzt? ("autom. Updates" und Uhrzeit)
Welche Adresse hast du eingetragen? Beim 2012 bspw. hatte ich Probleme, wenn ich mal so die Adresse rein schreibe, da will er:

http://<IP-des-WSUS>:8530

Natürlich sollte der Port i.d. Firewall freigegeben werden, da du keine AD hast :D

Vielleicht hilfts ja.
Bitte warten ..
Mitglied: Fenris14
02.04.2014 um 11:17 Uhr
Also in die Richtlinie habe ich folgendes geschrieben: http://WSUS-Server

So steht es auch in der Beschreibung der Richtlinie und so habe ich es auch schonmal früher eingerichtet. Es handelt sich übrigens um 2008 R2 .

Also ich habe jetzt nochmal in die Firewall gesehen und dort ist alles korrekt eingestellt. Updatetyp ist auch auf automatisch gesetzt. Komischerweise scheint der client auch einige updates zu bekommen, ab und zu kommen mal 1-2 updates... das war es dann auch schon.

So richtig kann mir bisher keinen Reim drauf machen. An der Freigabe vom "SelfUpdate" habe ich jetzt auch mal ein bisschen rumgeschraubt. Doch leider bisher kein Erfolg.
Bitte warten ..
Mitglied: goscho
02.04.2014 um 14:16 Uhr
Zitat von Fenris14:

Also in die Richtlinie habe ich folgendes geschrieben: http://WSUS-Server
Schreib den Port mit in die Richtlinie. Ich habe die Erfahrung gemacht, dass es von Vorteil war, die IP-Adresse des Server zu benutzen.
Egal, wie gut die Namensauflösung funktionierte.
So richtig kann mir bisher keinen Reim drauf machen. An der Freigabe vom "SelfUpdate" habe ich jetzt auch mal ein
bisschen rumgeschraubt. Doch leider bisher kein Erfolg.
Mal was anderes:

Der PC ist nicht zufällig geclont und es wurde nicht gesysprept (geiles Wort)?
Bitte warten ..
Mitglied: Fenris14
02.04.2014 um 14:20 Uhr
also beim WSUS handelt es sich um "richtig" installiertes win 2008 R2 auf eine dynamische VHD. Lediglich der Test-client besteht aus einer differenzierenden VHD von einen sysprep.
Bitte warten ..
Mitglied: Alchimedes
LÖSUNG 02.04.2014, aktualisiert 03.04.2014
Hallo Fenris ,

ich hoffe das Du mit http://wsus-server == http://<IP-DES WSUS-SERVER:PORT meinst ?
So wie Ultra geschrieben hat.

Nicht das ich Dich falsch verstanden habe.

Gruss
Bitte warten ..
Mitglied: Fenris14
03.04.2014 um 08:48 Uhr
Also ich hatte es sonst immer ohne port geschrieben, da hat es dann auch immer wunderbar funktioniert. Ich werd es gleich mal testen.
Bitte warten ..
Mitglied: Fenris14
03.04.2014 um 09:06 Uhr
Ok. jetzt hat es funktioniert. Tatsächlich scheint der Port eine wichtige rolle zu spielen. Ich bin immer davon ausgegangen das automatisch port 80 gewählt wird und das wenn man einen anderen port verwenden will dies relevant ist.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows 7
Wsus client findet am wsus server nicht alle updates (3)

Frage von endurance zum Thema Windows 7 ...

Windows 7
Windows 7 Client zieht sich keine MSI Pakete (6)

Frage von Ghost108 zum Thema Windows 7 ...

Windows 10
gelöst Windows 10 zieht keine Updates vom WSUS (4)

Frage von MediAd zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (14)

Frage von liquidbase zum Thema Windows Update ...

DSL, VDSL
Problem mit variernder Internetgeschwindigkeit (12)

Frage von schaurian zum Thema DSL, VDSL ...