Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

clientanmeldung mit startskript (gpo) läuft zu lange

Frage Microsoft Windows Server

Mitglied: riemus

riemus (Level 1) - Jetzt verbinden

05.03.2008, aktualisiert 10.03.2008, 6815 Aufrufe, 3 Kommentare

hallo!
wir haben ein problem mit der clientanmeldung an unserer windows 2003-domäne.

in einer gruppenrichtlinie haben wir im start-skript folgende batch-dateien hinterlegt:
1.) c:\
cd\
rd c:\temp
md c:\temp
rd c:\dat

2.) net use o: /delete
net use o:\\ipadresse\freigabe

seit die gruppenrichtlinie verknüpft ist, dauert die anmeldung an den clients bis zu 10 minuten.
kann man die abarbeitung des skripts irgendwie beschleunigen?

auch dachte ich dass die skripts in der gpo bereits vor der anmeldung durchgeführt werden? kann man hier noch etwas einstellen?
Mitglied: 60730
05.03.2008 um 16:40 Uhr
rd c:\temp /q
md c:\temp
rd c:\dat /q


net use o: /delete
net use o: \\ipadresse\freigabe

Hi,

zuerst mal, warum ist die batch so konstruiert?
c:\
cd\
kannst du dir - wenn das wirklich die Batch ist - sparen - genauso, wie die Fehlermeldungen die das Skript liefert....

"Sowas" brauchst du nur, wenn du innerhalb von c: in einen Ordner - en du nicht genau kennst wechseln mußt. z.B cd c:\ temp? - das sehe ich aber in deinem Beispiel nicht - daher raus damit.


Die Zeile rd c:\temp "reicht" doch
Allerdings würde ich dann auch c:\temp /q dranstellen, um die Nachfrage - ob wirklich gelöscht werden soll zu unterbinden.

"läuft" die Batch überhaupt durch?
"Sowas" immer in einer Dosbox Testen und Fehler suchen, bevor das in die GPO reinkommt.

PS: Wo steht das in der GPO? Beim Start des Rechners?

Probier mal die Änderungen, die du oben siehst...
Auch das Leerzeichen zwischen Net Use o: und \\ !!!
Bitte warten ..
Mitglied: riemus
10.03.2008 um 09:29 Uhr
hallo, als erstes mal danke für die antwort!

die fehlenden parameter im "rd"-befehl und das fehlende leerzeichen im "net use" war mein fehler beim erstellen des thread.
hab die ersten beiden zeilen rausgenommen und die batch-datei lautet jetzt genau so:

rd c:\temp /s/q
md c:\temp
rd c:\orbis32 /s/q

net use o: /delete
net use o: \\192.168.145.21\public

leider ist keine änderung eingetreten.

die batchdatei wird über folgende gpo aufgerufen:

Computerkonfiguration - Windows-Einstellungen - Skripts - Starten (die batch liegt im sysvol-ordner in der entsprechenden policy).

wie gesagt, wenn die policy aktiv ist, dauert die anmeldung bis zu 15min, bei inaktiver policy gehts ratz-fatz...
Bitte warten ..
Mitglied: 60730
10.03.2008 um 10:01 Uhr
Moin,

Mach mal folgendes:

Starte das Script, manuell, nachdem du dich angemeldet hast stoppe die Zeit.
Wahrscheinlich wird er sich beim temp Ordner beschweren, also kopiert du den vorher und löscht die Kopie.

Und dann zerdrösel das doch mal in einzelne Schritte.

Wie lange das Temp löschen dauert - das mußt du mal stoppen
Genauso wie den orbis Ordner und das Net use.

Das Net Use würde ich in das Userloginscript verschieben.
Bitte warten ..
Ähnliche Inhalte
Windows Netzwerk
Script läuft nicht auf Computer GPO
gelöst Frage von cyborg19Windows Netzwerk

Hallo zusammen Ich habe ein Computer GPO erstellt. Über diesen GPO werden die Druckerverteilt. Das funktioniert auch wunderbar. Zusätzlich ...

Windows Server
GPO-Aktualisierungen dauern sehr lange
Frage von MartinADWindows Server3 Kommentare

Hallo zusammen, folgendes Problem: Wir betreiben ein Active Directory mit mehreren Sites. Auf der "Haupt-Site" befinden sich aus Gründen ...

Batch & Shell
Homelaufwerke im Startskript zuweisen
Frage von SirTomBatch & Shell3 Kommentare

Hallo, ich möchte gerne die Homelaufwerke in einem Startskript (vbs, Windowsumgebung) zuweisen. Momentran sieht das so aus (nur Teile ...

Windows Server
Clientanmeldung in Nierderlassung ohne VPN
gelöst Frage von oversizzedWindows Server5 Kommentare

Hallo, Wir haben vor kurzem umgestellt auf 2012r2 und eine Niederlassung B dazu bekommen. Habe den zweiten Server als ...

Neue Wissensbeiträge
Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 4 StundenApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 9 StundenWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 9 StundenWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 21 StundenInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Von rj11 auf rj45
Frage von jensgebkenLAN, WAN, Wireless19 Kommentare

Hallo Gemeinschaft, könnt ihr mir vielleicht bei der anfertigung eines Kabels helfen - habe ein rj 11 stecker und ...

Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...

Windows Server
Remotesteuerung der Sitzung (Kennung XX) fehlgeschlagen
gelöst Frage von Stefan91Windows Server14 Kommentare

Hallo Zusammen, seit kurzem bekomme ich oben genannte Fehlermeldung, wenn ich versuche eine Remotesitzung über den Taskmanager fernzusteuern (Rechtsklick ...