Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Cmd liefert unterschiedliche ergebnisse

Frage Microsoft

Mitglied: OlibSyl

OlibSyl (Level 1) - Jetzt verbinden

20.04.2011, aktualisiert 10:25 Uhr, 2587 Aufrufe, 3 Kommentare

Hallo,

folgendes Problem:

ich melde mich mit meinem Login (ich bin Admin der Domäne) auf dem Server (2008R2) ein und starte eine Eingabeaufforderung. Dort habe ich Zugriff auf alle verbundenen Netzlaufwerke.
Wenn ich jetzt eine Eingabeaufforderung starte, indem ich "als anderer Benutzer ausführen" eingebe und dann wieder meine Daten eingebe, habe ich die Netzlaufwerke als "nicht verbunden" und bekomme auch keinen Zugriff drauf.

Beide male gibt die Abfrage "whoami" das selbe Ergebnis meine_Domäne\mein_Benutzer

Es scheint also so, als ob beide gleich arbeiten, das Ergebnis ist aber ein anderes.

Hintergrund meiner Frage ist, ich habe einen Dienst (NSClient++ für Nagios) mit dem ich eine Abfrage auf eine Datei im Netz machen will (vorhanden und nicht älter als 7 Tage). Wenn ich das Kommando in der Standard Eingabeaufforderung ausführe bekomme ich die Meldung alles O.K..
Wenn ich diese Abfrage auf der unter meinem User gestarteten Eingabeaufforderung mache bekomme ich die Meldung "File does not exist". Wenn ich ein "dir" auf das Verzeichnis (den kompletten UNC, weil das Netzlaufwerk ja nicht funktioniert) mache bekomme ich "Der Netzwerkname wurde nicht gefunden."

Hat jemand von euch einen Tip, woran das liegen kann?

Da ich nun schon mehrere Tage suche, bin ich für jeden Tip dankbar.

Gruss Oli
Mitglied: Jochem
20.04.2011 um 11:57 Uhr
Moin,

meine bisherigen Erkenntnisse in dem Falle, daß eine User angemeldet ist und über die CMD-Zeile (oder per "als andereer Benutzer ausführen") ein zweiter User aktiv werden soll:
Der zweite User bringt, unabhängig von seinem Status als Admin oder Nicht-Admin, keine "Umgebung" mit. Das bedeutet u.a., daß alle Netzlaufwerke für diesen User nicht vorhanden sind.

Mir fällt das immer dann auf, wenn ich an einem Client sitze und neue Software installieren soll, die auf einem Netzlaufwerk liegt. Angemeldet ist ein User und ich starte das Installationsprogramm auf dem Server über Rechtsklick mit "Ausführen als" und gebe dort als Benutzer den Admin vor. Das Programm startet, doch sobald irgendwelche Dateien aus dem Server-Verzeichnis nachgeladen werden müssen, kommt eine Fehlermeldung, das der Pfad nicht vorhanden ist.

Abhilfe schafft dann eine Anmeldung als Admin über das CMD-Fenster per "runas"-command mit einer eigenen Explorer-Sitzung, in der ich das Server-Verzeichnis verbinde und dann die Installation durchführe.

Gruß J chem
Bitte warten ..
Mitglied: 99045
20.04.2011 um 12:01 Uhr
Hi,

Zitat von OlibSyl:
Wenn ich jetzt eine Eingabeaufforderung starte, indem ich "als anderer Benutzer ausführen" eingebe und dann wieder
meine Daten eingebe, habe ich die Netzlaufwerke als "nicht verbunden" und bekomme auch keinen Zugriff drauf.

Du musst nur die Netzwerklaufwerke unter diesem Nutzer verbinden, dann hast du auch Zugriff.
Nicht vergessen, vor dem Verlassen der Konsole die Mappings auch wieder zu trennen.

Gruß
Bitte warten ..
Mitglied: OlibSyl
20.04.2011 um 12:06 Uhr
Ich habe festgestellt, das wenn ich den Pfad mit IP Adresse angebe funktioniert es. Zu dumm das ich das nicht früher ausprobiert habe.

Nun läuft auch meine Überwachung.
Bitte warten ..
Ähnliche Inhalte
Windows Server
gelöst Suche liefert keine Ergebnisse - SharePoint Foundation 13 (1)

Frage von erdmelone zum Thema Windows Server ...

Outlook & Mail
Outlook Suche liefert kein Ergebnise mehr (9)

Frage von Bjoern-B zum Thema Outlook & Mail ...

Batch & Shell
gelöst Ausgabe der einzelnen Ergebnisse einer For-Schleife mit Schalter F (11)

Frage von hipfzwirgel zum Thema Batch & Shell ...

Neue Wissensbeiträge
Ubuntu

Ubuntu 17.10 steht zum Download bereit

(3)

Information von Frank zum Thema Ubuntu ...

Datenschutz

Autofahrer-Pranger - Bewertungsportal illegal

(8)

Information von BassFishFox zum Thema Datenschutz ...

Windows 10

Neues Win10 Funktionsupdate verbuggt RemoteApp

(8)

Information von thomasreischer zum Thema Windows 10 ...

Microsoft

Die neuen RSAT-Tools für Win10 1709 sind da

(2)

Information von DerWoWusste zum Thema Microsoft ...

Heiß diskutierte Inhalte
Windows 10
Seekrank bei Windows 10 (18)

Frage von zauberer123 zum Thema Windows 10 ...

Windows 10
Windows 10 Fall Creators Update Fehler (14)

Frage von ZeroCool23 zum Thema Windows 10 ...

Router & Routing
gelöst Getrenntes Routing bei VoIP und Daten (12)

Frage von Hobbystern zum Thema Router & Routing ...