Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Code Funktioniert nicht bei IE

Frage Entwicklung HTML

Mitglied: TeddyTN

TeddyTN (Level 1) - Jetzt verbinden

12.07.2007, aktualisiert 13.07.2007, 3751 Aufrufe, 3 Kommentare

Folgender Code Funktioniert nicht unter IE wo könte der Fehler liegen??


<html>

<head>
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
<meta name="GENERATOR" content="Microsoft FrontPage 6.0">
<meta name="ProgId" content="FrontPage.Editor.Document">
<title>Neue Seite 2</title>

<script language="JavaScript">
function MItems(b) {
var a = document.getElementById(b);
if (a.style.visibility != "hidden") {
a.style.visibility = "hidden";
} else {
a.style.visibility = "visible"; }

if (a.style.position != "absolute") {
a.style.position = "absolute";
} else {
a.style.position = "static"; }
}
</script>

<style type="text/css">
a {
font-size:14px;
font-family:"Comic Sans MS";}
div {
font-size:14px;
font-family:"Comic Sans MS";}
a:link {
font-size:14px;
color: #D9312E;
text-decoration: none; }
a:visited {
color: #D9312E;
text-decoration: none; }
a:active {
color: #D9312E;
text-decoration: none; }
a:hover {
color: #D9312E;
font:bold;
text-decoration: underline;}
</style>

<base target="Hauptframe">

</head>

<body bgcolor="#D9312E" text="#D9312E" leftmargin="5">

<table bgcolor="#FFC801" border="0" cellspacing="0" cellpadding="0">
<tr>
<td><img src="images/oben.jpg" width="100%" height="38"></td>
</tr>
<tr>
<td><a href="home.htm">&#9679;&nbsp;&nbsp;Startseite</a><hr noshade size="1" color="#D9312E"></td>
</tr>
<tr>
<td><div onClick="MItems('menu1')"><a href="uberuns/ueber uns.htm">&#9679;&nbsp;&nbsp;Über uns</a></div><hr noshade size="1" color="#D9312E"></td>
</tr>
<tr id="menu1" style="visibility=hidden;position=absolute;">
<td><ul><li><a href=uberuns/geschichte.html>Geschichte</a></li>
<li><a href="neuigkeiten/sprechzeiten.htm">Sprechzeiten</a></li>
<li><a href="lemi/schulordnung.htm">Schulordnung</a></li></ul></td>
</tr>
<tr>
<td><div onClick="MItems('menu2')">&#9679;&nbsp;&nbsp;Neuigkeiten</div><hr noshade size="1" color="#D9312E"></td>
</tr>
<tr id="menu2" style="visibility=hidden;position=absolute;">
<td><ul><li><a href="neuigkeiten/infos.htm">Infos</a></li>
<li><a href=Neuigkeiten/Bilder.html>Bilder</a></li></ul></td>
</tr>
<tr>
<td><div onClick="MItems('menu3')">&#9679;&nbsp;&nbsp;Unterricht / Klassen</div><hr noshade size="1" color="#D9312E"></td>
</tr>
<tr id="menu3" style="visibility=hidden;position=absolute;">
<td><ul><li><a href="neuigkeiten/klassenfotos.htm">Klassenfotos</a></li>
<li><a href="neuigkeiten/stundenplan Muster.htm">Stundenplan</a></li></ul></td>
</tr>
<tr>
<td><div onClick="MItems('menu4')">&#9679;&nbsp;&nbsp;Lehrer</div><hr noshade size="1" color="#D9312E"></td>
</tr>
<tr id="menu4" style="visibility=hidden;position=absolute;">
<td><ul><li><a href=lehrer/steckbriefe.htm>Steckbriefe</a></li></ul></td>
</tr>
<tr>
<td><a href="ort/ort&lage.htm">&#9679;&nbsp;&nbsp;Ort & Lage</a><hr noshade size="1" color="#D9312E"></td>
</tr>
<tr>
<td><a href=links/links.htm>&#9679;&nbsp;&nbsp;Weiterführendeschulen</a><hr noshade size="1" color="#D9312E"></td>
</tr>
<tr>
<td><a href="kontakt/kontakte.htm">&#9679;&nbsp;&nbsp;Kontakt</a></td>
</tr>
<tr>
<td valign="top" height="28"><hr noshade size="1" color="#D9312E"></td>
</tr>
</table>
</body>

</html>
Mitglied: 8644
13.07.2007 um 08:43 Uhr
Moin,

es wäre durchaus hilfreich, wenn du mal beschreibst, was genau nicht funktioniert!


Psycho
Bitte warten ..
Mitglied: TeddyTN
13.07.2007 um 16:58 Uhr
also wenn ich im ie die menüs aufklappe kann ich die links die den im aufgeklapten menü zurverfügung stehen solten nicht ausführen.
Bitte warten ..
Mitglied: Mheatus
13.07.2007 um 19:28 Uhr
Habs gerade getestet. Das Problem scheint das "position=static"

Wenn du statt diesem

if (a.style.position != "absolute") {
a.style.position = "absolute";
} else {
a.style.position = "static"; }
}

folgendes nimmst:

if (a.style.position != "absolute") {
a.style.position = "absolute";
} else {
a.style.position = "relative"; }
}

funktioniert es.
Bitte warten ..
Ähnliche Inhalte
Exchange Server
gelöst OWA funktioniert nur im IE (18)

Frage von ketanest112 zum Thema Exchange Server ...

Windows 10
Anmeldung im Windows Store funktioniert nicht mehr (2)

Frage von Desert-Igel zum Thema Windows 10 ...

Microsoft Office
VBA Code zum Kopieren von einzelnen Zellen in Excel (3)

Frage von SebastianL zum Thema Microsoft Office ...

Neue Wissensbeiträge
Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(29)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Humor (lol)

Bester Vorschlag eines Supporttechnikers ever: APC

(15)

Erfahrungsbericht von DerWoWusste zum Thema Humor (lol) ...

Windows Server

Exchange 2010 Active Directory und Windows Server 2016

(4)

Erfahrungsbericht von Herbrich19 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Internet
gelöst Mitarbeiter surft auf unerwünschter Seite - Wie damit umgehen? (52)

Frage von sabines zum Thema Internet ...

Netzwerke
LAN2LAN Verbindung sehr langsam flaschenhals gesucht (27)

Frage von PixL86 zum Thema Netzwerke ...

Router & Routing
PFsense - Netzverbindung steht, aber kein Internet vorhanden (25)

Frage von aschmid zum Thema Router & Routing ...

Windows Server
gelöst Windows 2016 Hyper-V und VHDS (19)

Frage von emeriks zum Thema Windows Server ...