Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Code Funktioniert nicht bei IE

Frage Entwicklung HTML

Mitglied: TeddyTN

TeddyTN (Level 1) - Jetzt verbinden

12.07.2007, aktualisiert 13.07.2007, 3732 Aufrufe, 3 Kommentare

Folgender Code Funktioniert nicht unter IE wo könte der Fehler liegen??


<html>

<head>
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
<meta name="GENERATOR" content="Microsoft FrontPage 6.0">
<meta name="ProgId" content="FrontPage.Editor.Document">
<title>Neue Seite 2</title>

<script language="JavaScript">
function MItems(b) {
var a = document.getElementById(b);
if (a.style.visibility != "hidden") {
a.style.visibility = "hidden";
} else {
a.style.visibility = "visible"; }

if (a.style.position != "absolute") {
a.style.position = "absolute";
} else {
a.style.position = "static"; }
}
</script>

<style type="text/css">
a {
font-size:14px;
font-family:"Comic Sans MS";}
div {
font-size:14px;
font-family:"Comic Sans MS";}
a:link {
font-size:14px;
color: #D9312E;
text-decoration: none; }
a:visited {
color: #D9312E;
text-decoration: none; }
a:active {
color: #D9312E;
text-decoration: none; }
a:hover {
color: #D9312E;
font:bold;
text-decoration: underline;}
</style>

<base target="Hauptframe">

</head>

<body bgcolor="#D9312E" text="#D9312E" leftmargin="5">

<table bgcolor="#FFC801" border="0" cellspacing="0" cellpadding="0">
<tr>
<td><img src="images/oben.jpg" width="100%" height="38"></td>
</tr>
<tr>
<td><a href="home.htm">&#9679;&nbsp;&nbsp;Startseite</a><hr noshade size="1" color="#D9312E"></td>
</tr>
<tr>
<td><div onClick="MItems('menu1')"><a href="uberuns/ueber uns.htm">&#9679;&nbsp;&nbsp;Über uns</a></div><hr noshade size="1" color="#D9312E"></td>
</tr>
<tr id="menu1" style="visibility=hidden;position=absolute;">
<td><ul><li><a href=uberuns/geschichte.html>Geschichte</a></li>
<li><a href="neuigkeiten/sprechzeiten.htm">Sprechzeiten</a></li>
<li><a href="lemi/schulordnung.htm">Schulordnung</a></li></ul></td>
</tr>
<tr>
<td><div onClick="MItems('menu2')">&#9679;&nbsp;&nbsp;Neuigkeiten</div><hr noshade size="1" color="#D9312E"></td>
</tr>
<tr id="menu2" style="visibility=hidden;position=absolute;">
<td><ul><li><a href="neuigkeiten/infos.htm">Infos</a></li>
<li><a href=Neuigkeiten/Bilder.html>Bilder</a></li></ul></td>
</tr>
<tr>
<td><div onClick="MItems('menu3')">&#9679;&nbsp;&nbsp;Unterricht / Klassen</div><hr noshade size="1" color="#D9312E"></td>
</tr>
<tr id="menu3" style="visibility=hidden;position=absolute;">
<td><ul><li><a href="neuigkeiten/klassenfotos.htm">Klassenfotos</a></li>
<li><a href="neuigkeiten/stundenplan Muster.htm">Stundenplan</a></li></ul></td>
</tr>
<tr>
<td><div onClick="MItems('menu4')">&#9679;&nbsp;&nbsp;Lehrer</div><hr noshade size="1" color="#D9312E"></td>
</tr>
<tr id="menu4" style="visibility=hidden;position=absolute;">
<td><ul><li><a href=lehrer/steckbriefe.htm>Steckbriefe</a></li></ul></td>
</tr>
<tr>
<td><a href="ort/ort&lage.htm">&#9679;&nbsp;&nbsp;Ort & Lage</a><hr noshade size="1" color="#D9312E"></td>
</tr>
<tr>
<td><a href=links/links.htm>&#9679;&nbsp;&nbsp;Weiterführendeschulen</a><hr noshade size="1" color="#D9312E"></td>
</tr>
<tr>
<td><a href="kontakt/kontakte.htm">&#9679;&nbsp;&nbsp;Kontakt</a></td>
</tr>
<tr>
<td valign="top" height="28"><hr noshade size="1" color="#D9312E"></td>
</tr>
</table>
</body>

</html>
Mitglied: 8644
13.07.2007 um 08:43 Uhr
Moin,

es wäre durchaus hilfreich, wenn du mal beschreibst, was genau nicht funktioniert!


Psycho
Bitte warten ..
Mitglied: TeddyTN
13.07.2007 um 16:58 Uhr
also wenn ich im ie die menüs aufklappe kann ich die links die den im aufgeklapten menü zurverfügung stehen solten nicht ausführen.
Bitte warten ..
Mitglied: Mheatus
13.07.2007 um 19:28 Uhr
Habs gerade getestet. Das Problem scheint das "position=static"

Wenn du statt diesem

if (a.style.position != "absolute") {
a.style.position = "absolute";
} else {
a.style.position = "static"; }
}

folgendes nimmst:

if (a.style.position != "absolute") {
a.style.position = "absolute";
} else {
a.style.position = "relative"; }
}

funktioniert es.
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Batch & Shell
gelöst Paramter übergeben, Code funktioniert nicht unter Windows 10 (12)

Frage von DerHulk zum Thema Batch & Shell ...

Linux
LTSP: PXE Boot funktioniert nicht (22)

Frage von Fenris14 zum Thema Linux ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (12)

Frage von Motte990 zum Thema Microsoft Office ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...