Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

ComSpec Umgebungsvariable in Verbindung mit telnet und Windows Server 2008 R2 funktioniert nicht mehr

Frage Microsoft Windows Server

Mitglied: 92692

92692 (Level 1)

09.11.2011 um 17:13 Uhr, 3798 Aufrufe, 2 Kommentare

Hallo zusammen,
wir nutzen bisher eine VT220 Emulation über Telnet von einem MDE-Gerät zu einem Windows 2000 Server mit installierten Telnetserver. Dieser soll nun migriert werden auf Windows Server 2008 R2.

Damals haben wir in den Umgebungsvariablen des Benutzers die ComSpec Variable dafür genutzt, das emulierte Terminalprogramm (.exe) automatisch nach Anmeldung des Benutzers via Telnet zu starten. Zusätzlich haben wir in den Profileinstellungen des Benutzers auf dem Server den lokalen Pfad so eingestellt, dass dieser gleich ist mit dem Pfad in der die .exe des Programms liegt. Bei gleicher Vorgehensweise lässt sich dies aber nicht auf dem neuen Windows Server 2008 R2 umsetzen.

Nach einer Anmeldung via Telnet landen wir nur in dem "lokalen Pfad". Wenn man nun manuell über eine aktive Telnetsitzung die .exe des Programms aus dem lokalen Verzeichnis aufruft läuft wiederum alles.

Hat jemand eine Idee? Vielen Dank im Voraus.

Mit freundlichen Grüßen
Daniel
Mitglied: 60730
10.11.2011 um 01:11 Uhr
moin,

irgendwie blicke ich da nicht durch...

ComSpec Umgebungsvariable in Verbindung mit telnet und Windows Server 2008 R2 funktioniert nicht mehr
so lautet die Überschrift.
Damals haben wir in den Umgebungsvariablen des Benutzers die ComSpec Variable dafür genutzt, das emulierte Terminalprogramm (.exe) automatisch nach Anmeldung des Benutzers via Telnet zu starten.

Also sollte die Überschrift eigentlich lauten
  • Verbiegen der %Comspec%, um ein emuliertes Terminalprogramm.exe automatisch...

Hat jemand eine Idee?
  • ja du schreibst nochmal - da darfst du dann gerne Absatzmarken/Zeilenschalter benutzen, das ganze auf, denn ich lese da nur Bahnhof.

Immer dran denken, du sitzt vor dem "Problem" und findest keine Lösung, wie sollte es uns dann gehen?

Gruß
Bitte warten ..
Mitglied: 92692
10.11.2011 um 14:36 Uhr
Hallo TimoBeil,
entschuldige, wenn ich mich unverständlich ausgedrückt habe.

Wir haben das Problem mittlerweile soweit eingrenzen können, dass wir folgendes festgestellt haben:
  • bei einer Anmeldung via Telnet werden keine Benutzrerumgebungsvariablen geladen
  • bei vorheriger Anmeldung am Windows Desktop und nachträglicher Anmeldung über Telnet funktioniert die %comspec% Variable

Vielleicht nochmal zum Verständnis:
  • es wird eine Telnetverbindung auf einen Windows Server 2008 R2 gestartet (telnet 192.168.x.x)
  • sobald die Verbindung steht, wird automatisch eine VT220 Terminalemulation gestartet (vt220.exe)

... und genau dieser Automatismus soll wieder funktionieren. Ich möchte halt jetzt nicht immer den Benutzer xy am Windows Dekstop anmelden um anschließend von einem MDE-Gerät (Intermec CK-3) die Telnetsitzung öffnen zu können.

Ich hoffe ich konnte das Problem nun etwas besser beschreiben. Vielen Dank im Voraus!

Gruß
Bitte warten ..
Ähnliche Inhalte
Windows Netzwerk
Telnet-Server für Windows 10 (64bit) (4)

Frage von deadygfx zum Thema Windows Netzwerk ...

Windows Server
gelöst Windows 2008 R2 Upgrade (8)

Frage von VerwirrterUser zum Thema Windows Server ...

Windows Server
gelöst Fehler nach Neuinstallation von Windows Server 2008 R2 Standard (17)

Frage von bellerich zum Thema Windows Server ...

Neue Wissensbeiträge
Ubuntu

Ubuntu 17.10 steht zum Download bereit

(3)

Information von Frank zum Thema Ubuntu ...

Datenschutz

Autofahrer-Pranger - Bewertungsportal illegal

(8)

Information von BassFishFox zum Thema Datenschutz ...

Windows 10

Neues Win10 Funktionsupdate verbuggt RemoteApp

(6)

Information von thomasreischer zum Thema Windows 10 ...

Microsoft

Die neuen RSAT-Tools für Win10 1709 sind da

(2)

Information von DerWoWusste zum Thema Microsoft ...

Heiß diskutierte Inhalte
Router & Routing
Allnet - VDSL2 Modem - SFP (mini-GBIC) (20)

Frage von Dobby zum Thema Router & Routing ...

Voice over IP
DeutschlandLAN IP Voice Data M Premium, Erfahrung mit Faxgeräte? (17)

Frage von liquidbase zum Thema Voice over IP ...

Monitoring
Netzwerk-Monitoring Software (16)

Frage von Ghost108 zum Thema Monitoring ...

Windows 10
Windows 10 Ordnerfreigabe (15)

Frage von Xaero1982 zum Thema Windows 10 ...