Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

ComSpec Umgebungsvariable in Verbindung mit telnet und Windows Server 2008 R2 funktioniert nicht mehr

Frage Microsoft Windows Server

Mitglied: 92692

92692 (Level 1)

09.11.2011 um 17:13 Uhr, 3779 Aufrufe, 2 Kommentare

Hallo zusammen,
wir nutzen bisher eine VT220 Emulation über Telnet von einem MDE-Gerät zu einem Windows 2000 Server mit installierten Telnetserver. Dieser soll nun migriert werden auf Windows Server 2008 R2.

Damals haben wir in den Umgebungsvariablen des Benutzers die ComSpec Variable dafür genutzt, das emulierte Terminalprogramm (.exe) automatisch nach Anmeldung des Benutzers via Telnet zu starten. Zusätzlich haben wir in den Profileinstellungen des Benutzers auf dem Server den lokalen Pfad so eingestellt, dass dieser gleich ist mit dem Pfad in der die .exe des Programms liegt. Bei gleicher Vorgehensweise lässt sich dies aber nicht auf dem neuen Windows Server 2008 R2 umsetzen.

Nach einer Anmeldung via Telnet landen wir nur in dem "lokalen Pfad". Wenn man nun manuell über eine aktive Telnetsitzung die .exe des Programms aus dem lokalen Verzeichnis aufruft läuft wiederum alles.

Hat jemand eine Idee? Vielen Dank im Voraus.

Mit freundlichen Grüßen
Daniel
Mitglied: 60730
10.11.2011 um 01:11 Uhr
moin,

irgendwie blicke ich da nicht durch...

ComSpec Umgebungsvariable in Verbindung mit telnet und Windows Server 2008 R2 funktioniert nicht mehr
so lautet die Überschrift.
Damals haben wir in den Umgebungsvariablen des Benutzers die ComSpec Variable dafür genutzt, das emulierte Terminalprogramm (.exe) automatisch nach Anmeldung des Benutzers via Telnet zu starten.

Also sollte die Überschrift eigentlich lauten
  • Verbiegen der %Comspec%, um ein emuliertes Terminalprogramm.exe automatisch...

Hat jemand eine Idee?
  • ja du schreibst nochmal - da darfst du dann gerne Absatzmarken/Zeilenschalter benutzen, das ganze auf, denn ich lese da nur Bahnhof.

Immer dran denken, du sitzt vor dem "Problem" und findest keine Lösung, wie sollte es uns dann gehen?

Gruß
Bitte warten ..
Mitglied: 92692
10.11.2011 um 14:36 Uhr
Hallo TimoBeil,
entschuldige, wenn ich mich unverständlich ausgedrückt habe.

Wir haben das Problem mittlerweile soweit eingrenzen können, dass wir folgendes festgestellt haben:
  • bei einer Anmeldung via Telnet werden keine Benutzrerumgebungsvariablen geladen
  • bei vorheriger Anmeldung am Windows Desktop und nachträglicher Anmeldung über Telnet funktioniert die %comspec% Variable

Vielleicht nochmal zum Verständnis:
  • es wird eine Telnetverbindung auf einen Windows Server 2008 R2 gestartet (telnet 192.168.x.x)
  • sobald die Verbindung steht, wird automatisch eine VT220 Terminalemulation gestartet (vt220.exe)

... und genau dieser Automatismus soll wieder funktionieren. Ich möchte halt jetzt nicht immer den Benutzer xy am Windows Dekstop anmelden um anschließend von einem MDE-Gerät (Intermec CK-3) die Telnetsitzung öffnen zu können.

Ich hoffe ich konnte das Problem nun etwas besser beschreiben. Vielen Dank im Voraus!

Gruß
Bitte warten ..
Ähnliche Inhalte
Windows Server
Windows Server 2008 R2 - RUNDLL32 - Hohe CPU Auslastung (1)

Frage von CT-Legend zum Thema Windows Server ...

Windows Server
gelöst Fehlermeldung beim Versuch, per RDP auf Windows Server 2008 R2 Standard (4)

Frage von ChuckLeMoin zum Thema Windows Server ...

Neue Wissensbeiträge
Rechtliche Fragen

Heiseshow, live ab 12 Uhr: Steht die Vorratsdatenspeicherung vor dem Aus?

Tipp von sabines zum Thema Rechtliche Fragen ...

Outlook & Mail

Outlook Probleme nach Juni Updates - KB3203467 ist Schuld

(1)

Information von Deepsys zum Thema Outlook & Mail ...

Microsoft Office

Windows 7, Office 2016 RTM und Updates ohne WSUS

Tipp von chgorges zum Thema Microsoft Office ...

E-Mail

Thunderbird 52 hat Druckprobleme

(3)

Tipp von magicteddy zum Thema E-Mail ...

Heiß diskutierte Inhalte
Server-Hardware
Einem Stromausfall entgegen wirken (22)

Frage von OIOOIOOIOIIOOOIIOIIOIOOO zum Thema Server-Hardware ...

Festplatten, SSD, Raid
PC stellt nach dem Bios ab (20)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...

Windows 7
Freeware MSI Tool (13)

Frage von uridium69 zum Thema Windows 7 ...

DSL, VDSL
gelöst Ständige Störungen - Internet (12)

Frage von gamerff zum Thema DSL, VDSL ...