Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

CPU-Auslastung 100 Prozent und Standby-Blockierung in Windows XP nach Systemwiederherstellung

Frage Microsoft Windows XP

Mitglied: XProblem

XProblem (Level 1) - Jetzt verbinden

23.03.2011, aktualisiert 15:59 Uhr, 5263 Aufrufe, 2 Kommentare

Hallo,

ich habe ein CPU-100%-Problem vor allem in Firefox 3.6 unter Windows XP und hoffe sehr, dass Ihr mir helfen könnt.

Problem:
- Im Leerlauf und auch meistens sonst verhalten sich Windows und die installierten Programme normal.

- In manchen (leider oft benötigten) Situationen schnellt die CPU-Auslastung aber auf 100% und bleibt für einige Sekunden (oder auch mal viele Sekunden) auf diesem Level. Das fragliche Programm ist in dieser Zeit völlig blockiert, bis auf den Mauszeiger. Ich kann während der Blockierung zu anderen Programmen switchen und mit diesen arbeiten.Zu Beginn der Blockierung kann (muss nicht) mal ein kurzer Festplattenzugriff erfolgen, der aber gleich wieder abgeschlossen ist (LED blitzt kurz auf).

- Am meisten von diesen Auslastungsproblemen betroffen ist Firefox 3.6, mit dem ich auf dem PC allerdings auch am meisten arbeite.
- Vor allem das Öffnen der Combobox mit der Chronik der zuletzt besuchten Seiten (rechts neben dem "Vorwärts"- und "Zurück"-Button) ist jetzt sehr nervig . Früher kam diese Combobox praktisch sofort. Jetzt passiert nach dem Klick auf den Pfeil erstmal lange nichts, dann kommt ein leerer Rahmen, dann nochmal eine Pause, und dann erst zeigt die Combobox ihren Inhalt, die Auslastung geht zurück und FF reagiert wieder. Je mehr Einträge die Combobox hat, desto länger dauert es.
- Beim "Chronik"- und "Lesezeichen"-Menü dasselbe Symptom: Klick -> lange Pause -> Rahmen -> kurze Pause -> Menüinhalt. Gerade das "Lesezeichen"-Menü braucht manchmal unglaublich lange, gefühlt bis zu 30 Sekunden. (Wenn das Menü gerade eben erst genutzt wurde, öffnet es sich allerdings sofort, anscheinend spielt da noch ein Cache-System mit.)
- Ich habe das dumpfe Gefühl, dass das Problem irgend etwas mit den kleinen Icons zu tun haben könnte, die vor den Einträgen in der Combobox bzw. dem Menü gezeigt werden, da manchmal schon alle EInträge da stehen, während die Icons sich dann erst so nach und nach, im Sekundentakt, dazu gesellen. Auch öffnet sich eine bestimmte Combobox ohne solche Icons schneller.
- Der "Vorwärts"- und "Zurück"-Button selbst funktionieren insofern eingeschränkt, als ich die nicht mehr mehrmals nacheinander drücken kann, um z.B. gleich drei Seiten auf einmal zurückzuspringen (quasi "asynchron"). Ich muss jetzt drücken -> warten, bis die vorherige Seite angezeigt wird -> drücken -> warten -> drücken...

- Auch mein OpenOffice.org Writer 2.4 zeigt dieses CPU- und Blockierverhalten, und zwar dann, wenn ich in einem Dokument von einer Seite zur nächsten Seite blättern will (wobei also überhaupt keine Comboboxen beteiligt sind). So ein Weiterblättern dauert dann eben jedesmal 5 Sekunden mit 100 % CPU-Last, ist natürlich auch ziemlich nervig.

- Andere Anwendungen nutze ich auf dem PC derzeit kaum. Habe eben nochmal mein uraltes Photoshop durchgeguckt, da gibts keine Auffälligkeiten.

- Mit dem Thread-Stackfenster des hier oft empfohlenen ProcessExplorers konnte ich immerhin schonmal herausfinden, dass sowohl FireFox als auch OpenOffice bei einem Aufruf ntoskrnl.exe!ExReleaseResourceLite+0x1a8 in diesem CPU-100%-Zustand verharren, also anscheinend bei der Freigabe irgendeiner Ressource?? Ich bin nur Anwendungsprogrammierer und verstehe von Treiberprogrammierung nichts. Was könnte mit dieser Zahl 0x1a8 wohl gemeint sein?

- Seitdem ich das Problem mit der 100%-Auslastung habe, funktionieren auch der Standby und Ruhezustand nicht mehr (gingen früher wunderbar, obwohl der PC schon ziemlich alt ist). Das äußert sich so: Windows beendet die laufenden Programme und zeigt an, dass es den Standby bzw. Ruhezustand vorbereitet, aber dann bleibt es einfach stecken, selbst wenn ich den Rechner stundenlang so laufen lasse. Ich kann ihn dann nur noch "mit Gewalt" ausschalten. Beim nächsten Wiedereinschalten macht er dann eben einen normalen Neustart.
- Normales Herunterfahren klappt weiterhin problemlos.

- In anderen Benutzern desselben Windows' dieselben Probleme mit Firefox.
- Probehalber Firefox-Profilwechsel hat auch nichts gebracht.
- Früher hatte ich auch hin und wieder WIndows-Bluescreens mit dem anschließenden Hinweis beim Neustart, dass WIndows den PC heruntergefahren hat, um "Beschädigungen des Computers" zu vermeiden. Ich nehme an, dass Windows dann selbst "merkte", dass die 100%-Phasen sich zu sehr häuften und "fürchtete", dass der Prozessor zu heiß wird? Ich halte mich seitdem beim Surfen etwas zurück, seitdem kommen auch keine BS mehr. Trotzdem ist das auf Dauer kein Zustand, das Surferlebnis ist jetzt ungefähr so wie vor 10 Jahren mit einem Analogmodem.

- Ein schon länger parallel auf dem PC installiertes (selten genutztes) Windows 2000 hat dieses 100%-Problem nicht, dessen Firefox 3.6 flutscht eigentlich wunderbar (auch das Surfen an sich geht wesenltich schneller!). In diesem Windows 2000 funktionieren auch Standby und Ruhezustand noch.Allerdings gibt es in dem Windows 2000 ein anderes Firefox-Problem: Auf manchen komplexen Webseiten werden manchmal Mausbewegungen und Tastatureingaben verschluckt.

Vorgeschichte:
- Ich habe mir seit bestimmt 15 Jahren keinen Virus mehr eingefangen. Vor 1 oder 2 Monaten bin ich allerdings mal bei einer Google-Suche auf eine Webseite gestoßen, die sich verdächtig verhielt: Der Inhalt, den ich gesucht hatte, war gar nicht da, statt dessen wurde praktisch nur eine mehrzeilige Messagebox gezeigt, deren Text sinngemäß fragte, ob ich denn "das Geschenk nicht haben wollte". Das kam mir zwar spanisch vor, aber ich dachte, es ist wohl einfach ein Scherz und war erstmal nicht weiter alarmiert.
- Als ich später die Session beenden wollte, gingen aber der Standby und der Ruhezustand nicht mehr.
- Ich wollte erstmal mit der Systemwiederherstellung den Systemzustand vom Tag vor diesem Webseitenbesuch wiederherstellen. Das funktionierte zwar an sich, allerdings kam eine Fehlermeldung, dass ein bestimmter Cache-Ordner aus dem Firefox-Profilordner aus den und den Gründen umbenannt wurde. Den Cache-Ordner habe ich dann händisch wieder zurückbenannt oder einfach gelöscht (bin mir nicht mehr sicher). Standby und Ruhezustand funktionierten immer noch nicht.
- Ich bin mir nicht sicher, ob das CPU-100%-Problem erst seit diesem Wiederherstellungsversuch besteht oder auch schon seit dem Aufruf der verdächtigen Webseite, da das alles praktisch an einem Abend statt fand. Es kann also gut sein, dass auch das 100%-Problem von Anfang an bestand, aber mir erstmal noch nicht so aufgefallen ist, da ich ohnehin eine ziemlich langsame Internetverbindung habe (Handy als Modem mit HSDPA, manchmal gedrosselt).
- Daraufhin habe ich auch mal einen aktuellen Virenscanner aufgespielt , der auch prompt einen "Java Agent.AM" fand. Diesen habe ich in Quarantäne gesteckt und den PC seitdem ein paarmal gescannt mit dem Ergebnis, dass der PC jetzt sauber ist. Trotzdem sind die Probleme noch da.

- Ich habe später noch Verschiedenes ergoogelt und probiert, um die Probleme zu beseitigen, u.a. einen Registry-Cleaner angewandt, diverse Autoupdate- und Quickstart-Dienste abgeschaltet und im Firefox die meisten Cache- und Cookie-Daten gelöscht (bis auf die Formulareingaben, die mir wichtig sind und an denen es ja kaum liegen kann). Ich habe auch die deaktivierten Dienste des XP mit denen des parallel installierten Windows 2000 verglichen und im XP einige Dienste wieder re-aktiviert, in der Hoffnung, dass der Virus vielleicht irgendwas abgeschaltet hat. Alle diese Maßnahmen blieben aber ohne Erfolg.

Informationen:
- Ca. 8 Jahre alter PC mit Prozessor AMD Athlon XP 1800+
- 768 MB RAM
- Systempartition 20 GB, noch 7 GB frei
- Windowx XP SP2, vor Jahren installiert und praktisch täglich genutzt, allerdings nur wenige Anwendungen ohne große Ansprüche installiert (Internet, Office, Bildbearbeitung, älteres Delphi, früher oft ICQ, war auch alles kein Problem).

Jetzt bin ich mal auf Eure Ideen gespannt.

Tschüss
XProblem
Mitglied: Ausserwoeger
23.03.2011 um 17:07 Uhr
Ich würd sagen druck das hier aus und geh mit dem Zettel und deinem PC zu einem IT Geschäft und lass deinen PC durchtesten.

LG
Bitte warten ..
Mitglied: hwpodcast
24.03.2011 um 19:27 Uhr
Ich finde die Vorgehensweise bedenklich:

- Bei einem 8 Jahre alten PC kann es auch einfach sein das er schlicht Defekt ist. So etwas kann man auch nur bedingt testen.
- Bei Verdacht auf Schadsoftware: Formatieren und neu machen. ALLES andere ist Unsinn. Du kannst einen PC nicht im Nachhinein "säubern". Da die Schadsoftware sicher volle Kontrolle über das Gerät hatte kannst du dir nciht sicher sein was alles verändert wurde.
- Die "Systemwiederherstellung" kann in einigen seltenen Fällen helfen. Oft ist sie aber nur eine Gewissensberuhigung für Leute die keine Backups machen. Aus Erfahrung würde ich sagen das du damit keine Probleme lösen kannst.

Mein Tipp: Formatieren, Betriebsystem neu installieren (Orginalsoftware)
Wenn dann noch Probleme sind: Wegwerfen!


Klingt hart, aber du mußt da Ergebnissoffen an die Sache rangehen. Im Moment willst du dich mit dem Gedanken Software- oder Hardware-Defekt wohl nicht anfreunden und fragst daher "woran kann es noch liegen"?
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows 7
gelöst Windows 7 Skalierung auf 100 Prozent für normale Dömenenuser (2)

Frage von netzwerkschlumpf zum Thema Windows 7 ...

Windows 7
gelöst Windows Update bei virtuellem Windows 7 - hohe CPU Auslastung und keine Reaktion (6)

Frage von IT-Alexander zum Thema Windows 7 ...

Microsoft
Server 2012 cpu Auslastung durchgehend bei 10 prozent (1)

Frage von thomasreischer zum Thema Microsoft ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...