Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

CSS Link-Menü aktiver Link soll rot werden

Frage Internet CMS

Mitglied: admin1987

admin1987 (Level 2) - Jetzt verbinden

28.04.2006, aktualisiert 29.08.2006, 4970 Aufrufe, 1 Kommentar

CMS ist TYPO3 aber Problem ein CSS-Problem denke ich auf jeden Fall!?



Hallo seit Tagen versuche ich vergeblich das mein Subpart "NAVI" der ein HMENU ist, die Seite wo ich mich gerade befinde oben in der Navigation rot markiert solange ich mich dort aufhalte!

Also ich habe: Unternehmen | News | Kontakt ...

Standarmässig ist alles weiß und bei hover kurz rot ich möchte aber das wenn ich mich auf der Seite Unternehmen befinde, Unternehmen rot und fett wird, bitte helft mir ich kriege das echt nicht hin.

Unten mal meine CSS-Datei, des muss ja irgendein CSS-Befehl sein denke ich mal.

Vielen Dank++

CSS:
p {
margin: 0;
}

#rootline {
position: absolute;
top: 1px;
left: 20px;
width: 450px;
height: 13px;
background: #158BC6;
font: normal 9px Verdana, Arial, Helvetica, sans-serif;
color: white;
text-decoration: none;
}

#rootline li {
color: white;
}

#rootline li a {
text-decoration: none;
color: white;
}

#rootline li a:hover {
color: white;
}

#content {
position: absolute;
top: 225px;
left: 333px;
width: 600px;
background: #158BC6;
font: normal 15px Verdana, Arial, Helvetica, sans-serif;
color: white;
}


#head {
position: absolute;
top: 15px;
left: 20px;
width: 534px;
height: 117px;
background-image: url(img.gif);
}

#header-text {
position: relative;
top: 135px;
left: 285px;
width: 450px;
height: 12px;
background: #158BC6;
font: normal 15px Verdana, Arial, Helvetica, sans-serif;
}

#navi {
position: absolute;
left: 25px;
top: 170px;
background: #158BC6;
width: 800px;
height: 45px;
}

#navi ul {
margin: 0;
padding: 0;
}

#navi li {
float: left;
display: block;
color: white;
padding: 0 17px 0 0;
font: normal 17px Verdana,Arial,Helvetica,sans-serif;
}

#navi li a {
text-decoration: none;
color: white;
}

#navi li a:hover {
color: red;
}

#navi li.ACT a,
#navi li.CUR a {
font-size: 18 px;
color: red;
position: relative;
top: -4pxM
}


#topmenu {
position: absolute;
left: 42px;
bottom: 10px;
background: black;
float: left;
display: block;
color= #000000;
padding: 0 10px 0 0;
font: normal 14px Verdana, Arial, Helvetica, sans-serif;
}


#right {
position: absolute;
height: 250px;
top: 295px;
left: 21px;
width: 275px;
background: #158BC6;
}

#left {
position: absolute;
top: 220px;
left: 21px;^
width: 275px;
background: #158BC6;
}


#left ul {
margin: 0;
padding: 0;
list-style-type: none;
}

#left li {
text-decoration: none;
font: normal 13 px Verdana, Arial, Helvetica, sans-serif;
padding: 5px 15px 5px 10px;
color: white;
}

#left li a {
text-decoration: none;
color: white;

}

#left li a:hover {
color: red;
}

#left li.ACT,
#left li.CUR {
font-size: 18 px;
position: relative;
top: -4pxM
}


body, html {
border: 0;
margin: 0;
width: 100%;
height: 100%;
background: #158BC6;
font: normal 100.01% Verdana, Arial, Helvetic, sans-serif;
color: white;
scrollbar-highlight-color: #158BC6;
}


H1 {
font-family : Verdana, sans-serif;
font-size : 16px;
color : white;
margin-bottom : 0px;
margin-top : 10px;
}
H2 {
font-family : Verdana, sans-serif;
font-size : 15px;
color : white;
margin-bottom : 10px;
margin-top : 20px;
}
H3 {
font-family : Verdana, sans-serif;
font-size : 12px;
color : white;
margin-bottom : 0px;
margin-top : 10px;
}
H4 {
font-family : Verdana, sans-serif;
font-size : 10px;
color : white;
margin-bottom : 0px;
margin-top : 10px;
}
.subhead1 {
font-family : Verdana, sans-serif;
font-size : 10px;
color : black;
}
.subhead2 {
font-family : Verdana, sans-serif;
font-size : 10px;
color : green;
}
.subhead3 {
font-family : Verdana, sans-serif;
font-size : 10px;
color : red;
}
.headerdate {
font-family : Verdana, sans-serif;
font-size : 10px;
color : red;
font-weight: normal;
}

li {
text-decoration: none;
color: white;
}
li a {
color: white;
}
li a:hover {
color: red;
}

strong {
text-decoration: none;
color: white;
}




A {
color:white;
}

A:hover {
color:red;
}

A:active {
color:white;
}



[Dieser Beitrag wurde 1 mal bearbeitet. Zuletzt am 28.04.2006 um 10:21]
Mitglied: micha149
29.08.2006 um 08:57 Uhr
Das hängt auf jeden Fall vom TYPO3 ab. Kenne das jetzt nicht, aber ich weis das bei anderen CMS-Systemen eine CSS-id existiert mit der du den aktiven Link formatieren kannst. Guck mal ob du irgendwo eine auflistung der möglichen CSS-ids für Typo3 bekommst....
Bitte warten ..
Neuester Wissensbeitrag
Router & Routing

192.168er Adresse im öffentlichen Netz

(2)

Erfahrungsbericht von visco-c zum Thema Router & Routing ...

Ähnliche Inhalte
HTML
gelöst Angebundenes CSS funktioniert nach Link nicht mehr (4)

Frage von fugu zum Thema HTML ...

Webentwicklung
Jeden Link umschreiben ASP.NET (6)

Frage von Herbrich19 zum Thema Webentwicklung ...

Voice over IP
gelöst Netzwerkverkehr am Switch priorisieren ( QOS ) bei D-Link DGS-1210-52 (17)

Frage von takvorian zum Thema Voice over IP ...

Heiß diskutierte Inhalte
Zusammenarbeit
Als Administrator im Großraumbüro (29)

Frage von Dopamin85 zum Thema Zusammenarbeit ...

Exchange Server
Test-ActiveSyncConnectivity Error nach neuem Zertifikat (22)

Frage von Driphex zum Thema Exchange Server ...

Hyper-V
HYPER V und USB (16)

Frage von Hendrik2586 zum Thema Hyper-V ...

SAN, NAS, DAS
Backupserver für KMU (14)

Frage von Leo-le zum Thema SAN, NAS, DAS ...