Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

CSS Pulldown-Menü beinhaltet einen Fehler

Frage Entwicklung CSS

Mitglied: 15187

15187 (Level 2)

26.08.2008, aktualisiert 11:45 Uhr, 4096 Aufrufe, 4 Kommentare

Ich kann leider nicht mehr nachvollziehen, was ich geändert habe. Ich finde den Fehler nicht...

Es gibt für meine Entwicklungsseite einen Server, die Seite selbst findet Ihr hier:
http://kupraestivo.dyndns.org/entwicklung

Kann ja mal jemand kucken? Das Problem ist einfach, dass da ein Pulldownmenü weit rechts erscheint, wo es nicht hingehört. Während des "hoverns" steht es dann an der richtigen Stelle.

Vielen Dank im Voraus an alle, die mir weiterhelfen.
Gruß,
TC

Das CSS Skript für das Menü sieht so aus:

01.
#nav, #nav ul { 
02.
	list-style: none; 
03.
	float: center; 
04.
	padding: 10px 0 0 0; 
05.
	font-style: normal; 
06.
07.
 
08.
#nav li { 
09.
	float: left; 
10.
	text-align: center; 
11.
	background: #002040 url(../images/tab.gif) no-repeat left bottom; 
12.
	font-style: normal; 
13.
14.
 
15.
#nav a { 
16.
	display: block; 
17.
	width: 8em; 
18.
	padding: 2px 0px 0px 0px; 
19.
	margin: 0; 
20.
	color: #ddd; 
21.
	background: #ad0100 url(../images/tab.gif) no-repeat left bottom; 
22.
	font-style: normal; 
23.
24.
 
25.
#nav li a:hover { 
26.
	background: #999 url(../images/tabhover.gif) no-repeat left bottom; 
27.
	color: #000; 
28.
	font-style: normal; 
29.
30.
 
31.
#nav li ul { 
32.
	position: absolute; 
33.
	left: 200em; 
34.
	height: auto; 
35.
	width: 8em; 
36.
	font-weight: normal; 
37.
	margin: 0; 
38.
	padding: 0 0 0 0; 
39.
	background: #002040; 
40.
	font-style: normal; 
41.
42.
  
43.
#nav li li { 
44.
	width: 8em; 
45.
	line-height: 1.8em; 
46.
	text-align: left; 
47.
	font-size: 1em; 
48.
49.
  
50.
#nav li ul a { 
51.
	width: 11em; 
52.
	text-indent: 5px; 
53.
	padding: 0px; 
54.
55.
 
56.
#nav li ul a:hover { 
57.
	width: 11em; 
58.
59.
  
60.
#nav li ul ul { 
61.
	padding: 0; 
62.
	margin: -1.8em 0 0 11em; 
63.
64.
  
65.
#nav li:hover ul ul,  
66.
#nav li:hover ul ul ul,  
67.
#nav li.sfhover ul ul,  
68.
#nav li.sfhover ul ul ul { 
69.
	left: 200em; 
70.
71.
  
72.
#nav li:hover ul,  
73.
#nav li li:hover ul,  
74.
#nav li li li:hover ul,  
75.
#nav li.sfhover ul,  
76.
#nav li li.sfhover ul,  
77.
#nav li li li.sfhover ul { 
78.
	left: auto; 
79.
80.
  
81.
#nav li:hover,  
82.
#nav li.sfhover { 
83.
	background: transparent; 
84.
	color: #FEFFB8; 
85.
}
Mitglied: wakko
26.08.2008 um 10:23 Uhr
Moin,

mach mal in Zeile 32 (#nav li ul) das position: absolute weg, dann sollte das passen...

MfG
Bitte warten ..
Mitglied: 15187
26.08.2008 um 10:29 Uhr
Danke, fast schon ok. Jetzt sitzt das Menü am Platz, aber es wird schon angezeigt, bevor man draufklickt - kannst ja mal auf der Seite schauen.

Gruß,
TC
Bitte warten ..
Mitglied: wakko
26.08.2008 um 10:47 Uhr
Teste mal sowas:
01.
div#nav ul ul, div#nav ul li:hover ul ul, div#nav ul ul li:hover ul ul { 
02.
display:none; 
03.
04.
 
05.
div#nav ul li:hover ul, 
06.
div#nav ul ul li:hover ul, 
07.
div#nav ul ul ul li:hover ul 
08.
{display: block; 
09.
}
Erste Regel blendet das Menü aus, zweite Regel beim "hovern" wieder ein.
damit das auch für Browser < IE7 geht, kannst du die csshover.htc von hier einbinden...
Bitte warten ..
Mitglied: 15187
26.08.2008 um 11:45 Uhr
Also irgendwas ist hier arg faul. Ich mache Änderung, mache diese rückgängig, und nichts ist mehr wie es war... was wohl auch der Grund dafür ist, dass das Menü plötzlich falsch ist.
Ich werd hier nochmal wahnsinnig...

Und wie erwartet, da ja die Änderungen so grad garnicht nachvollziehbar sind, macht auch die Integration Deines Textblocks momentan leider keine Änderung - was jedoch sicherlich, es sei betont, nicht an Deinem Skript liegt.

Ich probiere weiter...

Gruß,
TC

PS: meintest Du IE >= 7 ? Es ist Sache von Microsoft, dafür Sorge zu tragen, dass neue Browser dem technischen Stand des alten überlegen sind.
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Fritz Box 7490 DNS und Telefonie Fehler (3)

Frage von Akcent zum Thema Router & Routing ...

Server
IIS 8.5 Server HTTP-Fehler 500.19 - Internal Server Error (1)

Frage von coldice-it zum Thema Server ...

Exchange Server
gelöst Exchange 2010 (Srv2008R2) merkwürdiger Fehler nach Router wechsel (5)

Frage von oel-auge zum Thema Exchange Server ...

Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
Windows 10
Windows für Privatanwender "nicht mehr handhabbar" (29)

Frage von FA-jka zum Thema Windows 10 ...

LAN, WAN, Wireless
Komplett neues Netzwerk, Ubiquiti WLAN, Router, Switch (15)

Frage von Freak-On-Silicon zum Thema LAN, WAN, Wireless ...

Backup
Backup Wochen- Monats- Jahressicherung (13)

Frage von Meterpeter zum Thema Backup ...

RedHat, CentOS, Fedora
Fedora, RedHat, Centos: DNS-Search Domain setzen (13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...