Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Cygwin mit Problemen beim Zugriff auf Netzlaufwerke

Frage Microsoft Windows Netzwerk

Mitglied: sebele

sebele (Level 1) - Jetzt verbinden

07.08.2007, aktualisiert 10.09.2007, 6485 Aufrufe, 2 Kommentare

Ich habe folgende Ausgangssituation:

Ich starte von einer XP-Kiste per PLink.exe (Putty V0.59) ein Python-Skript, welches sich auf einem Windowsserver2003 befindet. Dieses Skript wiederum soll eine seinerseits eine Programm anstossen, dessen exe sich auf einem Netzlaufwerk befindet. Das Skript meldet jedoch, dass es den Pfad nicht finden kann.

Wenn ich mir mit Putty in der bash die Umgebung anschaue, so ist das Netzlaufwerk unter /mnt/freigabe gemountet. Unter diesem Pfad kann allerdings das Pythonskript nicht darauf zugreifen, da es Windowspfade a la "O:prog...." erwartet.
Der angemeldete Benutzer sieht unter /cygdrive/ leider nur die lokalen Laufwerke des Servers aber leider keine Netzlaufwerke.

Ich habe versucht, mit einer neuen Windowsshell (cmd) in dieser Puttysession das Laufwerk mit NET USE zu verbinden, aber da bekomme ich nur eine Fehlermeldung, dass das Laufwerk bereits eingebunden ist (was ja auch stimmt!).

Die Frage ist nun, wie schaffe ich es ein Netzlaufwerk in der Cygwin-Umgebung in einem Skript anzusprechen.

PS: Ich habe noch einen vergleichbaren Linuxserver, auf dem das Verfahren prima klappt.

Vielen Dank schon mal für jegliche Hilfe.

Gruß Sebastian
Mitglied: juergwin
27.08.2007 um 19:50 Uhr
Hallo,
habe ähnliches Problem mit Datensicherungsprogramm Deltacopy
(nutzt ebenfalls Cygwin). Auch hier keine möglichkeit auf Netzlaufwerke
zu sichern.
Falls Du Lösung gefunden hast, bitte veröffentlichen.

Gruß

Juergwin
Bitte warten ..
Mitglied: sebele
10.09.2007 um 08:44 Uhr
Hi,

leider habe ich bis jetzt noch keine Lösung im Sinne dieses Problems gefunden.

Warscheinlich werde ich die benötigten Resourcen einfach lokal vorhalten um dem Problem aus dem Weg zu gehen. Passt mir zwar überhaupt nicht, da ich dadurch eine Redundanz im System erhalte.

Falls Du auf ne Lösung stößt, dann informiere mich bitte ebenfalls.

Mit freundlichen Grüssen


Sebastian
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
SAN, NAS, DAS
gelöst NAS Fernzugriff über DynDNS, kein Zugriff (13)

Frage von Amanuel zum Thema SAN, NAS, DAS ...

Windows Netzwerk
gelöst Anonymer Zugriff auf Netzlaufwerk für WSUS Offline (5)

Frage von hannsgmaulwurf zum Thema Windows Netzwerk ...

Router & Routing
gelöst Fritzbox 7490 und Zyxel USG20 - Zugriff auf LAN der USG20 (8)

Frage von Sebbi87 zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Switche und Hubs
LAG zwischen Cisco SG300 und Dlink DGS1100 herstellen - wie? (18)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

CPU, RAM, Mainboards
Hardware Fragen (12)

Frage von xaver-2 zum Thema CPU, RAM, Mainboards ...

Grafikkarten & Monitore
Neue Graifkkarte - kein Bild (10)

Frage von bestelitt zum Thema Grafikkarten & Monitore ...

Exchange Server
gelöst Exchange 2013 - Kontakte aus CSV importieren (9)

Frage von hesper zum Thema Exchange Server ...