Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Das DataGridView zeigt keine Daten der DB-Tabelle an

Frage Entwicklung Datenbanken

Mitglied: T-Back

T-Back (Level 1) - Jetzt verbinden

15.03.2009, aktualisiert 13:11 Uhr, 3704 Aufrufe

Ich habe ein Problem mit dem SQLEXPRESS - Server und einem von mir unter ADO.NET 3.5 (VS 2008) entwickelten Datenbank-Client Projekt

Hallo Leute,

Ich habe ein Datenbank-Client Projekt entwickelt bzw. ich bin gerade dabei und habe ein Problem mit allen DataGridView's!

Die DGVs zeigen beim Debuggen keine Daten von der Datenbank an.

Das Programm besteht aus 2 Klassenbibliotheken, der libDAL (DataAccessLayer) und der libBL (BusinessLogic), und aus einem Frontend Projekt mit den Windows-Forms.
Die Verweise stimmen alle, das habe ich mir schon angeschaut.

Der Datenbank-Zugriff der DataGridView ist Objekt-basierend.

Das komische ist, dass das DataGridViews jeweils pro Datenbank-Tabelle den Primary Key (habe ich als int deklariert) und einen bool-Datentyp anzeigt mittels einer Checkbox.
Das DataGridView zeigt auch genau so viele Zeilen an, wie die Datenbank hat!

Ich habe jeweils eine zweite Windows Form erstellt, um die Daten aus dem DataGridView zu ändern, also zum NEU hinzufügen eines Datensatzes und um einen Datensatz zu BEARBEITEN bzw. zu LÖSCHEN!
In einer Windows Form von diesen habe ich zwei verschiedene BindingSources (von zwei verschiedenen Tabellen) implementiert um in einer ComboBox, die Daten einer anderen Tabelle anzuzeigen.
UND DAS FUNKTIONIERT!

Wenn ich einen neuen Datensatz erstelle und danach in der Windows Form mit dem DGV mittels einem Button eine Gespeicherte Prozedur bspw. "UPDATE" ausführe, dann zeigt das DataGridView die neue Zeile an und den fortlaufenden Primary Key, der immer um 1 erhöht wird. Die NEUEN Daten sind auch in der Datenbank zu sehen, wenn ich eine Tabelle öffne in der "Microsoft SQL Server Express Edition"!

Ich habe schon einmal ein Projekt nach dem gleichen Schema programmiert, und dort funktioniert der Datenzugriff ganz normal! Dieses habe ich aber unter .NET 2.0 entwickelt, ich habe es dann aber in VS 2008 konvertiert und dort funktioniert es auch.


Ich bin über jeden Tipp und über jeden Ratschlag den Ihr mir geben könnt sehr dankbar!

LG T-Back
Ähnliche Inhalte
Windows 7
Windows 7 zeigt keine Netzwerkverbindungen an (2)

Tipp von Apophis zum Thema Windows 7 ...

MikroTik RouterOS
gelöst Dude - Server schickt keine Daten (7)

Frage von IP-PUPPI zum Thema MikroTik RouterOS ...

Neue Wissensbeiträge
Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(38)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Humor (lol)

Bester Vorschlag eines Supporttechnikers ever: APC

(15)

Erfahrungsbericht von DerWoWusste zum Thema Humor (lol) ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
POS Hardware und alternativen zu Raid 1? (21)

Frage von Brotkasten zum Thema Festplatten, SSD, Raid ...

Viren und Trojaner
Verschlüsselungstrojaner simulieren (16)

Frage von AlbertMinrich zum Thema Viren und Trojaner ...

Rechtliche Fragen
Hotspot rechtssicher betreiben? (14)

Frage von xSiggix zum Thema Rechtliche Fragen ...

Server-Hardware
gelöst Empfehlung KVM over IP Switch (8)

Frage von Androxin zum Thema Server-Hardware ...