Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Datein und Ordner auf externer USB-Festplatte fehlen im Explorer

Frage Hardware

Mitglied: chekov

chekov (Level 1) - Jetzt verbinden

21.12.2009 um 17:11 Uhr, 6918 Aufrufe, 4 Kommentare

Hallo zusammen,

dies ist mein erster Beitrag und ich hoffe, dass ich vorher ausreichend recherchiert und die richtige Lösung nicht übersehen haben.

Ich habe einen PC mit Windows 7 64bit, an dem ich ein externes USB-Laufwerk von WD mit 1TB angeschlossen habe.

Dieses Laufwerk war mit NTFS formatiert, die Daten wurden mit Robocopy auf dieses Laufwerk gespiegelt. Alle Daten waren im Explorer einwandfrei zu erkennen.

Nach einiger Zeit - leider unbestimmt - stellte ich fest, dass ich im Explorer zwar das Laufwerk korrekt angezeigt bekommen (K:\), aber keine Verzeichnisse bzw. Dateien.

Daraufhin habe ich das Laufwerk mit NTFS neu formatiert und neu gespiegelt. Alle Dateien waren sichtbar. Nach dem Entfernen des Laufwerks und dem erneuten Anschließen sind die Verzeichnisse und Dateien nicht mehr sichtbar. Unter Eigenschaften wird die korrekte Belegung (quantitativ) angezeigt. Chkdsk meldet keinen Fehler. Robocopy spiegelt alle Dateien und Verzeichnisse korrekt, d. h. es findet jede einzelne Datei. In der Datenträgerverwaltung ist das Laufwerk und seine Partition korrekt zu erkennen.

Schließe ich das Laufwerk an einem anderen PC an, kann ich alle Dateien und Verzeichnisse im Explorer erkennen.

Mit dem Tool "drivecleanup" von Uwe Sieber habe ich bereits alle USB-Daten mit und ohne angeschlossenem Laufwerk auf dem Win7-PC bereinigt, jedoch ohne Ergebnis.

Öffne ich über diesen Windows 7-PC eine RDP-Sitzung auf einem anderen PC und erlaube den Zugriff auf alle lokalen Resourcen des Win7-PCs, so wird im Explorer der RDP-Sitzung der Inhalt der Festplatte ebenfalls korrekt angezeigt.

Ich schließe daraus, dass es lediglich in Windows 7 bzw. auf der Hardware ein Problem gibt und wäre für jeden Tipp dankbar.

Vielen Dank im Voraus

chekov
Mitglied: kaiszy28
21.12.2009 um 17:33 Uhr
Hallo,

mit den Zugriffsrechten kann das nichts zutun haben, oder ? Du kopierst die Daten als Administrator auf die USB-Platte und versuchtst die Daten auch wieder als Administrator zu lesen ?

CU,
Kai.
Bitte warten ..
Mitglied: SamvanRatt
21.12.2009 um 17:49 Uhr
Hi
für mich sieht das wie eine Ansichtsproblematik aus. Was passiert wenn du es via Shell suchst (=cmd.exe) und des dir da ansiehst?
Da der Explorer (insbesondere die Bonbon Oberfläche von Vista/Win7) massenweise Filteroptionen hat (Powertoys helfen da ein wenig) kann ich sowas durchaus verstehen (auch wenn gar keine Ordner/Dateien schon sehr ungewöhnlich klingen). Ein Hardwareproblem oder Treiberproblem ist es aber sicher nicht da es ja via RDP sichtbar ist, also ein Userproblem (evtl hast du was an den Ansichten verdreht?)
Gruß
Sam
Bitte warten ..
Mitglied: chekov
21.12.2009 um 20:00 Uhr
Ich habe das Thema Zugriffsrechte mir noch einmal angesehen. Fakt ist, dass ich als User mit Adminrechten die Dateien angelegt und auch weiterhin mit demselben User und Robocopy gespiegelt habe.

Auf deinen Tipp hin habe ich im Explorer die Option "Systemdateien anzeigen" und "alle Ordner anzeigen" aktiviert und kann jetzt die Verzeichnisse und Dateien als versteckte Dateien sehen.

Als Besitzer bin nicht ich, sonder der Systemadministrator (unter dem ich nicht gearbeitet habe) eingetragen. Das habe ich geändert, trotzdem kann ich die Dateien nicht sehen. Ich habe mir daraufhin die Attribute anzeigen lassen. Diese lauten "HSD". H für hidden und S für Systemdatei ist mir bekannt, D jedoch nicht. Ändern mit attrib -s -h kann ich die Dateien nicht. Unter Eigenschaften ist das Feld für "versteckt" ausgegraut.

Es hat den Anschein, als gäbe es tatsächlich ein Rechteproblem. Aber die Ursache und eine Lösung ist mir noch nicht deutlich.

Gruß

chekov
Bitte warten ..
Mitglied: SamvanRatt
21.12.2009 um 21:54 Uhr
Dann vererbe mal die Attribute durch
attrib -r -h -s "Laufwerksbuchstabe":\*.* /s
D steht für Directory (und -r brauchst du damit das ReadOnly übergangen wird)
Der Explorer interessiert sich eigentlich nicht für die Attribute (das sind vergangene Zeiten) sondern eher für die ACLs, aber da du sie sehen kannst und verändern darfst?! Welche Parameter hast du robocopy mitgegeben? Ein normaler "rococopy A: B: /mir /copy:dato" sollte reichen um einen Kopie von a nach b zu kriegen; robocopy ist aber auch ein mächtiges tool, wobei kleinste Fehler spaßige Auswirkungen haben können (z.B. wenn du copyall oder dats benutzt hast)
Gruß
Sam
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows 10
Windows 10 von externer USB-HDD installieren (4)

Frage von cableguy007 zum Thema Windows 10 ...

Backup
gelöst Sicherung auf USB Festplatte mit Acronis Backup und Robocopy (5)

Frage von mike7050 zum Thema Backup ...

Batch & Shell
USB-Festplatte per Script sicher entfernen und wieder anhängen (8)

Frage von Atti58 zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (15)

Frage von liquidbase zum Thema Windows Update ...

DSL, VDSL
Problem mit variernder Internetgeschwindigkeit (12)

Frage von schaurian zum Thema DSL, VDSL ...