Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Deaktivierung AutoLogin

Frage Microsoft

Mitglied: todo

todo (Level 1) - Jetzt verbinden

23.01.2006, aktualisiert 29.03.2006, 10731 Aufrufe, 6 Kommentare

Habe unter Windows XP (Home) einen AutoLogin eingerichtet, welcher jedoch nur nach dem ersten Neustart des PCs funktioniert.

Ich setzte den Wert "Autologin" unter "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon", in der Registry, auf "1". Nach dem ersten Neustart funktioniert der AutoLogin auch wie erwartet und an dem Wert an sich hat sich, auch in der Registry, nichts geändert!

Nach einem erneuten Neustart des PCs bleibt Windows jedoch wieder am Willkommensbildschirm, mit der Benutzerauswahl, stehen. Ich habe feststellen müssen, dass der Registrywert für das AutoLogin wieder auf "0" gesetzt wurde!

Was verursacht dieses Phänomen und wie kann ich den AutoLogin dauerhaft festsetzen?

Zur Information:
Es handelt sich um einen reinen Standalone-PC, welcher nicht einmal einen Internetzugang besitzt!

Hat wer Rat?


Gruß

Thomas
Mitglied: CouchCoach
23.01.2006 um 08:47 Uhr
Sperr doch mal den Pfad in der Reg sodaß nur noch du hier Schreiben kannst und alle anderen Lesen.
Ist zwar nicht der Weisheit letzter Schluß aber wer oder welches Programm diesen Key immer wieder auf Null setzt kann ich dir leider nicht beantworten.
Es sei denn, aber du sagtest ja das der Rechner standalone ist, er befindet sich in eine Domäne und über die GPO wird die Anmeldung erzwungen!!!
Es gibt nämlich einen Parameter der die explizite Anforderung eines Passwortes, selbst wenn es übergeben wird, anfordert. (Kommt aus dem Bereich Terminalserver)

Grüße
Bitte warten ..
Mitglied: todo
23.01.2006 um 09:01 Uhr
Domäne / GPO kann ich gänzlich ausschließen, denn dann wäre das Problem auch nachvollziehbar!

Das Sperren des Pfades könnte die Lösung sein. Wobei es doch verwunderlich wäre, wenn es daran liegt, denn die Berechtigungen dort ensprechen immer noch den Standardeinstellungen.

Ein Versuch ist es wert, dann aber erst heute Abend!

Gruß

Thomas
Bitte warten ..
Mitglied: Biber
23.01.2006 um 10:35 Uhr
Moin todo,
ich könnte mir vorstellen, dass diese Deaktivierung durch einen von Dir gesetzten/übersehenen Haken in einem Tool wie TweakUI oder Deinem Virenscanner/Deiner Firewall/Deinem Anti-Spywaretool bewirkt wird.

Denn bei mehreren dieser Sicherheitstools wird das Deaktivieren von Autologons und das Nicht-Speichern von Passworten im Klartext als Default ausgeliefert.

HTH Biber
Bitte warten ..
Mitglied: todo
23.01.2006 um 10:47 Uhr
Tach Biber,

all das, könnte durchaus die Ursache sein. Ich kann aber sicher ausschließen, dass es daran liegt. Es sind keinerlei Tools in dieser Richtung installiert. Auch eine Firewall - auch die XP-eigene - und einen Virenscanner habe ich nicht im Einsatz ... zumindest nicht auf diesem "Standalone-PC".

Selbst wenn solch Tools / Programme installiert wären, würde ich mich doch fragen, weshalb das AutoLogin, nach der Aktivierung und des erstmaligen Neustarts des PCs funktioniert. Erst nach dem zweiten Neustart funktioniert es nicht mehr!

Gruß

Todo
Bitte warten ..
Mitglied: Biber
23.01.2006 um 11:03 Uhr
@todo

Na ja, wie immer im Leben zwei Möglichkeiten:
Entweder das Ändern dieses RegKeys verhindern (Lösung oben),
Oder der (Ur-)Sache auf den Grund gehen.

Im zweiten Fall wieder zwei Möglichkeiten:
Entweder den RegKey überwachen (mit sysinternals RegMon.exe oder ähnlichem),
Oder mal die Liste aller laufenden Dienste überprüfen. Wird ja eher ein aktiver Dienst im Autostart sein als ein von Dir bewusst gestartetes Programm Deiner Beschreibung nach.

Wenn Du nur das Ändern des RegKeys verhindern willst, können wir den Thread schließen
Bitte warten ..
Mitglied: baka-kun
29.03.2006 um 19:58 Uhr
Ich denke es liegt daran das dein Admin-Account ein Passwort hat.

HKEY_LOCAL_MACHINE \ Software \ Microsoft \ Windows NT \ Current Version \ Winlogon

AutoAdminLogon Zeichenfolge (REG_SZ) 1 Autologin Ein-/ Ausschalten
DefaultUserName Zeichenfolge (REG_SZ) <Benutzername> Anmeldename
DefaultPassword Zeichenfolge (REG_SZ) <Paßwort> Paßwort
DefaultDomainName Zeichenfolge (REG_SZ) <DomainName> Domain

Will man sich unter einem anderen Namen anmelden, muss man beim Startvorgang die Leertaste gedrückt halten. Wenn in der Registry kein Passwort eingetragen ist, funktioniert AutoLogin nur einmal. Windows stellt dann wieder AutoAdminLogin auf 0.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Server
GPO aktiv trotz Deaktivierung (7)

Frage von XxDarkAngelxX zum Thema Windows Server ...

Exchange Server
gelöst Outlook Abwesenheitsnotiz bleibt aktiviert, trotz Deaktivierung! (1)

Frage von Sachellen zum Thema Exchange Server ...

Windows Server
Xendesktop 7.6 Maschinen machen kein Autologin (3)

Frage von 116480 zum Thema Windows Server ...

Windows 10
gelöst Windows 10: Deaktivierung des automatischen ausloggen via RDP (6)

Frage von Phteven zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...