Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Debian - 2 verschiedene Netzwerke erreichen

Frage Linux Debian

Mitglied: Dani

Dani (Level 5) - Jetzt verbinden

21.06.2012, aktualisiert 24.06.2012, 7919 Aufrufe, 16 Kommentare

Guten Abend zusammen,
ich steh seit ca. 18 Stunden irgendwie aufm Schlauch...

Ich habe einfach ein kl. Bild gemalt, damit es deutlicher wird:

5f6a89b7914684eced760e3e55fe34c0 - Klicke auf das Bild, um es zu vergrößern

Wie auf den Bild zusehen, soll der Server von außen auf der IP-Adresse 89.1.1.11 erreichbar sein. Das funktioniert soweit auch, da ich dieser Netzwerkkarte (eth0) das Gateway angegeben habe.

So nun muss aber dieser Server (192.168.80.14) mit dem Server 10.20.30.39 kommunizieren. Und da steh ich nun aufn Schlauch. Denn meinen Wissens nach, kann es immer nur ein Default-Gateway geben.

Trotzdem bin ich bei Google auf diese Anleitung gestoßen, die es wohl möcglich machen soll. Leider efolglos!
Die Anleitung von aqui hilft mir hierbei direkt auch nicht weiter.

Wie muss ich den Server 192.168.80.14 (Debian Squeeze, 64 Bit) konfigurieren, damit die Kommunikation funktioniert?!

Netzwerkkonfiguration:
01.
iface eth0 inet static 
02.
  address   89.1.1.11 
03.
  netmask   255.255.255.0 
04.
  gateway   89.1.1.12 
05.
   
06.
   
07.
iface eth1 inet static 
08.
  address   192.168.80.14 
09.
  netmask   255.255.255.0 
10.
  gateway   192.168.80.1

Grüße,
Dani
Mitglied: Epixc0re
21.06.2012 um 19:40 Uhr
route add -net 10.20.30.0/24 gw 192.168.80.1

Bitte warten ..
Mitglied: Lochkartenstanzer
21.06.2012, aktualisiert um 20:42 Uhr
Hi Dani,

" Dich von Schlauch schubs "

Du willst keine default-route, sondern eine statische route.

Die kannst Du mit route add eingeben oder direkt in /etc/network/routes eintragen.

lks


Nachtrag:

Du kannst natürlich auch direkt in /etcNetwork/interfaces sowas ähnliches wie

up route add -net 10.20.30.0/24 gw 192.168.80.1 
down route del  -net 10.20.30.0/24 gw 192.168.80.1
bei eth1 eintragen
Bitte warten ..
Mitglied: Dani
21.06.2012 um 20:44 Uhr
@Epixc0re
Volltreffer, so einfach kann es sein.

@lkz
Muss ich die Datei "routes" anlegen oder sollte die schon da sein?!


Grüße,
Dani
Bitte warten ..
Mitglied: Lochkartenstanzer
21.06.2012, aktualisiert um 20:56 Uhr
Zitat von Dani:
@Epixc0re
Volltreffer, so einfach kann es sein.

@lkz
Muss ich die Datei "routes" anlegen oder sollte die schon da sein?!

Die muß ggf neu angelegt werden, aber die Variante mit /etc/network/interfaces ist fast schon besser, da dann die routen automatisch beim aktivieren/deaktivieren des Interfaces mitgeführt werden.

lks

Nachtrag: Hier ist die Dokumentation von debian http://www.debian.org/doc/manuals/debian-reference/ch05.en.html

ggf. mußt du noch ifupdown-extra nachinstallieren.
Bitte warten ..
Mitglied: Dani
21.06.2012 um 22:35 Uhr
Kommando zurück...
Mit der Route funktioniert es nicht.

Firewallregeln sind soweit auf "allow" gesetzt. Andere Server, die das Default Gateway im 192.168.80.x haben, können Problem den Server 10.20.30.39 anpingen.

Was habe ich unter Debian übersehen?!
Bitte warten ..
Mitglied: Lochkartenstanzer
22.06.2012 um 07:22 Uhr
Guten Morgen,

  • Hast Du fw-Regeln auf dem debian installiert (iptables & Co.)?
  • Was sagt tcpdump/wireshark, wenn Du pingst?
  • Funktioniert es, wenn Du statt einer statischen Route eine default route auf dieses Gateway setzt?

Post mal die Ausgabe von "netstat -rn", nachdem die Route angelegt wurde.

lks
Bitte warten ..
Mitglied: Dani
22.06.2012 um 08:00 Uhr
Guten Morgen,

  • Bewusst eigentlich nicht. iptables als Befehl werden aber erkannt. Mit iptables -L werden aber keine Regeln angezeigt.
  • Ich seh eben 2 Einträge für 2 Pings, aber mehr nicht.
  • Hab ich eben konfiguriert. Leider ändert das auch nichts. Was mir aber auffällt, dass der Server wenn ich "route" eingebe etwas länger brauch um mir die beiden Einträge anzuzeigen.


Grüße,
Dani
Bitte warten ..
Mitglied: Lochkartenstanzer
22.06.2012, aktualisiert um 08:20 Uhr
Zitat von Dani:
  • Bewusst eigentlich nicht. iptables als Befehl werden aber erkannt. Mit iptables -L werden aber keine Regeln angezeigt.

Das ist schon mal gut.

* Ich seh eben 2 Einträge für 2 Pings, aber mehr nicht.

  • gehen die echo requests auf dem richtigen Port raus? Nein -> Route prüfen.
  • Kommen auch die Replies? auf dem richtigen Port an? Nein -> Firewall 192.168.80.1 prüfen. ggf sniffing zwischen FW und 10.20.30.39 (Stimmen dort die routen?

* Hab ich eben konfiguriert. Leider ändert das auch nichts. Was mir aber auffällt, dass der Server wenn ich
"route" eingebe etwas länger brauch um mir die beiden Einträge anzuzeigen.

Dann liegt es vermutlich an der Firewall oder am Zielsystem. Hilft nur, dort zu sniffen/regeln zu überprüfen.

lks

Nachtrag: Erlaubt die FW überhaupt ICMP-Traffic zwischen den Netzwerken?
Bitte warten ..
Mitglied: aqui
22.06.2012 um 09:19 Uhr
Nur noch mal zur Erinnerung: Stelle auf alle Fälle sicher das der Default Gateway Eintrag an eth1 entfernt ist !! Dort darf wie im Tutorial beschrieben NUR IP und Maske eingetragen sein.
Wenn dem so ist dann die zusätzliche Route route add -net 10.20.30.0/24 gw 192.168.80.1 eintragen.
Mit netstat -nr kannst dir die Routing Tabelle ansehen ob die soweit stimmt.
Alles andere sind dann rein Firewall Sachen bzw. Regeln und haben mit dem Netzwerk an sich dann nix mehr zu tun.
Bitte warten ..
Mitglied: Dani
24.06.2012 um 17:54 Uhr
Moin,
also wir sind heute ein Stück weiter. Es sind wohl keine 2 seperate Firewalls wie auf dem Bild sondern Eine und die IP-Bereich sind von einander via VLAN getrennt. Ich bin mir aber nicht so ganz sicher, ob nicht da der Hund begraben ist. Weil ich hab immer wieder aussetzer auf beiden Netzen (89.x und 192.x).

Hier nochmal das aktualisierte Schaubild:
36a54dd05db221c61c94aea99c5553f5 - Klicke auf das Bild, um es zu vergrößern


Grüße
Bitte warten ..
Mitglied: aqui
24.06.2012 um 18:02 Uhr
Hat der Server (89.1.1.11) auch eine VLAN_Konfig auf die Firewall mit beiden IP Netzen ? (Ohne Routing).
Die Verbindung dieses Servers mit 2 IP Netzen ist etwas "merkwürdig". Hast du da mal die Gateway Konfig bzw. Routing Tabelle gecheckt ?

P.S. Hoffentlich ists nicht der freundliche Hund von oben mit der Zeitung im Maul ?!
Bitte warten ..
Mitglied: Dani
24.06.2012 um 18:10 Uhr
VLAN Konfiguration direkt nicht. Er hat 2 seperate phy. Netzwerkkarten verbaut (für jeden Bereich).
Das Routing ist nicht aktiviert. Von daher dürfte da nichts passieren.

Die ursprüngliche Netzwerkkonfig waren die 10 Zeilen (siehe oben). Was mich aufschreien lies, da zwei Gateways konfiguriert sind.

Das 89.x ist ein IPv4 Block vom ISP. Über diesen soll der Dienst X der Internetwelt zur Verfügung stellt werden. Der Server muss aber eine Website einbinden, die auf 10.20.30.39 liegt.


Grüße,
Dani
Bitte warten ..
Mitglied: aqui
24.06.2012 um 18:18 Uhr
OK, 2 Gateway gehen NICHT aber das weisst du ja selber
Das musst du unbedingt fixen. Über das 2te Interface kann man nur mit einzelnen Routen statisch routen ! (Weisst du ja auch...)
Der 10.20.30.39er Server ist ja erstmal außen vor, denn dort ist die Netzwerk Anbindung durch das singuläre Interface ja problemlos.
Muss der Server unten mit den 2 Interfaces den 10.20.30er Server erreichen und nur den ??
Bitte warten ..
Mitglied: Dani
24.06.2012 um 18:26 Uhr
Muss der Server unten mit den 2 Interfaces den 10.20.30er Server erreichen und nur den ??
Jup, das ist der einzigste Server.
Bitte warten ..
Mitglied: aqui
24.06.2012, aktualisiert um 18:37 Uhr
OK, dann ist die Lösung eigentlich recht einfach wenn du sie nicht eh schon so umgesetzt hast.
Das Default Gateway des 2 Port Servers darf NUR auf dem 89.1.1er Interface liegen und auf das korrespondierende FW Interface in diesem Netz zeigen !
Das 192.168.80.0er Interface darf KEIN Gateway Eintrag enthalten !
Statt dessen muss eine statische Route route add net 10.20.30.0 mask 255.255.255.0 192.168.80.x wobei "x" wieder die Hostadresse der FW in diesem Segment ist !
Mit "netstat -nr" kannst du dir dann die Routing Tabelle ansehen des 2 IP Servers.
Alles was jetzt Internet ist geht auf dem 89er raus und alles was zum 10.20.30er Server geht geht nur auf dem 192.168.80er Interface raus.
War es das was du erreichen wolltest ?
Die Firewall Regeln müssen natürlich entsprechend stimmen, was wir mal voraussetzen
Bitte warten ..
Mitglied: Dani
06.07.2012 um 16:27 Uhr
Moin,
das Problem konnte gelöst werden. Es war noch n Route auf der Firwall von einem falschen Netz aktiv.


Grüße,
Dani
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Netzwerk
Automatisches IP Setup für verschiedene (Wlan-)Netzwerke (4)

Frage von mraudi zum Thema Windows Netzwerk ...

Debian
Debian 8.6 Absichern? (11)

Frage von Motte990 zum Thema Debian ...

Virtualisierung
gelöst Interne Netzwerke untereinander kommunizieren lassen (9)

Frage von chelewae zum Thema Virtualisierung ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (22)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...