Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Debian 3.1 rev.1

Frage Linux Debian

Mitglied: forgi

forgi (Level 1) - Jetzt verbinden

22.03.2006, aktualisiert 18.10.2012, 6494 Aufrufe, 24 Kommentare

Hi ich habe folgenes vor ich will bei debian ein raid1 machen aber habe davon nicht viel ahrnung da ich hier ihn den forum was gefunden hatte aber wie unten dann bei den beitregen standt das das nicht mehr funktioniert wollte ich fragen wie ich das jetzt machen soll.meine informationen: habe 2 sata platten auf der ersten ist debian 3.1 rev.1 drauf und er soll die immer wieder spiegeln von alleine also wenn ich dann mal eine andere festplatte rein baue das er die auch automatisch spiegelt so das ich ich jede woche einmal die fesplatte wechseln kann.damit ich immer ein alteren stand habe.
Mitglied: stpe
22.03.2006, aktualisiert 18.10.2012
Bitte benutz doch ein paar Kommata - dann noch ein paar Großbuchstaben und der Text wird einigermaßen lesbar

Zur Frage: Wenn es wirklich ein Raid sein soll, dann hast Du wohl das entsprechende Tutorial von ITWissen von heute morgen verpasst

http://www.administrator.de/wissen/software-raid1-%28mirror%29-mit-debi ...

Wenn Du allerdings einen manuellen Snapshot von Deiner Platte ziehen möchtest, kannst Du das auch mit dd oder partimage.

Gruss
Stefan
Bitte warten ..
Mitglied: forgi
22.03.2006 um 16:37 Uhr
Da gibt es nur ein problem. Ich muss jedesmal, wenn ich die platten tauschen will.
Muß ich einen neuen bootloader installieren und das will ich nicht.
Bitte warten ..
Mitglied: stpe
22.03.2006 um 17:23 Uhr
Sowohl beim Spiegeln als auch mit "dd" wird der bootloader auch auf der BackupPlatte entsprechend gesetzt. Und wenn dies nicht der Fall sein sollte und Du von der Backup-Platte booten musst, dann boote von einer Linux-CD (z.B. Knoppix), mounte die Root-Partition, mache einen chroot auf den Mountpoint und abschließend ein "lilo". Ein zusammenfassendes Beispiel:
<font class="code">mount /dev/sda1 /mnt/sda1
chroot /mnt/sda1
lilo
exit</font>
Spätestens dann ist der Bootloader auch auf der Backup-Platte wieder ok.

Gruss
Stefan
Bitte warten ..
Mitglied: ITwissen
22.03.2006 um 17:34 Uhr
Man koennte das Aufspielen des Bootloaders scripten und beim Wecheln der Platten automatisch ablaufen lassen oder auch einfach per cronjob. Da das Software RAID unter Linux nur Partitionen spiegelt und nicht die ganze Platte, sehe ich softwareseitig keine andere Moeglichkeit.

Alternative:
Du kaufst dir einen SATA Hardware Raid-Controller, mit einem Hotswap Rahmen.

Damit bist du auf der sichern Seite.

Vorschlaege:

Promise Fasttrack TX2200
Adaptec Serial ATA RAID 1210SA
DELOCK 70127
Bitte warten ..
Mitglied: ITwissen
22.03.2006 um 17:35 Uhr
Debian benutzt kein lilo.
Bitte warten ..
Mitglied: stpe
22.03.2006 um 17:39 Uhr
Debian benutzt kein lilo.
Ok - Standardmaessig nicht. Hatte gerade nicht daran gedacht, weil ich auf allen Debian-Installationen lilo installiere. Und bei Sarge sowieso. Aber mit grub ist's ja ähnlich einfach.

Gruss
Stefan
Bitte warten ..
Mitglied: forgi
24.03.2006 um 10:34 Uhr
Hi habe es so gemacht wie itwissen es gepostet hat.
Ich habe aber noch einen fehler wenn ich die root patition mit diesem befehl ausfuhren will (mdadm --add /dev/md1 /dev/sda1)

der fehler der kommt

md: trying to hot-add unknown-block(8.1) to md1 .....
md: could not look unknown-block (8.1).
md: error. md_import_device() returned -16
mdadm hot add failed for /dev/sda1: invalid argument
Bitte warten ..
Mitglied: stpe
24.03.2006 um 11:08 Uhr
  1. Hast Du die richtigen Devices verwendet?
  2. Welche Kernel-Version hast Du?
  3. Was sagt "cat /proc/mdstat"?
Bitte warten ..
Mitglied: forgi
24.03.2006 um 11:16 Uhr
Die devices habe ich richtig.
ich habe den kernel 2.6.8-2-386
da staht md1: active raid1 sdb1[1]
123456 blocks [2/1] [_u]

und das halt für die 3 md
ich habe einfach ein neustart probiert da ist der dann stehen geblieben.
habe dann knoppixs reingeschmissen und die menu.ist wieder verandert

dann ist er wieder hochgefahren aber wenn ich dann wieder cat /pro.... ausfüre
zeigt er mir nur die md2 und md3 an
Bitte warten ..
Mitglied: forgi
24.03.2006 um 12:51 Uhr
re habe noch ein problem festgestellt wenn ich neu starte dann muss ich den mdadm --add /dev/md1 /dev/sda1 immer wieder ausfuhren erst dann fangt er an die zu spiegen und stellt die gleich.
Bitte warten ..
Mitglied: ITwissen
24.03.2006 um 13:17 Uhr
Das hatte ich auch schon.

Bitte kontrolliere, ob das md1 in folgenden Dateien korrekt eingetragen ist.

/etc/mdadm/mdadm.conf
/boot/grub/menu.lst
/etc/fstab

Wenn es in einem nicht stimmt, bootet dein Rechner von /dev/sda1 statt von md1
Bitte warten ..
Mitglied: forgi
24.03.2006 um 13:23 Uhr
es war fast alles ihn ordnung nur die boot.ist war falsch weil ich sie geandert habe wenn ich das so mache wie du sagst fahrt er nicht hoch dann kommt folgende fehlermeldung kernel panic: attempted to kill init!
Bitte warten ..
Mitglied: ITwissen
24.03.2006 um 13:31 Uhr
Ist die auf /dev/md1 ueberhaupt schon das root filesystem?

Was passiert, wenn du sagt:

mount /dev/md1 /mnt
Bitte warten ..
Mitglied: forgi
24.03.2006 um 13:39 Uhr
wenn ich das mounte kommt das normale root verzeichniss ihn den mnt ordner

und ja ich habe die daten rüberkopiert
Bitte warten ..
Mitglied: ITwissen
24.03.2006 um 13:47 Uhr
Okay.

Im /etc/modules und /etc/mkinitrd/modules ist md und raid1 drin?

Normal ist es nicht notwendig, aber vielleicht aenderst du noch im /etc/mkinitrd/mkinitrd.conf die Zeile
01.
ROOT=probe
in
01.
ROOT=/dev/md1
Immer wenn du im /etc/mkinitrd etwas aenderst musst du ein neues initrd erstellen und die /boot/grub/menu.lst anpassen.
Bitte warten ..
Mitglied: forgi
24.03.2006 um 13:53 Uhr
habe es jetzt gemacht fahrt auch hoch aber die anderungen übernimmt er nach einen neustart nicht.
damit meine ich wenn du cat /pro.... aufuhrst sind die immer noch unterscheidlich
Bitte warten ..
Mitglied: ITwissen
24.03.2006 um 14:02 Uhr
Kannst du mir die Ausgabe von
01.
cat /proc/mdstat
zeigen.
Bitte warten ..
Mitglied: forgi
24.03.2006 um 14:09 Uhr
so sieht die ausgabe aus

md1 : active raid1 sdb1[1]
3068288 blocks [2/1] [U_]

md3 : active raid1 sdb3[2]
104320 blocks [2/1] [U_]

md2 : active raid1 sdb2(1)
1020032 blocks [2/1] [U_]

und so wenn ich den mdadm --add /dev/md1 /dev/sda1
für alle dre patitionen mache

md1 : active raid1 sda1[0] sdb1[1]
3068288 blocks [2/1] [U_]

md3 : active raid1 sda3[0] sdb3[1]
104320 blocks [2/2] [UU]

md2 : active raid1 sda2[0] sdb2[1]
1020032 blocks [2/2] [UU]
Bitte warten ..
Mitglied: ITwissen
24.03.2006 um 14:16 Uhr
Das sieht doch schon ganz gut aus.

Sind jetzt die md-Drives gemountet? Was sagt "mount" ?

Wenn ja, dann gehe ich davon aus, dass im /etc/mdadm/mdadm.conf noch die /dev/sda1, /dev/sda2 und /dev/sda3 nicht richtig eingetragen sind.
Bitte warten ..
Mitglied: forgi
24.03.2006 um 14:31 Uhr
mount
/dev/md1 on / type ext3 (.......)
proc on /proc....
sysfs on /dev/pts
tmpfs on /dev/shm
/dev/md3 on /var Type ext3 (rw)
Bitte warten ..
Mitglied: forgi
24.03.2006 um 15:27 Uhr
habe ich vieleicht was vergessen einzutragen oder wieso sind die patitionen nicht gleich immer wenn ich neu starte muss immer den mdadm --add /dev/md1 /dev/sda1
Bitte warten ..
Mitglied: ITwissen
24.03.2006 um 15:31 Uhr
Ja, die muessen im /etc/mdadm/mdadm.conf eingetragen werden. Im Tutorial ist ein Beispiel.
Bitte warten ..
Mitglied: forgi
24.03.2006 um 15:36 Uhr
die sind da eingetragen alle drei

Device partitions
Device /dev/sda3 /dev/sdb3
Device /dev/sda2 /dev/sdb2
Device /dev/sda1 /dev/sdb1
Array /dev/md3 level=raid1 num-devices=2 UUID=.......... devices=/dev/sdb3
Array /dev/md2 level=raid1 num-devices=2 UUID=.......... devices=/dev/sdb2
Array /dev/md1 level=raid1 num-devices=2 UUID=.......... devices=/dev/sdb1

ist das so flasch ?
Bitte warten ..
Mitglied: ITwissen
24.03.2006 um 15:40 Uhr
So muessten die Zeilen richtig heissen:

Array /dev/md3 level=raid1 num-devices=2 UUID=.......... devices=/dev/sda3,/dev/sdb3
Array /dev/md2 level=raid1 num-devices=2 UUID=.......... devices=/dev/sda2,/dev/sdb2
Array /dev/md1 level=raid1 num-devices=2 UUID=.......... devices=/dev/sda1,/dev/sdb1

Aber erst rebooten, nachdem du sie mit "mdadm --add ..." hinzugefuegt hast.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Debian
Debian 8.6 Absichern? (12)

Frage von Motte990 zum Thema Debian ...

Linux Netzwerk
VPN Server mit Drosselung Linux Debian basiert (4)

Frage von Niklas434 zum Thema Linux Netzwerk ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...