Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Debian 4.0 (Etch) startet nicht auf DL380 G1

Frage Linux Debian

Mitglied: Lousek

Lousek (Level 2) - Jetzt verbinden

07.07.2008, aktualisiert 11.07.2008, 6507 Aufrufe, 16 Kommentare

Hallo Forum.

Ich habe Probleme mit der Installation von Debian 4.0 (Etch) auf einem Compaq DL380 G1.

Hardwarekonfiguration:

4x 18.2GB SCSI über internen RAID-Controller
2.5 GB RAM
1x 1GHz
1x Nic onBoard, 2x Nic extra

Mit dem sollte Debian ja eigentlich keine Probleme haben .... von der Leistung etc.

Was ich gemacht habe:

Von der Compaq Smart Start 5.5 CD gebootet ... Vollständiger Löschvorgang dann Konfiguration durchlaufen lassen:
Gewähltes OS: Linux
RAID: 4x 18.2 GB RAID 5 --> ca. 50 GB ...

alles paletti

Debian 4.0 CD reingehauen ... davon gebootet (Standardinstallation, einfach ENTER im Menü), alles normal installiert (eine Systempartition, ca. 10 GB, home-Partition, ca. 40 GB) ... GRUB-Bootloader in den MBR schreiben lassen, alles läuft normal durch, Installation wird erfolgreich abgeschlossen. Also CD raus, reboot ...

--> Hier wo der GRUB-Bootloader geladen werden sollte blinkt nur einfach die ganze Zeit ein Strich (so ein _) ... habe es über eine halbe Stunde laufen gelassen ... er bootet einfach nicht.

An was könnte das liegen?

Greetz, Lousek
Mitglied: Suppi250
07.07.2008 um 10:23 Uhr
Habe bei mir den lilo-bootloader installiert, mit dem hats funktioniert.
Bitte warten ..
Mitglied: Lousek
07.07.2008 um 10:32 Uhr
Hallo Suppi250.

Wie hast du den installiert?

Greetz, Lousek
Bitte warten ..
Mitglied: Lousek
07.07.2008 um 10:46 Uhr
Habe es entdeckt, werde mal schauen ob es funktioniert.

Thx & Greetz, Lousek
Bitte warten ..
Mitglied: 16568
07.07.2008 um 12:09 Uhr
Ts ts ts... den Teufel mit dem Belzebub austreiben ^^

Schon mal mit einer kleinen Boot-Partition probiert?


Lonesome Walker
Bitte warten ..
Mitglied: Lousek
07.07.2008 um 12:10 Uhr
Hmm, wenn ich im Debian-Installations-Prozedere beim Installieren vom GRUB-Bootloader bin (jedoch dann auf den LILO-Bootloader installieren) klicke, kommt:
eine Fehlermeldung (Fehler: Installieren von LILO-Bootloader) o.ä. ... muss ich für diesen Bootloader irgendetwas spezielels beachten?

Greetz, Lousek

Edit: Fehlermeldung lautet: "Ein Teil der Installation ist fehlgeschlagen. Sie können versuchendiesen Schritt aus dem Menü aufzurufen oder ihn überspringen und einen anderen wählen. Fehlgeschlagen: LILO-Bootloader auf einer Festplatte installieren"
Bitte warten ..
Mitglied: Lousek
07.07.2008 um 12:17 Uhr
@Lonesome Walker:

WIe meinst du das? Must das für einen Anfänger erklären ;)
Bitte warten ..
Mitglied: 16568
07.07.2008 um 12:35 Uhr
Also....

Normalerweise sollte man das RAID von Debian verwalten lassen.
Der Performance-Unterschied ist erst bei wirklich grossen Systemen merkbar.

Bei der Installation wird man von debconf gefragt, wie die Partitionierung aussehen soll.
Und da gibt man halt alles manuell an, sprich, man legt auch eine kleine Boot-Partition an (200 MB sollten okay sein), und weist dieser dann /boot zu.

Sowas sollte aber eigentlich nicht nötig sein...

Kann es evtl. sein, daß irgendetwas anderes den Boot-Vorgang gestört hat?
CD im Laufwerk, Floppy, RAID-Controller Netzwerk-Boot, etc...


Lonesome Walker
Bitte warten ..
Mitglied: Lousek
07.07.2008 um 13:03 Uhr
Hmm, meinst du mit "Normalerweise sollte man das RAID von Debian verwalten lassen." das Debian eigentlich ein Software-RAID daraus macht ??? Das wäre doch bei einem Hardware-Raid inkl. 64 MB Cache nicht wirklich schneller ...

Floppy war keine eingelegt, CD auch nicht (sonst hätte er von dieser gebootet), Netzwerk-Boot auch nicht ... wenn aber gar kein OS installiert wäre würde Operation System not found o.ä. gekommen ...

Mit W2K kann dieser ganz normal starten ...

Was bringt die seperate Boot-Partition aber?

Lousek
Bitte warten ..
Mitglied: 16568
07.07.2008 um 13:38 Uhr
Das wäre doch bei einem Hardware-Raid inkl. 64 MB Cache nicht wirklich schneller ...

Das Software-RAID ist im Vergleich zum Hardware-RAID etwas langsamer.
Aus div. Gründen (praktische Erfahrung) ist es manchmal aber störungsärmer zu verwalten...

Die separate /boot-Partition ist normalerweise nur im Falle eines GRUB Error 18 nötig, d.h. das BIOS kann mit der HD-Größe nichts anfangen (zu groß), und GRUB kann dann den Kernel nicht laden.

Mit einer extra Boot-Partition wird dieses Dilemma umgangen, da der/die Kernel auf dieser Partition abgelegt werden.


Eine weitere Alternative hierzu wäre auch die Super GRUB Disk, d.h. eine Boot-CD mit GRUB.

Lade Dir mal das aktuelle Image, und versuche, von CD direkt Debian zu booten, also ohne Reparatur oder so.

Erfahrung damit bitte im Anschluß posten


Lonesome Walker
Bitte warten ..
Mitglied: Lousek
07.07.2008 um 15:43 Uhr
Hallo.

Von der Super-GRUB-Disk bootet er ohne Probleme ...
Wenn ich über die GRUB-Disk sage er solle Linux auf hda (1. Festplatte) starten ... kommt der eigentliche GRUB-Bootloader der auf der HD ist. Wenn ich da wie default Debian auswähle ... kommt Error 15: File not found ...

Greetz, Lousek
Bitte warten ..
Mitglied: 16568
07.07.2008 um 15:58 Uhr
Hm:

15 : File not found
This error is returned if the specified file name cannot be found,
but everything else (like the disk/partition info) is OK.

Soll heißen, Deine menu.lst enthält einen falschen Eintrag.

Hast PN.


Lonesome Walker
Bitte warten ..
Mitglied: Lousek
07.07.2008 um 16:07 Uhr
MUSSS MEEEHHR ALLLSSS 30 ZZZEEEIIICCCHHEEENN EEENNNTTTHHAALLTTTEEENNN


PN? Demfall nicht :P

Edit: Ratere das Ganze jetzt mal mit einer /boot-Partition durch ...
Bitte warten ..
Mitglied: Lousek
07.07.2008 um 20:55 Uhr
Hat nichts gebracht ...

Entweder es kommt Error 15: File not found oder Error 22: Such no Partition o.ä. ...

Werde mal diese hier kontaktieren ...http://software.rde.de/linux-debian-10.0.html

Die installieren auch auf DL380 G1 Debian ... und sagen nichts von einem anderen Bootloader ...

Greetz, Lousek
Bitte warten ..
Mitglied: Lousek
10.07.2008 um 13:30 Uhr
Hallo.

Bekomme immer noch einen Fehler, allerdings einen anderen:
"Error 17"

Habe einen extra RAID-Controller eingebaut (Compaq Array Controller 3200, Firmware v4.5), das ganze System mit der SmartStart-CD 5.5 gelöscht und nochmals neu konfiguriert (OS: Linux, 4 SCSI-Platten --> RAID 5 ca. 54 GB) ... Debian 4.0 r3 Netinstall-CD rein, alles durchlaufen gelassen (ohne Fehler o.ä.), reboot, ... Error
Mit der Super-Grub-Disk kann ich Debian problemlos booten (auser das die Grafikkarte nicht unterstütz wird:P habe zum testen mal den X-Server auch installiert .... beim 2. Versuch habe ich ihn weggelassen wie es sich auf einem Server gehört ;) )

WIe kann ich den Error 17 beheben?

Greetz, Lousek

P.S. Ich habe den GRUB in den MBR geschrieben ... ist das vieleicht das Problem: http://board.raidrush.ws/archive/t-26227.html ?
Bitte warten ..
Mitglied: 16568
10.07.2008 um 18:15 Uhr
Wenn Du das Debian-Setup durchläufst, frägt er Dich ja, ob Du in den MBR schreiben willst, oder nicht.

Dein Problem ist ganz einfacher Natur:

17 : Cannot mount selected partition
This error is returned if the partition requested exists, but the filesystem type cannot be recognized by GRUB.

Bedeutet auf gut deutsch, GRUB findet den Kernel nicht, aber er findet schon ma ein Dateisystem.
Wird dann wahrscheinlich die SWAP sein, sofern Du nicht eine Windows-Paralell-Installation laufen hast.

Mußt Du mit der Super-Grub die menu.lst ändern.


Lonesome Walker
Bitte warten ..
Mitglied: Lousek
11.07.2008 um 15:16 Uhr
Sali.

Habe die Installation nochmals durchlaufen lassen (gleich wie vorher) ... und siehe da ... es funktioniert ...
Leider habe ich jetzt meine nächste Probleme mit der XEN-Installation ... aber Debian funktioniert jetzt.

THX an alle.

Lousek

Thread geschlossen.
Bitte warten ..
Ähnliche Inhalte
Server-Hardware
HP DL380 G7 - Startet nicht - Bootschleife
gelöst Frage von tweety2007Server-Hardware3 Kommentare

Guten Abend Zusammen, kurz vor dem Wochenende habe ich ein Serverausfall zu beklagen und finde leider keine Lösung. Nach ...

CPU, RAM, Mainboards
Passende CPU für DL380 G7
gelöst Frage von Luke74CPU, RAM, Mainboards4 Kommentare

Hallo Zusammen, ich habe mir folgende DL380 G7 gekauft: DL380 G7 Da ich jetzt allerdings bessere CPUs einbauen wollte, ...

Server-Hardware
HP DL380 G6 server
Frage von hoecedServer-Hardware24 Kommentare

Hallo Ich möchte mir zuhause ein server bauen dieser doll im kelker in einem serverschtank es soll ein linuxserver ...

Notebook & Zubehör
Dokkingstation oder Port Replicator für Hp ProBook 450 G1
Frage von GarnalothNotebook & Zubehör1 Kommentar

Hallo liebe Kollegen, ich habe hier ein aktuelles HP ProBook 450 G1. Core I7 8GB RAM Intel HD Graphics ...

Neue Wissensbeiträge
Microsoft Office

Office 2010 Starter erneut auf einer frischen Windows-Version installieren

Tipp von Lochkartenstanzer vor 20 StundenMicrosoft Office8 Kommentare

Moin, vor ein paar Tagen schlug bei mir ein Kunde auf, der sein Widnows 7 geschrottet und es inklusive ...

Datenbanken

Upgrade MongoDB 3.4 auf 3.6

Erfahrungsbericht von Frank vor 22 StundenDatenbanken

Seit kurzem gibt es das 3.6 Update für die MongoDB: Sicherheit, das Sortieren, Aggregation und auch die Performance wurde ...

SAN, NAS, DAS

Backdoor Zugang und Upload-Bug in vielen Western Digital MyCloud Geräten

Information von Frank vor 23 StundenSAN, NAS, DAS2 Kommentare

James Bercegay von der Firma Gulftech hat die Fehler an Western Digital gemeldet und das Unternehmen stellt bereits ein ...

Microsoft Office

Outlook 2016 - Beim Weiterleiten keine PDF Anhänge mehr - KB4011626 entfernen

Erfahrungsbericht von Deepsys vor 1 TagMicrosoft Office3 Kommentare

Wenn ihr feststellt das ihr beim Weiterleiten von E-Mails keine PDF Anhänge mehr versendent, dann dankt Microsoft. Diese tolle ...

Heiß diskutierte Inhalte
Netzwerke
NTFS-Berechtigung
Frage von Daoudi1973Netzwerke23 Kommentare

Hallo zusammen und frohes neues Jahr (Sorry, ich bin spät dran) Meine Frage: 1- Ich habe einen Ordner im ...

iOS
Einladung vom iphone kalender
Frage von jensgebkeniOS15 Kommentare

Hallo Gemeinschaft, folgendes Problem - immer wenn ich von meinem Iphone einen Termin einztrage und diesem Termin Teilnehmer zuweise, ...

Drucker und Scanner
Gesucht DIN A3 Drucker
Frage von NebellichtDrucker und Scanner14 Kommentare

Hallo, ich möchte einen neuen DIN A3 Drucker kaufen. Um ab und zu, ca. 1 mal die Woche Farbausdrucke ...

Windows Netzwerk
Drucker isolieren in Windows Domäne
gelöst Frage von lcer00Windows Netzwerk14 Kommentare

Hallo zusammen, habe eine Windows-AD (2012R2) in der es einen Druckerserver gibt. Mittlerweile verliere ich das Vertrauen in die ...