Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Debian 6 - Xen - rtc und mount Probleme

Frage Linux Debian

Mitglied: sxxt60

sxxt60 (Level 1) - Jetzt verbinden

08.06.2011, aktualisiert 10:06 Uhr, 5110 Aufrufe, 1 Kommentar

Hallo zusammen,

ich bitte vorab um sanfte Behandlung, da ich in der Unix Welt nicht mehr als Grundkentnisse besitze
und mich dort erst langsam einarbeite. Vielen Dank

Zu meiner bestehenden Hardware:
Server Hetzner EQ4
Intel Core I7 CPU
8GB DDR3 RAM
750GB Software RAID 1
OS Debian Squeeze, ohne LVM

Nun zu meiner Frage..
Ich möchte auf einem Hetzner EQ4 Webserver unter Debian Squeeze Xen als Virtualisierunglösung einsetzen.
Hierzu gibt es von Hetzner auch ein HowTo unter http://wiki.hetzner.de/index.php/Xen_auf_einem_EQ_4_mit_Debian_Squeeze_ ...

Zusätzlich zum HowTo setze ich in /etc/defaults/grub den Wert GRUB_CMDLINE_LINUX_DEFAULT auf "acpi=off"
Dies hat den Hintergrund, dass die Hetzner Server wohl einen ACPI Bug haben und ohne das abschalten nach einem Reboot nicht mehr hochfahren.

Generell habe ich mich beim einrichten weitestgehend an das Tutorial gehalten, ich verwende ein image basiertes System.

Das einrichten der DomU mit mkdir /xen
xen-create-image --hostname=xen1 --size=24Gb --swap=512b --ide \
--ip=xxx.xxx.xxx.xxx --netmask=255.255.255.240 --gateway=xxx.xxx.xxx.xxx \
--memory=512Mb \ --debootstrap --dist=squeeze \ --mirror=http://ftp2.de.debian.org/debian/ --passwd --role=udev

sowie das starten der DomU per xm create /etc/xen/xen1.cfg funktioniert problemlos.

Beim einloggen auf die Console (xm console xen1) stoße ich dann aber auf mehrere Probleme.

root@server2 ~ # xm console xen1
...
[ 0.180797] /build/buildd-linux-2.6_2.6.32-31-amd64-vrfdM4/linux-2.6-2.6.32/debian/build/source_amd64_none/drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
Dies ist nach meinen Kentnissen ein Problem mit dem Kernel. Kann damit ein Problem zusammenhängen, dass der Server nach einem reboot reproduzierbar nicht mehr hochfährt?

...

Der Vollständigkeit halber

Begin: Loading essential drivers ... [ 0.461111] SCSI subsystem initialized
[ 0.497830] md: raid0 personality registered for level 0
[ 0.501196] md: raid1 personality registered for level 1
[ 0.503497] async_tx: api initialized (async)
[ 0.504095] xor: automatically using best checksumming function: generic_sse
[ 0.524005] generic_sse: 3479.000 MB/sec
[ 0.524009] xor: using function: generic_sse (3479.000 MB/sec)
[ 0.592015] raid6: int64x1 3137 MB/s
[ 0.660007] raid6: int64x2 3928 MB/s
[ 0.728019] raid6: int64x4 2913 MB/s
[ 0.796005] raid6: int64x8 2717 MB/s
[ 0.864009] raid6: sse2x1 7389 MB/s
[ 0.932010] raid6: sse2x2 8617 MB/s
[ 1.000012] raid6: sse2x4 9612 MB/s
[ 1.000017] raid6: using algorithm sse2x4 (9612 MB/s)
[ 1.004487] md: raid6 personality registered for level 6
[ 1.004492] md: raid5 personality registered for level 5
[ 1.004495] md: raid4 personality registered for level 4
[ 1.009772] md: raid10 personality registered for level 10
[ 1.012401] 3ware Storage Controller device driver for Linux v1.26.02.002.
[ 1.015300] 3ware 9000 Storage Controller device driver for Linux v2.26.02.012.
[ 1.018661] Adaptec aacraid driver 1.1-5[2461]-ms

...

Begin: Running /scripts/init-premount ... done.
Begin: Mounting root file system ... Begin: Running /scripts/local-top ... Begin: LoadingSuccess: loaded module raid1.
done.
Begin: Assembling all MD arrays ... Failure: failed to assemble all arrays.
done.
[ 1.042484] device-mapper: uevent: version 1.0.3
[ 1.042857] device-mapper: ioctl: 4.15.0-ioctl (2009-04-01) initialised: dm-devel@redhat.com
done.
Begin: Waiting for root file system ... done.
Gave up waiting for root device. Common problems:
- Boot args (cat /proc/cmdline)
- Check rootdelay= (did the system wait long enough?)
- Check root= (did the system wait for the right device?)
- Missing modules (cat /proc/modules; ls /dev)
ALERT! /dev/hda2 does not exist. Dropping to a shell!


Hier liegt mein Problem. Ich habe schon Stunden mit googlen verbracht, habe aber einfach keine für meinen Ansatz funktionierende Lösung gefunden.
Vielleicht weiß von euch jemand weiter? Warum kann die hda2 nicht gemountet werden?

Vielen Dank schonmal für eure Bemühungen!

Grüße,
Florian
Mitglied: H41mSh1C0R
08.06.2011 um 10:46 Uhr
Was soll denn hda2 sein?

Wieso ein SW Raid?

Wie immer:

RootServer im Netz-->UNIX Grundkenntnisse-->FAIL

Gerade zum rumspielen gibt es doch genügend Möglichkeiten auf dem eigenen Rechner zu virtualisieren und zu lernen.

vg
Bitte warten ..
Ähnliche Inhalte
Apache Server
Apache probleme nach update von php 5.3 Debian 6
gelöst Frage von cc-frauensteinApache Server10 Kommentare

Guten tag ich habe ei problem nach update von php 5.3 eines Debian 6 hier mal die Apache error. ...

Debian
Debian FTP-Mount mit curlftpfs in fstab wird mehrmals gemountet?
gelöst Frage von wireless-teamDebian7 Kommentare

Hallo, wie im Titel schon beschrieben mounte ich einen FTP-Server über die fstab mit curlftpfs. Die Zugriffsrechte passen alle ...

Debian
Debian Eine Zusätzliche HDD an bestehenden Mount Point
gelöst Frage von Netgear24Debian1 Kommentar

Hallo Zusammen Stehe wiedereinmal vor einem Problem. Habe bei uns ein Redmine auf einem Supermicro Server Installiert. Dieses wird ...

Windows Netzwerk
Probleme mit Netzlaufwerken mounten nicht mehr möglich
Frage von winlinWindows Netzwerk1 Kommentar

Hallo Kollegen, ich habe folgendes Problem. Ich habe das Problem das mein mapping skript nicht mehr mein LW mountet ...

Neue Wissensbeiträge
Linux

Limux-Ende in München: Wie ein Linux Projekt unter Ausschluss der Öffentlichkeit zerstört wurde

Information von Frank vor 7 StundenLinux12 Kommentare

Mein persönlicher Kommentar zum Thema "Limux-Ende". Die SPD-Politikerin Anne Hübner hat die Richtung von München ganz klar definiert: "Wir ...

Batch & Shell

Open Object Rexx: Eine mittlerweile fast vergessene Skriptsprache aus dem Mainframebereich

Information von Penny.Cilin vor 1 TagBatch & Shell9 Kommentare

Ich kann mich noch sehr gut an diese Skriptsprache erinnern und nutze diese auch heute ab und an noch. ...

Humor (lol)

"gimme gimme gimme": Automatischer Test stolpert über Easter Egg im man-Tool

Information von Penny.Cilin vor 1 TagHumor (lol)6 Kommentare

Interessant, was man so alles als Easter Egg implementiert. Ist schon wieder Ostern? "gimme gimme gimme": Automatischer Test stolpert ...

MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Anleitung von colinardo vor 2 TagenMikroTik RouterOS8 Kommentare

Einleitung Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal ...

Heiß diskutierte Inhalte
Router & Routing
Zwei Netzwerke erstellen
Frage von bunteblumeRouter & Routing14 Kommentare

Hallo Zusammen, Ich möchte gerne ein backup von einem bestimmten Folder welcher auf dem Server regelmässig synchronisiert wird auf ...

Windows 10
Alle Programme mit bestimmtem Namen automatisch (per GPO) deinstallieren
gelöst Frage von lordofremixesWindows 1012 Kommentare

Hallo zusammen, gibt es eine Möglichkeit, alle Programme beginnend mit z.B. "Dell" im Namen per Script und somit per ...

Off Topic
Fachkräftemangel in Deutschland? - Talentschmiede schreibt alle 2 Tage die gleichen Stellen aus
Frage von Penny.CilinOff Topic12 Kommentare

Hallo, haben wir in Deutschland Fachkräftemangel? Die Talentschmiede schreibt gefühlt alle zwei Tage dieselben Stellen aus. Und das schon ...

Linux
Limux-Ende in München: Wie ein Linux Projekt unter Ausschluss der Öffentlichkeit zerstört wurde
Information von FrankLinux12 Kommentare

Mein persönlicher Kommentar zum Thema "Limux-Ende". Die SPD-Politikerin Anne Hübner hat die Richtung von München ganz klar definiert: "Wir ...