Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Debian 7.4 stable, Ifconfig wird nicht ohne root und pfad ausgeführt

Frage Linux Debian

Mitglied: alaim89

alaim89 (Level 1) - Jetzt verbinden

08.03.2014, aktualisiert 16.03.2014, 1648 Aufrufe, 6 Kommentare

Hallo liebe Gemeinde,

ich habe heute auf meinem Client die Debian 7.4 stable Version aufgesetzt.
Mir ist aufgefallen nachdem ich mal schauen wollte welche IP-Adresse mir zugewiesen worden ist,
das ifconfig nicht "einfach" ausführbar ist als standard user.
Es kommt die Meldung:
bash: ifconfig: Kommando nicht gefunden.

Kommt mir komisch vor. Denn ich habe unter /sbin/ geschaut und dort ist ifconfig aufgeführt.

Dann habe ich diesen Befehl nochmals mit sudo ifconfig gestartet und tatsächlich hat dieser funktioniert und mir die Auswertung ausgegeben.

Anschließend habe ich mir gedacht, das kann doch nicht wahr sein.
Zur zwischeninfo vllt nochmal, mein Konto habe ich zuvor dem sudoers hinzugefügt gehabt.

Blitzschnell kam mir die Idee mal einfach /sbin/ifconfig ohne sudo auszuführen. Das hat tatsächlich geklappt.

Ich versteh nicht wieso ich den Pfad unbedingt mit angeben muss, um ifconfig auszuführen
Vielleicht hat da jemand eine Antwort für mich parat. Denn ich habe auch schon im Handbuch nachgeschaut aber ich kann mir das irgendwie nicht zusammen reimen.

Mit besten Grüßen


alaim89
Mitglied: Lochkartenstanzer
LÖSUNG 08.03.2014, aktualisiert 16.03.2014
Zitat von alaim89:

Ich versteh nicht wieso ich den Pfad unbedingt mit angeben muss, um ifconfig auszuführen
Vielleicht hat da jemand eine Antwort für mich parat. Denn ich habe auch schon im Handbuch nachgeschaut aber ich kann mir das
irgendwie nicht zusammen reimen.

Weil der Pfad sbin nicht im Standardpfad der User ist und auch nicht sein sollte, damit die nicht auf dumme Ideen kommen. Der ist für den sysadmin gedacht.

Und wenn man /sbin im Pfad haben will, trägt man den halt in .login oder .bashrc mit ein.

lks
Bitte warten ..
Mitglied: Lochkartenstanzer
11.03.2014, aktualisiert um 18:00 Uhr
Und? Problem gelöst?

lks
Bitte warten ..
Mitglied: alaim89
13.03.2014 um 22:11 Uhr
Hi LKS,
ich bin da noch nicht so wirklich hintergekommen. Den Ansatz den du mir gegeben hast scheint aber mit Sicherheit schon mal richtig zu sein.
Momentan habe ich das System nicht in Reichweite und werde es übers Wochenende nochmal angehen. Ich werder auf jeden fall bescheid geben.


Gruß

alaim89
Bitte warten ..
Mitglied: Lochkartenstanzer
14.03.2014, aktualisiert 16.03.2014
Zitat von alaim89:

Hi LKS,
ich bin da noch nicht so wirklich hintergekommen. Den Ansatz den du mir gegeben hast scheint aber mit Sicherheit schon mal richtig
zu sein.
Momentan habe ich das System nicht in Reichweite und werde es übers Wochenende nochmal angehen. Ich werder auf jeden fall
bescheid geben.


Wie gesagt, kannst Du das entweder beim User oder generell ins System einbinden. Du kannst das natürlich auch einfach dadurch machen, daß Du in /bin einen symblischen Link zu /sbin/ifconfig anlegst.

lks
Bitte warten ..
Mitglied: alaim89
16.03.2014 um 15:01 Uhr
HI LKS,

nachdem ich mir dein Link nochmals genauer durchgearbeitet habe, hat sich das folgende Problem, das ich besaß nun erledigt.
Es wurden die angeforderten Ausführungen einfach nach /bin verschoebn und voila, es hatte funktioniert.



Gruß


alaim89
Bitte warten ..
Mitglied: Lochkartenstanzer
16.03.2014 um 15:30 Uhr
Zitat von alaim89:

Es wurden die angeforderten Ausführungen einfach nach /bin verschoebn und voila, es hatte funktioniert.

Verschieben ist das Falsche, weil Du spätestens beim nächsten Update probleme bekommst (z.B. mehrere Versionen desselben Programms). Sinnvoller wäre es entweder die PATH-Variable in /etc/environment zu erweitern oder symbolische Link von /bin/ nach /sbin anzulegen.

lks
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Nach bestimmten Ordner namen suchen und in einem anderem Pfad kopieren (8)

Frage von erdgnrft zum Thema Batch & Shell ...

Debian
IPv6 Firewalling unter Debian 8 (5)

Frage von agowa338 zum Thema Debian ...

Debian
Keine Verbindung zwischen zwei Debian Maschinen (2)

Frage von Philippe27 zum Thema Debian ...

Heiß diskutierte Inhalte
Verschlüsselung & Zertifikate
gelöst Festplattenverschlüsselung im Ausland (13)

Frage von Nicolaas zum Thema Verschlüsselung & Zertifikate ...

Windows Server
gelöst Microsoft-Lizenz CALs und passendes Server-Betriebssystem (13)

Frage von planetIT2016 zum Thema Windows Server ...

Batch & Shell
HTML in Batch und Powershell (12)

Frage von michi-ffm zum Thema Batch & Shell ...

Festplatten, SSD, Raid
gelöst Fehlerhafte Blöcke im RAID 10 (12)

Frage von Kojak-LE zum Thema Festplatten, SSD, Raid ...