Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Debian auf andere Hardware übertragen

Frage Linux Debian

Mitglied: hitazcl

hitazcl (Level 1) - Jetzt verbinden

04.02.2009, aktualisiert 11:49 Uhr, 9237 Aufrufe, 16 Kommentare

Installiertes Debian OS vom Desktop PC auf ein IBM xSeries 3250 M2 System übertragen und wieder lauffähig machen

Hallo Leute,

heute stehe ich vor der großen Aufgabe, mein installiertes Debian OS von einem Desktop PC auf ein IBM xSeries 3250 M2 zu übertragen. Der Rackserver läuft im Raid-1.
Ich habe ein HDD Klon in Acronis True Image Echo Server angestoßen...

Nach dem erfolgreichen Kopieren der Festplatte, lässt sich der Server starten. Es kommt der Grub Boot Loader hoch, der Boot läuft an, aber ich vermute, dass die Partitionen nicht richtig erkannt werden. Irgend wie ist er jetzt von "/dev/hda" auf "/dev/sda" umgestiegen.

Kann mir jemand einen guten Link zu der Lösung dieses Problems helfen und mir vielleicht noch sagen, was ich noch beachten kann!?

Vielen Dank vorab.

Gruß
[hitazcl]
Mitglied: godlie
04.02.2009 um 12:00 Uhr
Tja das wird witzig

Rescue CD rein, fstab umscrheiben, grub umschreiben, grub neu installieren dann sollte die kiste wieder hochkommen.

Die Umstellung von hda auf sda kann 2 Gründe haben, entweder verwendet das neue System SATA oder SAS.
Das alte system dürfte noch "IDE" gewesen sein oder doich schon SATA und der Controller war in einem schwindligem Modus oder whatever.
Bitte warten ..
Mitglied: hitazcl
04.02.2009 um 12:15 Uhr
Ok, ich habe schon die Installations CD eingeschmissen und auf "rescue" gestartet.

In dem Modus komme ich bis zu dem Fenster mit "shell auf /dev... ausführen", "Bootloader neuinstallieren" etc.

Mal ganz blöd gefragt, die fstab bearbeite ich wie - also unter welchem Modus?
Bitte warten ..
Mitglied: ITwissen
04.02.2009 um 12:32 Uhr
Mit udev bekommst du noch ein kleines Problem mit den UUIDs der Platten. Selbst innerhalb eines Rechners die Platte wechseln hat mich ein paar Stunden gekostet. Leider hab ich mir die Schritte nicht notiert.

UUID

Am besten bootest du eine Knoppix, statt des Rescue Systems. Fuer das gibt es sowieso kein Klick-Klick Gui, sondern nur die Kommandozeile mit einem Dateieditor (z.B. vi)
Bitte warten ..
Mitglied: hitazcl
04.02.2009 um 13:18 Uhr
Ich habe die fstab jetzt abgeändert.

Beim Boot bleibt er trotzdem immer auf
Begin: Mounting root file system... ...
Done.
Begin: Waiting for root file system... ...
Done.
Check root= bootarg cat /proc/cmdline
or missing modules
...
ALERT! /dev/hda1 does not exist. Dropping to shell!

Das steht dann da...
Bitte warten ..
Mitglied: godlie
04.02.2009 um 13:35 Uhr
check root= bootarg <-- das würd für mich heisen das das root device im grub oder so noch net stimmt.
oder evlt. im boot irgendwo noch ein hda versteckt ist.

was hast du alles für dateien geändert?
Bitte warten ..
Mitglied: hitazcl
04.02.2009 um 13:46 Uhr
Ausschließlich die "fstab".
Danach muss doch auch noch mal der grub neu geschrieben werden oder nicht?!
Bitte warten ..
Mitglied: godlie
04.02.2009 um 13:51 Uhr
Ja du musst den grub neu einrichten auf dem System, als auch die menu.lst editieren und anpassen.......
Bitte warten ..
Mitglied: hitazcl
04.02.2009 um 14:15 Uhr
Ich befinde mich jetzt unter "Knoppicillin 7 - Diagnostic Mode"...
Dort habe ich mir /dev/sda1 auf /rootNew gemounted.
Kann da auch reinschauen...
...aber irgend wie ist keine menu.lst darin!?!
unter /boot befindet sich nicht einmal der Ordner grub!
Bitte warten ..
Mitglied: ITwissen
04.02.2009 um 14:31 Uhr
Debian installiert /boot auf eine eigene Partition. Die musst du zuerst mounten.
Bitte warten ..
Mitglied: hitazcl
04.02.2009 um 14:43 Uhr
Hab's jetzt irgendwie gefunden. Entschuldige.
Werde mich mal an das File ranwagen...

Da steht tatsächlich noch /dev/hda1 drin!

Habe mal /dev/hda1 auf /dev/sda1 geändert - hoffe das reicht?!
Bitte warten ..
Mitglied: godlie
04.02.2009 um 14:49 Uhr
Nein das wird nicht reichen du musst den grub noch neu installieren auf dem MBR oder so.
Howtos gibs im netz.
Bitte warten ..
Mitglied: ITwissen
04.02.2009 um 14:55 Uhr
Wenn er Glueck hat, hat das Acronis den MBR richtig geschrieben.
Bitte warten ..
Mitglied: hitazcl
04.02.2009 um 15:00 Uhr
Hat geklappt!!!

Prima. Euch tausend Dank!

Mein Debian läuft wieder...

Habe ich nun die Möglichkeit, die Hardware neu erkennen zu lassen?!
(z.B. Damit eth0 auch die neue Netzwerkkarte ist und der Chipsatz erkannt wird...)
Bitte warten ..
Mitglied: godlie
04.02.2009 um 15:02 Uhr
Sicherlich hast du die Möglichkeit, nennt sich Kernel neu kompilieren
Was ich dir auch schwer empfehle....
kennst du das Debiananwenderhandbuch schon?
Bitte warten ..
Mitglied: hitazcl
04.02.2009 um 16:32 Uhr
Ja, danke, mir ist das Handbuch bekannt.

Habe da heute nur noch nicht reingeschaut, ist aber total klasse die Page!
Bitte warten ..
Mitglied: ITwissen
04.02.2009 um 17:20 Uhr
loesche mal:

/etc/udev/rules.d/z25-persistent-net.rules

Anschliessend rebooten und dann ist deine Netzwerkkarte wieder eth0 (sofern sie vom Kernel erkannt wird).

Mit "lspci" bekommst du eine Liste aller Geraete, die am PCI bus haengen (u.a. Netzwerk).
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Windows Server
gelöst Windows Server 2012 R2 Lizenz auf neue Hardware übertragen (12)

Frage von JohnDorian zum Thema Windows Server ...

Server-Hardware
gelöst Hilfe bei einer Server (Hardware) auswahl (30)

Frage von bjk190368 zum Thema Server-Hardware ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...