Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Debian und Apache problem

Frage Linux Apache Server

Mitglied: nitramf

nitramf (Level 1) - Jetzt verbinden

16.08.2007, aktualisiert 10:47 Uhr, 4476 Aufrufe, 3 Kommentare

Hallo,

ich habe in einem Hotel einen Server laufen, auf dem Debian installiert ist. Auf diesem Server ist Apache installiert. Der Server ist für ein Hotspot Login Script gedacht. Dieses Script benutzt eine .htaccess, welche aber komischerweise nur im SSL Modus funktioniert. An was liegt das? Falsche Config?

Und der 2. Fehler:
Sobald im Browser (Internet Explorer 7) der SSL Modus anspringt, kommt ein Zertifikatsfehler. An was kann das liegen?

Ich hoffe ihr könnt mir helfen

Gruß,
nitramf
Mitglied: baumpaul
16.08.2007 um 10:09 Uhr
1.
Sowas wie das da sollte im virtual host stehen, damit die abfrage mit .htaccess funktioniert.

<Directory /var/www>
AllowOverride Options FileInfo Authconfig
Order allow,deny
Allow from all
</Directory>

Das musst du also in die default site noch eintragen. (War bei mir auch nicht drin)

2.
Zertifkatsfehler mit ".... das Zertifikat gehöhrt ..... und nicht... " ?
Hier musst du beim erstellen der Server-Zertifikate unter common name nicht den
tatsächlichen, physikalischen Rechnernamen benutzen, sondern den Namen des Virtual Host,
also den, den du mit http://<rechner>.<domain>.<ext> rufst.

Greetz
Bitte warten ..
Mitglied: nitramf
16.08.2007 um 10:16 Uhr
Hallo,

es gibt auf dem Server keinen Virtuellen Host.

Der .htaccess Quellcode ist schon vorhanden.

htaccess geht ja, aber NICHT im SSL!

Gruß,
Martin
Bitte warten ..
Mitglied: baumpaul
16.08.2007 um 10:47 Uhr
.... Dieses Script benutzt eine .htaccess, welche aber komischerweise nur im SSL Modus funktioniert.

...htaccess geht ja, aber NICHT im SSL!

????? Ok ich bin heute noch nicht all zu lange wach, aber ist da nicht ein Widerspruch ?

Gut nun nochmal zur Geschichte mit den Virtual-Hosts.
Die Sites sind ja in Debian hier definiert, oder ?
/etc/apache2/sites-available/
In der default steht nicht sowas wie <VirtualHost _default_:*> ?
Leider habe ich die default Debian-files nicht mehr, weil ich meine Sites von
Debian zu Debian immer mit umziehe und entsprechend der Aufgaben erweitere.
Weiter habe ich die Virtual-Hosts getrennt in <VirtualHost _default_:80> und <VirtualHost _default_:443>

Ich habe letztens für eine Schulung Testseiten mit .htaccess für mit und ohne SSL auf einem Debian etch gemacht
und da funtzt es (visit https://baumpaul.homelinux.net:443)
Name netzwerker, PW netz!Werker
Wenn du willst kann ich dir ja meine configs schicken.
Bitte warten ..
Ähnliche Inhalte
Apache Server
gelöst Apache 2 Debian Zertifikat von GeoTrust installieren (3)

Frage von zeroblue2005 zum Thema Apache Server ...

Ubuntu
Problem mit MailServer unter Debian - Postfix, Dovecot (4)

Frage von Richard8 zum Thema Ubuntu ...

Firewall
PFSense 2.3.3 Squid Reverse Proxy mit Apache Tomcat

Frage von horstvogel zum Thema Firewall ...

Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
Windows 10
Windows für Privatanwender "nicht mehr handhabbar" (35)

Frage von FA-jka zum Thema Windows 10 ...

CMS
Lokales Wordpress im LAN - wie aufsetzen? (15)

Frage von Static zum Thema CMS ...

LAN, WAN, Wireless
Komplett neues Netzwerk, Ubiquiti WLAN, Router, Switch (15)

Frage von Freak-On-Silicon zum Thema LAN, WAN, Wireless ...

Backup
Backup Wochen- Monats- Jahressicherung (13)

Frage von Meterpeter zum Thema Backup ...