Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Debian LAMP Mailserver (Postfix Dovecot) langsam bei Outlook IMAP nicht bei Livemail

Frage Linux Debian

Mitglied: Bernd42

Bernd42 (Level 1) - Jetzt verbinden

27.01.2012 um 14:38 Uhr, 6740 Aufrufe, 6 Kommentare

Hallo

Es geht um ein Debian LAMP mit Dovecot als Server und

Windows 7 mit Outlook 2010 und Livemail. Desktopfirewall aus, kein Vierenscanner an als Client.

Der Mailabruf mit Outlook (imap) dauert sehr lange. (30 Sec. und mehr) Jedes mal wenn man einen Reiter (imap Ordner) erweitert beginnt die Wartezeit von neuem. Andere Mailkonten (ebenfalls Imap) mit deutlich mehr E-Mails darin auf dem selben Outlook verhalten sich sehr deutlich schneller.

Der Abruf via Livemail geht dagegen schnell und unauffällig.

Was macht Outlook anders ?
Ich habe gelesen das dies ein Authentifizierungsproblem (Plaintext?) sein kann. Jedoch gibt es keine Fehler im Mailprotokoll.
Anbei die main.cf

Kennt jemand dieses Problem welches unter Outlook aber nicht unter Livemail auftritt ?
Wäre sehr nett wenn mir jemand dabei helfen könnte.

Gruß
Bernd

myhostname = mail.xxx.com
myorigin = $myhostname
mydestination = $myhostname
mynetworks = 127.0.0.0/8

inet_protocols = ipv4
biff = no
append_dot_mydomain = no

alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases


message_size_limit = 40000000

smtpd_banner = $myhostname ESMTP Mailserver
smtpd_helo_required = yes
smtpd_sender_restrictions = reject_unknown_address
smtpd_recipient_restrictions =
permit_sasl_authenticated,
reject_non_fqdn_sender,
reject_non_fqdn_recipient,
reject_unknown_sender_domain,
reject_unknown_recipient_domain,
reject_unauth_pipelining,
permit_mynetworks,
reject_unauth_destination,
reject_unverified_recipient,
reject_unauth_destination,
reject_rbl_client bl.spamcop.net,
reject_rbl_client sbl-xbl.spamhaus.org,
permit

strict_rfc821_envelopes = yes

smtpd_sasl_auth_enable = yes
smtpd_sasl_type = dovecot
smtpd_sasl_path = private/auth
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain =

smtp_sasl_auth_enable = no
broken_sasl_auth_clients = yes

virtual_mailbox_base = /var/syscp/mails/
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_mailbox_maps.cf
virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_mailbox_domains.cf
virtual_alias_domains =
virtual_alias_maps = mysql:/etc/postfix/mysql-virtual_alias_maps.cf
virtual_uid_maps = static:2000
virtual_gid_maps = static:2000

dovecot_destination_recipient_limit = 1
virtual_transport = dovecot
Mitglied: AndiEoh
31.01.2012 um 12:29 Uhr
Hallo

wenn Livemail (auch per IMAP?) schnell und Outlook auf dem selben PC langsam ist gibt es mehrere Möglichkeiten:
- Outlook nutzt LiveSearch und ähnliches und muß die Mails erstmal komplett indizieren --> Sollte beim zweiten Aufruf schneller sein
- Outlook hat clientbasierte Filter eingestellt die wegen des e-Mail Inhaltes (viele Anhänge etc.) lange brauchen

Liegen die anderen IMAP Ordner in Outlook die "schnell" sind auf einem anderen Server oder ist es lediglich ein anderes Konto?

Du solltest auf jeden Fall auch das Dovecot Log (nicht Postfix!) überprüfen und eventuell das Outlook IMAP Konto mit Standardwerten neu einrichten.

Gruß

Andi
Bitte warten ..
Mitglied: Bernd42
02.02.2012 um 21:57 Uhr
Danke für die Antwort.
Also,
Andere Postfächer (auf anderen servern) laufen auf dem selben Outlook im vergleich rasend schnell.
Auch auf verschiedenen PC,s verhällt es sich genau so. Die Log schaue ich mir morgen an, da ich erst dann Gelegenheit dazu habe. Wie gesagt das selbe Outlook ist bei MAilfächern anderer Provider sehr viel schneller.
Daher komme ich ja darauf das es an der Webserverkonfiguration liegen muss. Wenn man auf dem langsamen Mailaccount (ca 30 E-Mails selten mit Anhängen) den Posteingang erweitert, kommt erst mal die Sanduhr und unten steht eMail wird abgerufen ... meist so 10-30 sec. die anderen Mailfächer (andere Provider ) sind quasi nach ca. 2 Sec. da. Dieses Verhalten ist aber nur bei Outlook der Fall. Wie gesagt gelesen habe ich irgentwo das dieses Verhalten vorkommt wenn er die Plaintext Authentifikation nicht erkennt. Aber ich finde einfach den Fehler nicht.

Ok, in der Mail error log stand nichts, wohl aber in der Mail.warn

Die letzten beiden Zeilen deuten doch auf ein Authentifizierungsproblem hin oder ?

mail.warn [----] 0 L:[209+21 230/230] *(34741/34741b) <EOF>
Feb 2 14:15:22 srv01 postfix/smtpd[27731]: warning: 46.174.xxx: hostname 120.34.novosedly.net verification failed: Name or service not known
Feb 2 14:15:40 srv01 postfix/smtpd[27731]: warning: 113.178.xxx: address not listed for hostname localhost
Feb 2 16:35:33 srv01 postfix/smtpd[31652]: warning: 213.144.xxx: address not listed for hostname www.xxx.de
Feb 2 18:38:28 srv01 postfix/smtpd[2449]: warning: 74.63.xxx: hostname 235-242-63-74.static.reverse.lstn.net verification failed: Name or service not known
Feb 2 18:53:13 srv01 postfix/smtpd[2835]: warning: 74.63.xxx: hostname 235-242-63-74.static.reverse.lstn.net verification failed: Name or service not known
Feb 2 19:49:25 srv01 postfix/smtpd[4199]: warning: 89.42.xxx: hostname static-89-42-93-153 verification failed: Name or service not known
Feb 2 20:30:39 srv01 postfix/smtpd[5176]: warning: 109.86.xxx: hostname 87.76.86.109.triolan.net verification failed: Name or service not known
Feb 2 20:30:39 srv01 postfix/smtpd[5182]: warning: 94.233.134.140: hostname inside-ip-115.astranet.ru verification failed: Name or service not known
Feb 2 21:49:39 srv01 postfix/smtpd[7043]: warning: xxx.dip.t-dialin.net[84.136.xxx]: SASL NTLM authentication failed: xxxxxxxxxxxxxxxxxxxxxxxxxxAAAFAooA8XqE/RwKiW0AAAAAAAAAAD
Feb 2 21:49:41 srv01 postfix/smtpd[7043]: warning: xxx.dip.t-dialin.net[84.136.xxx]: SASL DIGEST-MD5 authentication failed: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Alles mit einem ganz frisch eingerichtetem Konto.

Gruß
Bernd
Bitte warten ..
Mitglied: AndiEoh
03.02.2012 um 12:26 Uhr
Hallo

Die logs sind von Postfix (--> SMTP) also vom Mailversand. Das Problem mit IMAP Zugriff sollte in der Logdatei von Dovecot auftauchen. Eventuell gibt es dort ein Limit an gleichzeitigen Verbindungen welches von Outlook überschritten wird. Mit Plaintext oder nicht sollte es nur wenig zu tun haben, da die Authentifizierung entweder funktioniert oder eben nicht. Einzige Möglichkeit wäre noch das der IMAP Server (Dovecot, nicht Postfix) mehrere Authentifizierungsverfahren anbietet die nicht funktionieren.
Vieleicht hier mal nachschauen:
http://wiki1.dovecot.org/FrontPage?action=show&redirect=StartSeite# ...

Gruß

Andreas
Bitte warten ..
Mitglied: Bernd42
06.02.2012 um 17:27 Uhr
Dovecot scheint bei mir kein Logfile zu schreiben. Ich schätze loging ist deaktiviert. zumindest findet sich keine dovecot.log unter /var/log und auch nicht unter /etc/dovecot
Stichwort mail_debug = yes setzen ? .....

Mit smtp scheint ja dann auch etwas nicht zu stimmen wenn er jedes mal nicht unterstützte Authentifizierungsverfahren versucht .. aber zurück zu dovecot. UND natürlich ein herzliches Danke das du mir helfen möchtest.

Hier mal die Config zu dovecot :


base_dir = /var/run/dovecot
protocols = imap pop3
listen = *
mail_access_groups = vmail
mail_debug = no
disable_plaintext_auth = no

protocol imap {
mail_plugins = quota imap_quota
}

protocol pop3 {
pop3_uidl_format = UID%u-%v
mail_plugins = quota
}
protocol lda {
postmaster_address = root@localhost
auth_socket_path = /var/run/dovecot/auth-master
mail_plugins = quota
sendmail_path = /usr/sbin/sendmail
}


auth default {
mechanisms = plain login digest-md5 cram-md5 ntlm rpa
user = vmail

passdb sql {
args = /etc/dovecot/dovecot-sql.conf
}
userdb sql {
args = /etc/dovecot/dovecot-sql.conf
}
socket listen {
client {
path = /var/spool/postfix/private/auth
mode = 0660
user = postfix
group = postfix
}
}
socket listen {
master {
path = /var/run/dovecot/auth-master
mode = 0600
user = vmail
group = vmail
}
}
}
plugin {
<------>quota = maildir:
}



alles in Allem die Standartkonfiguration, bzw. händisch nichts drann geändert. Ob das Problem erst seit dem letzten Debianupdate besteht oder schon länger ist leider nicht zu beantworten da vorher kein Outlook genutzt wurde.

Gruß
Bernd
Bitte warten ..
Mitglied: AndiEoh
07.02.2012 um 13:03 Uhr
Hallo

also ohne die genaue Umgebung zu kennen würde ich vermuten das lediglich die Verfahren plain und login funktionieren, da für die anderen (challange-response) die klartext Passwörter vorliegen müssten was üblicherweise nicht getan wird.

Also einfach mal die folgende Zeile

mechanisms = plain login digest-md5 cram-md5 ntlm rpa

in

mechanisms = plain login

ändern.


Gruß

Andreas
Bitte warten ..
Mitglied: Bernd42
08.02.2012 um 15:43 Uhr
Also ob die Fehlermeldungen nun auch verschwunden sind muss ich noch schauen, aber mechanisms = plain login hat dazu geführt das auch Outlook jetzt rasend schnell ist.

Vielen Dank Andreas.

Gruß
Bernd
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...