Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Debian Lenny - apt-get Problem

Frage Linux Debian

Mitglied: jan.xb

jan.xb (Level 1) - Jetzt verbinden

03.12.2011, aktualisiert 21:56 Uhr, 6066 Aufrufe, 13 Kommentare

Ohne das ich wissentlich etwas geändert habe, gibt mir "apt-get" den Fehler "Encountered a section with no Package: header" aus.

Hi Leute,
Seit heute kann ich mein Debian Lenny nicht mehr updaten.
Der Befehl
01.
apt-get update
lädt alle Listen normal runter, gibt mir aber am Ende folgenden Fehler aus:
01.
Reading package lists... Error! 
02.
E: Encountered a section with no Package: header 
03.
E: Problem with MergeList /var/lib/apt/lists/security.debian.org_dists_lenny_updates_main_binary-amd64_Packages 
04.
E: The package lists or status file could not be parsed or opened.
Als Standardlösung steht in vielen Foren, dass man die Inhalte im Verzeichnis /var/lib/apt/lists löschen soll.
Diese Lösung funktioniert bei mir allerdings nicht, apt-get lädt danach alle Listen erneut runter, der Fehler bleibt der gleiche.
Auch mit dem Befehl apt-get clean bekomme ich Aptitude nicht mehr zum laufen.

Ich weiß so langsam nicht mehr weiter, kann mir jemand helfen?


Edit: Nach Ausprobieren und Auskommentieren der Einträge in der sources.list ist mir ein Eintrag aufgefallen (Zeile 4).
Dieser ist jetzt auskommentiert, dann funktioniert alles ohne Fehler, ich bekomme aber logischerweise keine Sicherheitsupdates mehr.
Das ist die funktionierende sources.list:
01.
deb http://ftp2.de.debian.org/debian/ lenny main 
02.
deb-src http://ftp2.de.debian.org/debian/ lenny main 
03.
 
04.
#deb http://security.debian.org/ lenny/updates main 
05.
deb-src http://security.debian.org/ lenny/updates main 
06.
 
07.
deb http://volatile.debian.org/debian-volatile lenny/volatile main 
08.
deb-src http://volatile.debian.org/debian-volatile lenny/volatile main
Mitglied: hmarkus
03.12.2011 um 22:28 Uhr
Guten Abend,

ich hab von Debian keine Ahnung, hatte aber ein ähnliches Problem mal mit Gentoo.

Du kannst entweder (falls das bei Debian möglich ist) einen anderen Mirror ausprobieren oder abwarten ob die beschädigte Datei ersetzt wird.

Ich glaube eher nicht, dass es ein Fehler bei Dir auf dem System ist.

Markus
Bitte warten ..
Mitglied: jan.xb
03.12.2011 um 22:33 Uhr
Danke für die schnelle Antwort
soweit ich gefunden habe, gibt es nur einen Mirror für die Sicherheits-Updates.
Dann muss ich wohl einfach ein paar Tage warten...
Bitte warten ..
Mitglied: hmarkus
03.12.2011 um 22:40 Uhr
Hast Du mal in den Foren gesucht ob zur Zeit andere Leute das gleiche Problem haben? Wahrscheinlich ja, aber Du solltest das beobachten, wenn in den nächsten Tagen keiner das gleich Problem hat (oder es wieder funktioniert) musst Du wohl noch mal selbst nach einer Lösung suchen.

Oder poste mal in einem speziellen Debian-Forum, das ist wahrscheinlich effektiver.

Markus
Bitte warten ..
Mitglied: fearmaster
04.12.2011 um 03:00 Uhr
Ich habe das selbe Problem und zwar auf 3 verschiedenen Debian lenny Servern. Scheint sich also um einen Fehler seitens Debian zu handeln.

Gruß,
fearmaster
Bitte warten ..
Mitglied: mrtux
04.12.2011 um 05:24 Uhr
Hi !

Zitat von fearmaster:
Ich habe das selbe Problem und zwar auf 3 verschiedenen Debian lenny Servern. Scheint sich also um einen Fehler seitens Debian zu
handeln.

Richtig.

Zitat von jan.xb:
Dieser ist jetzt auskommentiert, dann funktioniert alles ohne Fehler, ich bekomme aber logischerweise keine Sicherheitsupdates
mehr.

Wirst Du eh bald nicht mehr bekommen, denn ihr solltet euch darüber im Klaren sein, dass der Support für Lenny (oldstable) im Februar 2012 sowieso ausläuft. Von daher ist es ziemlich unklug (vorsichtig ausgedrückt) daran festzuhalten, wenn man spätestens dann sowieso auf Squeeze (stable) umsteigen muss, denn dann wird es keine Sicherheitspatches mehr für Lenny geben....

Guggst Du hier:

F: Wie lange sind Sicherheitsaktualisierungen vorgesehen?

A: Das Sicherheits-Team versucht eine stabile Distribution für in etwa ein Jahr zu unterstützen, nachdem die nächste stabile Distribution freigegeben wurde; außer, eine weitere stabile Distribution wird innerhalb dieser Zeitspanne freigegeben. Es ist nicht möglich, drei Distributionen zu unterstützen; die gleichzeitige Unterstützung für zwei ist bereits schwierig genug.


Quelle: www.debian.org/security/faq

mrtux
Bitte warten ..
Mitglied: orcape
04.12.2011 um 08:43 Uhr
Hi mrtux,

und wie verfährt man dann mit einem, vor einem halben Jahr gekauften NETGEAR-NAS, bei dem man nach Blick ins System feststellt, das dort noch ein Debian-Sarge werkelt.
http://debianforum.de/forum/viewtopic.php?f=31&t=131434
Hoffen das Netgear das OS aktuell hält ? ...oder das "Ding" in die Tonne drücken......
Nun hoffe ich nur das Aqui den Tread nicht liest.........

Gruß orcape
Bitte warten ..
Mitglied: jan.xb
04.12.2011 um 10:48 Uhr
Gut, dann bin ich ja beruhigt
Bitte warten ..
Mitglied: flitzenderelch
04.12.2011 um 13:38 Uhr
Zitat von jan.xb:
Das ist die funktionierende sources.list:
01.
deb http://ftp2.de.debian.org/debian/ lenny main 
02.
> deb-src http://ftp2.de.debian.org/debian/ lenny main 
03.
>  
04.
> #deb http://security.debian.org/ lenny/updates main 
05.
> deb-src http://security.debian.org/ lenny/updates main 
06.
>  
07.
> deb http://volatile.debian.org/debian-volatile lenny/volatile main 
08.
> deb-src http://volatile.debian.org/debian-volatile lenny/volatile main 
09.
> 

Hat es einen tieferen Hintergrund warum Du eine Zeile auskommentierst?
#deb http://security.debian.org/ lenny/updates main

für ein reibungsloses update wird immer beides benötigt, deb & deb-src.

Nimm mal die Raute raus und lass nochmal laufen.
Bitte warten ..
Mitglied: flitzenderelch
04.12.2011 um 13:39 Uhr
Zitat von orcape:
Hi mrtux,

und wie verfährt man dann mit einem, vor einem halben Jahr gekauften NETGEAR-NAS, bei dem man nach Blick ins System
feststellt, das dort noch ein Debian-Sarge werkelt.
http://debianforum.de/forum/viewtopic.php?f=31&t=131434
Hoffen das Netgear das OS aktuell hält ? ...oder das "Ding" in die Tonne drücken......
Nun hoffe ich nur das Aqui den Tread nicht liest.........

Gruß orcape

Das ist Hersteller Sache.
Wenn Du das Ding rootest und ihm System rumwerkelst verlierst Du die Garantie.
Bitte warten ..
Mitglied: jan.xb
04.12.2011 um 14:56 Uhr
Die Zeile ist auskommentiert, um zu zeigen, dass bei einer Abfrage dieser Quelle der Fehler auftritt.
Wenn ich sie auskommentiere, wird sie nicht mehr abgefragt, daher tritt der Fehler nicht mehr auf ...
Bitte warten ..
Mitglied: fearmaster
04.12.2011 um 15:26 Uhr
Das Problem hat sich erledigt, es funktioniert wieder tadellos, mrtux hat aber natürlich recht, wird langsam Zeit für ein Upgrade

Gruß,
fearmaster
Bitte warten ..
Mitglied: mrtux
04.12.2011 um 18:37 Uhr
Hi !

Zitat von orcape:
und wie verfährt man dann mit einem, vor einem halben Jahr gekauften NETGEAR-NAS, bei dem man nach Blick ins System

Naja auf das Thema Netgear NAS möchte ich einfach mal besser nicht eingehen... ;-P

Aber wie schon angemerkt, ist das dann eine reine Herstellersache ob man Firmware Updates bekommt oder nicht....Und in dem Fall tippe ich eher auf nicht oder zumindest nicht lange... ;-P

Ausserdem ist da schon ein kleiner Unterschied zwischen einer komplett offenen x86/amd64 Plattform für Server und Workstations bzw. Desktops und einer in sich geschossen Firmware eines Herstellers. Dort wird bei einem Update meist immer das gesamte Image ausgetauscht ohne genauer zu Wissen, welche Teile darin vom Hersteller aktualisiert wurden, während man bei einer offenen Distribution meist mittels eines Paketmanagers einzelnen Pakete aktualisieren kann....

mrtux
Bitte warten ..
Mitglied: jan.xb
04.12.2011 um 21:28 Uhr
Jo, jetzt muss ich nur noch warten bis mein Serveranbieter seinen Cache erneuert hat.
Bis jetzt läufts bei mir nämlich noch nicht ...
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Ubuntu
gelöst Problem mit apt-get autoremove (4)

Frage von Henere zum Thema Ubuntu ...

Debian
Debian 8, SSH Logging, Popuser-Meldung und rkhunter Problem (5)

Frage von d4shoerncheN zum Thema Debian ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (18)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...