Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Debian SSH funktioniert nicht richtig

Frage Linux Debian

Mitglied: geforce28

geforce28 (Level 1) - Jetzt verbinden

05.10.2014, aktualisiert 02:13 Uhr, 2919 Aufrufe, 8 Kommentare

Hallo.

Ich habe eine Debian 7.6.0 amd64 Version frisch installiert. (minimal)
Dann via "apt-get install ssh" den ssh Server installiert.

Nun habe ich folgendes Phänomen:
SSH Verbindung mit Putty vom Windows 8 Client kommt zu stande, bricht dann immer wieder ab nach 1-2 Min.
SSH Verbindung kommt manchmal garnicht zu stande.

Wie kann das sein ?
Ping geht weiterhin durch auf den Server.


Gruß
geforce28
Mitglied: Lochkartenstanzer
05.10.2014 um 01:50 Uhr
Zitat von geforce28:

Nun habe ich folgendes Phänomen:
SSH Verbindung mit Putty vom Windows 8 Client kommt zu stande, bricht dann immer wieder ab nach 1-2 Min.
SSH Verbindung kommt manchmal garnicht zu stande.

Wie kann das sein ?
Ping geht weiterhin durch auf den Server.

  • Hast du mal ein debian-ssh versucht, z.B. mit knoppx?

  • Hast Du in den Logdateien nachgeschaut, ob Fehlermeldungen vorhanden sind?

  • Hast du eine Firewall oder ein NAT-Gateway dazwischen, daß in einen Timeout läuft.?

Zuviel für die Kristallkugel.

lks
Bitte warten ..
Mitglied: geforce28
05.10.2014 um 02:01 Uhr
Wie gesagt, frisch installierter Debian Rechner...

Ich habe einen weiteren, funktionierenden Debian Rechner hier und da gibt es keine Probleme, das kann doch nicht sein !

Log bei Putty sagt einfach nur "connection refused"
Jetzt aktuell habe ich es bspw., dass ich garnicht drauf komme.
Bei Putty kann ich root eingeben und auch mein pw und dann kommt "access denied"
Bitte warten ..
Mitglied: Lochkartenstanzer
05.10.2014, aktualisiert um 02:06 Uhr
Zitat von geforce28:

Wie gesagt, frisch installierter Debian Rechner...

Ich habe einen weiteren, funktionierenden Debian Rechner hier und da gibt es keine Probleme, das kann doch nicht sein !

Und wenn Du von diesen rechne rper ssh daraufgehst?

Log bei Putty sagt einfach nur "connection refused"

Und was sagt das logh auf dem debian-rechner? Läfut der sshd überhaupt? Hast du überhaupt openssh-server installiert?

Jetzt aktuell habe ich es bspw., dass ich garnicht drauf komme.
Bei Putty kann ich root eingeben und auch mein pw und dann kommt "access denied"

root-Acces ist per default deaktiviert. Das wundert micht nciht, das das nciht geht. Wenn, dann m,üßten Du ins /etc/ssh/sshd_conf den root-acces aktivieren, was aber eine schlechte Idee ist.

lks

Nachtrag:

Stichwort:

PermitRootLogin yes
Bitte warten ..
Mitglied: geforce28
05.10.2014 um 02:13 Uhr
PermitRootLogin ist aktiviert ! (überigens auch standartmäßig)
Auch läuft der dienst sshd !
Openssh-server wird automatisch mitinstalliert, wenn man apt-get install ssh eingibt.


So Problem ist gelöst....
Habe mal ne andere Netzwerkkarte eingebaut und die Onboard Karte deaktiviert. Damit gehts...
Bitte warten ..
Mitglied: Lochkartenstanzer
05.10.2014, aktualisiert um 02:21 Uhr
Zitat von geforce28:
> So Problem ist gelöst....
Habe mal ne andere Netzwerkkarte eingebaut und die Onboard Karte deaktiviert. Damit gehts...

Ups. Das ist natürlich befremdlich.

Gute Nacht.
Bitte warten ..
Mitglied: aqui
05.10.2014 um 10:01 Uhr
Vermutlich die falschen oder alte Treiber für die Onboard Karte geladen ! Oder...
Autonegotiation Problem mit der Onboard karte und dem Switch.
Meist haben die Chipsatz Hersteller des verbauten onboard Chipset für die NIC aktuelle Linux Treiber zum Download.
Die fixen in 99% alle Fäle die Problematik sicher !
Bitte warten ..
Mitglied: LordGurke
05.10.2014 um 13:22 Uhr
Bei einigen billigen Mainboards wird auch nur eine 100 MBit/s-Karte angeboten, der Chipsatz ist aber für eine Gigabit-Karte gebaut. Damit aber kein Gigabit funktioniert sind dann teilweise die äußeren Kontakte in der Buchse unbelegt oder gleich ganz weggelassen worden...
Führt dann bei Gigabit-Switches zu interessanten Phänomenen, wenn man der Netzwerkkarte nicht explizit 100 MBit/s als Geschwindigkeit einhämmert.
Bitte warten ..
Mitglied: aqui
05.10.2014 um 18:10 Uhr
Guter Hinweis....!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Netzwerkmanagement
gelöst Auf Debian 8.6 mit Putty zugreifen über SSH, Zugriff verweigert seit der neuen VM (4)

Frage von M.Marz zum Thema Netzwerkmanagement ...

Windows Server
Raid funktioniert nicht richtig (20)

Frage von Roadrunner777 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (14)

Frage von liquidbase zum Thema Windows Update ...