Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Debian v.6.0.4 (Squeeze) Webserver mit Apache2, Adressbereich geändert und seit dem Ist die Homepage nicht mehr erreichbar. Warum?

Frage Linux Apache Server

Mitglied: Sierjoerg

Sierjoerg (Level 1) - Jetzt verbinden

05.04.2012 um 08:00 Uhr, 4579 Aufrufe, 7 Kommentare

Ich wollte meinen Webserver einfach nur ins Intranet einbinden, damit ich auch an anderen Rechnern zugriff auf die Homepage habe, um z.B. meinem Chef die Fortschritte an der Homepage präsentieren kann.

Hallo liebe Administratorinen und Administratoren,
folgendes Problem beschäftigt mich seit 2 Tagen. Ich habe die Aufgabe für unsere Tochterfirma eine Homepage nach vorbild unserer eigenen Homepage zu erstellen. Also habe ich mir eine Virtuellen Maschine (vmware) mit Debian v.6.0.4 eingerichtet.
Darauf habe ich mir einen Webserver mit Apache2 eingerichtet, Php5 und Mysql für die Datenbank eingerichtet.

Anfangs habe ich den Webserver auserhalb des Firmennetzes eingerichtet. Das bedeutet ich habe eine IP-Adresse auserhalb unseres IP Adressbereichs verwendet. Da ich in meinem Rechner zwei NIC's habe konnte ich mir eine von den beiden für das andere Netz konfigurieren. Das einrichten und drauf zugreifen auf die Homepage war auch Anfangs kein Problem, bis ich den Webserver in unseren Firmennetz sprich in unseren Adressbereich einfügen wollte. Nach dem Ich die IP geändert hatte, konnte ich auf einmal nur noch auf die Startseite meiner Homepage drauf zugreifen. Zudem wurde die Seite nicht richtig dargestellt. Es fehlen jegliche art von Logos Farblichen Hintergründen, eingerichtete Menüleisten usw. Wenn ich z.B auf einen anderen Bereich klicken will, sagen wir Impressum, bekomme ich die Meldung vom Server, das der Zugriff auf die angeforderte URL nicht erfolgreich war: Grund die Verbindung schlug fehl. Das interessante daran ist, er will die alte IP Adresse für den Zugriff auf die Seite nutzen. Aufruf der Hompage lief bis jetzt nur über die IP!
Darauf hin habe ich erst mal den Verlauf und den Cache meines Browsers gelöscht. Hat aber nicht geholfen. Also bin ich mal an einen anderen Rechner gegangen und habe versucht dort die Homepage aufzurufen. Aber auch da versucht der Browser eine Verbindung zur alten IP Adresse aufzunehmen.
Leider kenne ich mich in Linux nicht ganz so gut aus um das Problem auch nur irgendwie einzugrenzen. Für mich sieht das so aus, als würde irgendwo, in irgend einer Datei stehen, dass die Seiten meiner Homepage über diese Adresse erreichbar sind. Obwohl die Netzwerkkarte in einen anderen Adressbereich gebracht worden ist.

Ich hoffe ihr könnt mir helfen.
Falls ihr noch infos benötigt bitte fragen. Ich versuch mein bestes eure Fragen zu beantworten.

MFG Sierjörg
Mitglied: it-frosch
05.04.2012 um 08:10 Uhr
Hallo Sierjörg,

ich vermute mal das du ein CMS verwendest. Hast du darin mal die Einstellungen geprüft.
Es schaut ja so aus das die Pfade für bestimmte Inhalte die alte IP enthalten. Also würde ich da ansetzen.
Wenn du schreibst mit welchem CMS du arbeitest, gibt es hier bestimmt einen Admin der dir aus dem Hut sagen kann wo die Einstellung ist.

grüße vom it-frosch
Bitte warten ..
Mitglied: Sierjoerg
05.04.2012 um 08:23 Uhr
Ich schätze du meinst Mit CMS so was wie Websitebaker oder? Was zu gleich auch die Antwort dieser Frage ist .
Bitte warten ..
Mitglied: SlainteMhath
05.04.2012 um 08:58 Uhr
Moin,

sieht für mich so aus, als wäre das Problem in deinem Sourcecode zu suchen. Durchsuche doch einfach mal all deine PHP und Config-Dateien nach der alten IP. Oder hast du bei Apache rewrites, redirects oder aliases eingetragen?

lg,
Slainte
Bitte warten ..
Mitglied: Sierjoerg
05.04.2012 um 09:28 Uhr
Moin Slainte,
in Apache habe ich keinerlei der artiger Einstellungen vorgenommen. Und was dem Sourcecode angeht, der stammt ja von Websitebaker, und dem Template von unserer Firmen Homepage. Den habe ich nur leicht in sachen anderes Logo und andere Sidebar Einträge geändert.
Bitte warten ..
Mitglied: Sierjoerg
05.04.2012 um 09:31 Uhr
Hallo noch mal,
ich habe mir gerade ein bischen Quellcode angeschaut und siehe da, gleich am Anfang steht die alte IP Adresse.
Bitte warten ..
Mitglied: Sierjoerg
05.04.2012 um 10:02 Uhr
So Problem dank Slainte Hinweis gelöst. Ich darf dann mal eben die Lösung präsentieren.

Die Lösung steckt inder Config.php vom Websitebacker. Hier der Quellcode:

<?php

define('DB_TYPE', 'mysql');
define('DB_HOST', 'localhost');
define('DB_Name','Websitebaker');
define('DB_USERNAME', 'rootr');
define('DB_PASSWORD', 'password');
define('DB_NAME', 'name');
define('TABLE_PREFIX', '');

define('WB_PATH', dirname(__FILE__));
define('WB_URL', 'http://192.xxx.xxx.241/wservice/wb'");
define('ADMIN_PATH', WB_PATH.'/admin');
define('ADMIN_URL',WB_URL.'/admin');

require_once(WB_PATH.'/framework/initialize.php');

?>
Wenn man jetzt den IP Adressbereich seines Webservers ändert, muss man auch die Config.php dem entsprechend an der stell WB_URL ändern.

Ich bedanke mich bei allen, die so schnell auf meine Frage geantwortet haben und wünsche euch frohe Ostern.
MFG Sierjörg
Bitte warten ..
Mitglied: it-frosch
05.04.2012 um 10:50 Uhr
Hallo Sierjörg,

noch zur Info. ( http://www.websitebaker2.org/de/hilfe/entwicklerhandbuch/variablen-und- ... )

dir auch schöne Ostern.

grüße vom it-frosch
Bitte warten ..
Ähnliche Inhalte
Apache Server
gelöst Debian CPU Auslastung durch Apache2 sehr hoch (12)

Frage von zeroblue2005 zum Thema Apache Server ...

Apache Server
gelöst HTTPS für Apache2 für interne Zwecke (8)

Frage von WinLiCLI zum Thema Apache Server ...

Debian
Debian 8.6 Absichern? (14)

Frage von Motte990 zum Thema Debian ...

Neue Wissensbeiträge
Firewall

PfSense OpenVPN beschleunigen

Tipp von Dobby zum Thema Firewall ...

Utilities

CCleaner 5.33 mit Malware infiziert

(25)

Information von SeaStorm zum Thema Utilities ...

Windows Server

Exchange Server 2016 Probleme auf Server 2016 mit iOS 11 Mailapp

Information von Oneplus zum Thema Windows Server ...

Internet

Pirate Bay lässt heimlich Krypto-Miner auf Nutzer-PCs laufen

(5)

Information von BassFishFox zum Thema Internet ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
gelöst Problem mit DELL 815R Server und Windows Bluescreen (24)

Frage von Leo-le zum Thema Festplatten, SSD, Raid ...

Utilities
CCleaner 5.33 mit Malware infiziert (24)

Information von SeaStorm zum Thema Utilities ...

JavaScript
gelöst Kopierschutz auf Webseite (13)

Frage von honeybee zum Thema JavaScript ...

Windows Server
Änderung Subnetz an AD Standort (13)

Frage von hansdampf zum Thema Windows Server ...