Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Default Gateway über VLAN Schnittstelle

Frage Linux Linux Netzwerk

Mitglied: martin2002

martin2002 (Level 1) - Jetzt verbinden

14.05.2010 um 15:56 Uhr, 5623 Aufrufe, 7 Kommentare

Hi.

Ich habe gerade versucht meinen Router so umzustellen, dass er VLAN Schnittstellen zum Zugangs ins Netz des Providers nutzt statt meherer physischer Netzwerkkarten. Das Funktioniert wunderbar bis auf einen Punkt: Das ifup script stellt nicht das Gateway welches per DHCP empfangen wird als Default Gateway ein... Es werden zwar einige Routen ins Provider Netz hinzugefügt, aber kein default Gateway eingerichtet. Bei der Verwendung der physischen Netzwerkkarte ist das kein Problem:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.99.99 * 255.255.255.255 UH 0 0 0 dsl0
10.0.0.0 * 255.255.255.0 U 0 0 0 eth3
192.168.1.0 * 255.255.255.0 U 0 0 0 eth1
192.168.10.0 * 255.255.255.0 U 0 0 0 vlan2
xx-xx-xx-xx-dyni * 255.255.248.0 U 0 0 0 eth2
link-local * 255.255.0.0 U 0 0 0 eth1
loopback * 255.0.0.0 U 0 0 0 lo
default xx-xx-xx-yy-dy 0.0.0.0 UG 0 0 0 eth2

Ich verwende openSUSE 10.3, die Netzwerkkarte eth3 ist der Link zum Switch worüber die VLANs laufen würden. Eth2 ist die momentane Externe Netzwerkkarte. Das VLAN replacement für eth2 heißt dann vlan22.

ifcfg-vlan22:

NAME="VLAN 22 on eth3"
ETHERDEVICE="eth3"
BOOTPROTO='dhcp'
REMOTE_IPADDR=""
NETMASK=''
BROADCAST=''
STARTMODE='auto'
IPADDR=''
NETWORK=''
USERCONTROL='no'

ifcfg-eth2:

BOOTPROTO='dhcp'
BROADCAST=''
ETHTOOL_OPTIONS=''
IPADDR=''
MTU=''
NAME='Accton EN-1207D Fast Ethernet Adapter'
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='no'
PREFIXLEN=''
NETMASK=''

ifcfg-eth3:

NAME="ASUSTeK RTL8111/8168B PCI Express Gigabit Ethernet controller"
BOOTPROTO=static
REMOTE_IPADDR=""
NETMASK=255.255.255.0
ETHTOOL_OPTIONS=""
MTU=""
UNIQUE=1273838958
BROADCAST=10.0.0.255
STARTMODE=auto
IPADDR=10.0.0.254
NETWORK=10.0.0.0
USERCONTROL=no

Hat dazu jemand eine Idee?

Greets,
Martin.
Mitglied: aqui
14.05.2010 um 18:59 Uhr
Nur nochmal der Nachfrage zum Verständnis:
Das VLAN 22 schleifst du dann auch wieder auf dem VLAN Trunk zum Switch und koppelst es dort aus für ein DSL Modem oder DSL Router, richtig ??
Bist du dir sicher das so ein "Router on a stick" wirklich Sinn macht ??
Es ist ja sicher ganz sexy alles über ein einziges Kabel zu machen aber du doppelst ja schon den inter VLAN Traffic, da der incoming und outgoing über den VLAN Trunk geht und dann zusätzlich noch den Internet Traffic...??
Funktioniert zwar aber kein wirklich gutes Design. Besser du behälst ein dediziertes Interface für den Internet Zugang oder hat das einen bestimmten Sinn das alles über den Trunk gehen soll ??
Was passiert denn wenn du die Default Route manuell statisch anlegst ??? Löst das dein Problem ??
Bitte warten ..
Mitglied: martin2002
15.05.2010 um 01:23 Uhr
Richtig. Die Konfiguration war so gedacht, dass am Switch drei Ports (ich habe zwei Internet Verbindungen) in VLANs gepackt werden. Der Port für den Router-Server in "alle" und dann zwei dedizierte Ports für die VLAN IDs 22 und 23 (DSL Modem und Kabel Deutschland).
Der Punkt hinter der Überlegung ist, dass Kabel Deutschland bei uns (hoffentlich) bald auch Verbindungen bis 100 MBit/s anbietet. Der Server der das Routing übernimmt hat aber "nur" eine Gigabit Karte und zwei 100Mbit Karten (die zusätzlich auch noch alt sind). Ich wollte mal die Bitraten mit einer solchen Konfiguration in Erfahrung bringen. An und für sich sollte der Traffic kein Problem für das Switch sein... Ist ein Web-Smart Switch mit 48Gbit/s Backplane. Aber das wollte ich eben herausfinden; ob ich so eine größere WAN-to-LAN Bitrate bekomme oder nicht.

Wenn ich die Default Route manuell eintrage funktioniert alles super. Die Route kann sich aber schon hin und wieder ändern, deshalb macht das nicht so viel Sinn. Die Konfiguration mit der zweiten Internetverbindung ist noch nicht fertig eingerichtet, denn da müssten die Routes eh anders gesetzt werden... (Würde über die Shorewall laufen, also mit irgend einer Art zusätzlichem ifup-script. Da bin ich mir aber noch nicht ganz sicher und es ist eh off-topic) Bis dahin sollte es also schon automatisch gehen.
Wie gesagt, lustig ist, dass es mit der physischen Karte problemlos eingestellt wird...

Greets,
Martin.
Bitte warten ..
Mitglied: aqui
15.05.2010 um 18:09 Uhr
Das kann eigentlich nur ein kleiner Konfig Punkt sein. Wie wird das def. Gateway vom Provider mitgeteilt ? Geht das über DHCP oder PPPoE ? Bzw. welchen Anschluss nutzt du den Kabel kommt ja generell per DHCP und DSL mit PPPoE.
Beide Leitungen kannst du so nicht aktiv haben, denn es kann ja nur ein def. Gateway geben. Es sei denn du setzt ein Link Load Balancing oder Policy Based Routing auf.
Wenn du erstmal nur einen Link testest wie KD, dann sollte auch ein VLAN Interface die IP bzw. Router per DHCP bekommen...das macht normalerweise keinen Unterschied.
Sieht dann eher so aus als ob die DHCP Client Funktion nicht auf dem VLAN Interface aktiv ist (wenn du KD als Link testest...)
Bitte warten ..
Mitglied: martin2002
16.05.2010 um 17:31 Uhr
Joa das beide Links nicht ohne weiteres Parallel gehen ist klar. Mit der Shorewall kann man das relativ gut konfigurieren... Das ist aber eine andere Geschichte. Ich habe momentan definitiv nur Kabel Deutschland als aktiven Link und die verteilen das per DHCP. Die Client IP wird auch übernommen + eine Route in das entsprechende Subnetz über das Vlan Interface eingestellt. Nur die default Route bleibt unkonfiguriert.
Würde es Sinn machen, wenn ich in der Konfiguration des VLAN Interface diese DEBUG option setze?

Greets,
Martin.
Bitte warten ..
Mitglied: aqui
16.05.2010 um 18:23 Uhr
Das wäre mal ganz sinnvoll. Auch mal das DHCP Loog anzusehen, denn das default Gateway wird ja per DHCP bekanntgegeben.
Das Problem ist das das dann nicht in deine Routing Tabelle übernommen wird.... Steht da ggf. schon eine statische default Route drin ?? Die muss dann natürlich weg.
Bitte warten ..
Mitglied: martin2002
16.05.2010 um 18:28 Uhr
Habs gelöst... Es war ein ganz simpler blöder Fehler. Ich hatte das vorherige physische Interface für den Link noch aktiv. Das hat natürlich auch DHCP als Einstellung und wird vor dem VLAN22 aufgerufen... Demnach hat er an dieser Stelle wohl bereits versucht die default route zu setzen und es dann später einfach nicht mehr gemacht, weil der vorherige Prozess noch im hintergrund lief.

Greets,
Martin.
Bitte warten ..
Mitglied: aqui
16.05.2010 um 19:53 Uhr
Alles wird gut ... !!

Dann bitte auch
http://www.administrator.de/index.php?faq=32
nicht vergessen !!
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
Default VLAN und Gäste VLAN...
gelöst Frage von itse.comLAN, WAN, Wireless5 Kommentare

Hallo ich muss mal eine Verständnis-Frage(n) stellen zum Thema VLAN genauer gesagt das default VLAN, Management VLAN oder wie ...

Router & Routing
Mehrere Gateways - Syslog nicht an Default Gateway
gelöst Frage von sebasschaRouter & Routing4 Kommentare

Hallo, ich habe ein "kleines" Problem :) Erstmal zum Aufbau meines Netzes. Ich habe mehrere Switchen in einem Netzwerk. ...

Router & Routing
Standortübergreifendes Routing ohne Default Gateway bei den Clients
gelöst Frage von ralf.beckmannRouter & Routing26 Kommentare

Hallo zusammen, einer unserer Kunden baut gerade ein standortübergreifendes, geroutetes Netz auf. Hier gibt es seitens der SPS Welt ...

Switche und Hubs
VLAN Gateway Routing
gelöst Frage von DerPraktikantSwitche und Hubs7 Kommentare

Hallo, und zwar habe ich mir eine Testumgebung aufgebaut : Mein Problem ist das ich über den Rechner im ...

Neue Wissensbeiträge
Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 4 StundenInternet3 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registierunf von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Verschlüsselung & Zertifikate

19 Jahre alter Angriff auf TLS funktioniert immer noch

Information von BassFishFox vor 11 StundenVerschlüsselung & Zertifikate1 Kommentar

Interessant zu lesen. Der Bleichenbacher-Angriff gilt unter Kryptographen als Klassiker, trotzdem funktioniert er oft noch. Wie wir herausgefunden haben, ...

Windows 10

Windows 10 Fall Creators Update - Neue Funktion Hyper-V Standardswitch kann ggf. Fehler bei Proxy Configs verursachen

Erfahrungsbericht von rzlbrnft vor 22 StundenWindows 103 Kommentare

Hallo Kollegen, Da wir die Gefahr lieben, haben wir bei einigen Usern nun mittlerweile das Creators Update drauf. Einige ...

Sicherheit

TLS-Zertifikat und privater Schlüssel von Microsofts Dynamics 365 geleakt

Information von Penny.Cilin vor 1 TagSicherheit

Microsoft hat versehentlich das TLS-Zertifikat inklusive dem privaten Schlüssel seiner Business-Anwendung Dynamics 365 geleakt. TLS-Zertifikat und privater Schlüssel von ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

Netzwerkmanagement
NAS über zwei weitere Ethernet Anschlüsse verbinden
gelöst Frage von Sibelius001Netzwerkmanagement16 Kommentare

Sorry - ich bin hier wahrscheinlich als kompetter IT Trottel unterwegs. Aber eventuell kann mir jemand ganz einfach helfen: ...

LAN, WAN, Wireless
Von rj11 auf rj45
Frage von jensgebkenLAN, WAN, Wireless16 Kommentare

Hallo Gemeinschaft, könnt ihr mir vielleicht bei der anfertigung eines Kabels helfen - habe ein rj 11 stecker und ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...