Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Defekte Voucherliste im CP der Monowall...

Frage Netzwerke Router & Routing

Mitglied: mrtux

mrtux (Level 4) - Jetzt verbinden

11.04.2014, aktualisiert 28.06.2014, 1844 Aufrufe, 8 Kommentare

Hi liebe Kollengen!

Ich habe ein Problem mit dem Captive-Portal einer Monowall. Mir ist jetzt auch nicht klar wie das letztendlich passiert ist aber ich kann eine Voucher-Roll nicht mehr löschen bzw. die oberste Reihe bleibt leer und kann auch nicht mehr editiert bzw. gelöscht werden, egal was ich versuche. Wenn man dann auf der Voucher Statusseite ist, kommt da eine nette PHP-Warnmeldung. Zur Veranschaulichung habe ich zwei Screenshots angehängt.

Voucherseite:
3d566df62f069e886c9d03923b94ddec - Klicke auf das Bild, um es zu vergrößern

Die Statusseite der Voucher:
24e885937e09f7b89e916b09d867c864 - Klicke auf das Bild, um es zu vergrößern

Hatte schon mal jemand von Euch das Problem und wie könnte man da wieder Ordnung rein bringen könnte, möglichst ohne in den Eingeweiden (hab ich bisher noch nicht gemacht) der Mono herumzupfuschen oder diese manuell neu aufsetzen zu müssen. Ich vermute, dass in der Voucher-Datenbank ein leerer Datensatz laienhaft ausgedrückt "drin hängt"...

mrtux
Mitglied: aqui
11.04.2014, aktualisiert um 15:45 Uhr
Da rächt sich dann das die Monowall keinen Shell Zugriff hat wie die pfSense, denn damit könntest du die Datei oder den Datensatz einfach löschen über den Shellzugang und gut iss.
Vermutlich hast du nur 2 Optionen:
1.) Konfig sichern und Flash neu beschreiben und Konfig wieder rücksichern. Wenn du Pech hast sichert der aber den kaputten Voucher File mit zurück...da hilft nur ausprobieren.
2.) Auf pfSense wechseln und CF damit flashen und Voucher Roll dort neu generieren.
Letztlich bist du mit dem Shellzugang der pfSense besser bedient und flexibler.
Bitte warten ..
Mitglied: mrtux
14.04.2014, aktualisiert 28.06.2014
Hi aqui!

Danke für deine Antwort und die Tipps!

Zitat von aqui:
Da rächt sich dann das die Monowall keinen Shell Zugriff hat wie die pfSense, denn damit könntest du die Datei oder den
Ja..Das wurde halt schon vor längerer Zeit eingerichtet und dann nur noch aktualisiert, mehr habe ich da nicht mehr gemacht. Die Mono lief dort im längsten Fall länger als 1 Jahr ohne Neustart problemlos durch....An sich ein absolut stabiles System und die erweiterten Funktionen der pfSense waren in der Konstellation damals eben nicht nötig, darum habe ich das so gelassen...

Letztlich bist du mit dem Shellzugang der pfSense besser bedient und flexibler.
Yo wenn es nicht anders geht, dann mache ich das. Wie sieht es mit der aktuellen Version (2.1.x) der pfSense eigentlich mit den Resourcen aus, ist das dann langsamer auf einen Alix Board als die Mono? Du hast doch da bestimmt genauere Erfahrungswerte als ich...

mrtux
Bitte warten ..
Mitglied: aqui
14.04.2014 um 20:17 Uhr
Nein, ich habe keinerlei Unterschied feststellen können. Wenn man eine relativ kleine Anwendung hat kann man die RRD Statistiken bei der pfSense deaktivieren im Setup das bringt noch einen Performance Step. Gilt aber nur für Antwortszeiten des GUI. In Bezug auf das Packet Forwarding und Firewalling hat das keinerlei Einfluss.
Die aktuelle 2.1.2 hat übrigens schon einen Heartbleed Fix. So schnell war keine kommerzielle Firewall mit einem Fix !
Ansonsten ist es keinerlei Unterschied...
Bitte warten ..
Mitglied: jstrebel
LÖSUNG 21.04.2014, aktualisiert 28.06.2014
Hallo mrtux,
Ich sehe 2 möglichkeiten.
1) lade die congfig runter und lösche in diesem file den eintrag (zeile) heraus.
Ich habe die struktur nicht "im kopf" aber du findest diese rasch raus wenn du noch einen neuen eintrag machst.

2) versuch im menue einen factory reset zu machen und von vorne anzufangen.

Ich sehe nicht wie ein ssh zugang helfen könnte dieses problem zu lösen.
Pfsense braucht etwas mehr resourcen.
Grüsse auch aus der Schweiz
Bitte warten ..
Mitglied: aqui
21.04.2014 um 09:53 Uhr
@jstrebel
Nützt ja alles nichts, denn inspesondere 2 hat er ja schon ohne Erfolg probiert. Das ist ein Amok laufender Prozess in der Monowall und deren gravierender Nachteil ist das sie keinen Shell Zugang hat wie die pfSense mit der man das in 1 Minute fixen könnte ! Man ist also erheblich eingeschränkt in den Optionen.
Das beste ist wohl Kollege Tux flasht sich ne pfSense auf die CF und startet neu !
Alles neu macht der Mai...
Bitte warten ..
Mitglied: jstrebel
22.04.2014 um 07:57 Uhr
Sorry mrtux, habe zuwenig genau gelesen. Du schreibst, dass das Ding bereits eimal von Grund auf neu konfiguriert hast und das Problem immer noch da war.
Ich hatte auch schon einen ähnlichen Effekt. CF Karte getauscht und das Problem war weg.
@aqui. Ich wäre daran interessiert zu erfahren wie drauf kommst, dass dies ein Amok laufender Prozess ist.
Persönlich bleibe ich dabei, dass ein remote Zugang mit SSH zwar bequem ist aber aus Sicherheitsgründen weggelassen sein sollte.
Bitte warten ..
Mitglied: aqui
22.04.2014, aktualisiert um 11:28 Uhr
wie drauf kommst, dass dies ein Amok laufender Prozess ist.
Du hast Recht... Das ist es ganz sicher nicht, eher eine kaputte Datei. Mir fehlte in der Hektik die richtige Formulierung
dass ein remote Zugang mit SSH zwar bequem ist aber aus Sicherheitsgründen weggelassen sein sollte.
Darum geht es auch gar nicht und du hast wieder mal nicht richtig gelesehn.
In der Sache hast du Recht keine Frage aber die pfSense bietet am Gerät selber einen physischen seriellen RS232 Zugang per Terminal (PuTTY, TeraTerm, ZTerm) damit bekommt man "am Gerät" Shell Zugriff und kann das Problem schnell fixen.
Das SSH besser aus sein sollte bei einer FW ist klar aber abgesehen davon stellt sich auch auch diese Problematik ja bei der Monowall gar nicht erst weil sie auch das nicht zur Verfügung stellt.
Bitte warten ..
Mitglied: mrtux
30.04.2014, aktualisiert 28.06.2014
Hi!

Die Konfigdatei direkt zu bearbeiten war zwar etwas umständlich aber brachte letztendlich die Lösung und seitdem läuft das CP der Mono wieder ganz wie gewohnt. Danke euch beiden für eure Anworten und eure Unterstützung!

mrtux
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Windows Server
gelöst Windows 2012 R2 - Remotedesktop-Dienste defekte Sammlung entfernen (12)

Frage von Synchro zum Thema Windows Server ...

Batch & Shell
gelöst Windows 7: Problem mit CP in Batch (3)

Frage von Maik87 zum Thema Batch & Shell ...

Festplatten, SSD, Raid
gelöst Defekte HDD, realistischer Aufwand für Datenrettung? (52)

Frage von Androxin zum Thema Festplatten, SSD, Raid ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...