Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Dell PowerEdge R200 Energiehungrig, langsam und laut?

Frage Hardware Server-Hardware

Mitglied: Ignazius

Ignazius (Level 1) - Jetzt verbinden

05.03.2010, aktualisiert 14:26 Uhr, 10602 Aufrufe, 4 Kommentare

DELL Server verbraucht fast doppelt so viel Energie und ist fast nur halb so schnell wie ein vergleichbares OEM Serversystem?!

Ich habe vor einigen Tagen aufgrund eines "Sonderangebots" bei DELL einen PowerEdge R200 mit einer Intel E5400 CPU, 2GB ECC RAM und einer 250GB WD SATA HDD erstanden. Es handelt sich um den ersten Server, den ich von DELL habe. Da ich einige Wochen zuvor bereits einen anderen 1HE Server ähnlichen Typs bei einem lokalen Händler erstanden hatte dachte ich, dass ich in etwa weiß was mich in Sachen Leistung und Stromverbrauch erwartet.

Beim Anstecken des DELL-Servers hat mein Energiemessgerät mich mit 33W begrüßt - dabei lief der Rechner nicht mal, nur die Lüfter des Netzteils - was eine Eigenart des PowerEdge zu sein scheint. Nach dem tatsächlichen Einschalten des Systems lag die Leistung dann nach einigen Minuten im Idle-Zustand an der Linux-Console bei 101Watt bei im Schnitt 82% Effizienz (ohne mitgeliefertem DVD-Laufwerk). PowerSaving im "BIOS" des DELLs ist aktiviert.

Der Vergleichsserver hat im Gegensatz zum Dell-Server statt dem Intel E5400 einen E5300, statt 2x1GB ECCRAM nur 1x2GB RAM, eine 2,5" Festplatte statt einer 3,5" Festplatte und hat eine Leistungsaufnahme von grade mal 40W idle.

Wenn ich die 17W, die die beiden Föns im DELL benötigen abziehe, ebenso wie die Festplatte, klafft hier imho immer noch eine große Differenz von grob 40W, die ich mir nicht erklären kann. Ich hätte gerne bei DELL nachgefragt, jedoch ist mein "ServiceTag" noch nicht freigeschaltet...

Eigentlich wollte ich mich schon damit abfinden bis ich ein größeres mit bzip2 komprimiertes TAR-File entpackt habe, was gefühlt ungewöhnlich lange dauerte. Ich habe dann die Zeit zum entpacken des aktuellen Linux-Kernels auf beiden Maschinen vergleichen. Eigentlich sollte der DELL dank etwas schnellerer CPU gleichen Typs, zwei Speicherriegeln statt einem und besserer Festplatte etwas schneller sein, jedoch:

01.
time tar jxf linux-2.6.33.tar.bz2  
02.
DELL: real    0m50.239s, user    0m43.743s, sys     0m3.784s 
03.
OEM: real    0m38.368s, user    0m32.610s, sys     0m2.920s
Daraufhin habe ich noch mit bc etwas gerechnet:

01.
time echo "scale=10000; 4*a(1)" | bc -l 
02.
DELL: 7m5.462s 
03.
OEM: 4m56.456s
Dieser Performance-Unterschied kann doch nicht alleine ECC geschuldet sein - es sind immerhin gute 40% Differenz zugunsten des OEM-System trotz der stärkeren CPU. Macht mich neugierig.

Jemand eine Erklärung oder Denkanstoß für mich?
Mitglied: DerWoWusste
05.03.2010 um 14:38 Uhr
Hi.
Wie sieht es denn mit der Taktung der Cores aus?
Bitte warten ..
Mitglied: Ignazius
05.03.2010 um 14:55 Uhr
Beide laufen auf 100%, sprich im Linux-Kernel ist derzeit kein cpufreq aktiviert. Somit liegt der 5300 bei 2,6GHz, der 5400 läuft auf 2,7GHz.
NB: Lade ich acpi-cpufreq und die CPU wird auf 1,2GHz getaktet tut sich verbrauchsmäßig übrigens nichts beim DELL-Server, nach wie vor 101W bei 82% Eff.
Bitte warten ..
Mitglied: DerWoWusste
05.03.2010 um 15:16 Uhr
Kann ich mir nicht erklären. Ich würde auch noch einmal die Größe des L2 Caches vergleichen.
Vielleicht auch nochmal unter einem Windows-OS testen.
Bitte warten ..
Mitglied: Ignazius
11.03.2010 um 12:18 Uhr
Danke, L2 Größe nicht, sondern Geschwindigkeit brachte mich dann doch etwas dem Problem näher. Folgendes habe ich bei einem Vergleich der beiden Server mit memtest86+ festgestellt:

memtest86+ in Version 1.7 meldete beim DELL-Server einen CPU-Speed von 2700MHz (und deutlich niedrigere L-Cache-Speedwerte als beim OEM-System), Version 4.0 meldet hingegen einen CPU-Speed von 1200MHz. Was mich wieder auf eine zu niedrige die Taktung der CPU verwies.

Im BIOS des DELLs gibt es die Option "Demand Based Power Management" unterhalb des Menüpunkts "CPU Information Screen". Diese stand beim Test des Eingangsposts auf "Enabled". Mit dieser Option brachte /proc/cpuinfo OHNE acpi-cpufreq bspw.

01.
dell:~# cat /proc/cpuinfo | grep -E -e "^(cpu\ MHz|model\ name)"    
02.
model name      : Pentium(R) Dual-Core  CPU      E5400  @ 2.70GHz 
03.
cpu MHz         : 2700.000 
04.
model name      : Pentium(R) Dual-Core  CPU      E5400  @ 2.70GHz 
05.
cpu MHz         : 2700.000
und die oben beschriebene schlechte Performance (trotz hohen Energieverbrauchs). Aufgrund der obigen Ausgabe (+dmesg) ging ich davon aus, dass die CPU mit voller Leistung läuft.

Ich habe daraufhin erneut "Demand Based Power Management" im BIOS deaktiviert und siehe da, die Performance ist erheblich gestiegen, so ist die obige PI-Berechnung 6 Sekunden schneller als beim OEM-System (dank der besseren CPU). Stromverbrauch im Idle: 2W mehr .. dürfte im Bereich der Messtoleranz meines Equipments liegen. "/proc/cpuinfo" meldet exakt dasselbe wie mit dieser BIOS-Option aktiviert (s.o.)

modprobe acpi-cpufreq meldet nun jedoch: No such device. Aktiviere ich nun wieder die BIOS-Option und lade acpi-cpufreq habe ich die erwartete Leistung und dennoch die Möglichkeit des Powermanagements.

Fazit: Vertraue nicht der Ausgabe von /proc/cpuinfo. Leider ist der Energiehunger des Systems immer noch sehr hoch im Vergleich zu dem OEM-System.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Festplatten, SSD, Raid
DELL PowerEdge T630, RAID1 auf PERC S130 CONTROLLER, Festplattentausch (14)

Frage von EdisonHH zum Thema Festplatten, SSD, Raid ...

Windows Server
Dell Poweredge T20 Hardwaremonitoring (2)

Frage von CortexA8 zum Thema Windows Server ...

Server-Hardware
gelöst Dell Poweredge 600 SC Chassis Fan Fehlererkennung ausschalten geht das? (4)

Frage von TechnoX zum Thema Server-Hardware ...

LAN, WAN, Wireless
gelöst Netzwerkkarte am Ort A schnell und am Ort B langsam (8)

Frage von dressa zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...

Windows Tools
gelöst Aussendienst Datensynchronisierung (12)

Frage von lighningcrow zum Thema Windows Tools ...