Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Denkfehler?!

Frage Microsoft Windows Server

Mitglied: bangboomben

bangboomben (Level 1) - Jetzt verbinden

30.03.2012 um 00:53 Uhr, 4101 Aufrufe, 6 Kommentare

Da ich noch relativ neu auf dem Gebiet Administration eines W2k8R2 bin habe ich wohl einen ziemlichen Denkfehler bzgl. DNS-Server Konfiguration.

Liebe Community,

z.Z. befindet sich die Enterprise Version von Windows Server 2008 R2 auf einem kleinen Server bei mir Zuhaus.
Die Installation etc. hat tadellos funktioniert.

Nachdem ich, wie in nahezu jeder Anleitung beschrieben, den Befehl "dcpromo" ausgeführt habe um AD + DNS-Server zu installieren habe ich den DNS-Server auch entsprechend konfiguriert.
Soll heißen "nslookup" funktioniert in jegliche Richtung. Mich irritiert jetzt zweierlei:

Best-Prac-Analyzer spuckt folgendes aus:

Titel:
DNS: DNS-Server für LAN-Verbindung sollten die Loopbackadresse enthalten, jedoch nicht als ersten Eintrag.
Schweregrad:
Fehler
Datum:
30.03.2012 00:41:28
Kategorie:
Konfiguration
Problem:
Der Netzwerkadapter LAN-Verbindung listet die IP-Loopbackadresse nicht als DNS-Server auf oder sie ist als erster Eintrag konfiguriert.


kann mit dieser Fehlermeldung leider wenig bis gar nichts anfangen.
Meine "LAN-Verbindung" ist so konfig. dass der Server eine feste IP hat und als DNS-Server
als 1. IP die 127.0.0.1 und als 2. IP die des Server drinn steht. Liegt da vll. schon der Hund begraben?

Darüber hinaus, lese ich in fast jedem Tutorial auch, dass man einen 2. DC anlegen muss. (warum überhaupt?!)
Wenn ich dies wie gewohnt über den Befehl "dcpromo" versuche, kann ich nur den bereits vorhanden wieder deinstallieren, aber keinen weiteren hinzufügen.
Hat das vll. auch was damit zu tun, dass hier im Hausnetz noch einen Router gibt der vor dem Server kommt?


Über Hilfe würde ich mich sehr freuen.

Greetz

Ben
Mitglied: hmarkus
30.03.2012 um 01:11 Uhr
Zitat von bangboomben:
das
Problem:
Der Netzwerkadapter LAN-Verbindung listet die IP-Loopbackadresse nicht als DNS-Server auf oder sie ist als erster Eintrag
konfiguriert.
und das
Meine "LAN-Verbindung" ist so konfig. dass der Server eine feste IP hat und als DNS-Server
als 1. IP die 127.0.0.1 und als 2. IP die des Server drinn steht. Liegt da vll. schon der Hund begraben?
ist wohl das Problem, also die Loopbackadresse 127.0.0.1 sollte nicht als 1. Adresse auftauchen. So verstehe ich die Fehlermeldung.

Darüber hinaus, lese ich in fast jedem Tutorial auch, dass man einen 2. DC anlegen muss. (warum überhaupt?!)
weiß ich auch nicht, sollte nicht nötig sein. Oder meinst Du einen zweiten DNS-Server?
Wenn ich dies wie gewohnt über den Befehl "dcpromo" versuche, kann ich nur den bereits vorhanden wieder
deinstallieren, aber keinen weiteren hinzufügen.
Ein zusätzlicher DC bedeutet einen zweiten Server der dann auch hochgestuft wird.
Hat das vll. auch was damit zu tun, dass hier im Hausnetz noch einen Router gibt der vor dem Server kommt?
was meinst Du? bezogen auf DNS ist es so, wenn Dein Router im Netz der DNS-Server ist, dann musst Du (wenn der DC auch Adressen aus dem Internet auflösen soll) dem DC die Adresse des Routers als DNS-Server einstellen.
Der DC, bzw die AD-Domäne hat mit dem Router eigentlich nix zu tun, außer das der Router dafür sorgt, dass eine Verbindung nach draußen besteht. Du musst natürlich darauf achten, dass der DC keine Funktionen übernimmt, die der Router schon hat, also beispielsweise DHCP-Server.

Markus
Bitte warten ..
Mitglied: danielfr
30.03.2012 um 01:12 Uhr
DNS: DNS-Server für LAN-Verbindung sollten die Loopbackadresse enthalten, jedoch nicht als ersten Eintrag.
...
als 1. IP die 127.0.0.1 und als 2. IP die des Server drinn steht. Liegt da vll. schon der Hund begraben?
127.0.0.1 ist ja die Loopbackadresse und bei Dir als ersten Eintrag. Also ja, da liegt der Hund begraben.

Darüber hinaus, lese ich in fast jedem Tutorial auch, dass man einen 2. DC anlegen muss. (warum überhaupt?!)
Der 2. DC muss auf einen eigenen Server! Den zweiten braucht man wg. Ausfallsicherheit. Wenn der erste mal ausfällt verrichtet der 2. DC halt seinen Dienst, da der DC extrem wichtig ist (ohne geht im MS Netz nix) wird immer empfohlen einen zweiten DC einzurichten. Zum testen und in kleinen Netzen wird trotzdem oft nur einer benutzt.

Gruß Daniel
Bitte warten ..
Mitglied: keine-ahnung
30.03.2012 um 08:54 Uhr
Moin,

ja definitiv: ein zweiter DC im Heimnetzerk wird Schwerpunktthema auf der CEBIT 2013 .

LG, Thomas
Bitte warten ..
Mitglied: bangboomben
30.03.2012 um 18:18 Uhr
Habe nun zweierlei probiert:

beim Router den DNS-Server eingetragen:
als 1.IP die vom Server und als 2. wollte ich die 127.0.0.1 allerdings schluckt die mein Router nicht.

wenn ich es mit der 8.8.8.8 versuche (als 2. IP) spuckt mir der dns server total viele Fehler aus, im gegensatz zu der 127.0.0.1 -aber die kann ich ja wiederum nicht bei meinem router eintragen -.-*
Bitte warten ..
Mitglied: danielfr
30.03.2012 um 18:42 Uhr
Auf dem Router muss gar nichts eingetragen werden... erst recht nicht 127.0.0.1, der bleibt wie er ist. Das gehört nur auf den Server selbst. Nach welcher Anleitung richtest Du Dich denn? Klingt etwas durcheinander.
Bitte warten ..
Mitglied: bangboomben
31.03.2012 um 15:06 Uhr
hab jetzt im Router trotzdem die IP vom DNS server stehen lassen und soweit funktioniert ja auch alles (Dömäne AD etc.)
denn egtl. habe ich jetzt gar kein problem, weil es funktioniert ja alles, aber die Fehlermeldungen irritieren mich halt :x

http://s7.directupload.net/file/d/2846/meypg9ps_jpg.htm

und ja, das klingt nicht nur durcheinander, sondern ist es auch )
ich schau mal hier in ein tutorial rein
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Datenbanken
Kleiner Denkfehler in einem social Network (2)

Frage von Yanmai zum Thema Datenbanken ...

Datenbanken
ORACLE - MERGE Abfrage mit Denkfehler? (3)

Frage von Chillministrator zum Thema Datenbanken ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...