Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

DFÜ und LAN Verbindung gleichzeitig verwenden

Frage Microsoft Windows Netzwerk

Mitglied: Joerg18470

Joerg18470 (Level 1) - Jetzt verbinden

06.05.2011 um 00:54 Uhr, 8591 Aufrufe, 15 Kommentare

Es gibt zwar schon genug ähnliche Fragen, doch leider fand ich in den Antworten keine für mich passende Lösung.

Ich habe ein Steuergerät welches Maschinen überwacht. Dieses besitzt nur eine COM1 Schnittstelle, ( KEIN RJ45 ) an diesem Gerät kann ich direkt eine feste IP einstellen. Jetzt habe ich eine Art Remote-Server mit ins Netz eingebracht, sodaß man via Fernzugriff auf dieses Gerät zugreifen kann. Jetzt kommt der ähnliche Teil meiner Vorfrager, ich bekomme per Wählverbindung auf das Gerät das Webinterface auf dem Explorer zu Gesicht, über das ich auch die Einstellungen darauf vornehmen kann, nur leider wird die LAN-Verbindung getrennt und man bekommt diese nur durch einen Neustart wieder zum laufen, wodurch allerdings dann die Wählverbindung zum Gerät wieder weg ist. Da ich aber aus der Ferne auf dieses Gerät zugreifen möchte brauche ich beide Verbindungen gleichzeitig. Auf diesem Remote-Server gibt es noch andere solche Dienste, welche aber alle über DSL funktionieren und teilweise über eigene Software verfügen oder einige nutzen auch den Explorer, sodas ich nicht sagen kann der Explorer ist nur für dieses Gerät zuständig. Die Fernverbindung wird über Teamviewer gelöst. Natürlich säge ich mir ja dann den Ast weg auf dem ich sitze, wenn ich via Teamviewer eine Wählverbindung aufbauen würde. Das Betriebssystem ist Vista und die IP der Wählverbindung liegt im Adressbereich der anderen Netzwerkteilnehmer. Ich hoffe ihr könnt mir irgendwie weiter helfen.
Vielen Dank schon mal für Eure investierte Zeit !
Mitglied: mrtux
06.05.2011 um 03:58 Uhr
Hi !

Also ich hab mir das jetzt mehrmals durchgelesen....Aber sorry ich versteh nix, trotz der Tatsache, dass ich schon einige Industriemaschinen (CAD/CAM und Laserschneidmaschinen) an Netzwerke angebunden habe...

Wie stellst Du an dem Steuergerät eine IP-Adresse ein, wenn es doch nur eine serielle Schnittstelle (z.B. RS-232, RS-422 oder RS-485) hat? Ich vermute Du stellst die IP der Wählverbindung ein, nicht am Steuergerät...Was verstehst Du unter "einer Art" Remote Server"? Einen PC? Mach mal eine Zeichnung, vielleicht verstehe ich es dann....

mrtux
Bitte warten ..
Mitglied: Lochkartenstanzer
06.05.2011 um 07:36 Uhr
Ich schau mal in meine Kristallkugel und sehe folgendes:

Due hast einen Rechner, der über Ethernet mit deinem LAN verbunden ist und über eine seriellen Modem mit einer Maschine, die es zu steuern gilt. Die serielle Verbindung nutzt TCP/IP über PPP:

Sobald die IP-Verbindung über COM1 aufgebaut wird, wird dir andere Verbindung unterbrochen:

Ich tippe mal, da hat einer nicht auf die default-route, nameserver, etc, geachtet und verstellt diese mit Durchwahl zu der Maschine.

- moment - da kommt grad eine neuen Nachricht auf der Kristallkugel rein:

...

...

...

Vielleicht ist das ja Absicht, damit man sich nicht eine offene Hintertür ins LAN schafft und damit die Firewall umgeht.

So, jetzt ist meine Kristallkugel aus.
Bitte warten ..
Mitglied: aqui
06.05.2011 um 08:21 Uhr
.Lochkarte hat aber Recht. Das kann nur an einer Fehlkonfiguration des Rechners liegen. Falsche IP Adressierung, falsche Maske, überlappende IP netze oder was auch immer.
Der PPP Anschluss über die serielle COM Schnittstelle sieht das System wie eine weitere IP Schnittstelle.
Wenn sauber konfiguriert funktioniert das einwandfrei in Verbindung mit einem LAN Port. Sogar in verbindung mit 2 und mehr LAN Ports.
Du solltest also deine Konfig checken. Irgendwo hast du da unter Garantie etwas falsch konfiguriert !
Ohne weitere Details dazu bleibst hier aber bei der Kristallkugel und raten....
Bitte warten ..
Mitglied: brammer
06.05.2011 um 09:24 Uhr
Hallo,

zusätzlich zur Kristallkugel und den fehlenden Informationen frage ich mich wieso du nicht eine VPN Verbindung per DSL (anscheinend ja bereits vorhanden..) nimmst sondern zusätzlich noch ein Wählverbindung nutzt.
Das ist uneffektiv, teuer, aufwendig Fehleranfällig und hat keinerlei Vorteile.
Ich vermute mal das du irgendwo ein bisschen vielan Gateways eingestellt hast.

Ansonsten kann ich nur das empfehlen was bereits angedeutet wurde: Mehr Informationen (Screneshots und IP Adressen, Netzmaske,Gateway ...) und ein Bildchen wäre gut.

brammer
Bitte warten ..
Mitglied: Joerg18470
06.05.2011 um 10:30 Uhr
Lochkarte, du könntest da schon irgendwie den Finger drauf haben. Wo stelle ich unter Vista bei einer Wählverbindung die default Route sowie den DNS-Server ein? Bin sonst immer mit Suse unterwegs, sorry...
Die IP die Subnetzmaske und alles andere muß ja stimmen, sonst könnte ich ja nicht auf das Webinterface dieses Gerätes zugreifen.
Das Gerät hat eine RS-232 Schnittstelle und an diesem kann ich die IP mittels eigenem kleinen Menü festlegen, was fehlen da jetzt noch für Informationen ?????
Dieses Gerät ist ein Überwachungssystem welches permanent Temperaturen überwacht, wenn diese aus dem Toleranzbereich gehen, schaltet ein Alarmkontakt der wiederum auf ein Wählgerät geht und meldet eine Störung an ein bestimmtes Telefon oder Handy. Dann sollte es gehen das man auf Grund einer Störung sich auf dem Teil einwählt und entsprechende Konfigurationen vor nimmt.
Dieses Gerät ist ein Klimacomputer ( Stuhl und Regelsysteme ) http://www.stuhl.com/de/catalog/sheets/79138l.pdf
Für mich steht zu 99,9% fest das ich in der Konfig der Wählverbindung einen Fehler habe. Nur wo ?
Bitte warten ..
Mitglied: Lochkartenstanzer
06.05.2011 um 12:13 Uhr
Zitat von Joerg18470:
Für mich steht zu 99,9% fest das ich in der Konfig der Wählverbindung einen Fehler habe. Nur wo ?

Wie wäre es, wenn Du an die Maschine läufst und mehrmals ipconfig/all machst, je nachdem,. ob die Verbindung aufgebaut ist oder nicht und uns die Ergebnisse mitteilst. Die Ausgaben von netstat -r wären auch nicht schlecht. Eine Skizze (notfalls auch in ASCII) wäre nicht auch hilfreich. Meine Kristallkugel habe ich nämlich gerade an einen Kollegen verliehen.
Bitte warten ..
Mitglied: mrtux
06.05.2011 um 22:04 Uhr
Hi !

Zitat von aqui:
Der PPTP Anschluss über die serielle COM Schnittstelle sieht das System wie eine weitere IP Schnittstelle.

Ooops...An "PPTP over serial" habe ich in dem Moment nicht gedacht, das ist natürlich möglich, kein Thema! Es fehlen aber trotzdem noch Infos....

mrtux
Bitte warten ..
Mitglied: aqui
06.05.2011 um 22:18 Uhr
@mrtux
Sorry mrtux es sollte natürlich PPP heissen und natürlich nicht PPTP. ist oben korrigiert.
Ansonsten den Tip von Lochkarte befolgen und posten hier...
Bitte warten ..
Mitglied: Joerg18470
06.05.2011 um 23:50 Uhr
Vielen Dank vorerst, kann nur gerade nicht an die Maschine, ist ja Wochenende. Werde selbstverständlich eure super Tips wie z.B. das Netstat probieren und wenn ich es nicht selbst dadurch schon in Griff bekomme, euch die Daten hier posten. Bei Erfolg werde ich das euch natürlich auch zusammen mit der Lösung wissen lassen, bis dahin wünsch ich euch allen ein schönes Wochenende.
Bitte warten ..
Mitglied: Joerg18470
13.05.2011 um 21:33 Uhr
Habe die Lösung gefunden. Das problem liegt darin das man das Standardgatway nicht auf das des normalen Netzwerkes legen kann (Router), da die Wählverbindung PPP und das Netz TCP/IP ist. Somit brauche ich einen Adapter der mir die RS232 Schnittstelle auf RJ45 umsetzt. Dieses funktioniert mit
http://www.integrate-computer.de/epages/61416610.sf/?Locale=de_DE&O ...
diesem Gerät hoffe ich gut. Somit kann ich dem Gerät eine ganz normale Netzwerkadresse zuordnen als wäre es ein Teilnehmer des gleichen Netzes.
Vielen Dank für eure mitgebrachte Zeit.
Bitte warten ..
Mitglied: aqui
14.05.2011 um 12:59 Uhr
In Bezug auf PPP ist diese Aussage technisch vollkommen falsch. PPP ist eine IP Point zu Point Verbindung mit einer 32 Bit Maske und funktioniert natürlich auch zusammen mit einem Gateway auf dem LAN Interface.
Essentiell wichtig ist die korrekte IP Adressierung des PPP Interfaces, das sich IP seitig NICHT mit dem LAN Netz überschneiden darf.
Das ist das einzig wichtige...nicht mehr und nicht weniger und dann funktioniert so ein Link problemlos mit einem LAN und natürlich dem Standardgateway dort zusammen.
Wenn du dich einmal an die seligen Zeiten von PPP Einwahlen beim Internet Provider mit analogen Modems über die serielle COM Schnittstelle zurückerinnerst zeigt diese Praxis das das schon immer koexistierte, denn diese PPP Verbindung konnte man immer per NAT/ICS im LAN freigeben. Analog dazu Firmen PPP Dialins ins lokale Firmen LAN zur Fernwartung.
Beide Designs bzw. Verfahren waren millionenfach so im Einsatz und entsprechen exakt deinem oben.
Fazit: Du hast schlicht und einfach diesen PPP Link fehlerhaft konfiguriert. Wie auch immer, da bis dato detailierteer Infos hier fehlen und wir nur raten können

Deine Metallbox von oben ist ein simpler RS-232 Wandler auf Ethernet. Was der macht ist die Daten der seriellen Schnittstelle in ein Ethernet Paket zu packen und über ein LAN zu übertragen und am anderen Ende wieder auszupacken sofern du dort wieder serielle Daten benötigst.
Nichts anderes also als ein simpler Medienwandler für die serielle RS-232.
Seriele PPP Pakete in Ethernet IP umzuwandlen kann der also de facto nicht , denn das wäre eine komplette Protokollwandlung von PPP in IP !
Wenn du das erwartest wirst du wieder Schiffbruch erleiden mit deinem Vorhaben !
Bitte warten ..
Mitglied: Joerg18470
15.05.2011 um 16:17 Uhr
Was du da schreibst ist mir einleuchtend. Da ich nur sehr selten an diesem Rechner bin kann ich die Daten nur schwer beschaffen. Werde mal im folgenden die Topologie aus dem mir bekannten Wissen jetzt posten.

Internet -------> Router ------->
Rechner --------> Roboter Steuerung
|
|---------------> Wählverbindung ------> SC2000 ( Klimasteuergerät )

Vom Internet aus wird via Teamview eine Verbindung aufgebaut zum Rechner, welchen ich jetzt mal als Remote Server nenne, da er nur die Verbindung vom Internet aus ermöglicht um auf die verschiedenen Anwendungen zugreifen zu können. Von diesem Rechner aus kann man via IP das Interface der Roboter Steuerung anzeigen. ( Dieses funktioniert Problemlos ) Jetzt möchte ich von diesem Rechner zusätzlich noch eine Wählverbindung zu dem SC2000 aufbauen. Wenn ich vor dem Rechner sitze kann ich diese Wählverbindung auch problemlos aufbauen und habe dann auch das Interface dieses Gerätes auf dem Monitor. Soweit klappt das alles prima, aber wenn diese Wählverbindung steht habe ich kein Internet mehr.
Mache ich einen Ping auf :
- 192.168.2.10 [das SC2000] = OK ( ist an diesem Gerät selbst nur fest einstellbar )
- 127.0.0.1 = OK
- 192.168.2.11 [eigener Rechner] = OK
- 192.168.2.1 [Router] = OK
- 209.85.148.95 [Google] = Zeitüberschreitung, also nicht OK
Die Adressen sind statisch vergeben, könnte sie zwar auch via DHCP einstellen, aber da ändert sich an der Problematik auch nichts.

Muß ich bei den PPP Einstellungen den Haken für " Mehrfachverbindungen für Einzelverbindungen aushandeln " setzen ? Zur Zeit ist er nicht gesetzt.
Unter Netzwerk der Wählverbindung habe ich bei TCP/IPv4 in den Eigenschaften " Sandartgateway für das Remote Netzwerk verwenden " den Haken gesetzt, Metrik auf Auto (sollte io sein ) und ppp-link verwendet Haederkomprimierung.
Für den DNS-Server habe ich die IP des Routers zum ersten und den Telekom DNS zum zweiten angegeben. Ob Automatisch über DHCP oder statisch bringt keine Änderung (sollte in diesem Fall ja auch egal sein )
Unter dem Reiter Freigabe habe ich die Verbindung frei gegeben und die Verbindung Teamview eingestellt. Den Haken bei " eine Wählverbindung herstellen wenn ein Computer im Netzwerk auf das Internet zugreift " habe ich nicht gesetzt, da ich ja mit dieser Verbindung nicht auf das Internet zugreifen möchte. Alle anderen Einstellungen habe ich so belassen wie sie waren.
Ein tracert -d brachte natürlich nichts, wie du siehst sind die Ping Angaben denke ich mal Aussagekräftig genug.
Unter ipconfig -all kommen zu viele Einträge um sie hier alle rein zu posten, da stehen 38 Netzwerkadapter drin, die wie ich es mir erlesen habe nur vom Vista selbst her rühren. Was mir dabei spanisch vor kam war, das bei der Wählverbindung die IP = 0000 und die Subnetzmaske 255.255.255.255 ( also der Rundspruch ) war. Aber das sollte bei dieser Verbindungsart nicht ganz so relevant sein. Alle anderen Ausgaben waren soweit ich das gesehen habe in Ordnung, es wurden die korrekten IP Adressen für die für mich interessanten Adapter angezeigt, die Subnetzmasken waren auch richtig ( also 255.255.255.0 ). Einzig die vielen Tunneladapter habe ich mir nicht angeschaut. ( Das waren echt zuviele von denen ich denke das sie nicht von Interesse sein sollten.
Im Router sollte ich nichts ändern müssen da ja Teamview alles über den sowieso offenen Port 80 abwickelt.
Vielleicht kann ja diese grobe Beschreibung dir helfen, die Glaskugel noch mal zum aufleuchten zu bekommen
Würde euch gern mehr sagen, aber mehr Details hab ich jetzt nicht im Kopf. Vielleicht könnte man ja schonmal dadurch zu einer Eingrenzung des Fehlers kommen. Ich werde irgendwie den Gedanken nicht los das da nur eine kleine Einstellung irgendwo fehlt, oder ich da einen Gedankenfehler habe.
Du hast geschrieben das sich die IP Adressierung NICHT mit dem LAN Netz überschneiden darf. Wie darf ich das verstehen ? Möchtest du damit sagen das diese IP des SC2000 nicht in den Netzwerk Adressen Bereich des normalen Lans liegen darf ? Also Subnetting anwenden ?
Bitte warten ..
Mitglied: Lochkartenstanzer
16.05.2011 um 02:17 Uhr
Zitat von Joerg18470:
- 192.168.2.10 [das SC2000] = OK ( ist an diesem Gerät selbst nur fest einstellbar )
- 127.0.0.1 = OK
- 192.168.2.11 [eigener Rechner] = OK
- 192.168.2.1 [Router] = OK
- 209.85.148.95 [Google] = Zeitüberschreitung, also nicht OK

Da ist schon das Problem:

Da sind identische Netze eingestellt. Die PPP-Verbindung sollte ein anderes netz als 192.168.2.0/24 haben.
Bitte warten ..
Mitglied: Joerg18470
10.06.2011 um 18:35 Uhr
VIELEN DANK !!!
Stanzer Deine Antwort war die richtige Lösung. Bin leider erst heute nochmal an den Rechner gekommen und habe die IP an dem Gerät geändert in 192.168.3.10. Zuerst hat sich das System zwar gewehrt und wollte keine Änderung zeigen, dann so zwei - drei Zigarettchen später das gleiche nochmal versucht und siehe da, es klappte. Also die Lösung lag wie du schon schriebst in der Netzwerkadresse die einfach nur in diesem Bereich des allgemeinen LAN lag.
Man sieht das es hier Leute gibt die ihr Handwerk verstehen....Danke...
Bitte warten ..
Mitglied: aqui
10.06.2011 um 19:57 Uhr
Na ja ...es wurde hier im Thread mehrfach auf eine korrekte IP Adressierung deiner Adapter hingewiesen weil das häufig eine Fehlerquelle ist hier, wobei korrekt natürlich die IP Netze der entsprechenden Segmente meint.
Ein simpler Standardgrundsatz im TCP/IP das IP Netze einzigartig sein müssen und jeder Praktikant kennt.
Gut aber wenns nun klappt...wie immer: kleine Ursache grosse Wirkung.
Bitte warten ..
Neuester Wissensbeitrag
Festplatten, SSD, Raid

12TB written pro SSD in 2 Jahren mit RAID5 auf Hyper-VServer

Erfahrungsbericht von Lochkartenstanzer zum Thema Festplatten, SSD, Raid ...

Ähnliche Inhalte
Voice over IP
LAN zu Lan Verbindung VOIP (4)

Frage von Gunnar2100 zum Thema Voice over IP ...

Router & Routing
VPN in LAN-LAN Verbindung zwischen zwei Fritzbox-Netzwerken in DMZ (3)

Frage von Molar88 zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...