Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

DHCP Discover mit mehreren Wlan APs

Frage Microsoft Windows Netzwerk

Mitglied: geforce28

geforce28 (Level 1) - Jetzt verbinden

04.01.2015, aktualisiert 09.01.2015, 1645 Aufrufe, 33 Kommentare

Hallo Leute,

ich habe in meinem Heimnetz 3 Asus AC-RT68U als Accesspoints konfiguriert. (AP-Modus)
Diese sind alle direkt per Kabel ins Netzwerk angebunden.

DHCP und DNS macht ein Windows Server 2012 R2 Server.

Mein Problem ist nun, welches relativ sporadisch auftritt:
Ein Gerät verbindet sich im Wlan aber bekommt kein DHCP Lease.
Ich mache das Wlan am Gerät wieder aus und wieder an und sofort ist das DHCP Lease auch da.

Das Problem tritt definitiv nur im WLAN auf. Über LAN sind immer direkt die DHCP Leases da, keine Probleme.

Jetzt habe ich die Frage wo das Problem liegen könnte.
Kann ich irgendwo einen DHCP Relay Server angeben? Beim Asus AC-RT68U kann man es auf jeden fall nicht eintragen.

Liegt es vielleicht daran, dass DHCP Discover nicht korrekt funktioniert ?

Wenn ihr noch mehr Info's zu meiner Konfiguration braucht, lasst es mich wissen.. .
33 Antworten
Mitglied: Pjordorf
05.01.2015 um 05:23 Uhr
Hallo,

Zitat von geforce28:
Ein Gerät verbindet sich im Wlan aber bekommt kein DHCP Lease.
Was sagt der DHCP Server, bekommt der die Anfrage? Geht eine Antwort auch dort raus? Bekommt der AP auch das Antwort Paket und leitet es über sein WLAN Radio weiter? All das kann dir auch ein Wireshark sagen, oder gar deine Switche....

Jetzt habe ich die Frage wo das Problem liegen könnte.
Am AP.

Kann ich irgendwo einen DHCP Relay Server angeben?
Warum? Was soll das bringen? Du hast doch nur ein Netz und keine weiteren Router in andere Netze....

Liegt es vielleicht daran, dass DHCP Discover nicht korrekt funktioniert ?
Was bringt dich auf diese Idee nachdem DHCP schon Jahrzehnte läuft? Aber ein Wireshark oder die Protokolle deines DHCP Servers sagen es dir.

Gruß,
Peter
Bitte warten ..
Mitglied: aqui
05.01.2015 um 08:58 Uhr
ich habe in meinem Heimnetz 3 Asus AC-RT68U als Accesspoints konfiguriert. (AP-Modus)
WIE hast du das gemacht ??
Richtig ist die Verschlatung wie es hier in der Alternative 3 aufgeführt ist:
http://www.administrator.de/wissen/kopplung-von-2-routern-am-dsl-port-4 ...
Wenn du strikt danach gegangen bist (WAN Port unbeschaltet) und es richtig gemacht hast, dann hat sich auch dein Problem mit den DHCP Broadcasts gleich erledigt !
Bitte warten ..
Mitglied: colinardo
05.01.2015, aktualisiert um 09:35 Uhr
Hallo GeForce,
Ich mache das Wlan am Gerät wieder aus und wieder an und sofort ist das DHCP Lease auch da.
wenn das so ist, kommen die Broadcasts ja auch am Client an. Ich vermute hier eher ein Treiberproblem der Netzwerkkarte, wenn du die Karte per Hardware-Schalter kurz aus und wieder einschalten musst. Hatte ein ähnliches Phänomen damals bei Fujitsu Siemens Lifebooks, die nach dem Standby keine IP mehr zugewiesen bekamen.
Check das mal ganz genau ab, nicht immer sind die Treiber der Chipsatzhersteller geeignet, manchmal passen die NB-Hersteller das etwas an, wie z.B. Dell das bei manchen Modellen gerne macht. In dem Fall dann zu den Treibern des NB-Herstellers greifen.

Auch gerne eine Ursache: Der Energiesparmodus der WLAN-Apapter, den du ebenfalls mal deaktivieren solltest um dies als Ursache auszuschließen.

Grüße Uwe
Bitte warten ..
Mitglied: geforce28
05.01.2015 um 11:01 Uhr
Hallo und danke für die Antworten!

Die Router laufen alle im Ap (Access Point) Modus, wie in der Anleitung beschrieben.

Ich sollte vielleicht erwähnen, dass es sich um Clients von Apple handelt. (hauptsächlich iphones, Ipad's und Macbooks)
Mit meinem Windows (Dell Notebook) habe ich das Problem über Wlan aber auch.

Mit Wireshark habe ich jetzt noch nichts analysiert, ist aber ne gute Idee...
Bitte warten ..
Mitglied: Pjordorf
05.01.2015 um 12:00 Uhr
Hallo,

Zitat von geforce28:
Ich sollte vielleicht erwähnen, dass es sich um Clients von Apple handelt. (hauptsächlich iphones, Ipad's und Macbooks)
Hatte da mal einen Preiswert AP (kein Router) der ebenfalls immer wieder mit iPxx teile genau das gleiche Verhalten zeigte. Nach neu starten des AP war jedes Mal es wieder eine Zeitlang OK. Ei iPhone 3G hatte zur gleichen zeit niemals Probleme. Die AP interne Bridge wollte irgendwann einfach nicht mehr und das obwohl die Clients z.B. FreeCom Radios 24/7 liefen. Auch bei den war dies verhalten zu beobachte. APs dort gegen Unifi UAP-Pro getauscht und seitdem bekommen alle IMMER ihre IP. Manchmal ist es doch einfach die Technik die uns narrt.

Die Teile mit dem i sind halt wählerischer als die ohne das i

Mit Wireshark habe ich jetzt noch nichts analysiert, ist aber ne gute Idee...
Hatte dort auch die APs als Fehlerquelle ermitteln lassen...

Gruß,
Peter
Bitte warten ..
Mitglied: geforce28
05.01.2015 um 12:29 Uhr
Das wäre echt schade, denn die AP's von Asus sind eigentlich echt gut (für den Heimbereich)
Und unterstützen sogar Features, wie Radius usw...
Bitte warten ..
Mitglied: Pjordorf
05.01.2015 um 12:35 Uhr
Hallo,

Zitat von geforce28:
die AP's von Asus sind eigentlich echt gut
Gut das du noch Platz für das Wort eigentlich hattest

Und unterstützen sogar Features, wie Radius usw...
Eine mindest Funktion, mehr nicht....

ruß,
Peter
Bitte warten ..
Mitglied: geforce28
05.01.2015 um 12:39 Uhr
Naja wenn du mal die Toplist bei Chip anguckst, also der Asus AC-RT68U ist überall ganz weit oben, aber du hast schon recht...

Blöd ist nur, dass das mit dem DHCP nicht vernünftig funktioniert...
Überigens: Wenn ich den Router neu starte funktioniert auch erstmal alles n halben Tag super !
Bitte warten ..
Mitglied: colinardo
05.01.2015, aktualisiert 06.01.2015
Zitat von geforce28:

Naja wenn du mal die Toplist bei Chip anguckst, also der Asus AC-RT68U ist überall ganz weit oben, aber du hast schon
recht...
Wenn du die Dinger mit Open(DD)-WRT betreibst dann sind sie annehmbar.

Gab hier schon mal einen Thread eines Users
der mit einem TP-Link TL1043ND ähnliche Probleme hatte, nur war bei diesem dann der WAN-Port nach einiger Betriebszeit tot. Nach dem Bespielen mit OpenWRT waren diese Kinderkrankheiten Geschichte, da es einfach an der Original-Firmware des Herstellers lag, die bei Multicast-Floods die Grätsche machte.

Wäre also mal einen Versuch Wert einen der AP umzuflashen, dann weist du was Sache ist.

Grüße Uwe
Bitte warten ..
Mitglied: geforce28
06.01.2015 um 13:06 Uhr
Joa, ein Versuch ist es Wert.
Ich suche nun schon seit knapp ner Stunde nach ner Anleitung / nach nem File womit ich OpenWRT flashen kann ?
Hast du da zufällig was parat für mich ?
Bitte warten ..
Mitglied: colinardo
LÖSUNG 06.01.2015, aktualisiert 09.01.2015
Ich sehe gerade das Teil ist unter OpenWRT noch als "Work-in-Progress" gekennzeichnet, dann besser noch nicht.
Unter DD-WRT solls inzwischen soweit gehen:
Bitte warten ..
Mitglied: geforce28
06.01.2015 um 13:22 Uhr
Okay, dann werde ich's mal mit dd-wrt versuchen und berichten.. !

Aber ich verstehe das richtig, dass ich mir das Firmware File ("asus_rt-ac68u-firmware.trx") einfach runterlade und über die momentan aktuelle ASUS Firmware flashen kann (Übers WebIF?)

Vielen Dank schonmal !
Bitte warten ..
Mitglied: colinardo
LÖSUNG 06.01.2015, aktualisiert 09.01.2015
Zitat von geforce28:
Aber ich verstehe das richtig, dass ich mir das Firmware File ("asus_rt-ac68u-firmware.trx") einfach runterlade und
über die momentan aktuelle ASUS Firmware flashen kann (Übers WebIF?)
Bitte alle Links von oben genau lesen und nicht vorschnell handeln !

Dort steht z.B. folgendes:

WARNING: It is recommended to use ASUS Firmware restoration tool for ASUS routers initial flash (use *.TRX file)
Bitte warten ..
Mitglied: geforce28
08.01.2015 um 09:32 Uhr
So danke erstmal an alle, habe jetzt seit gestern DD-WRT geflasht und es läuft soweit erstmal alles.
Wird sich jetzt zeigen, ob das DHCP Problem damit behoben ist.

Noch eine andere Frage.
Man kann die Sendeleistung anpassen.
Ich habe 3x 9dbi Antennen an meinen AP's.

Auf wie viel mw kann ich die Sendeleistung hochschrauben, sodass es noch "legal" bleibt.
Aktuell sind (std) 78mw eingestllt und es geht bis 1000 oO !
Bitte warten ..
Mitglied: colinardo
LÖSUNG 08.01.2015, aktualisiert 09.01.2015
Zitat von geforce28:
Noch eine andere Frage.
Man kann die Sendeleistung anpassen.
Ich habe 3x 9dbi Antennen an meinen AP's.

Auf wie viel mw kann ich die Sendeleistung hochschrauben, sodass es noch "legal" bleibt.
Aktuell sind (std) 78mw eingestllt und es geht bis 1000 oO !

In Deutschland ist im 2,4GHz Band eine maximale Sendeleistung von 100mW erlaubt.
Bei deiner Antennenverstärkung von 9db was gerundet etwa 8mW entspricht dürftest du also im AP bis auf eine Sendeleistung von 92mW gehen um die zulässigen 100mW nicht zu überschreiten.

Grüße Uwe
Bitte warten ..
Mitglied: geforce28
08.01.2015 um 10:02 Uhr
Und im 5GHZ Band?
Bitte warten ..
Mitglied: colinardo
LÖSUNG 08.01.2015, aktualisiert 09.01.2015
Zitat von geforce28:

Und im 5GHZ Band?
je nach verwendetem Kanal sind hier bis zu 1000mW erlaubt.
Hier ist aber zusätzlich das Wetterradar zu beachten (TPC/DFS). Siehe dazu
http://de.m.wikipedia.org/wiki/IEEE_802.11a
Bitte warten ..
Mitglied: colinardo
LÖSUNG 08.01.2015, aktualisiert 09.01.2015
Beachte aber auch das das 5GHz eine höhere Dämpfung als das 2,4GHz Band besitzt, da sich die Signalausbreitung bei höheren Frequenzen dem Licht annähert, und das kann bekanntermaßen schlechter durch eine Wand strahlen. Für Outdoor-Links ist es aber das bevorzugte Band, und wenn die Nachbarschaft mit 2,4GHz Netzen vollgepropft ist.
Bitte warten ..
Mitglied: geforce28
08.01.2015 um 14:34 Uhr
okay super, an dieser stelle schonmal vielen Dank an dich, Colinardo...
DHCP über Wlan scheint jetzt auch durchgehend zu funktionieren, jedenfalls bis jetzt. Ich bin guter Dinge ))

Jetzt habe ich noch die Frage, wie ich am besten ein Gastnetz (WLAN) realisieren kann... !?

Mein Aufbau ist:
- Internet macht eine Fritzbox, die im Netz 10.0.9.0/24 ist.
- Asus AP's sind alle direkt per Kabel mit dem Netz Fritzbox verbunden.
- DHCP + DNS machen wie gesagt ein Windows 2012 R2 Server

Und ich möchte jetzt folgendes:
- 2 Wlan Netze einrichten, ein Privates WLAN, ein Gast WLAN
(das bekomme ich noch hin im DD-WRT, also das reine einrichten 2 verschiedener SSID's)

- GastNetz soll z.b. 192.168.145.0/24 sein.
- GastNetz soll nicht auf das private Netz 10.0.9.0 zugreifen können, muss jedoch für den Internet Zugang doch zugriff auf das Gateway haben oder ? (Fritzbox: 10.0.9.1) und auch auf den DNS Server oder ? (10.0.9.2)

Wie kann ich das am besten realisieren?

Colinardo, mir scheint so, als ob du dich ziemlich gut damit auskennst...
Kannst du dich nochmal erbahmen und mir erklären, wie ich das zu machen habe ?

Vielen lieben Dank schoneinmal im Voraus.
Bitte warten ..
Mitglied: colinardo
LÖSUNG 08.01.2015, aktualisiert 09.01.2015
Hierzu seinen dir unbedingt folgende Tutorials von @aqui ans Herz gelegt:

Wenns einfach sein soll das Gastnetz an der Fritte auf LAN 4 aktivieren und die Gastnetz-APs an Port 4 der Fritte klemmen.

Grüße Uwe
Bitte warten ..
Mitglied: geforce28
08.01.2015 um 15:59 Uhr
Möchte ja auch gerne über alle Router das Gastnetz zur Verfügung stellen und das könnte ich ja dann nur mit dem machen der direkt neben der Fritte steht...
Ich kann ja nicht noch jeweils n 2. Kabel von der Fritzbox zu den jeweiligen Routern nur für das Gastnetz ziehen...

Die Tuturials erklären Vlan, ja, aber das ist eigentlich nicht die Antwort auf meine frage...
Ich kämpf mich jetzt schon seit Stunden damit rum ...
Bitte warten ..
Mitglied: colinardo
LÖSUNG 08.01.2015, aktualisiert 09.01.2015
Zitat von geforce28:

Möchte ja auch gerne über alle Router das Gastnetz zur Verfügung stellen und das könnte ich ja dann nur mit
dem machen der direkt neben der Fritte steht...
Ich kann ja nicht noch jeweils n 2. Kabel von der Fritzbox zu den jeweiligen Routern nur für das Gastnetz ziehen...

Die Tuturials erklären Vlan, ja, aber das ist eigentlich nicht die Antwort auf meine frage...
Doch lese sie mal ganz genau, die meisten sind nur zu faul sie ganz durchzulesen und zu verstehen. Wenn deine APs MultiSSID unterstützen(und das machen sie ja mit DD-WRT) können diese mit VLANs entsprechend aufgetrennt werden. Kleiner Mikrotik(30€) als Router zwischen den VLANs fertig ist die Kiste. Mit der Fritzbox kommst du da nicht weit.
Mit der Fritte hast du eben nur die oben geschilderte Möglichkeit verschiedene Netze voneinander zu trennen.

Wenn du nicht mit VLANs arbeiten willst bleibt dir nur noch eine Routerkaskade
Bitte warten ..
Mitglied: geforce28
09.01.2015 um 13:31 Uhr
Okay ich habe es jetzt über den LAN-4 Port der FritzBox gemacht und in Kauf genommen, dass nur einer meiner 3 AP's das Gast WLAN bereitstellt...

Vielen Dank an alle.
Bitte warten ..
Mitglied: colinardo
09.01.2015, aktualisiert um 13:49 Uhr
Zitat von geforce28:

Okay ich habe es jetzt über den LAN-4 Port der FritzBox gemacht und in Kauf genommen, dass nur einer meiner 3 AP's das
Gast WLAN bereitstellt...
Ein Switch an den Port, bewirkt da Wunder wenn er denn nur fürs Gäste-LAN zuständig sein soll
Bitte warten ..
Mitglied: geforce28
09.01.2015 um 17:33 Uhr
Ja schon klar, dass ich da n Switch dranklemmen kann.
Nur müsste ich zu den anderen 2 AP's dann auch von dort nochmal ein zusätzliches Kabel als Verbindung dahin haben, richtig ?
Bitte warten ..
Mitglied: colinardo
09.01.2015, aktualisiert um 17:52 Uhr
Zitat von geforce28:

Ja schon klar, dass ich da n Switch dranklemmen kann.
Nur müsste ich zu den anderen 2 AP's dann auch von dort nochmal ein zusätzliches Kabel als Verbindung dahin haben,
richtig ?
wenn die APs nur für das Gäste-LAN zuständig sind, nicht.
Kauf dir einen Mikrotik ab 35€ und du wirst glücklich ... da dann auf einmal alles geht was du dir vorstellen kannst.
Bitte warten ..
Mitglied: geforce28
09.01.2015 um 17:43 Uhr
Wie gesagt, die AP's machen sowohl Gäste-WLan, also auch das Private WLAN...

Was von Mikrotik meinst du genau ? Noch nie gehört die Firma...
Bitte warten ..
Mitglied: geforce28
09.01.2015 um 18:29 Uhr
Ja aber was soll mir das sagen ?
Was genau soll ich mit dem Ding machen?

N Layer 3 Switch kann auch Routing... ?!
Bitte warten ..
Mitglied: colinardo
09.01.2015, aktualisiert um 18:46 Uhr
Zitat von geforce28:
Ja aber was soll mir das sagen ?
Was genau soll ich mit dem Ding machen?
N Layer 3 Switch kann auch Routing... ?!
aber die sind meist wesentlich teurer ... kein Wort hast du erwähnt das du einen Layer-3 Switch mit VLAN rumliegen hast ?!

Du schließt deine APs an einen tagged Port(trunk) an und definierst im AP für beide SSIDs jeweils eine separate VLANID ... Deswegen haben wir ja VLANs empfohlen !!
Bitte warten ..
Mitglied: geforce28
09.01.2015 um 18:35 Uhr
Also soll ich quasi das andere Netz über Vlan's schicken...

Das Problem ist nur, dass ich dann noch einen 2. Managed switch bräuchte oder ? Je am Ende, wo ich die beiden AP's stehen habe oder ?
Bitte warten ..
Mitglied: colinardo
09.01.2015, aktualisiert um 18:53 Uhr
Zitat von geforce28:
Das Problem ist nur, dass ich dann noch einen 2. Managed switch bräuchte oder ? Je am Ende, wo ich die beiden AP's
stehen habe oder ?
nope ...du hast das Tutorial von Aqui nicht gelesen, da steht das alles hervorragend erklärt !

Hier auch noch ein passender Beitrag
Mikrotik mehrere VirtualAccessPoints mit gleicher SSID

Gastnetz und VLANs mit DD-WRT
Bitte warten ..
Mitglied: geforce28
13.01.2015 um 19:49 Uhr
So colinardo, ich habe mir deinen Rat mal zu Herzen genommen und mich ins thema Vlans eingelesen und es jetzt auch alles über VLAN's realisiert und es funktioniert wirklich gut

Wollte nur nochmal ne Rückmeldung an dieser Stelle geben!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
LAN, WAN, Wireless
Welche WLan APs für Aussenbereich (11)

Frage von cookymonster zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
LAN mit 2 APs, Smartphone an AP1 erreicht WLAN Geräte an AP2 nicht (39)

Frage von Pagemaster101 zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
WLAN Repeater DNS und DHCP (3)

Frage von Angelo131095 zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...