Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

DHCP NACK BAD ADDRESS mit Dualbetriebssystem

Frage Netzwerke

Mitglied: Rummel

Rummel (Level 1) - Jetzt verbinden

29.05.2007, aktualisiert 30.05.2007, 7369 Aufrufe, 4 Kommentare

Hallo,

ich hab hier einen Windows 2003 Server im Netzwerk stehen auf dem ADS, DNS, WINS und DHCP
läuft. Der DHCP-Server macht leider Probleme. Dort ist ein IP-Adressbereich eingetragen
von 192.168.100.1-192.168.100.200. Alle Clients, sei es mit Windows XP oder Linux, bekommen
fein Ihre Daten vom DHCP Server (DNS-Server, Gateway, IP-Adresse usw.).

Nun müssen einige Rechner eine "feste" IP bekommen, sodass ich Reservierungen anlegen muss.
Die Reservierungen sind außerhalb des bereichs: 192.168.200.201 ist z.B. die 1. Reservierung.
Anhand der MAC-Adresse bekommen die meisten Rechner auch die richtige IP dauerhaft zugewiesen.
Das Problem ist, wenn ich Windows XP UND Linux auf einem Rechner installiert habe. In diesem
Fall bekommt Linux eine IP (ganz normal). Fahre ich mit Windows XP hoch bekommt Windows keine
IP zugewiesen. Statt dessen versucht Windows XP stundenlang eine Netzwerkadresse zu beziehen.
Im DHCP-LOG wird in dieser Zeit mit folgender Nachricht alles zugespammt:

15,05/29/07,16:26:21,NACK,192.168.200.210,xp-test.dom.local,0016D3B0C570, usw. usw.

In der Reservierungsliste schreibt der Server zur gleichen Zeit BAD_ADRESS hinein. Was mich
wundert ist, dass die Fehlermeldung gar nicht kommen dürfte, weil 1. nicht ein anderer Rechner
diese IP hat und 2. die IP nur einmal vorkommen kann da sie nur zu einer einzigen MAC-Adresse
passt.

Wie kommt das bitte schön zu stande?
Mitglied: aqui
29.05.2007 um 18:49 Uhr
MS beschreibt das in seiner Knowledgebase:

http://support.microsoft.com/kb/167014/
Bitte warten ..
Mitglied: Rummel
30.05.2007 um 08:30 Uhr
Hallo aqui, ich habe hier nur ein einziges Segment und hab diesen Rechner nur an dieses Netzwerk angebunden. Von daher hat das nichts mit diesem Thema zu tun. ipconfig /release und /renew bewirken dasselbe: Der Client sucht und sucht vergeblich nach einer IP-Adresse.

Noch ne Info: die beiden Betriebssysteme haben unterschiedliche Computernamen, damit es dort nicht zu konflikten kommt.
Bitte warten ..
Mitglied: aqui
30.05.2007 um 10:24 Uhr
Der Name sollte eigentlich egal sein. Vermutlich hat der MS DHCP Server auf dem 2k3 Server aber doch Probleme damit. Eigentlich ist es ja nichts anderes als ob man das Gerät neu bootet. Welches OS da zum Einsatz kommt sollte beim DHCP Request keine Rolle spielen.
Hast du testweise diesen DHCP Test mal an einem Segment gemacht wo du nur einen einfachen DHCP Server z.B. mal den deines Routers dran hattest. Zeigt der auch so ein komisches Verhalten ? Dort dürfte eigentlich der Reboot mit einem anderen OS kein Problem sein und eine neue Adresse sofort zugeteilt werden.

Du solltest als mögliche Lösung mal versuchen die Lease Time des DHCP Servers drastisch zu verkürzen. das würde bedeuten, das eine IP Adresse bei Unbenutzung dann schneller freigegeben wird. Ggf. löst das das Problem.
Bitte warten ..
Mitglied: Rummel
30.05.2007 um 10:50 Uhr
Ja, an die Leasetime hab ich auch schon gedacht. Das Problem ist, das ich die für die anderen Clients nicht zu kurz machen möchte. Kann man nicht verschiedene Leasezeiten für verschiedene Adressbereiche konfigurieren? Z.B. von 192.168.100.1-192.168.100.200 => 2 Tage und von 192.168.100.201-192.168.100.220 => 0 Sekunden ?
Bitte warten ..
Ähnliche Inhalte
Sonstige Systeme
gelöst Cisco 1841, dhcp Client keine Adresse (31)

Frage von rudeboy zum Thema Sonstige Systeme ...

Router & Routing
gelöst HP Procurve 2915-8G-PoE DHCP Server über Router (5)

Frage von xRed8Dogx zum Thema Router & Routing ...

Windows Netzwerk
gelöst Einrichtung DHCP (6)

Frage von halington zum Thema Windows Netzwerk ...

Apache Server
Bad Request (6)

Frage von HacktoxX zum Thema Apache Server ...

Neue Wissensbeiträge
Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(2)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(9)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Heiß diskutierte Inhalte
Exchange Server
Exchange 2016 Standard Server 2012 R2 Hetzner Mail (36)

Frage von Datsspeed zum Thema Exchange Server ...

Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

Windows 10
Windows Store Apps ohne Windows Store installieren (10)

Frage von keefien zum Thema Windows 10 ...

Internet Domänen
Nameserver ein Geist? (9)

Frage von zelamedia zum Thema Internet Domänen ...